On 06/12/18 at 05:10pm, Julia Lawall wrote:
> This looks wrong. After a list iterator, the index variable points to a
> dummy structure.
>
> julia
>
> url:
> https://github.com/0day-ci/linux/commits/Baoquan-He/resource-Use-list_head-to-link-sibling-resource/20180612-1
In the PI433_IOC_WR_TX_CFG case in pi433_ioctl, instance->tx_cfg is
modified via
copy_from_user(&instance->tx_cfg, argp, sizeof(struct pi433_tx_cfg)))
without any kind of synchronization. In the case where two threads
would execute this same command concurrently the tx_cfg field might
enter in an
> > case PI433_IOC_WR_TX_CFG:
> > if (copy_from_user(&instance->tx_cfg, argp,
> >sizeof(struct pi433_tx_cfg)))
> > return -EFAULT;
> > break;
>
> Btw, it looks so wrong to me that we copy partial data to
> &instance->tx_cfg... I'd really prefer copy
> We read the data from the user here and then we write it to the fifo
> in pi433_write(). We should be using the device->tx_fifo_lock so that
> we don't copy over the data at the same time we're writing it to the
> fifo.
Oh right, that makes the bug even worse.
In this case we don't even need t
From: Stephen Hemminger
Date: Mon, 11 Jun 2018 12:44:53 -0700
> This set of patches addresses two set of fixes. First it backs out
> the common callback model which was merged in net-next without
> completing all the review feedback or getting maintainer approval.
>
> Then it fixes the transpare
Add support for overriding the default driver for a VMBus device
in the same way that it can be done for PCI devices. This patch
adds the /sys/bus/vmbus/devices/.../driver_override file
and the logic for matching.
This is used by driverctl tool to do driver override.
https://gitlab.com/driverctl/
On Tue, Jun 12, 2018 at 08:56:58PM +0200, Jakob Albert wrote:
> Fix SPACING errors in drivers/hwmon/nct7904.c reported by checkpatch.pl
>
Subject for all patches in this series should be
hwmon: (nct7904)
There is no need to reference the file name in the patch description.
It is obvious from b
On Sat, Jun 02, 2018 at 09:30:10AM +0200, Sergio Paracuellos wrote:
> Add a devicetree binding documentation for the mt7621 driver.
Bindings are for h/w, not a driver.
> Signed-off-by: Sergio Paracuellos
> Reviewed-by: NeilBrown
Space ^
> ---
> .../bindings/gpio/mediatek,mt7621-
On Tue, Jun 12, 2018 at 08:56:58PM +0200, Jakob Albert wrote:
> Fix SPACING errors in drivers/hwmon/nct7904.c reported by checkpatch.pl
>
> Signed-off-by: Lorenz Kaestle
> Signed-off-by: Jakob Albert
> ---
> drivers/hwmon/nct7904.c | 12 ++--
> 1 file changed, 6 insertions(+), 6 deletio
On Tue, Jun 12, 2018 at 2:37 AM, Greg KH wrote:
> On Tue, Jun 12, 2018 at 02:30:27AM +0530, Souptick Joarder wrote:
>> > >
>> > > If no further comment, we would like to get this patch in 4.18-rc-X.
>> >
>> > Why? Is it a regression fix? That's all that is allowed after -rc1.
>>
>> No, this is n
Changes since v3:
a) Reverted u64 to unsigned long long and u32 to unsigned int.
b) Added patch versioning.
c) Changed type of scans_left to unsigned long long to avoid cast.
d) Clarified and updated changelog.
>8---8<
Improve re
Fix SPACING errors in drivers/hwmon/nct7904.c reported by checkpatch.pl
Signed-off-by: Lorenz Kaestle
Signed-off-by: Jakob Albert
---
drivers/hwmon/nct7904.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/hwmon/nct7904.c b/drivers/hwmon/nct7904.c
index
Fix UNSPECIFIED_INT warning in drivers/hwmon/nct7904.c reported by
checkpatch.pl
Signed-off-by: Lorenz Kaestle
Signed-off-by: Jakob Albert
---
drivers/hwmon/nct7904.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/hwmon/nct7904.c b/drivers/hwmon/nct7904.c
in
This set of patches fixes style errors in drivers/hwmon/nct7904.c reported
by checkpatch.pl. This adapts the code to the coding style.
Jakob Albert (3):
staging: hwmon: Fix SPACING errors
staging: hwmon: Fix CODE_INDENT error
staging: hwmon: Fix UNSPECIFIED_INT warning
drivers/hwmon/nct7
Fix CODE_INDENT error in drivers/hwmon/nct7904.c reported by checkpatch.pl
Signed-off-by: Lorenz Kaestle
Signed-off-by: Jakob Albert
---
drivers/hwmon/nct7904.c | 48
1 file changed, 24 insertions(+), 24 deletions(-)
diff --git a/drivers/hwmon/n
On Fri, Jun 8, 2018 at 7:32 AM, Janani Sankara Babu wrote:
> This patch is created to solve the warning shown by checkpatch script
> Prefer using '"%s...", __func__' to using ', this function's name,
> in a string
Have you even tried to compile it?
NAK
>
> Signed-off-by: Janani Sankara Babu
>
Hi Dan,
Thank you for the feedback, I'll update V4 of the patch accordingly
and resend. I'll soon get a hang of the workflow! :)
Best Regards,
Chris Opperman
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailm
Use sign_extend32 kernel function instead of code duplication.
This function is also safe for 16 bits.
Signed-off-by: Karim Eshapa
---
drivers/staging/iio/accel/adis16203.c | 6 +-
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16203.c
b/drivers/s
Use sign_extend32 kernel function instead of code duplication,
Safe also for 16 bit. and remove declaration of bits variable not needed.
Signed-off-by: Karim Eshapa
>On Tue, 2018-06-12 at 01:38 +0200, Karim Eshapa wrote:
>> Use sign_extend32 kernel function instead of code duplication.
>> Safe a
This looks wrong. After a list iterator, the index variable points to a
dummy structure.
julia
url:
https://github.com/0day-ci/linux/commits/Baoquan-He/resource-Use-list_head-to-link-sibling-resource/20180612-113600
:: branch date: 7 hours ago
:: commit date: 7 hours ago
>>
On Tue, 12 Jun 2018 12:51:28 +0300
Dan Carpenter wrote:
> On Mon, Jun 11, 2018 at 12:44:55PM -0700, Stephen Hemminger wrote:
> > When finding the parent netvsc device, the search needs to be across
> > all netvsc device instances (independent of network namespace).
> >
> > Find parent device of
On Tue, Jun 12, 2018 at 5:20 PM, Andy Shevchenko
wrote:
> On Tue, Jun 12, 2018 at 12:38 PM, Baoquan He wrote:
>> On 06/12/18 at 11:29am, Andy Shevchenko wrote:
>>> On Tue, Jun 12, 2018 at 6:28 AM, Baoquan He wrote:
>
>>> > +{
>>>
>>> > + for (pp = &parent->child; (p = *pp) != NULL; pp = &p
On Tue, Jun 12, 2018 at 12:38 PM, Baoquan He wrote:
> On 06/12/18 at 11:29am, Andy Shevchenko wrote:
>> On Tue, Jun 12, 2018 at 6:28 AM, Baoquan He wrote:
>> > +{
>>
>> > + for (pp = &parent->child; (p = *pp) != NULL; pp = &p->sibling) {
>> > + if (p->end < res->start)
>> > +
On Sun, Jun 10, 2018 at 12:40:17PM +0530, Nishad Kamdar wrote:
> Type used is unsigned char but expected is restricted __le16.
> Warning reported by sparse. Part of eudyptula challenge.
>
The code is buggy, but this fix just papers over it. We discussed this
code earlier.
https://lkml.org/lkml/
On Sat, Jun 09, 2018 at 10:34:43PM +0300, Andy Shevchenko wrote:
> On Sat, Jun 9, 2018 at 7:58 PM, wrote:
> > On 2018-06-09 12:38, Anton Vasilyev wrote:
> >>
> >> If rtsx_probe fails to allocate dev->chip, then NULL pointer
> >> dereference occurs at rtsx_release_resources().
> >>
> >> Patch adds
On Sat, Jun 09, 2018 at 11:48:42AM -0400, Hugo Lefeuvre wrote:
> case PI433_IOC_WR_TX_CFG:
> if (copy_from_user(&instance->tx_cfg, argp,
>sizeof(struct pi433_tx_cfg)))
> return -EFAULT;
> break;
Btw, it looks so wrong to me that we copy partial data
On Mon, Jun 11, 2018 at 01:09:24PM +0800, Zhouyang Jia wrote:
> When nlmsg_put fails, the lack of error-handling code may
> cause unexpected results.
>
> This patch adds error-handling code after calling nlmsg_put.
>
> Signed-off-by: Zhouyang Jia
> ---
> drivers/staging/gdm724x/netlink_k.c | 3
On Tue, Jun 12, 2018 at 11:25:35AM +0800, Zhouyang Jia wrote:
> When vmap fails, the lack of error-handling code may
> cause unexpected results.
>
> This patch adds error-handling code after calling vmap.
>
Again, this is not error handling, this is just an error message. This
error condition i
On Tue, Jun 12, 2018 at 11:18:43AM +0800, Zhouyang Jia wrote:
> When register_netdev fails, the lack of error-handling code may
> cause unexpected results.
>
> This patch adds error-handling code after calling register_netdev.
>
It doesn't add any error handling. It just adds an error message.
There is no need to check for 'pending' before loop over the
interrupts using 'for_each_set_bit' if nothing is set the
return values will be the same so just avoid this check avoiding
also one level intentation and improving readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt76
Checkpatch script is complaining about a comment line
which exceeds 80 characteres. Just silence it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-gpio/gpio-mt7621.c
If there is no interrupt defined in the dts 'irq_of_parse_and_map'
returns 0 and we should't set up interrupts for each gpio chip in
that case.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 42 ---
1 file changed, 22 insertions(+),
Currently the driver defines 3 gpiochips, one for each bank.
/sys/class/gpio/gpiochip416/label:1e000600.gpio
/sys/class/gpio/gpiochip448/label:1e000600.gpio
/sys/class/gpio/gpiochip480/label:1e000600.gpio
Unfortunately they all have the same label
Interrupts from /proc/interrupt show the same na
Function 'to_mediatek_gpio' cannot return NULL, so this NULL
checkings are pointless.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 9 -
1 file changed, 9 deletions(-)
diff --git a/drivers/staging/mt7621-gpio/gpio-mt7621.c
b/drivers/staging/mt7621-gp
Update kernel doc for mtk_data and also remove no needed
documentation for mtk_gc which is clear enough to don't
need it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 15 +++
1 file changed, 3 insertions(+), 12 deletions(-)
diff --git a/drivers/s
There was two remaining defines which weren't properly
aligned with the rest. Align them improving readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-gpio/gpio
Now that all seems to be working these are the last minor
cleanups in order to make a second try to get this out
of staging.
Sergio Paracuellos (7):
staging: mt7621-gpio: remove no more necessary PIN_MASK macro
staging: mt7621-gpio: update kerneldoc for state containers
staging: mtk7621-gpio
PIN_MASK macro was being used because of the fact we were only
using one interrupt controller for all of the gpio chips. This
has been changed to use one per gpio chip and each has 32 irqs.
Because of this this macro is not needed anymore. Use BIT macro
instead.
Signed-off-by: Sergio Paracuellos
On Mon, Jun 11, 2018 at 09:12:00PM -0400, Hugo Lefeuvre wrote:
> In the PI433_IOC_WR_TX_CFG case in pi433_ioctl, instance->tx_cfg is
> modified using
>
> copy_from_user(&instance->tx_cfg, argp, sizeof(struct pi433_tx_cfg)))
>
> without any kind of synchronization. In the case where two threads
>
On Tue, 12 Jun 2018 02:57:48 +0200
Karim Eshapa wrote:
> Use sign_extend32 kernel function instead of code duplication.
> Safe also for 16 bit.
>
> Signed-off-by: Karim Eshapa
Please resend as a fresh patch marked at V2 with a change log below the ---
so we can easily see what has changed.
Th
On Mon, Jun 11, 2018 at 12:44:55PM -0700, Stephen Hemminger wrote:
> When finding the parent netvsc device, the search needs to be across
> all netvsc device instances (independent of network namespace).
>
> Find parent device of VF using upper_dev_get routine which
> searches only adjacent list.
On 06/12/18 at 11:29am, Andy Shevchenko wrote:
> On Tue, Jun 12, 2018 at 6:28 AM, Baoquan He wrote:
> > reparent_resources() is duplicated in arch/microblaze/pci/pci-common.c
> > and arch/powerpc/kernel/pci-common.c, so move it to kernel/resource.c
> > so that it's shared. Later its code also need
On 06/12/18 at 11:29am, Andy Shevchenko wrote:
> On Tue, Jun 12, 2018 at 6:28 AM, Baoquan He wrote:
> > reparent_resources() is duplicated in arch/microblaze/pci/pci-common.c
> > and arch/powerpc/kernel/pci-common.c, so move it to kernel/resource.c
> > so that it's shared. Later its code also need
On 12/06/18 10:41, Philipp Zabel wrote:
> Hi,
>
> On Mon, 2018-06-11 at 22:48 +0200, Peter Seiderer wrote:
>> Hello *,
>>
>> On Fri, 16 Mar 2018 10:05:44 -0700, Steve Longerbeam
>> wrote:
>>
>>> Reviewed-by: Steve Longerbeam
>>
>> Ping? Anybody taking this one?
>
> The patches have been marked
You haven't been sending the v2 and v3 patches in the right way.
Take a look through the email archive and see how this is normally done.
Also google it:
https://www.google.com/search?q=how+to+send+a+v2+patch
On Sun, Jun 10, 2018 at 12:30:01PM +0200, chris wrote:
> Hi Greg,
> I've added changelog
Hi,
On Mon, 2018-06-11 at 22:48 +0200, Peter Seiderer wrote:
> Hello *,
>
> On Fri, 16 Mar 2018 10:05:44 -0700, Steve Longerbeam
> wrote:
>
> > Reviewed-by: Steve Longerbeam
>
> Ping? Anybody taking this one?
The patches have been marked not applicable in patchwork [1][2].
They do apply on
Looks good thanks.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Tue, Jun 12, 2018 at 6:28 AM, Baoquan He wrote:
> reparent_resources() is duplicated in arch/microblaze/pci/pci-common.c
> and arch/powerpc/kernel/pci-common.c, so move it to kernel/resource.c
> so that it's shared. Later its code also need be updated using list_head
> to replace singly linked
Reply Me Now It's Very Urgent
Hello My Good Friend,I am a banker in Bank Atlantic Ivory Coast .
I want to transfer an abandoned sum of 7.2millions USD to your account.
50% will be for you. No risk involved. Contact me immediately for more details
becuase this is a deal at stake.
Mrs Celina Jo
On Tue, Jun 12, 2018 at 12:33:42PM +1000, NeilBrown wrote:
> On Mon, Jun 11 2018, Sergio Paracuellos wrote:
>
> > After submiting this driver to try to get mainlined and get
> > out of staging some new cleanups seems to be necessary.
> > According to this main of Linus Walleij:
> >
> > http://driv
On Tue, Jun 12, 2018 at 12:01:38PM +1000, NeilBrown wrote:
> On Mon, Jun 11 2018, Sergio Paracuellos wrote:
>
> > On Mon, Jun 11, 2018 at 06:33:44PM +1000, NeilBrown wrote:
> >> On Mon, Jun 11 2018, Sergio Paracuellos wrote:
> >>
> >> > After submiting this driver to try to get mainlined and get
51 matches
Mail list logo