According to error handling path before and after this one, we should go
to 'out_md_fid' here, instead of 'out_md', if 'obd_connect()' fails.
Signed-off-by: Christophe JAILLET
---
The last goto 'out_lock_cn_cb' looks spurious but is correct.
In case of error, 'd_make_root()' performs a 'iput()',
On May 11, 2018, at 07:38, Colin King wrote:
>
> From: Colin Ian King
>
> Trivial fix to spelling mistake in DEBUG_REQ message text
>
> Signed-off-by: Colin Ian King
Reviewed-by: Andreas Dilger
> ---
> drivers/staging/lustre/lustre/ptlrpc/client.c | 2 +-
> 1 file changed, 1 insertion(+), 1
We just need some integer handles that can map back to our message
struct when we're handling a reply, which struct idr is perfect for.
v2: Fix error check to look at the right variable.
Signed-off-by: Eric Anholt
---
.../vc04_services/bcm2835-camera/mmal-vchiq.c | 135 --
1 fil
On Fri, 2018-05-11 at 17:09 +0200, Julia Lawall wrote:
>
> On Fri, 11 May 2018, Christophe JAILLET wrote:
>
> > The use of 'fail1' and 'fail2' is not correct. Reorder these calls
> > to
> > branch at the right place of the error handling path.
>
> Maybe it would be good to improve the names at t
If 'v4l2_ctrl_handler_init()' fails, we go to the error handling path, do
some clean-up and return err, which is known to be 0 (i.e. success).
Axe the 'ret' variable and use 'err' directly in order to return the error
code instead.
Also remove the initialization of 'err' which was hiding this issu
The use of 'fail1' and 'fail2' is not correct. Reorder these calls to
branch at the right place of the error handling path.
Signed-off-by: Christophe JAILLET
---
drivers/staging/media/atomisp/i2c/atomisp-lm3554.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/st
On Fri, 11 May 2018, Christophe JAILLET wrote:
> The use of 'fail1' and 'fail2' is not correct. Reorder these calls to
> branch at the right place of the error handling path.
Maybe it would be good to improve the names at the same time?
julia
>
> Signed-off-by: Christophe JAILLET
> ---
> dr
According to the doc, 'media_entity_cleanup()' must be called after
unregistering the entity.
All places I've check do it that way.
So, move the call after 'v4l2_device_unregister_subdev()' as done
elsewhere.
Actually, this is not an issue, because 'media_entity_cleanup()' does
nothing, but it is
These 3 patches fixes (at least I hope) some issues found in or around
'lm3554_probe()'.
Please review them carefully. I've only compile tested the changes and
I propose them because they sound logical to me.
The first one, return an error code instead of 0 if the call to an
initialisation functi
From: Colin Ian King
Trivial fix to spelling mistake in DEBUG_REQ message text
Signed-off-by: Colin Ian King
---
drivers/staging/lustre/lustre/ptlrpc/client.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/ptlrpc/client.c
b/drivers/staging/lu
On Thu, May 10, 2018 at 11:07:01AM -0700, Doug Oucharek wrote:
> Under upstream staging commit 5a2ca43fa54f561c252c2, the list handling
> code in kiblnd_handle_early_rxs() got changed to list_for_each_safe().
> That protects against the current thread from deleting the current entry
> it is looking
On 11 May 2018 at 00:12, Stefan Schake wrote:
> The overlay code is non-functional since it relies on firmware control
> of the HVS.
>
> Signed-off-by: Stefan Schake
> ---
> Dave, does this match your understanding?
Yes, the overlay only works if you are not running the vc4 driver,
therefore dro
From: Martijn Coenen
New devices launching with Android P need to use the 64-bit
binder interface, even on 32-bit SoCs [0].
This change removes the Kconfig option to select the 32-bit
binder interface. We don't think this will affect existing
userspace for the following reasons:
1) The latest An
On 11.5.2018 09:58, James Kelly wrote:
> Hi Michal
>
> On 11 May 2018 at 16:06, Michal Simek wrote:
>
>> On 7.5.2018 03:20, James Kelly wrote:
>>> The CCF clock providers that are currently used by the driver are not
>>> capable of supporting the Clocking Wizard IP register interface for
>>> fra
On Fri, May 11, 2018 at 10:08 AM, Greg KH wrote:
> I think using !CONFIG_M68K is a good start. We can blacklist any other
> arch that doesn't support this, and that list should be small as I doubt
> any new ones will be added without this support.
Thanks, I will send a v2.
>
> thanks,
>
> greg
Cleanup patch to avoid use of datatype in variable name to follow as
per linux coding style.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wf
Added comments for mutex and spinlock_t to avoid checkpatch.pl script.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.h | 2 +-
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 5 +++--
2 files changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/wilc1
Cleanup patch to have variable names as per linux coding style.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b/drivers/staging/wilc1000/host_interface.c
in
Remove 'connect_resp_info' structure as most of its elements are not used.
Modified wilc_parse_assoc_resp_info() to directly parse and fill value
in connect_info structure variable. Remove use of 'assoc_resp_len' variable.
get_assoc_resp_cap_info() & get_asoc_id() functions are remove as its
not u
Cleanup patch to remove the unused variable from 'wilc_priv' structure.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_netdevice.h
b/drivers/staging/wilc1000/wilc_wfi_netdevice.h
in
Remove 'flag' function parameter in wilc_mac_indicate() as only one
condition was handled using that parameter. Also removed unnecessary
call to wilc_mac_indicate() as no operation was performed in that
function call.
After above changes below macros are not required anymore.
WILC_MAC_INDICATE_STAT
Refactor the code to fix open parenthesis alignment issue reported by
checkpatch.pl script in del_station().
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 18 ++
1 file changed, 10 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/wil
Fix line over 80 characters issues found by checkpatch.pl script with
the help of local variable.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperat
Fix line over 80 characters issue found by checkpatch.pl script in
function declaration.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.h | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.h
b/driv
Fix line over 80 chars issue found by checkpatch.pl script by placing
the comment message above the macro preprocessor.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_sdio.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/wilc_sdio.c
b
Fix line over 80 characters in connect() by using temporary variables.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 29 +--
1 file changed, 17 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
Fix line over 80 character issue found by checkpatch.pl script in
add_key().
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 19 +--
1 file changed, 9 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
Added new macro to resolve below checkpatch issues in linux_mon.
"Lines should not end with a '('"
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_mon.c | 11 +--
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/wilc1000/linux_mon.c
b/drivers/s
Fix line over 80 characters issues reported by checkpatch.pl script in
wilc_wfi_cfg_tx_vendor_spec() by using temporary variable. Simplified
'if else' condition with 'if'.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 14 +++---
1 file changed, 7 inser
Fix below checkpatch issue found in mgmt_tx()
Prefer kmalloc(sizeof(*mgmt_tx)...) over kmalloc(sizeof(struct
p2p_mgmt_data)...)
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wil
Refactor wilc_wfi_remain_on_channel_expired() to avoid line over 80
character issue reported by checkpatch.pl script. Also assigned value in the
variable at the time of declaration.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 16 +++-
1 file chan
Fix line over 80 characters issue in get_station().
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
b/drivers/staging/wilc1000/wilc_wfi_cfgope
Fix below reported checkpatch issues in wilc_wfi_cfg_alloc().
kzalloc(sizeof(*wdev)...) over kzalloc(sizeof(struct wireless_dev)
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wil
Rename clear_duringIP() function to avoid camelCase issue reported by
checkpatch.pl script.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
b
Fix line over 80 characters issue reported by checkpatch in
add_network_to_shadow() by using temporary variable.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 52 +++
1 file changed, 25 insertions(+), 27 deletions(-)
diff --git a/drivers/s
Use kmemdup instead of kmalloc & memcpy in add_network_to_shadow(). Also
added code to set 'ies_len' to zero in case of memory allocation
failure.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff
This patch series contains modification to remove checkpatch related issues,
mainly related to 'line over 80 chars'.
Also code cleanup related change to follow as per linux coding style are
included in this patch series.
changes from v1:
- Dropped patch#5 and add a new patch #30 to address its re
Fix checkpatch reported issue of line over 80 char in handle_key().
Introduced new functions by spliting existing function to address the
checkpatch issue.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 59 +++
1 file changed, 37 insertions(
Fix line over 80 char issue reported by checkpatch.pl script.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_mon.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/wilc1000/linux_mon.c
b/drivers/staging/wilc1000/linux_mon.c
index 2
Hi James,
On 11.5.2018 09:31, James Kelly wrote:
> Hi Michal,
>
> On 11 May 2018 at 16:04, Michal Simek wrote:
>
>> Hi,
>>
>> On 7.5.2018 03:20, James Kelly wrote:
>>> Add a description for how the Xilinx Clocking Wizard IP works to guide
>>> subsequent patches.
>>>
>>> Signed-off-by: James Kel
Instead of kmalloc and memcpy use kmemdup in handle_connect_timeout().
Also return -ENOMEM incase of failure to allocate the memory.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/stagin
Fix line over 80 char issue in host_int_handle_disconnect() by using
temp variable to hold the 'wilc_connect_result' function pointer.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/stagi
Fix line over 80 characters issue in host_int_parse_assoc_resp_info() by
using shorter name for the local variable.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/wilc1000/host_i
During memory allocation failure in handle_key() the complete() was not
called for comp_test_key_block event. So now added the code to call
complete() for event during error scenario.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 19 +++
1 file changed
Remove the use of unnecessary 'ret' variable and use existing 'result'
variable to hold the status. Also changed type of 'result' from s32 to
int to confirm with the function return type.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 17 +
1 file chang
Fix line over 80 character issue found by checkpatch.pl script by
aligning the input argument in function call.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/wilc1000/host_interfac
Split host_int_parse_join_bss_param() to avoid the line over 80
character issue reported by checkpatch.pl script.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 247 --
1 file changed, 131 insertions(+), 116 deletions(-)
diff --git a/driver
On Fri, May 11, 2018 at 09:57:52AM +0200, Martijn Coenen wrote:
> On Sat, May 5, 2018 at 2:10 PM, kbuild test robot wrote:
> >drivers/android/binder.o: In function `binder_thread_write':
> >>> binder.c:(.text+0x6a16): undefined reference to `__get_user_bad'
>
> Looks like m68k doesn't support
On Sat, May 5, 2018 at 2:10 PM, kbuild test robot wrote:
>drivers/android/binder.o: In function `binder_thread_write':
>>> binder.c:(.text+0x6a16): undefined reference to `__get_user_bad'
Looks like m68k doesn't support 64-bit get_user(). I could just have
binder depend on !CONFIG_M68K, but t
Fix checkpatch warning for misaligned * characters in the block
comment at the start of p80211metastruct.h; with this change the file
is checkpatch clean.
Signed-off-by: Tim Collier
---
drivers/staging/wlan-ng/p80211metastruct.h | 88 +++---
1 file changed, 44 insertions(
Hi,
On 7.5.2018 03:20, James Kelly wrote:
> Add a description for how the Xilinx Clocking Wizard IP works to guide
> subsequent patches.
>
> Signed-off-by: James Kelly
> ---
> .../clocking-wizard/clk-xlnx-clock-wizard.c| 52
> ++
> 1 file changed, 52 insertions(+)
>
On 09.05.2018 17:29, Greg KH wrote:
On Wed, May 09, 2018 at 05:18:47PM +0200, Christian Gromm wrote:
On 09.05.2018 16:54, Dan Carpenter wrote:
On Wed, May 09, 2018 at 04:09:21PM +0200, Christian Gromm wrote:
On 09.05.2018 15:19, Dan Carpenter wrote:
On Tue, May 08, 2018 at 11:44:49AM +0200, C
52 matches
Mail list logo