This function, being a variant of walk_system_ram_res() introduced in
commit 8c86e70acead ("resource: provide new functions to walk through
resources"), walks through a list of all the resources of System RAM
in reversed order, i.e., from higher to lower.
It will be used in kexec_file code.
Signe
For kexec_file loading, if kexec_buf.top_down is 'true', the memory which
is used to load kernel/initrd/purgatory is supposed to be allocated from
top to down. This is what we have been doing all along in the old kexec
loading interface and the kexec loading is still default setting in some
distrib
The struct resource uses singly linked list to link siblings, implemented
by pointer operation. Replace it with list_head for better code readability.
Based on this list_head replacement, it will be very easy to do reverse
iteration on iomem_resource's sibling list in later patch.
Besides, type o
This patchset is doing:
1) Replace struct resource's sibling list from singly linked list to
list_head. Clearing out those pointer operation within singly linked
list for better code readability.
2) Based on list_head replacement, add a new function
walk_system_ram_res_rev() which can does reversed
On Sun, 6 May 2018 00:33:33 -0700
Nathan Chancellor wrote:
> This statment triggers GCC's -Wtype-limit since key_index is an
> unsigned integer so it cannot be less than zero.
>
> Signed-off-by: Nathan Chancellor
Reviewed-by: Ajay Singh
> ---
> drivers/staging/wilc1000/wilc_wfi_cfgoperation
On Sun, 6 May 2018 00:33:32 -0700
Nathan Chancellor wrote:
> GCC warns that 'wid' is unused in wilc_remove_key and it's correct;
> the variable is only local. Get rid of the function (since it just
> returns zero) and shuffle the remaining code into one if statement.
>
> Signed-off-by: Nathan Ch
Thank you for the patch series.
On Sun, 6 May 2018 00:33:31 -0700
Nathan Chancellor wrote:
> GCC warns these variables are all set but never used so remove them.
>
> Signed-off-by: Nathan Chancellor
Reviewed-by: Ajay Singh
> ---
> drivers/staging/wilc1000/host_interface.c | 12
On 05-05-18, 23:50, Nathan Chancellor wrote:
> Fixes the following W=1 warning: variable ‘intf_id’ set but
> not used [-Wunused-but-set-variable]
>
> Signed-off-by: Nathan Chancellor
> ---
> drivers/staging/greybus/svc.c | 3 ---
> 1 file changed, 3 deletions(-)
>
> diff --git a/drivers/staging
Hi James,
Thank you for the patch! Perhaps something to improve:
[auto build test WARNING on staging/staging-testing]
[also build test WARNING on v4.17-rc3 next-20180504]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.c
Hi everyone,
I compiled the ion driver with W=1 where I encountered the two following
warnings and I had a couple of questions about solving them.
1.
drivers/staging/android/ion/ion.c: In function ‘ion_dma_buf_begin_cpu_access’:
drivers/staging/android/ion/ion.c:316:8: warning: variable ‘vaddr’
Allow CLK_SET_RATE_PARENT to be optionally enabled on first divider clock.
This has the potential to set the rate of one output clock with more
precision. On Zynq-7000 this is typically achieved using a PS FCLK as
input to the Clocking Wizard IP.
This feature is enabled by the optional device-tre
Existing constraints in the driver were overly simplistic and do not
accurately represent the diversity of Clocking Wizard IP implementations.
Constant data added to express the constraints around available
rates, divider/multiplier ratios and hardware features. These were
extracted from the rele
Update clock provider to support fraction divider and multiplier ratios.
Ratios are now fixed point unsigned numbers with the lower WZRD_FRAC_BITS
containing the fractional part of the ratio.
Fractional ratios are only supported on MMCM primitives and only for the
PLL multiplier and first output d
Publish clock divider/multiplier ratios and flags specific to our
clock provider implementation as these are not available via the
debugfs entries provided by the common clock framework.
Signed-off-by: James Kelly
---
.../clocking-wizard/clk-xlnx-clock-wizard.c| 57 ++
Provide initial support for CCF clk_set_rate API on all clock components.
Clock consumers that want to set the first divider or PLL clock will need
to use clk_get_parent on one of the output clocks as there is no support
for CLK_SET_RATE_PARENT yet.
Care must be taken when setting the first divid
Allow CLK_SET_RATE_PARENT to be optionally enabled on one of the output
clocks. This will automatically choose the "best" rates for the first
divider and PLL multiplier. Best is defined as those first divider and
PLL multplier rates that minimise the error in the rate of the output clock
that has
Adds test_round_rate and test_set_rate entries to debugfs so that the
driver can be tested by a user space test application.
It would appear that patches that allow access to clk_set_rate from user
space are controversial so there is no expectation that this patch can
be merged.
Signed-off-by: Ja
Add support for the clk_round_rate API to our CCF clock provider.
Signed-off-by: James Kelly
---
.../clocking-wizard/clk-xlnx-clock-wizard.c| 107 +
1 file changed, 107 insertions(+)
diff --git a/drivers/staging/clocking-wizard/clk-xlnx-clock-wizard.c
b/drivers/stag
This series of patches attempts to implement many of the outstanding TODOs
for the Xilinx Clocking Wizard IP driver that has been languishing in the
staging tree for some time. I had a need for this driver so I thought it
appropriate to give it some love. Hopefully others will find these patches
The CCF clock providers that are currently used by the driver are not
capable of supporting the Clocking Wizard IP register interface for
fractional ratios, nor are they able to enforce constraints require to
ensure the PLL will always lock.
None of the common CCF clock providers seem to be a good
Add a description for how the Xilinx Clocking Wizard IP works to guide
subsequent patches.
Signed-off-by: James Kelly
---
.../clocking-wizard/clk-xlnx-clock-wizard.c| 52 ++
1 file changed, 52 insertions(+)
diff --git a/drivers/staging/clocking-wizard/clk-xlnx-clock-
Do some cosmetic cleanups before we start adding lots of code.
- Shorten clk_wzrd identifier to cw to keep lines short
- Replace &pdev->dev with dev to keep lines short
- Remove convenience variable np as it was only used once in function
- Add some tabs to make clk_wzrd structure definitions easi
The order of the internal clocks does not match how the hardware
is arranged. We need to fix this before we can add new function.
Swap the order of the internal multiplier and divider clocks so that the
divider is the parent of the multiplier.
Signed-off-by: James Kelly
---
.../clocking-wizard
Replace existing CCF clock providers with new clock provider that can
be enhanced to meet our needs.
AXI clock prepare/enable/disable/unprepare is now managed by regmap APIs.
Unregistering of clk instances now handled by devm APIs.
Drop warning that fractional ratios are not supported because it
Split probe function so that we can add more code in future patches
without it becoming too big.
Signed-off-by: James Kelly
---
.../clocking-wizard/clk-xlnx-clock-wizard.c| 63 +-
1 file changed, 51 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/clocking
Fixes a checkpatch.pl warning.
Signed-off-by: Nathan Chancellor
---
drivers/staging/android/ion/ion.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion.c
b/drivers/staging/android/ion/ion.c
index 269a431646be..d10b60fe4a29 100644
--- a/drivers/staging/android/io
checkpatch.pl complains these are invalid because the rules in
Documentation/process/license-rules.rst state that C headers should
have "/* */" style comments.
Signed-off-by: Nathan Chancellor
---
drivers/staging/android/ion/ion.h | 2 +-
drivers/staging/android/uapi/ion.h | 2 +-
2 files chang
Hi Wei Yang,
On 04/26/18 at 09:18am, Wei Yang wrote:
> On Thu, Apr 19, 2018 at 08:18:46AM +0800, Baoquan He wrote:
> >The struct resource uses singly linked list to link siblings. It's not
> >easy to do reverse iteration on sibling list. So replace it with list_head.
> >
>
> Hi, Baoquan
>
> Besi
Fixes checkpatch.pl warnings about lines ending with parentheses.
Signed-off-by: Nathan Chancellor
---
drivers/staging/android/vsoc.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/android/vsoc.c b/drivers/staging/android/vsoc.c
index b5307fa584d3..7e9cf3
Fixes checkpatch.pl warnings about lines ending with parentheses.
Signed-off-by: Nathan Chancellor
---
drivers/staging/android/vsoc.c | 21 ++---
1 file changed, 10 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/android/vsoc.c b/drivers/staging/android/vsoc.c
index
Fixes checkpatch.pl warnings about lines ending with parentheses.
Signed-off-by: Nathan Chancellor
---
drivers/staging/android/vsoc.c | 25 +++--
1 file changed, 11 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/android/vsoc.c b/drivers/staging/android/vsoc.c
in
Fixes checkpatch.pl warnings about lines ending with parentheses.
Signed-off-by: Nathan Chancellor
---
drivers/staging/android/vsoc.c | 42 +-
1 file changed, 21 insertions(+), 21 deletions(-)
diff --git a/drivers/staging/android/vsoc.c b/drivers/staging/android/
Fixes the following checkpatch.pl warning:
"prefer 'help' over '---help---' for new help texts"
Signed-off-by: Nathan Chancellor
---
drivers/staging/android/Kconfig | 4 ++--
drivers/staging/android/ion/Kconfig | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/st
Add the identifiers when missing and fix the ones already present
according to checkpatch.pl.
Signed-off-by: Nathan Chancellor
---
drivers/staging/android/ashmem.h| 6 +-
drivers/staging/android/uapi/ashmem.h | 6 +-
drivers/staging/android/uapi/vsoc_shm.h | 10 +-
dr
Thanks for these. Unfortunately you didn't cc me on the individual
patches so I had to go and look in the online archive.
Comments below.
On Sun, May 06 2018, Kamal Heib wrote:
> This patches fixes an compilation error and cleanup few errors reported
> by checkpatch.pl script.
>
> Cc: NeilBrown
Fixes a checkpatch.pl warning.
Signed-off-by: Nathan Chancellor
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7010/ks_hostif.c
index 094f8c11b4ab..628171091786 100644
--- a/driver
uwrq is an unsigned 32-bit integer, it cannot be less than zero.
Signed-off-by: Nathan Chancellor
---
drivers/staging/ks7010/ks_wlan_net.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/ks7010/ks_wlan_net.c
b/drivers/staging/ks7010/ks_wlan_net.c
index
This satisfies a checkpatch.pl warning and is the preferred method for
notating the license due to its lack of ambiguity.
Signed-off-by: Nathan Chancellor
---
drivers/staging/ks7010/ks7010_sdio.c | 5 +
drivers/staging/ks7010/ks7010_sdio.h | 5 +
drivers/staging/ks7010/ks_hostif.c
Fixes checkpatch.pl warnings.
Signed-off-by: Nathan Chancellor
---
drivers/staging/ks7010/ks_hostif.c | 4 ++--
drivers/staging/ks7010/ks_wlan.h | 4 ++--
drivers/staging/ks7010/ks_wlan_net.c | 8
3 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/ks701
checkpatch.pl warns about too many or not enough spaces in these
locations. Adjust them accordingly.
Signed-off-by: Nathan Chancellor
---
drivers/staging/ks7010/ks7010_sdio.c | 1 -
drivers/staging/ks7010/ks_hostif.c | 2 +-
drivers/staging/ks7010/michael_mic.c | 1 -
3 files changed, 1 insert
Fixes checkpatch.pl warnings.
Signed-off-by: Nathan Chancellor
---
drivers/staging/ks7010/ks_hostif.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7010/ks_hostif.c
index a2833707e0bf..094f8c11b4ab 100644
--- a/d
GCC warns these variables are all set but never used so remove them.
Signed-off-by: Nathan Chancellor
---
drivers/staging/ks7010/ks_hostif.c | 12 +---
1 file changed, 1 insertion(+), 11 deletions(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7010/ks_hostif.c
i
This patches fixes an compilation error and cleanup few errors reported
by checkpatch.pl script.
Cc: NeilBrown
Cc: Greg Kroah-Hartman
Kamal Heib (4):
staging: mt7621-eth: Fix compilation error
staging: mt7621-eth: Remove unnecessary blank lines
staging: mt7621-eth: Add missing blank lines
Fix the following compilation error:
error: passing argument 3 of ‘dma_alloc_coherent’ from incompatible pointer type
Signed-off-by: Kamal Heib
---
drivers/staging/mt7621-eth/mtk_eth_soc.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-eth/mtk_eth
Remove un-necessary blank lines to solve errors found by checkpatch.pl.
Signed-off-by: Kamal Heib
---
drivers/staging/mt7621-eth/ethtool.c| 1 -
drivers/staging/mt7621-eth/gsw_mt7621.c | 2 --
drivers/staging/mt7621-eth/soc_mt7621.c | 1 -
3 files changed, 4 deletions(-)
diff --git a/driver
Add missing blank lines after declarations to solve checkpatch.pl errors.
Signed-off-by: Kamal Heib
---
drivers/staging/mt7621-eth/gsw_mt7621.c | 1 +
drivers/staging/mt7621-eth/mdio.c | 2 ++
2 files changed, 3 insertions(+)
diff --git a/drivers/staging/mt7621-eth/gsw_mt7621.c
b/drivers
Fix alignment issues reported by checkpatch.pl.
Signed-off-by: Kamal Heib
---
drivers/staging/mt7621-eth/mtk_eth_soc.c | 22 --
1 file changed, 12 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/mt7621-eth/mtk_eth_soc.c
b/drivers/staging/mt7621-eth/mtk_eth_soc.c
On Thu, 3 May 2018 22:56:54 -0400
Brian Masney wrote:
> Hey Jonathan,
>
> I intentionally didn't run git format-patch with the --no-renames since
> patch 10 renamed the driver. Here is the .[ch] files included inline to
> make your review easier.
Thanks :)
A few really minor things beyond that
On Thu, 3 May 2018 22:53:18 -0400
Brian Masney wrote:
> This patch renames this driver from tsl2x7x to tsl2772 since it is
> highly likely that additional devices will be added to this driver that
> do not match that wildcard. The tsl2772 driver name was selected since
> that is currently the de
On Thu, 3 May 2018 22:53:17 -0400
Brian Masney wrote:
> The thresh periods assumed an integration time of 3ms. This patch adds
> support for the correct integration time (2.72ms or 2.73ms). The code
> had the ALS filter values as going up to 15, however the values actually
> went up to 60 since
On Thu, 3 May 2018 22:53:16 -0400
Brian Masney wrote:
> This patch adds the device IDs to the device_channel_config array to
> improve code readability.
>
> Signed-off-by: Brian Masney
Applied to the togreg branch of iio.git and pushed out as testing
for the autobuilders to play with it.
Than
On Thu, 3 May 2018 22:53:15 -0400
Brian Masney wrote:
> The driver assumed that the ALS increment was 2.72 ms, and the upper
> range was 696 ms. Some other supported devices use 2.73 ms - 699 ms.
> This patch adds support for the multiple ranges.
>
> Signed-off-by: Brian Masney
My problem her
On Sun, May 06, 2018 at 08:19:49PM +0300, Alexey Dobriyan wrote:
> +++ b/fs/proc/internal.h
> @@ -48,8 +48,8 @@ struct proc_dir_entry {
> const struct seq_operations *seq_ops;
> int (*single_show)(struct seq_file *, void *);
> };
> - unsigned int state_size;
>
On Thu, 3 May 2018 22:53:14 -0400
Brian Masney wrote:
> The integration_time sysfs attribute did not report the correct
> time. Changing the integration time would cause the reported lux to
> change wildly. Once the integration time was corrected, all of the
> equations, and lux tables needed to
On Thu, 3 May 2018 22:53:12 -0400
Brian Masney wrote:
> The calibscale_available attribute is currently associated with the
> IIO_LIGHT channel but should be associated with the IIO_INTENSITY
> channel. This patch corrects that association and it also corrects
> lines that were unnecessarily spl
On Thu, 3 May 2018 22:53:11 -0400
Brian Masney wrote:
> The driver would expose to userspace the events directory even if the
> interrupts were not configured. This patch changes the driver so that
> the events directory is not exposed to user space if interrupts are
> not configured. This patch
On Thu, 3 May 2018 22:53:13 -0400
Brian Masney wrote:
> The in_intensity0_calibscale_available sysfs attribute has code that
> checks the device type to determine which calibration scales are
> available. This check is not necessary since all of the supported
> ALS device types use the scales 1
On Thu, 3 May 2018 22:53:10 -0400
Brian Masney wrote:
> The sysfs attributes in_illuminance0_target_input,
> in_illuminance0_calibrate, and in_proximity0_calibrate did not have
> proper range checking in place so this patch adds the correct range
> checks.
>
> Signed-off-by: Brian Masney
Appli
On Thu, 3 May 2018 22:53:09 -0400
Brian Masney wrote:
> The summary text for the GPL is not needed since the SPDX identifier
> is a legally binding shorthand that can be used instead.
>
> Signed-off-by: Brian Masney
I'm always less than totally keen on these patches not coming from the
copyrig
On Wed, Apr 25, 2018 at 05:47:47PM +0200, Christoph Hellwig wrote:
> Changes since V1:
> - open code proc_create_data to avoid setting not fully initialized
>entries live
> - use unsigned int for state_size
Need this to maintain sizeof(struct proc_dir_entry):
Otherwise ACK fs/proc/ part.
d
GCC warns these variables are all set but never used so remove them.
Signed-off-by: Nathan Chancellor
---
drivers/staging/wilc1000/host_interface.c | 12
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 6 --
2 files changed, 18 deletions(-)
diff --git a/drivers/sta
GCC warns that 'wid' is unused in wilc_remove_key and it's correct; the
variable is only local. Get rid of the function (since it just returns
zero) and shuffle the remaining code into one if statement.
Signed-off-by: Nathan Chancellor
---
drivers/staging/wilc1000/host_interface.c | 12 -
This statment triggers GCC's -Wtype-limit since key_index is an
unsigned integer so it cannot be less than zero.
Signed-off-by: Nathan Chancellor
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/wil
63 matches
Mail list logo