Hi Roy,
I love your patch! Yet something to improve:
[auto build test ERROR on staging/staging-testing]
[also build test ERROR on next-20180322]
[cannot apply to linus/master v4.16-rc6]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url
Hi Roy,
I love your patch! Perhaps something to improve:
[auto build test WARNING on staging/staging-testing]
[also build test WARNING on next-20180322]
[cannot apply to linus/master v4.16-rc6]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system
Some of the code for reading IEs is replicated multiple times in the
switch statement for get_ap_information(). Factor that code out into
read_ie().
Signed-off-by: Quytelda Kahja
---
drivers/staging/ks7010/ks_hostif.c | 31 +++
1 file changed, 15 insertions(+), 16 de
The AUTH_TYPE_OPEN_SYSTEM and AUTH_TYPE_SHARED_KEY #define lines
are duplicated in ks_hostif.h. Replace them both with one set of
Signed-off-by: Quytelda Kahja
---
drivers/staging/ks7010/ks_hostif.h | 7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ks701
The handling of hostif_infrastructure_set_request_t and
hostif_infrastructure_set2_request_t is identical, with the exception
of the event type value. Merge the two structs so they can be handled
by a single function ('hostif_infrastructure_set_request').
Signed-off-by: Quytelda Kahja
---
drive
Instead of using memcmp() to directly compare BSSIDs, use
ether_addr_equal() from 'linux/etherdevice.h'.
Signed-off-by: Quytelda Kahja
---
drivers/staging/ks7010/ks_hostif.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/sta
There are several instances where comments are spaced so far to the
right they cause the line to go over the 80 character limit. Move
these comments to above the statements they describe instead.
Signed-off-by: Quytelda Kahja
---
drivers/staging/ks7010/ks_hostif.c | 19 ---
1 fi
Most of the request structures defined in ks_hostif.h have common
members:
* __le16 phy_type;
* __le16 cts_mode;
* __le16 scan_type;
* __le16 capability;
* struct rate_set16_t rate_set;
Factor out these members into a common substructure of type
'hostif_request_t'. This allows a large portion of
There is no reason for comment describing the BSSID check for loop
to be spaced so far to the right. Move it above the for loop.
Signed-off-by: Quytelda Kahja
---
drivers/staging/ks7010/ks_hostif.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_h
From: Long Li
This is a best effort for estimating on how busy the ring buffer is for
that channel, based on available buffer to write in percentage. It is still
possible that at the time of actual ring buffer write, the space may not be
available due to other processes may be writing at the time
From: Long Li
In Vmbus, we have defined a function to calculate available ring buffer
percentage to write.
Use that function and remove duplicate netvsc code.
Signed-off-by: Long Li
---
drivers/net/hyperv/netvsc.c | 17 +++--
drivers/net/hyperv/netvsc_drv.c | 3 ---
2 files c
From: Long Li
Netvsc has a similar function to calculate how much ring buffer in
percentage is available to write. This function is useful for storvsc and
other vmbus devices.
Define a similar function in vmbus to be used by storvsc.
Signed-off-by: Long Li
---
drivers/hv/ring_buffer.c | 2 ++
From: Long Li
Unlike SCSI and FC, we don't use multiple channels for IDE.
Also fix the calculation for sub-channels.
Change log:
v2: Addressed comment on incorrect number of sub-channels.
(Michael Kelley )
Signed-off-by: Long Li
---
drivers/scsi/storvsc_drv.c | 7 +--
1 file changed, 5 in
In the current implementation, `rmmod snd_bcm2835` does not release
resources properly. It causes an oops when trying to list sound devices.
This commit fixes it.
The details WRT allocation / free are described below.
Device structure WRT allocation:
pdev
\childdev[]
\card
\chip
On 03/21/18 20:24, Andy Shevchenko wrote:
> On Wed, Mar 21, 2018 at 8:48 PM, Kirill Marinushkin
> wrote:
>> In the current implementation, `rmmod snd_bcm2835` does not release
>> resources properly. It causes an oops when trying to list sound devices.
>>
>> This commit fixes it.
>>
>> The details
The following patch series clean michael_mic source and header files. Changes
are
as follows:
* avoid camel cases in some structs and function definitions
* replace macros with inline functions
* use u8 type replacing some uint8_t types and avoid some no more
needed casts.
Sergio Paracuellos (12
Replace upper case fields and camel cases for fields included in
michael_mic_t structure
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 8 +++---
drivers/staging/ks7010/michael_mic.c | 54 ++--
drivers/staging/ks7010/michael_mic.h |
This commit replaces param which is uint8_t in michael_append
function in favour of preferred one u8.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/michael_mic.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/ks7010/michael_mic.c
b/drive
This commit replaces MichaelBlockFunction macro with similar inline function
renaming it to michael_block.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/michael_mic.c | 30 +++---
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/stagi
This commit replaces MichaelClear macro with similar inline function
renaming it to michael_clear.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/michael_mic.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/ks7010/michael_mic.c
This commit avoid camel cases in MichaelAppend function and params
renaming it to michael_append.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/michael_mic.c | 45 ++--
1 file changed, 22 insertions(+), 23 deletions(-)
diff --git a/drivers/staging/
This commit replaces uint8_t parameter for preferred one u8 in
michael_get_mic function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/michael_mic.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/michael_mic.c
b/drivers/staging/ks7010/m
This commit replace camel cases for name and params used in
MichaelMICFunction. This improves a bit readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 24
drivers/staging/ks7010/michael_mic.c | 15 +++
drivers/staging/ks
This commit avoid camel cases in MichaelInitFunction signature and params
renaming it to michael_init.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/michael_mic.c | 11 +--
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/ks7010/michael_mic.c
This commit replaces GetUInt32 with inline function renaming
it to get_uint32.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/michael_mic.c | 15 +--
1 file changed, 9 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/ks7010/michael_mic.c
b/drivers/staging/ks
This commit replaces PutUInt32 macro in favour of inline function
renaming it to put_uint32.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/michael_mic.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/ks7010/michael_mic.c
b/d
This commit avoid camel cases in MichaelGetMIC function and params
renaming it to michael_get_mic.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/michael_mic.c | 27 +--
1 file changed, 13 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/ks7010/m
This commit replaces uint8_t for preferred one u8 in parameter
of michael_init function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/michael_mic.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/michael_mic.c
b/drivers/staging/ks7010/m
Remove few unused headers files since the adis core handles the buffer and
sysfs support.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel/adis16201.c
ind
Use GENMASK to improve readability and remove the local variables used to
store intermediate data.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 34 +++---
1 file changed, 15 insertions(+), 19 deletions(-)
diff --git a/drivers/staging/iio/ac
Move adis16201 driver out of staging and merge into mainline
IIO subsystem.
Signed-off-by: Himanshu Jha
---
drivers/iio/accel/Kconfig | 12 ++
drivers/iio/accel/Makefile| 1 +
drivers/iio/accel/adis16201.c | 321 ++
drivers/stagi
Split the line over 80 characters limit to fix checkpatch
warning.
Signed-off-by: Himanshu Jha
---
drivers/staging/iio/accel/adis16201.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/iio/accel/adis16201.c
b/drivers/staging/iio/accel/adis16201.c
index e759
From: Haiyang Zhang
This patch adds range checking for rx packet offset and length.
It may only happen if there is a host side bug.
Signed-off-by: Haiyang Zhang
---
drivers/net/hyperv/hyperv_net.h | 1 +
drivers/net/hyperv/netvsc.c | 17 +++--
2 files changed, 16 insertions(+)
From: Haiyang Zhang
As defined in hyperv_net.h, the NVSP_STAT_SUCCESS is one not zero.
Some functions returns 0 when it actually means NVSP_STAT_SUCCESS.
This patch fixes them.
In netvsc_receive(), it puts the last RNDIS packet's receive status
for all packets in a vmxferpage which may contain m
From: Haiyang Zhang
Fix the status code returned to the host. Also add range
check for rx packet offset and length.
Haiyang Zhang (2):
hv_netvsc: Fix the return status in RX path
hv_netvsc: Add range checking for rx packet offset and length
drivers/net/hyperv/hyperv_net.h | 1 +
drivers
On Mon, Mar 19, 2018 at 10:58:10PM -0700, Quytelda Kahja wrote:
> Some of the code for reading IEs is replicated multiple times in the
> switch statement for get_ap_information(). Factor that code out into
> read_ie().
>
> Signed-off-by: Quytelda Kahja
> ---
> drivers/staging/ks7010/ks_hostif.c
On Mon, Mar 19, 2018 at 10:58:15PM -0700, Quytelda Kahja wrote:
> The code to initialize various different types of request structs
> is repeated multiple times. Factor this code out into a macro
> called INIT_REQUEST.
>
> Signed-off-by: Quytelda Kahja
> ---
> drivers/staging/ks7010/ks_hostif.c
On Mon, Mar 19, 2018 at 10:58:12PM -0700, Quytelda Kahja wrote:
> Remove unnecessary parentheses highlighted by checkpatch.
>
> Signed-off-by: Quytelda Kahja
> ---
> drivers/staging/ks7010/ks_hostif.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/k
From: Stephen Hemminger
Date: Tue, 20 Mar 2018 15:03:01 -0700
> This set of patches fixes issues identified by Vitaly Kuznetsov and
> Mohammed Gamal related to state changes in Hyper-v network driver.
>
> A lot of the issues are because setting up the netvsc device requires
> a second step (in w
On 22/03/18 12:27, Jian Zhang wrote:
This is a patch to the cb_pcidas64.c file that fixes up a multiple line
dereference warning found by the checkpatch.pl tool
Signed-off-by: Jian Zhang
---
drivers/staging/comedi/drivers/cb_pcidas64.c | 17 +++--
1 file changed, 7 insertions(+)
This is a patch to the cb_pcidas64.c file that fixes up a multiple line
dereference warning found by the checkpatch.pl tool
Signed-off-by: Jian Zhang
---
drivers/staging/comedi/drivers/cb_pcidas64.c | 17 +++--
1 file changed, 7 insertions(+), 10 deletions(-)
diff --git a/drivers/s
On Thu, Mar 22, 2018 at 08:27:28PM +0800, Jian Zhang wrote:
> This is a patch to the cb_pcidas64.c file that fixes up a multiple line
> dereference warning found by the checkpatch.pl tool
Please properly wrap your changelog comments at 72 columns, like your
editor tried to force you to do :)
>
Hello Stefan Wahren,
The patch d1eab9dec610: "staging: vchiq_core: Bail out in case of
invalid tx_pos" from May 26, 2017, leads to the following static
checker warning:
drivers/staging/vc04_services/interface/vchiq_arm/vchiq_core.c:617
reserve_space()
warn: inconsistent returns 'state->slot_avai
From: Colin Ian King
Trivial fix to spelling mistake in dev_err message text
Signed-off-by: Colin Ian King
---
drivers/staging/mt7621-eth/mtk_eth_soc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/mt7621-eth/mtk_eth_soc.c
b/drivers/staging/mt7621-eth/mtk
Dear Friend,
I have a profitable business to share with you .But only need your
permision to disclose it to you.
Thanks
Ahmed Zama
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-de
45 matches
Mail list logo