[PATCH 2/2] drivers: android: binder: fixed a brace coding style issue

2018-03-09 Thread Vaibhav Murkute
Fixed a coding style issue. Signed-off-by: Vaibhav Murkute --- drivers/android/binder.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/android/binder.c b/drivers/android/binder.c index 764b63a5aade..2729bb75ca19 100644 --- a/drivers/android/binder.c +++ b/drive

Re: [PATCH] staging: lustre: o2iblnd: fix race at kiblnd_connect_peer

2018-03-09 Thread Doug Oucharek
Please ignore this patch. Turns out it depends on a series which has not been submitted yet. I’ll resend this one once all of those are done. Doug > On Mar 9, 2018, at 3:29 PM, Doug Oucharek wrote: > > cmid will be destroyed at OFED if kiblnd_cm_callback return error. > if error happen befor

[PATCH] staging: lustre: o2iblnd: fix race at kiblnd_connect_peer

2018-03-09 Thread Doug Oucharek
cmid will be destroyed at OFED if kiblnd_cm_callback return error. if error happen before the end of kiblnd_connect_peer, it will touch destroyed cmid and fail as (o2iblnd_cb.c:1315:kiblnd_connect_peer()) ASSERTION( cmid->device != ((void *)0) ) failed: Signed-off-by: Alexander Boyko I

[PATCH 4/4] staging:iio:ad2s1210: Add comments/documentation

2018-03-09 Thread Rodrigo Siqueira
The original code of AD2S1210 does not have documentation for structs and register configurations; this difficult the code comprehension. This patch adds structs documentation, briefly comments some register settings and acronyms, and adds little explanations of some calculation found in the code.

[PATCH 2/4] staging:iio:ad2s1210: Remove unused #define directive

2018-03-09 Thread Rodrigo Siqueira
This patch removes some #define directives not used in the code. Signed-off-by: Rodrigo Siqueira --- drivers/staging/iio/resolver/ad2s1210.c | 10 -- 1 file changed, 10 deletions(-) diff --git a/drivers/staging/iio/resolver/ad2s1210.c b/drivers/staging/iio/resolver/ad2s1210.c index 0cd

[PATCH 3/4] staging:iio:ad2s1210: Remove old_data from ad2s1210_state

2018-03-09 Thread Rodrigo Siqueira
The variable old_data is a bool type, which only receives the value 'true' in the function ad2s1210_config_write and ad2s1210_config_read. There is no other use for this variable. This patch removes old_data from the ad2s1210_state and from all the function that use it. Signed-off-by: Rodrigo Siqu

[PATCH 0/4] staging:iio:ad2s1210: Driver cleanup

2018-03-09 Thread Rodrigo Siqueira
This patchset removes some unused #define directive and variables. Additionally, it fixes two checkpatch problems. Finally, the last patch adds struct documentation and comments to some part of the code. All of the changes have the intention to improve the readability of new updates. Rodrigo Siqu

[PATCH 1/4] staging:iio:ad2s1210: Remove end of line with '['

2018-03-09 Thread Rodrigo Siqueira
This patch fixes the checkpatch.pl check: iio/resolver/ad2s1210.c:202: CHECK: Lines should not end with a '[' Signed-off-by: Rodrigo Siqueira --- drivers/staging/iio/resolver/ad2s1210.c | 7 --- 1 file changed, 4 insertions(+), 3 deletions(-) diff --git a/drivers/staging/iio/resolver/ad2s1

RE: [PATCH v3 1/6] PCI: hv: fix a comment typo in _hv_pcifront_read_config()

2018-03-09 Thread Haiyang Zhang
> -Original Message- > From: Dexuan Cui > Sent: Tuesday, March 6, 2018 1:22 PM > To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan > ; Stephen Hemminger ; > o...@aepfle.de; a...@canonical.com; jasow...@redhat.com > Cc: linux-ker...@vger.kernel.org; driverdev-devel@linuxdri

RE: [PATCH v3 2/6] PCI: hv: hv_eject_device_work(): remove the bogus test

2018-03-09 Thread Haiyang Zhang
> -Original Message- > From: Dexuan Cui > Sent: Tuesday, March 6, 2018 1:22 PM > To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan > ; Stephen Hemminger ; > o...@aepfle.de; a...@canonical.com; jasow...@redhat.com > Cc: linux-ker...@vger.kernel.org; driverdev-devel@linuxdri

RE: [PATCH v3 4/6] PCI: hv: remove hbus->enum_sem

2018-03-09 Thread Haiyang Zhang
> -Original Message- > From: Dexuan Cui > Sent: Tuesday, March 6, 2018 1:22 PM > To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan > ; Stephen Hemminger ; > o...@aepfle.de; a...@canonical.com; jasow...@redhat.com > Cc: linux-ker...@vger.kernel.org; driverdev-devel@linuxdri

RE: [PATCH v3 5/6] PCI: hv: hv_pci_devices_present(): only queue a new work when necessary

2018-03-09 Thread Haiyang Zhang
> -Original Message- > From: Dexuan Cui > Sent: Tuesday, March 6, 2018 1:22 PM > To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan > ; Stephen Hemminger ; > o...@aepfle.de; a...@canonical.com; jasow...@redhat.com > Cc: linux-ker...@vger.kernel.org; driverdev-devel@linuxdri

RE: [PATCH v3 3/6] PCI: hv: serialize the present/eject work items

2018-03-09 Thread Haiyang Zhang
> -Original Message- > From: Dexuan Cui > Sent: Tuesday, March 6, 2018 1:22 PM > To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan > ; Stephen Hemminger ; > o...@aepfle.de; a...@canonical.com; jasow...@redhat.com > Cc: linux-ker...@vger.kernel.org; driverdev-devel@linuxdri

RE: [PATCH v3 6/6] PCI: hv: fix 2 hang issues in hv_compose_msi_msg()

2018-03-09 Thread Haiyang Zhang
> -Original Message- > From: Dexuan Cui > Sent: Tuesday, March 6, 2018 1:22 PM > To: bhelg...@google.com; linux-...@vger.kernel.org; KY Srinivasan > ; Stephen Hemminger ; > o...@aepfle.de; a...@canonical.com; jasow...@redhat.com > Cc: linux-ker...@vger.kernel.org; driverdev-devel@linuxdri

Re: [PATCH] typec: tcpm: fusb302: Do not log an error on -EPROBE_DEFER

2018-03-09 Thread Greg Kroah-Hartman
On Sun, Feb 25, 2018 at 04:20:01PM +0100, Hans de Goede wrote: > Do not log an error if tcpm_register_port() fails with -EPROBE_DEFER. > > Fixes: commit cf140a356971 ("typec: fusb302: Use dev_err during probe") > Signed-off-by: Hans de Goede > --- > drivers/usb/typec/fusb302/fusb302.c | 3 ++- >

Re: [PATCH] staging: vchiq_arm: Clear VLA warning

2018-03-09 Thread Linus Torvalds
On Fri, Mar 9, 2018 at 10:35 AM, Kees Cook wrote: > > I think you mean ARRAY_SIZE(service_data) ? In that case, yeah, it > seems like a raw "64" for the array size can be used instead. I think 64 is much too big anyway. That's 768 bytes of stack data that is used to check stuff deep in some trans

Re: [PATCH net-next] hv_netvsc: Correct filter setting for multicast/broadcast

2018-03-09 Thread Sergei Shtylyov
On 03/09/2018 09:37 PM, Sergei Shtylyov wrote: >> Commit 009f766 intended to filter multicast/broadcast, however > >At least 12 digits needed here, and the summary line too, just like you do > for the Fixes: tag. > >> the NDIS filter wasn't set properly in non-promiscuous modes, >> which res

Re: [PATCH net-next] hv_netvsc: Correct filter setting for multicast/broadcast

2018-03-09 Thread Sergei Shtylyov
Hello! On 03/09/2018 04:25 PM, Mohammed Gamal wrote: > Commit 009f766 intended to filter multicast/broadcast, however At least 12 digits needed here, and the summary line too, just like you do for the Fixes: tag. > the NDIS filter wasn't set properly in non-promiscuous modes, > which resulte

[PATCH v2 2/2] staging: fsl-dpaa2/eth: allow the driver to compile multi-arch

2018-03-09 Thread Ioana Radulescu
Drop dependency on ARCH_LAYERSCAPE (which in turn depends on ARM64), thus allowing this driver to compile on all architectures supported by the fsl-mc bus driver. This was compile tested on: - powerpc (corenet_basic_defconfig, ppc64_defconfig) - x86 (i386_defconfig, x86_64_defconfig, needs CONFI

[PATCH v2 1/2] staging: fsl-dpaa2/eth: Use __leXX types where needed

2018-03-09 Thread Ioana Radulescu
One MC command structure got away with using uXX fields instead of __leXX. Fix it. Signed-off-by: Ioana Radulescu --- v2: new patch drivers/staging/fsl-dpaa2/ethernet/dpni-cmd.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/fsl-dpaa2/ethernet/dpni-cmd.h

[PATCH v2 0/2] fsl-dpaa2/eth: Enable multi-arch compile

2018-03-09 Thread Ioana Radulescu
The Ethernet driver can be built on multiple architectures, so remove the ARCH_LAYERSCAPE dependency from its Kconfig. This patchset is marked as v2 because it includes the final patch from this set: https://lkml.org/lkml/2018/2/26/626, preceeded by a patch fixing a sparse warning when building on

Re: [PATCH] staging: vchiq_arm: Clear VLA warning

2018-03-09 Thread Kees Cook
On Fri, Mar 9, 2018 at 10:11 AM, Eric Anholt wrote: > "Tobin C. Harding" writes: > >> The kernel would like to have all stack VLA usage removed[1]. The >> array here is fixed (declared with a const variable) but it appears >> like VLA to the compiler. We can use a pre-processor define to quiet

Re: [PATCH] staging: vchiq_arm: Clear VLA warning

2018-03-09 Thread Eric Anholt
"Tobin C. Harding" writes: > The kernel would like to have all stack VLA usage removed[1]. The > array here is fixed (declared with a const variable) but it appears > like VLA to the compiler. We can use a pre-processor define to quiet > the compiler. > > [1]: https://lkml.org/lkml/2018/3/7/621

[PATCH] staging:r8188eu: Use lib80211 to support TKIP

2018-03-09 Thread Ivan Safonov
Custom TKIP decryption replaced with lib80211 implementation. MIC check use lib80211 too. Signed-off-by: Ivan Safonov --- drivers/staging/rtl8188eu/Kconfig | 1 + drivers/staging/rtl8188eu/core/rtw_recv.c | 161 -- drivers/staging/rtl8188eu/core/rtw_secu

Re: [PATCH] PCI: hv: fix bus domain ID corruption

2018-03-09 Thread Lorenzo Pieralisi
On Fri, Mar 09, 2018 at 05:02:34AM +, Sridhar Pitchai wrote: > When PCI BUS is added, PCI_BUS domain ID is set. When PCI_BUS and a device > added to the bus is racing against each other, the first device tends to > overwrite the domain ID. In order to avoid the race, this patch make sure > when

Re: [PATCH net-next] hv_netvsc: Correct filter setting for multicast/broadcast

2018-03-09 Thread David Miller
From: Mohammed Gamal Date: Fri, 9 Mar 2018 12:22:22 +0100 > Commit 009f766 intended to filter multicast/broadcast, however > it did cause DHCP timeouts. A closer look showed that the filters > were not set properly causing this issue. > > Fixes: 009f766 ("hv_netvsc: filter multicast/broadcast")

[PATCH net-next] hv_netvsc: Correct filter setting for multicast/broadcast

2018-03-09 Thread Mohammed Gamal
Commit 009f766 intended to filter multicast/broadcast, however the NDIS filter wasn't set properly in non-promiscuous modes, which resulted in issues like DHCP timeouts. This patch sets the filter flags correctly. Fixes: 009f766 ("hv_netvsc: filter multicast/broadcast") Signed-off-by: Mohammed Ga

Re: [PATCH v2 1/3] staging: xm2mvscale: Driver support for Xilinx M2M Video Scaler

2018-03-09 Thread Hans Verkuil
On 22/02/18 14:46, Greg KH wrote: > On Wed, Feb 21, 2018 at 02:43:14PM -0800, Rohit Athavale wrote: >> This commit adds driver support for the pre-release Xilinx M2M Video >> Scaler IP. There are three parts to this driver : >> >> - The Hardware/IP layer that reads and writes register of the IP >>

Re: [PATCH 00/10] staging: wilc1000: fixes for checkpatch issues & coding style related

2018-03-09 Thread Claudiu Beznea
Reviewed-by: Claudiu Beznea On 07.03.2018 04:13, Ajay Singh wrote: > This patch series contains modification to remove the checkpatch warnings > and changes to follow linux coding style. > > Ajay Singh (10): > staging: wilc1000: rename pstrHostIFconnectAttr to avoid camelCase > issue > s

Re: [lustre-devel] [PATCH v2] staging: lustre: Remove VLA usage

2018-03-09 Thread Dilger, Andreas
On Mar 7, 2018, at 13:54, Kees Cook wrote: > > The kernel would like to have all stack VLA usage removed[1]. This switches > to a simple kasprintf() instead, and in the process fixes an off-by-one > between the allocation and the sprintf (allocation did not include NULL > byte in calculation). >

Re: [PATCH 00/10] staging: wilc1000: fixes related to camelCase & line over 80 chars

2018-03-09 Thread Claudiu Beznea
Reviewed-by: Claudiu Beznea On 07.03.2018 03:32, Ajay Singh wrote: > Patch series contains fixes to remove checkpatch reported warnings. > > Ajay Singh (10): > staging: wilc1000: rename strHiddenNetwork to avoid camelCase > staging: wilc1000: rename pstrNetworkInfo to avoid camelCase > sta

Re: [PATCH 10/10] staging: wilc1000: fix line over 80 char in cfg_scan_result()

2018-03-09 Thread Claudiu Beznea
On 07.03.2018 03:32, Ajay Singh wrote: > Refactor cfg_scan_result() API to avoid 'line over 80 chars' issue > reported by checkpatch.pl script. > > Signed-off-by: Ajay Singh > --- > drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 148 > +++--- > 1 file changed, 77 insertio