[PATCH] binder: check for binder_thread allocation failure in binder_poll()

2018-01-30 Thread Eric Biggers
From: Eric Biggers If the kzalloc() in binder_get_thread() fails, binder_poll() dereferences the resulting NULL pointer. Fix it by returning POLLERR if the memory allocation failed. This bug was found by syzkaller using fault injection. Reported-by: syzbot Fixes: 457b9a6f09f0 ("Staging: andro

Re: BUG: unable to handle kernel NULL pointer dereference in binder_poll

2018-01-30 Thread Eric Biggers
On Mon, Dec 18, 2017 at 08:23:01AM -0800, syzbot wrote: > Hello, > > syzkaller hit the following crash on > 6084b576dca2e898f5c101baef151f7bfdbb606d > git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/master > compiler: gcc (GCC) 7.1.1 20170620 > .config is attached > Raw console o

[PATCH] Staging: speakup: Fixed a multiple assignment issue

2018-01-30 Thread Shannon Booth
Fixed a coding style issue. Signed-off-by: Shannon Booth --- drivers/staging/speakup/main.c | 9 ++--- 1 file changed, 6 insertions(+), 3 deletions(-) diff --git a/drivers/staging/speakup/main.c b/drivers/staging/speakup/main.c index cf12590..b721f41 100644 --- a/drivers/staging/speakup/mai

[PATCH] staging: android: ion: Remove unused declaration ion_buffer_fault_user_mappings

2018-01-30 Thread Yisheng Xie
ion_buffer_fault_user_mappings's definition has been removed and not be used anymore, just remove its useless declaration. Signed-off-by: Yisheng Xie --- drivers/staging/android/ion/ion.h | 9 - 1 file changed, 9 deletions(-) diff --git a/drivers/staging/android/ion/ion.h b/drivers/sta

Re: [PATCH 1/1] scsi: storvsc: Increase cmd_per_lun for higher speed devices

2018-01-30 Thread Martin K. Petersen
> Increase cmd_per_lun to allow more I/Os in progress per device, > particularly for NVMe's. The Hyper-V host side can handle the > higher count with no issues. Long/KY/Cathy/Stephen: Please ack/review Michael's patches. -- Martin K. Petersen Oracle Linux Engineering _

Re: [PATCH v4 5/7] x86/irq: Count Hyper-V reenlightenment interrupts

2018-01-30 Thread Thomas Gleixner
On Tue, 30 Jan 2018, Thomas Gleixner wrote: > On Tue, 30 Jan 2018, Radim Krčmář wrote: > > 2018-01-29 22:48+0100, Thomas Gleixner: > > > On Wed, 24 Jan 2018, Radim Krčmář wrote: > > > > 2018-01-24 14:23+0100, Vitaly Kuznetsov: > > > > > Hyper-V reenlightenment interrupts arrive when the VM is migr

Re: [PATCH v2] staging: android: ion: Add implementation of dma_buf_vmap and dma_buf_vunmap

2018-01-30 Thread alexey
On 01/31/2018 12:15 AM, Greg KH wrote: On Tue, Jan 30, 2018 at 10:39:13PM +0200, Alexey Skidanov wrote: dma_buf_vmap and dma_buf_vunmap allow drivers to access buffers, created by ion. But why would anyone ever want to do that? What is wrong with the existing interfaces that drivers use to a

Re: [PATCH v2] staging: android: ion: Add implementation of dma_buf_vmap and dma_buf_vunmap

2018-01-30 Thread Greg KH
On Tue, Jan 30, 2018 at 10:39:13PM +0200, Alexey Skidanov wrote: > dma_buf_vmap and dma_buf_vunmap allow drivers to access buffers, created by > ion. But why would anyone ever want to do that? What is wrong with the existing interfaces that drivers use to access buffers created by ion? What cod

Re: BUG: unable to handle kernel NULL pointer dereference in binder_deferred_func

2018-01-30 Thread Eric Biggers
On Tue, Dec 19, 2017 at 08:25:00AM -0800, syzbot wrote: > Hello, > > syzkaller hit the following crash on > 6084b576dca2e898f5c101baef151f7bfdbb606d > git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/master > compiler: gcc (GCC) 7.1.1 20170620 > .config is attached > Raw console o

Re: binder epoll bug (was KASAN: use-after-free Read in __lock_acquire (2))

2018-01-30 Thread Eric Biggers
On Tue, Dec 12, 2017 at 04:05:17PM -0800, Eric Biggers wrote: > [+Cc binder maintainers and list] > [-Cc lockdep maintainers, USB maintainers, and other random people] > > On Sat, Dec 02, 2017 at 08:08:01AM -0800, syzbot wrote: > > BUG: KASAN: use-after-free in __lock_acquire+0x465e/0x47f0 > > ker

Re: [PATCH v2] staging: android: ion: Add implementation of dma_buf_vmap and dma_buf_vunmap

2018-01-30 Thread Dan Carpenter
Are you working against linux-next? The get_maintainer.pl script should have told you to CC a bunch of other Android maintainers as well. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org

[PATCH v2] staging: android: ion: Add implementation of dma_buf_vmap and dma_buf_vunmap

2018-01-30 Thread Alexey Skidanov
dma_buf_vmap and dma_buf_vunmap allow drivers to access buffers, created by ion. Signed-off-by: Alexey Skidanov --- Changes in v1: - Added changelog text drivers/staging/android/ion/ion.c | 13 + 1 file changed, 13 insertions(+) diff --git a/drivers/staging/android/ion/ion.c b/

Re: [RFC PATCH 2/2] hv_netvsc: Change GPADL teardown order according to Hyper-V version

2018-01-30 Thread Stephen Hemminger
On Tue, 23 Jan 2018 10:34:05 +0100 Mohammed Gamal wrote: > Commit 0cf737808ae7 ("hv_netvsc: netvsc_teardown_gpadl() split") > introduced a regression causing VMs not to shutdown on pre-Wind2016 > hosts after netvsc_remove_device() is called. This was caused as the > GPADL teardown sequence was ch

Re: [RFC PATCH 1/2] hv_netvsc: Split netvsc_revoke_buf() and netvsc_teardown_gpadl()

2018-01-30 Thread Stephen Hemminger
On Tue, 23 Jan 2018 10:34:04 +0100 Mohammed Gamal wrote: > Split each of the functions into two for each of send/recv buffers > > Signed-off-by: Mohammed Gamal Splitting these functions is not necessary ___ devel mailing list de...@linuxdriverproject

[PATCH v2 05/10] Staging: rtl8192e: kconfig: Remove empty help text

2018-01-30 Thread Ulf Magnusson
In preparation for adding a warning ("kconfig: Warn if help text is blank"): https://lkml.org/lkml/2018/1/30/516 Signed-off-by: Ulf Magnusson --- drivers/staging/rtl8192e/rtl8192e/Kconfig | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/rtl8192e/rtl8192e/Kconfig b/drivers/stag

[PATCH v2 04/10] Staging: rtl8192u: kconfig: Remove empty help text

2018-01-30 Thread Ulf Magnusson
In preparation for adding a warning ("kconfig: Warn if help text is blank"): https://lkml.org/lkml/2018/1/30/516 Signed-off-by: Ulf Magnusson --- drivers/staging/rtl8192u/Kconfig | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/rtl8192u/Kconfig b/drivers/staging/rtl8192u/Kconfi

[PATCH 05/10] Staging: rtl8192e: kconfig: Remove empty help text

2018-01-30 Thread Ulf Magnusson
In preparation for adding a warning ("kconfig: Warn if help text is blank"): https://lkml.org/lkml/2018/1/30/516 Signed-off-by: Ulf Magnusson --- drivers/staging/rtl8192e/rtl8192e/Kconfig | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/rtl8192e/rtl8192e/Kconfig b/drivers/stag

[PATCH 04/10] Staging: rtl8192u: kconfig: Remove empty help text

2018-01-30 Thread Ulf Magnusson
In preparation for adding a warning ("kconfig: Warn if help text is blank"): https://lkml.org/lkml/2018/1/30/516 Signed-off-by: Ulf Magnusson --- drivers/staging/rtl8192u/Kconfig | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/rtl8192u/Kconfig b/drivers/staging/rtl8192u/Kconfi

[PATCH v3] Staging: iio: ade7758: Expand buf_lock to cover both buffer and state protection

2018-01-30 Thread Shreeya Patel
iio_dev->mlock is to be used only by the IIO core for protecting device mode changes between INDIO_DIRECT and INDIO_BUFFER. This patch replaces the use of mlock with the already established buf_lock mutex. Introducing 'unlocked' forms of read and write registers. The read/write frequency function

[PATCH 3/7] staging: wilc1000: rename strWIDList variable to avoid camelCase

2018-01-30 Thread Ajay Singh
Fix "Avoid camelCase" issue found by checkpatch.pl script. Signed-off-by: Ajay Singh Reviewed-by: Claudiu Beznea --- drivers/staging/wilc1000/host_interface.c | 176 +++--- 1 file changed, 88 insertions(+), 88 deletions(-) diff --git a/drivers/staging/wilc1000/host_inte

[PATCH 5/7] staging: wilc1000: rename pu8CurrByte variable to avoid camelCase

2018-01-30 Thread Ajay Singh
Fix "Avoid camelCase" issue reported by checkpatch.pl script. Signed-off-by: Ajay Singh Reviewed-by: Claudiu Beznea --- drivers/staging/wilc1000/host_interface.c | 232 +++--- 1 file changed, 116 insertions(+), 116 deletions(-) diff --git a/drivers/staging/wilc1000/host

[PATCH 7/7] staging: wilc1000: rename Handle_Key() and Handle_ConnectTimeout()

2018-01-30 Thread Ajay Singh
Fix "Avoid camelCase" issue found by checkpatch.pl script. Signed-off-by: Ajay Singh Reviewed-by: Claudiu Beznea --- drivers/staging/wilc1000/host_interface.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging

[PATCH 4/7] staging: wilc1000: rename u32WidsCount to avoid camelCase

2018-01-30 Thread Ajay Singh
Fix "Avoid camleCase" issue reported by checkpatch.pl script. Signed-off-by: Ajay Singh Reviewed-by: Claudiu Beznea --- drivers/staging/wilc1000/host_interface.c | 146 +++--- 1 file changed, 73 insertions(+), 73 deletions(-) diff --git a/drivers/staging/wilc1000/host_i

[PATCH 6/7] staging: wilc1000: rename Handle_ScanDone function to avoid camelCase

2018-01-30 Thread Ajay Singh
Fix "Avoid camelCase" issue reported by checkpatch.pl. Signed-off-by: Ajay Singh Reviewed-by: Claudiu Beznea --- drivers/staging/wilc1000/host_interface.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/st

[PATCH 2/7] staging: wilc1000: rename Handle_DelAllSta() and its variable using camelCase

2018-01-30 Thread Ajay Singh
Fix "Avoid camelCase" issue reported by checkpatch.pl script. Signed-off-by: Ajay Singh Reviewed-by: Claudiu Beznea --- drivers/staging/wilc1000/host_interface.c | 24 1 file changed, 12 insertions(+), 12 deletions(-) diff --git a/drivers/staging/wilc1000/host_interfac

[PATCH 0/7] fixes to avoid use of cameCase

2018-01-30 Thread Ajay Singh
Patch set to fix "Avoid camelCase" issues found by checkpatch.pl. Ajay Singh (7): staging: wilc1000: rename variables using camelCase in host_int_ParseJoinBssParam() staging: wilc1000: rename Handle_DelAllSta() and its variable using camelCase staging: wilc1000: rename strWIDList var

[PATCH 1/7] staging: wilc1000: rename variables using camelCase in host_int_ParseJoinBssParam()

2018-01-30 Thread Ajay Singh
Fix "Avoid CamelCase:" issue reported by checkpatch.pl script. Rename host_int_ParseJoinBssParam() & its variables using camelCase. Signed-off-by: Ajay Singh Reviewed-by: Claudiu Beznea --- drivers/staging/wilc1000/host_interface.c | 230 +++--- 1 file changed, 115 inser

Re: [PATCH] staging: android: ion: Add implementation of dma_buf_vmap and dma_buf_vunmap

2018-01-30 Thread Greg KH
On Tue, Jan 30, 2018 at 05:47:38PM +0200, Alexey Skidanov wrote: > Signed-off-by: Alexey Skidanov > --- I can't take patches without any changelog text at all, sorry :( Please fix up and describe _why_ you are making this change. thanks, greg k-h ___

Re: [PATCH v2 13/14] staging: wilc1000: rename Handle_Connect() to avoid camelCase

2018-01-30 Thread Ajay Singh
On Tue, 30 Jan 2018 17:40:31 +0300 Dan Carpenter wrote: > On Tue, Jan 30, 2018 at 07:29:49PM +0530, Ajay Singh wrote: > > On Tue, 30 Jan 2018 02:13:53 +0800 > > kbuild test robot wrote: > > > > > > > > > The patch only change variable names to avoid the camelCase, didn't modify > > any ex

[PATCH] staging: android: ion: Add implementation of dma_buf_vmap and dma_buf_vunmap

2018-01-30 Thread Alexey Skidanov
Signed-off-by: Alexey Skidanov --- drivers/staging/android/ion/ion.c | 13 + 1 file changed, 13 insertions(+) diff --git a/drivers/staging/android/ion/ion.c b/drivers/staging/android/ion/ion.c index f480885..4f1dc7f 100644 --- a/drivers/staging/android/ion/ion.c +++ b/drivers/stagin

Re: [PATCH v2 13/14] staging: wilc1000: rename Handle_Connect() to avoid camelCase

2018-01-30 Thread Dan Carpenter
On Tue, Jan 30, 2018 at 07:29:49PM +0530, Ajay Singh wrote: > On Tue, 30 Jan 2018 02:13:53 +0800 > kbuild test robot wrote: > > > > The patch only change variable names to avoid the camelCase, didn't modify > any extra code to dereference memory. You are responding to a robot and I think we

Re: [PATCH v2 13/14] staging: wilc1000: rename Handle_Connect() to avoid camelCase

2018-01-30 Thread Dan Carpenter
On Tue, Jan 30, 2018 at 02:13:53AM +0800, kbuild test robot wrote: > Hi Ajay, > > Thank you for the patch! Perhaps something to improve: > > [auto build test WARNING on staging/staging-testing] > [cannot apply to v4.15 next-20180126] > [if your patch is applied to the wrong git tree, please drop

Re: [PATCH v4 5/7] x86/irq: Count Hyper-V reenlightenment interrupts

2018-01-30 Thread Thomas Gleixner
On Tue, 30 Jan 2018, Radim Krčmář wrote: > 2018-01-29 22:48+0100, Thomas Gleixner: > > On Wed, 24 Jan 2018, Radim Krčmář wrote: > > > 2018-01-24 14:23+0100, Vitaly Kuznetsov: > > > > Hyper-V reenlightenment interrupts arrive when the VM is migrated, we're > > > > not supposed to see many of them. H

Re: [PATCH v4 5/7] x86/irq: Count Hyper-V reenlightenment interrupts

2018-01-30 Thread Radim Krčmář
2018-01-29 22:48+0100, Thomas Gleixner: > On Wed, 24 Jan 2018, Radim Krčmář wrote: > > 2018-01-24 14:23+0100, Vitaly Kuznetsov: > > > Hyper-V reenlightenment interrupts arrive when the VM is migrated, we're > > > not supposed to see many of them. However, it may be important to know > > > that the

Re: [PATCH v2 13/14] staging: wilc1000: rename Handle_Connect() to avoid camelCase

2018-01-30 Thread Ajay Singh
On Tue, 30 Jan 2018 02:13:53 +0800 kbuild test robot wrote: > Hi Ajay, > > Thank you for the patch! Perhaps something to improve: > > [auto build test WARNING on staging/staging-testing] > [cannot apply to v4.15 next-20180126] > [if your patch is applied to the wrong git tree, please drop us a