On Sun, Jan 28, 2018 at 09:06:48PM +, Michael Kelley (EOSG) wrote:
> From: Michael Kelley
>
> The 2016 version of Hyper-V offers the option to operate the guest VM
> per-vcpu stimer's in Direct Mode, which means the timer interupts on its
> own vector rather than queueing a VMbus message. Dir
On Fri, 2018-01-26 at 13:52 +, Colin King wrote:
> From: Colin Ian King
>
> The initialization of cfg_cmd is redundant as the value is never read
> and it is being re-assigned to cfg_cmd = pwrcfgcmd[ary_idx] inside a
> loop, hence it can be removed.
>
> Cleans up clang warning:
> drivers/sta
From: Michael Kelley
The 2016 version of Hyper-V offers the option to operate the guest VM
per-vcpu stimer's in Direct Mode, which means the timer interupts on its
own vector rather than queueing a VMbus message. Direct Mode reduces
timer processing overhead in both the hypervisor and the guest,
On 01/28/2018 08:05 AM, Erik Liodden wrote:
Add identifier names to function definition arguments to comply with
the kernel coding style and the naming convention in the rest of the
file.
Issues found by checkpatch.
Signed-off-by: Erik Liodden
---
As far as I am concerned, this patch is mere
Hi,
According to my understanding, the allocation fall back order
completely depends on heap->id that is assigned during the heap
creation:
plist_for_each_entry(heap, &dev->heaps, node) {
/* if the caller didn't specify this heap id */
if (!((1 << heap->id) & heap_id_mask))
Add identifier names to function definition arguments to comply with
the kernel coding style and the naming convention in the rest of the
file.
Issues found by checkpatch.
Signed-off-by: Erik Liodden
---
drivers/staging/rtlwifi/wifi.h | 29 +++--
1 file changed, 15 inser
On Sun, 2018-01-28 at 08:31 +, Jonathan Cameron wrote:
> On Thu, 25 Jan 2018 22:10:08 +0530
> Shreeya Patel wrote:
>
> >
> > iio_dev->mlock is to be used only by the IIO core for protecting
> > device mode changes between INDIO_DIRECT and INDIO_BUFFER.
> >
> > This patch replaces the use of
On Thu, 25 Jan 2018 22:10:08 +0530
Shreeya Patel wrote:
> iio_dev->mlock is to be used only by the IIO core for protecting
> device mode changes between INDIO_DIRECT and INDIO_BUFFER.
>
> This patch replaces the use of mlock with the already established
> buf_lock mutex.
>
> Introducing 'unlock