Re: [PATCH 6/8] staging: lustre: Fix overlong lines

2018-01-18 Thread Dilger, Andreas
On Jan 11, 2018, at 10:17, Fabian Huegel wrote: > > Fixed four lines that went over the 80 character limit > to reduce checkpatch warnings. > > Signed-off-by: Fabian Huegel > Signed-off-by: Christoph Volkert > --- > drivers/staging/lustre/lustre/include/obd_class.h | 14 ++ > 1 file

staging: lustre: Cleanup of obd_class.h

2018-01-18 Thread Fabian Huegel
Here are the remaining patches rebased on the current staging-testing. ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[PATCH 1/2] staging: lustre: Fix comment style

2018-01-18 Thread Fabian Huegel
Most multi-line comments started on the first line, but the preferred linux kernel style is to start multi-line comments on the second line. Some comments became less readable after the change, so we changed them to single-line comments. Signed-off-by: Fabian Huegel Signed-off-by: Christoph Volke

[PATCH 2/2] staging: lustre: Align struct member identifiers

2018-01-18 Thread Fabian Huegel
This patch properly left aligns all member identifiers in every struct defined in obd_class.h for better readability. Signed-off-by: Fabian Huegel Signed-off-by: Christoph Volkert --- drivers/staging/lustre/lustre/include/obd_class.h | 44 +++ 1 file changed, 22 insertions(+

[PATCH 14/14] staging: wilc1000: rename Handle_ConnectTimeout() and Handle_Key()

2018-01-18 Thread Ajay Singh
fix "Avoid camelCase" issue found by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_interface.c in

[PATCH 10/14] staging: wilc1000: rename ptstrJoinBssParam variable to avoid camelCase

2018-01-18 Thread Ajay Singh
fix "Avoid camelCase" issue reported by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 78 +++ 1 file changed, 39 insertions(+), 39 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging

[PATCH 00/14] fix to remove unnecessary parenthesis, typedef and avoid camelCase

2018-01-18 Thread Ajay Singh
This patch series contains changes to fix issues reported by checkpatch.pl script. Ajay Singh (14): staging: wilc1000: remove unnecessary use of parentheses staging: wilc1000: removed unnecessary defined enums typedef staging: wilc1000: fix alignments to match open parenthesis staging: w

[PATCH 13/14] staging: wilc1000: rename Handle_Connect() to avoid camelCase

2018-01-18 Thread Ajay Singh
fix "Avoid camelcase" issue found by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_interface.c index

[PATCH 04/14] staging: wilc1000: rename host_int_ParseJoinBssParam() and it's variable using camelCase

2018-01-18 Thread Ajay Singh
fix "Avoid CamelCase:" issue reported by checkpatch.pl script Rename host_int_ParseJoinBssParam() & its variables name using camelCase. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 230 +++--- 1 file changed, 115 insertions(+), 115 deletions(-

[PATCH 08/14] staging: wilc1000: rename pu8CurrByte variable to avoid camelCase

2018-01-18 Thread Ajay Singh
fix "Avoid camelCase" issue reported by checkpatch.pl script. rename variable name from "pu8CurrByte" to "cur_byte" Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 232 +++--- 1 file changed, 116 insertions(+), 116 deletions(-) diff --git a/driv

[PATCH 11/14] staging: wilc1000: rename strConnectInfo variable to avoid camelCase

2018-01-18 Thread Ajay Singh
fix "Avoid camelCase" issue reported by checkpatch.pl script. In this patch rename "strConnectInfo" variable to resolve issue reported by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 74 +++ 1 file changed, 37 inserti

[PATCH 12/14] staging: wilc1000: rename Handle_ScanDone() to avoid camelCase

2018-01-18 Thread Ajay Singh
fix "Avoid camelCase" issue reported by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_in

[PATCH 05/14] staging: wilc1000: rename camelCase used in Handle_DelAllSta() and its variable

2018-01-18 Thread Ajay Singh
fix "Avoid camelCase" issue reported by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 24 1 file changed, 12 insertions(+), 12 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc10

[PATCH 03/14] staging: wilc1000: fix alignments to match open parenthesis

2018-01-18 Thread Ajay Singh
fix "Alignment should match open parenthesis" issues reported by checkpatch.pl script. changes to comply with linux coding style. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 4 +-- drivers/staging/wilc1000/linux_wlan.c | 2 +- drivers/staging/w

[PATCH 01/14] staging: wilc1000: remove unnecessary use of parentheses

2018-01-18 Thread Ajay Singh
fix "Unnecessary parentheses around" issue found by checkpatch.pl script.Remove the unnecessary parentheses to follow linux coding style. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/coreconfigurator.c | 2 +- drivers/staging/wilc1000/host_interface.c | 34 +++---

[PATCH 07/14] staging: wilc1000: rename u32WidsCount variable to avoid camelCase

2018-01-18 Thread Ajay Singh
fix "Avoid camleCase" issue reported by checkpatch.pl script. rename variable name from u32WidsCount to wid_cnt to fix checkpatch.pl report issue. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 146 +++--- 1 file changed, 73 insertions(+), 73 de

[PATCH 02/14] staging: wilc1000: removed unnecessary defined enums typedef

2018-01-18 Thread Ajay Singh
fix the "do not add new typedefs" issue found by checkpatch.pl script Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wlan_if.h | 72 - 1 file changed, 36 insertions(+), 36 deletions(-) diff --git a/drivers/staging/wilc1000/wilc_wlan_if.h b/drivers/s

[PATCH 06/14] staging: wilc1000: rename strWIDList variable to wid_list to avoid camelCase

2018-01-18 Thread Ajay Singh
fix "Avoid camelCase" issue found by checkpatch.pl script. Rename variable name from strWIDList to wid_list. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 176 +++--- 1 file changed, 88 insertions(+), 88 deletions(-) diff --git a/drivers/stagi

[PATCH 09/14] staging: wilc1000: rename pstrHostIFconnectAttr argument to avoid camelCase

2018-01-18 Thread Ajay Singh
fix "Avoid camelCase" issue found by checkpatch.pl script. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 104 ++ 1 file changed, 49 insertions(+), 55 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wi

Re: [PATCH 1/7] staging: ccree: remove ccree from staging tree

2018-01-18 Thread Greg Kroah-Hartman
On Thu, Jan 18, 2018 at 10:39:11AM +0200, Gilad Ben-Yossef wrote: > On Sat, Jan 13, 2018 at 3:21 PM, Greg Kroah-Hartman > wrote: > > On Thu, Jan 11, 2018 at 09:17:08AM +, Gilad Ben-Yossef wrote: > >> Remove the ccree driver from the staging tree in preparation to > >> introducing it in the cry

Re: [PATCH -next] staging: ccree: remove redundant dev_err call in init_cc_resources()

2018-01-18 Thread Gilad Ben-Yossef
On Thu, Jan 11, 2018 at 1:14 PM, Wei Yongjun wrote: > There is a error message within devm_ioremap_resource > already, so remove the dev_err call to avoid redundant > error message. > > Signed-off-by: Wei Yongjun > --- > drivers/staging/ccree/cc_driver.c | 4 +--- > 1 file changed, 1 insertion(+

[PATCH v2] ION: Sys_heap: fix the incorrect pool->gfp_mask setting

2018-01-18 Thread Zeng Tao
The gfp_mask low order pool is overlapped by the high order inside the loop, so the gfp_mask of all pools are set to high_order_gfp_flags. And all the allcations will have no __GFP_RECLAIM flag, we will easily get the allocation failure problem with memory presure. Changes since v1: 1. fix the tag

Re: [PATCH 1/7] staging: ccree: remove ccree from staging tree

2018-01-18 Thread Gilad Ben-Yossef
On Sat, Jan 13, 2018 at 3:21 PM, Greg Kroah-Hartman wrote: > On Thu, Jan 11, 2018 at 09:17:08AM +, Gilad Ben-Yossef wrote: >> Remove the ccree driver from the staging tree in preparation to >> introducing it in the crypto tree. >> >> Signed-off-by: Gilad Ben-Yossef > > Heh, no, just make a pa