On Tue, Jan 16, 2018 at 12:58 AM, syzbot
wrote:
> Hello,
>
> syzkaller hit the following crash on
> 8418f88764046d0e8ca6a3c04a69a0e57189aa1e
> git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/master
> compiler: gcc (GCC) 7.1.1 20170620
> .config is attached
> Raw console output is
The series is a preparation series for individual architectures
to use 64 bit time_t syscalls in compat and 32 bit emulation modes.
This is a follow up to the series Arnd Bergmann posted:
https://sourceware.org/ml/libc-alpha/2015-05/msg00070.html [1]
Big picture is as per the lwn article:
https:/
All the current architecture specific defines for these
are the same. Refactor these common defines to a common
header file.
The new common linux/compat_time.h is also useful as it
will eventually be used to hold all the defines that
are needed for compat time types that support non y2038
safe typ
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-next
head: 0f45b23aedf91ae66890d13320c5147c15013a0c
commit: 6106c0f82481e686b337ee0c403821fb5c3c17ef [468/515] staging: lustre:
lnet: convert selftest to use workqueues
config: x86_64-randconfig-u0-01160700 (atta
The "Neo" devices are never allowed to be bound to this driver, as they
are not in the valid list of PCI ids, so delete them from the driver as
the code in the probe function has no way to ever run.
Also delete the defines that are no longer used in relation to the Neo
devices, as they are not nee
None of these were being used at all, only set and never used again, so
remove them from the code.
Cc: Lidza Louina
Cc: Mark Hounschell
Signed-off-by: Greg Kroah-Hartman
---
drivers/staging/dgnc/dgnc_driver.c | 8
drivers/staging/dgnc/dgnc_driver.h | 14 --
2 files change
It was only ever read from the device, and spit out to the kernel log
for no good reason. So remove it, and the way it was read from the
device, and the now unused "board file" callback.
Cc: Lidza Louina
Cc: Mark Hounschell
Signed-off-by: Greg Kroah-Hartman
---
drivers/staging/dgnc/dgnc_cls.c
No one was even ever setting the thing, so just remove it.
Cc: Lidza Louina
Cc: Mark Hounschell
Signed-off-by: Greg Kroah-Hartman
---
drivers/staging/dgnc/dgnc_driver.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_driver.h
b/drivers/staging/dgnc/dgnc_driver.h
It was only set, and never looked at, so drop the thing as no one cares
about it. And when it was set, it was not even set correctly, the index
it was using to read from was incorrect, so this has never even been
correct...
Cc: Lidza Louina
Cc: Mark Hounschell
Signed-off-by: Greg Kroah-Hartman
It was only set, and never looked at, so drop the thing as no one cares
about it.
Cc: Lidza Louina
Cc: Mark Hounschell
Signed-off-by: Greg Kroah-Hartman
---
drivers/staging/dgnc/dgnc_driver.c | 3 ---
drivers/staging/dgnc/dgnc_driver.h | 3 ---
drivers/staging/dgnc/digi.h| 4
3 fi
As the Neo devices were never actually supported by the driver, delete
the files that purported to control that type of device as they are not
needed. This will let us shrink the driver a lot over time.
Cc: Lidza Louina
Cc: Mark Hounschell
Signed-off-by: Greg Kroah-Hartman
---
drivers/staging
It was only set, and never looked at, so drop the thing as no one cares
about it.
Cc: Lidza Louina
Cc: Mark Hounschell
Signed-off-by: Greg Kroah-Hartman
---
drivers/staging/dgnc/dgnc_driver.c | 3 ---
drivers/staging/dgnc/dgnc_driver.h | 2 --
drivers/staging/dgnc/digi.h| 5 -
3 fi
Move the few #defines we actually use into the dgnc_driver.c file, no
need to have a .h file for a driver that is only used by a single .c
file.
Cc: Lidza Louina
Cc: Mark Hounschell
Signed-off-by: Greg Kroah-Hartman
---
drivers/staging/dgnc/dgnc_driver.c | 12 +++-
drivers/staging/dgnc
Now that the "neo" portion of the driver is gone (it was never being
used), drop the unused neo_uart_struct variable as well.
Cc: Lidza Louina
Cc: Mark Hounschell
Signed-off-by: Greg Kroah-Hartman
---
drivers/staging/dgnc/dgnc_driver.h | 2 --
drivers/staging/dgnc/dgnc_tty.c| 5 +
2 fi
On 01/15/18 06:54, Greg Kroah-Hartman wrote:
> On Sun, Jan 14, 2018 at 09:10:54PM -0800, Randy Dunlap wrote:
>> From: Randy Dunlap
>>
>> Drivers should not 'select' a subsystem. Instead they should depend
>> on it. If the subsystem is disabled, the user probably did that for
>> a purpose and one d
Hello Dan,
It looks this condition is missed in the code. Sorry we should fix this.
Dmitry.
> -Original Message-
> From: Eremin, Dmitry
> Sent: Monday, January 15, 2018 9:27 PM
> To: Dan Carpenter ; ne...@suse.com
> Cc: de...@driverdev.osuosl.org; lustre-de...@lists.lustre.org
> Subject:
Fix a number of checkpatch warnings in xgfib/vb_setmode.c about line
length being over 80 characters.
Signed-off-by: Kenny Ballou
---
drivers/staging/xgifb/vb_setmode.c | 58 --
1 file changed, 37 insertions(+), 21 deletions(-)
diff --git a/drivers/staging/xg
Changes since v4:
- Old 1/3 was accepted, shifting the patch numbers
- Removed pythonisms and bad line edits in 1/2: fix long line warnings
- Removed bad patch/commit separation in 2/2: brace style fixes
___
devel mailing list
de...@linuxdriverproject
Add braces to certain "multiline" conditions where "multiline" means
including comments.
Signed-off-by: Kenny Ballou
---
drivers/staging/xgifb/vb_setmode.c | 23 +++
1 file changed, 15 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/xgifb/vb_setmode.c
b/drivers/s
Hello Dan,
The function kiblnd_destroy_conn() is conditionally free the conn pointer.
void kiblnd_destroy_conn(kib_conn_t *conn, bool free_conn)
{
[…]
if (free_conn)
LIBCFS_FREE(conn, sizeof(*conn));
}
Therefore
> 3317 kib
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-testing
head: 0f45b23aedf91ae66890d13320c5147c15013a0c
commit: 6106c0f82481e686b337ee0c403821fb5c3c17ef [468/515] staging: lustre:
lnet: convert selftest to use workqueues
config: mn10300-allmodconfig (attached a
On Thu, Jan 11, 2018 at 06:16:55PM +0100, Fabian Huegel wrote:
> Checkpatch wants complex macros to be enclosed in parentheses, so we
> put parentheses around these four macros.
>
> Signed-off-by: Fabian Huegel
> Signed-off-by: Christoph Volkert
> ---
> drivers/staging/lustre/lustre/include/obd
On Thu, Jan 11, 2018 at 06:16:58PM +0100, Fabian Huegel wrote:
> Most multi-line comments started on the first line, but the preferred
> linux kernel style is to start multi-line comments on the second line.
> Some comments became less readable after the change, so we changed them
> to single-line
On Fri, Jan 12, 2018 at 03:34:44PM -0700, Kenny Ballou wrote:
> Fix a number of checkpatch warnings in xgfib/vb_setmode.c about line
> length being over 80 characters.
>
> Signed-off-by: Kenny Ballou
> ---
> drivers/staging/xgifb/vb_setmode.c | 64
> +-
> 1 f
On Fri, Jan 12, 2018 at 03:34:45PM -0700, Kenny Ballou wrote:
> Add braces to certain "multiline" conditions where "multiline" means
> including comments.
>
> Signed-off-by: Kenny Ballou
> ---
> drivers/staging/xgifb/vb_setmode.c | 26 +-
> 1 file changed, 17 insertions(+
On Sun, Jan 14, 2018 at 09:10:54PM -0800, Randy Dunlap wrote:
> From: Randy Dunlap
>
> Drivers should not 'select' a subsystem. Instead they should depend
> on it. If the subsystem is disabled, the user probably did that for
> a purpose and one driver shouldn't be changing that.
>
> Signed-off-b
On Thu, Jan 11, 2018 at 08:36:59AM +, Jeremy Sowden wrote:
> This patch fixes sparse warnings arising when the addresses of signed
> variables are passed to functions expecting pointers to unsigned
What exact sparse warnings are being fixed here?
Please include that in the changelog text.
th
On Thu, Jan 11, 2018 at 08:36:58AM +, Jeremy Sowden wrote:
> Replaced hard-coded indices used during initialization of array elements
> with a variable which is incremented once initialization of each element
> is complete.
Why?
What does this help out with?
confused,
greg k-h
_
Thomas Gleixner writes:
> On Wed, 13 Dec 2017, Vitaly Kuznetsov wrote:
>
>> This is going to be used from KVM code where we need to get both
>> TSC and TSC page value.
>>
>> When Hyper-V code is compiled out just return rdtsc(), this will allow us
>> to avoid ugly ifdefs in non-Hyper-V code.
>
>
Thomas Gleixner writes:
> On Wed, 13 Dec 2017, Vitaly Kuznetsov wrote:
>> +static int hv_cpu_die(unsigned int cpu)
>> +{
>> +struct hv_reenlightenment_control re_ctrl;
>> +int i;
>> +static DEFINE_SPINLOCK(lock);
>> +
>> +if (hv_reenlightenment_cb == NULL)
>> +return 0
Hello Amir Shehata,
The patch 6c9e5a55cb62: "staging: lustre: DLC Feature dynamic net
config" from Feb 15, 2016, leads to the following static checker
warning:
drivers/staging/lustre/lnet/lnet/api-ni.c:1804 lnet_dyn_add_ni()
error: dereferencing freed memory 'ni'
drivers/staging/
[ This code was already buggy, it's just that Neil's change made it
show up in static analysis. - dan ]
Hello NeilBrown,
The patch 3c88bdbbf919: "staging: lustre: replace simple cases of
LIBCFS_ALLOC with kzalloc." from Jan 9, 2018, leads to the following
static checker warning:
dri
> These messages are not displayed anywhere else:
> "unable to allocate receive buffer of size %u\n"
> "unable to allocate send buffer of size %u\n",
>
> After set ret = -ENOMEM; and cleanup, we won't know which buffer allocation
> failed without the error message.
How do you think about to achi
33 matches
Mail list logo