On Thu, Jan 11, 2018 at 08:33:00AM +0200, Gilad Ben-Yossef wrote:
>
> Herbert, it's up to you - shall I send a new patch set or do you want to just
> move what's in the staging tree?
Please send a new patch.
Thanks,
--
Email: Herbert Xu
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: h
On Wed, Jan 10, 2018 at 6:39 PM, Greg Kroah-Hartman
wrote:
> On Wed, Jan 10, 2018 at 08:54:55AM +0200, Gilad Ben-Yossef wrote:
>> Hi folks,
>>
>> With the enormous help of people in the to and CCed lists I've gotten
>> the ccree driver to a point I believe it is ready to graduate out of
>> the sta
Hi Jermey,
On Wed, Jan 10, 2018 at 3:33 PM, Jeremy Sowden wrote:
> This patch fixes sparse warnings arising when the addresses of signed
> variables are passed to functions expecting pointers to unsigned
> integers by converting those signed variables to unsigned as follows:
>
> * changed the t
>-邮件原件-
>发件人: Laura Abbott [mailto:labb...@redhat.com]
>发送时间: 2018年1月11日 8:01
>收件人: Zengtao (B) ; Dan Carpenter
>; Chenfeng (puck)
>抄送: sumit.sem...@linaro.org; gre...@linuxfoundation.org;
>a...@android.com; tk...@android.com; m...@android.com;
>de...@driverdev.osuosl.org; linux-ker...@vge
This patch fixes the below warnings with new glibc and gcc:
hv_vss_daemon.c:100:13: warning: In the GNU C Library, "major" is defined
by . For historical compatibility, it is currently
defined by as well, but we plan to remove this soon.
To use "major", include directly.
hv_fcopy_daemon.c:42
On Wed, 2018-01-10 at 17:01 +, Luis de Bethencourt wrote:
> On 01/10/2018 04:51 PM, Luis de Bethencourt wrote:
> > Hi,
> >
> > Removing the last patch from the original series after Dan's comment.
> >
> > Tomorrow, I will send a new patch that removes the commented out code. This
> > will
>
On Wed, Jan 10, 2018 at 06:30:35PM +0100, Jonny Schaefer wrote:
> From: Luis Gerhorst
>
> This fixes the checkpatch message:
>
> CHECK: Alignment should match open parenthesis
> #1380: FILE: drivers/staging/fbtft/fbtft-core.c:1380:
> + dev_warn(dev,
> + "n
On 01/09/2018 04:06 AM, Zengtao (B) wrote:
-邮件原件-
发件人: Dan Carpenter [mailto:dan.carpen...@oracle.com]
发送时间: 2018年1月9日 17:14
收件人: Chenfeng (puck)
抄送: Zengtao (B) ; labb...@redhat.com;
sumit.sem...@linaro.org; gre...@linuxfoundation.org; a...@android.com;
tk...@android.com; m...@android.c
From: Long Li
The original patch was made for stable 4.1 and was Acked on 08/22/2017, but for
some reason it never made it to the stable tree.
Change from v1:
Changed comment that this patch is for linux-stable 4.1 and all prior stable
kernels.
storvsc checks the SG list for gaps before passing
On Wed, Jan 10, 2018 at 04:42:47PM +0530, Ajay Singh wrote:
> This patch removes following N_OPERATING_MODE_T,N_OBSS_DETECTION_T,
> N_PROTECTION_TYPE_T,N_SMPS_MODE_T,TX_ABORT_OPTION_T, typedef enum.
> Now, these enums are used as anonymous-enums for constants.
>
> checkpatch.pl warning to not add
On 01/10/2018 03:18 AM, syzbot wrote:
Hello,
syzkaller hit the following crash on 69eed2290e1d81b7a33774a24bbcb79f51958e57
git://git.cmpxchg.org/linux-mmots.git/master
compiler: gcc (GCC) 7.1.1 20170620
.config is attached
Raw console output is attached.
Unfortunately, I don't have any reproduce
On 01/09/2018 02:58 PM, syzbot wrote:
Hello,
syzkaller hit the following crash on 06d41862286aa7bc634a1dd9e6e7e96f925ef30a
git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/master
compiler: gcc (GCC) 7.1.1 20170620
.config is attached
Raw console output is attached.
C reproducer
From: Luis Gerhorst
This fixes the checkpatch message:
CHECK: Alignment should match open parenthesis
#1380: FILE: drivers/staging/fbtft/fbtft-core.c:1380:
+ dev_warn(dev,
+ "no default functions for regwidth=%d and
buswidth=%d\n",
Signed-off-by: Lui
On Wed, Jan 10, 2018 at 5:57 PM, Stephen Hemminger
wrote:
> On Wed, 10 Jan 2018 17:42:38 +0100
> Arnd Bergmann wrote:
>
>> I moved the virt_to_phys() conversion into hv_uio_probe() as part of
>> a warning fix. Stephen's cleanup to remove the private mmap() function
>> seems reasonable, but part o
On 01/10/2018 04:51 PM, Luis de Bethencourt wrote:
> Hi,
>
> Removing the last patch from the original series after Dan's comment.
>
> Tomorrow, I will send a new patch that removes the commented out code. This
> will
> replace that last patch.
>
> Thanks for the review,
> Luis
>
>
> Luis de
On Wed, 10 Jan 2018 17:42:38 +0100
Arnd Bergmann wrote:
> I moved the virt_to_phys() conversion into hv_uio_probe() as part of
> a warning fix. Stephen's cleanup to remove the private mmap() function
> seems reasonable, but part of it reverted the change that I did to
> hide the warnings, so they
Hi,
Removing the last patch from the original series after Dan's comment.
Tomorrow, I will send a new patch that removes the commented out code. This will
replace that last patch.
Thanks for the review,
Luis
Luis de Bethencourt (2):
staging: rtl8723bs: Fix trailing semicolon
staging: rtl87
The trailing semicolon is an empty statement that does nothing.
Removing it since it has no purpose.
Signed-off-by: Luis de Bethencourt
---
drivers/staging/rtl8723bs/hal/rtl8723b_phycfg.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723bs/hal/rtl8723b_p
The trailing semicolon is an empty statement that does no operation.
Removing it since it doesn't do anything.
Signed-off-by: Luis de Bethencourt
---
drivers/staging/rtl8723bs/hal/HalPhyRf_8723B.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723bs/hal/H
On Tue, Jan 09, 2018 at 12:57:33PM -0800, Stephen Hemminger wrote:
> Use sysfs to allow supporting sub-channels. The userspace application
> makes request to host to create sub-channels and the UIO kernel
> driver populates the sysfs per-channel directory with a binary
> attribute file that can be
I moved the virt_to_phys() conversion into hv_uio_probe() as part of
a warning fix. Stephen's cleanup to remove the private mmap() function
seems reasonable, but part of it reverted the change that I did to
hide the warnings, so they are back now:
drivers/uio/uio_hv_generic.c: In function 'hv_uio_
On Wed, Jan 10, 2018 at 08:54:55AM +0200, Gilad Ben-Yossef wrote:
> Hi folks,
>
> With the enormous help of people in the to and CCed lists I've gotten
> the ccree driver to a point I believe it is ready to graduate out of
> the staging tree:
>
> - The code base has been reduced by something by 3
On Wed, Jan 10, 2018 at 01:50:38PM +, Luis de Bethencourt wrote:
> Even though the code is commented out, it has a small bug. The trailing
> semicolon is an empty statement that does no operation. Removing it since
> it doesn't do anything.
It's not a bug because it's totally harmless to add e
Hi,
This is a follow-up of yesterday's water-testing patch [0]. Just 3 more
similar cases of trailing semicolons.
Sending them separately to atomize the changes, but happy to merge them all
into one. It is easier to first try separate and later merge if people want me
to.
In patch 3/3, not sure
The trailing semicolon is an empty statement that does no operation.
Removing it since it doesn't do anything.
Signed-off-by: Luis de Bethencourt
---
drivers/staging/rtl8723bs/hal/HalPhyRf_8723B.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723bs/hal/H
Even though the code is commented out, it has a small bug. The trailing
semicolon is an empty statement that does no operation. Removing it since
it doesn't do anything.
Signed-off-by: Luis de Bethencourt
---
drivers/staging/rtl8723bs/core/rtw_mlme.c | 2 +-
1 file changed, 1 insertion(+), 1 del
The trailing semicolon is an empty statement that does nothing.
Removing it since it has no purpose.
Signed-off-by: Luis de Bethencourt
---
drivers/staging/rtl8723bs/hal/rtl8723b_phycfg.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723bs/hal/rtl8723b_p
This patch fixes sparse warnings arising when the addresses of signed
variables are passed to functions expecting pointers to unsigned
integers by converting those signed variables to unsigned as follows:
* changed the types of a number of index and length variables from
signed to unsigned i
The driver uses a mixture of signed and unsigned integer variables for
holding arrays lengths and indices, which gives rise to sparse warnings
when the addresses of signed variables are passed to functions expecting
pointers to unsigned integers. This patch-set fixes those warnings by
converting t
Replaced hard-coded indices used during initialization of array elements
with a variable which is incremented once initialization of each element
is complete.
Signed-off-by: Jeremy Sowden
---
drivers/staging/ccree/cc_aead.c | 48 +++--
1 file changed, 27 inser
On Wed, Jan 10, 2018 at 3:08 PM, Jeremy Sowden wrote:
> On 2018-01-10, at 15:03:01 +0200, Gilad Ben-Yossef wrote:
>> On Wed, Jan 10, 2018 at 1:53 PM, Jeremy Sowden wrote:
>> > The driver uses a mixture of signed and unsigned integer variables
>> > for holding arrays lengths and indices, which give
On 2018-01-10, at 15:03:01 +0200, Gilad Ben-Yossef wrote:
> On Wed, Jan 10, 2018 at 1:53 PM, Jeremy Sowden wrote:
> > The driver uses a mixture of signed and unsigned integer variables
> > for holding arrays lengths and indices, which gives rise to sparse
> > warnings when the addresses of signed v
Hi Jeremy,
On Wed, Jan 10, 2018 at 1:53 PM, Jeremy Sowden wrote:
> The driver uses a mixture of signed and unsigned integer variables for
> holding arrays lengths and indices, which gives rise to sparse warnings
> when the addresses of signed variables are passed to functions expecting
Just curi
The driver uses a mixture of signed and unsigned integer variables for
holding arrays lengths and indices, which gives rise to sparse warnings
when the addresses of signed variables are passed to functions expecting
pointers to unsigned integers. This patch fixes those warnings by
converting those
This patch removes following N_OPERATING_MODE_T,N_OBSS_DETECTION_T,
N_PROTECTION_TYPE_T,N_SMPS_MODE_T,TX_ABORT_OPTION_T, typedef enum.
Now, these enums are used as anonymous-enums for constants.
checkpatch.pl warning to not add new typedef is fixes with this patch.
Signed-off-by: Ajay Singh
---
This patch removes enum typedef BUS_ACQUIRE_T and define
enum bus_acquire to use instead of typedef.
checkpatch.pl not to add new typedef warning is fixed with this patch.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wlan.c| 2 +-
drivers/staging/wilc1000/wilc_wlan_if.h | 4 +
This patch removed the unnecessary enum typedef for BEACON_IE &
TX_RATE_T
It fix "WARNING: do not add new typedefs" reported by checkpatch.pl
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wlan_if.h | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/
This patch removes enum typedef BUS_RELEASE_T and define
"enum bus_release" to use instead of typedef.
checkpatch.pl not to add new typedef warning is fixed with this patch.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wlan.c| 2 +-
drivers/staging/wilc1000/wilc_wlan_if.h | 4
This patch removes enum typedef CHIP_PS_STATE_T and introduce
enum chip_ps_states to use instead of typedef.
checkpatch.pl not to add new typedef warning is fixed with this patch.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wlan.c| 2 +-
drivers/staging/wilc1000/wilc_wlan_if
v2: The patch series is created instead of independent patches &
updated the name for Signed-off-by field.
This patch series fix "WARNING: do not add new typedefs" issues
found by checkpatch.pl
Ajay Singh (9):
staging: wilc1000: removed typedef from enum BSSTYPE_T
staging: wilc1000: remov
This patch removes typedef from enum BSSTYPE_T and
rename it to bss_types.
It fixes "WARNING: do not add new typdefs" warning
reported by checkpatch.pl.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 2 +-
drivers/staging/wilc1000/wilc_wlan_if.h | 4 ++--
2 files ch
This patch removes following RSNA_REKEY_POLICY_T,SCAN_CLASS_FITLER_T,
SCAN_PRI_T,CH_FILTER_T,N_PROTECTION_MODE_T,G_PROTECTION_MODE_T typedef
enum.
Now, these enums are used as anonymous-enums for constants.
checkpatch.pl warning to avoid new typedef is fixes with this patch.
Signed-off-by: Ajay S
This patch has removed G_OPERATING_MODE_T typedef enum.
Now, its used as anonymous-enums for constants.
checkpatch.pl warning to avoid new typedef is fixes with this patch.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wlan_if.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletion
This patch removes following G_PREAMBLE_T,SCANTYPE_T,
USER_PS_MODE_T,SECURITY_T,ACK_POLICY_T,RESET_REQ_T typedef enum.
Now, these enums are used as anonymous-enums for constants.
checkpatch.pl warning to avoid new typedef is fixes with this patch.
Signed-off-by: Ajay Singh
---
drivers/staging/
Fixes the misspelled constant to 'SWITCH_NO_ERR'.
Issue reported by checkpatch.pl
Signed-off-by: Sumit Pundir
---
drivers/staging/rts5208/sd.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rts5208/sd.h b/drivers/staging/rts5208/sd.h
index 55764e1..900be44 10
Joe Perches schrieb am 10.01.2018 10:05:
> On Wed, 2018-01-10 at 09:44 +0100, Greg Kroah-Hartman wrote:
> > On Tue, Jan 09, 2018 at 11:42:16AM -0800, Joe Perches wrote:
> > > if (a == b && c == d)
> > > is pretty trivial.
> >
> > But again, don't do that.
>
> We disagree. Life goes on.
>
> cheer
On Wed, 2018-01-10 at 09:44 +0100, Greg Kroah-Hartman wrote:
> On Tue, Jan 09, 2018 at 11:42:16AM -0800, Joe Perches wrote:
> > if (a == b && c == d)
> > is pretty trivial.
>
> But again, don't do that.
We disagree. Life goes on.
cheers, Joe
__
On Tue, Jan 09, 2018 at 11:42:16AM -0800, Joe Perches wrote:
> On Tue, 2018-01-09 at 20:28 +0100, Greg Kroah-Hartman wrote:
> > On Tue, Jan 09, 2018 at 11:21:37AM -0800, Joe Perches wrote:
> > > On Tue, 2018-01-09 at 15:31 +0100, Greg Kroah-Hartman wrote:
> > > > On Mon, Jan 08, 2018 at 06:38:55PM
48 matches
Mail list logo