Remove unused variable and also remove unused code
associated with initializing the unused variable.
Unused variable was detected using the following
semantic patch by coccinelle.
@@
type T;
identifier i;
constant C;
@@
(
extern T i;
|
- T i;
<+... when != i
- i = C;
...+>
)
Signed-off-by:
Hi Andy and Dan,
On Wed, Dec 20, 2017 at 12:24:36PM +0200, Andy Shevchenko wrote:
> On Wed, Dec 20, 2017 at 6:54 AM, Dan Carpenter
> wrote:
> > On Tue, Dec 19, 2017 at 10:59:52PM +0200, Andy Shevchenko wrote:
> >> @@ -1147,10 +1145,8 @@ static int gc2235_probe(struct i2c_client *client)
> >>
Function rf69_reset_flag is unused and should be removed.
Signed-off-by: Marcin Ciupak
---
Changes in v2:
- rebase against staging-testing
drivers/staging/pi433/rf69.c | 12
drivers/staging/pi433/rf69.h | 1 -
2 files changed, 13 deletions(-)
diff --git a/drivers/staging/pi433/rf
Function rf69_set_sync_tolerance is unused and should be removed.
Signed-off-by: Marcin Ciupak
---
Changes in v2:
- rebase against staging-testing
drivers/staging/pi433/rf69.c | 12
drivers/staging/pi433/rf69.h | 1 -
2 files changed, 13 deletions(-)
diff --git a/drivers/staging/
Remaining patches of unused functions cleanup patchset rebased against
staging-testing.
Marcin Ciupak (2):
staging: pi433: remove unused rf69_set_sync_tolerance function
staging: pi433: remove unused rf69_reset_flag function
drivers/staging/pi433/rf69.c | 24
drivers
On 2017-12-19, at 14:07:49 +0200, Sakari Ailus wrote:
> On Sat, Dec 02, 2017 at 10:11:59PM +, Jeremy Sowden wrote:
> > The CSS API uses a lot of nested anonymous structs defined in object
> > macros to assign default values to its data-structures. These have
> > been changed to use compound-li
On 2017-12-21, at 18:51:09 +0100, Greg KH wrote:
> On Thu, Dec 21, 2017 at 05:28:00PM +, Jeremy Sowden wrote:
> > Changed the types of a number of index and length variables and the
> > return-types of a couple of functions that return values which are
> > assigned to a couple of these variable
On Thu, Dec 21, 2017 at 05:28:00PM +, Jeremy Sowden wrote:
> Changed the types of a number of index and length variables and the
> return-types of a couple of functions that return values which are
> assigned to a couple of these variables from signed to unsigned integer
> types.
>
> Fixes a n
On Wed, Dec 20, 2017 at 04:12:48PM +, Marcin Ciupak wrote:
> These patches make local functions static and remove unused ones. Each
> function is removed by separate patch in order to make it easier to
> revert patch in future if the function will be needed in later version
> of the driver.
>
On Tue, Dec 19, 2017 at 09:16:21PM +0100, Martin Homuth wrote:
> This patch series fixes some coding style issues reported by checkpatch.pl.
>
> It is based on next-20171218
Only one patch in this series applied, please rebase and resend the
remaining ones.
thanks,
greg k-h
Changed the types of a number of index and length variables and the
return-types of a couple of functions that return values which are
assigned to a couple of these variables from signed to unsigned integer
types.
Fixes a number of warnings arising from the variables' addresses being
passed to fun
On Tue, Dec 19, 2017 at 09:16:22PM +0100, Martin Homuth wrote:
> This patch fixes various coding style issues in the rtl8712 module as
> noted by checkpatch.pl by reducing the characters per line to under
> 80.
>
> It fixes the following checkpatch.pl warning:
>
> WARNING: line over 80 characters
On Thu, Dec 21, 2017 at 01:07:22AM +0200, Kamal Heib wrote:
> This patch set fixes multiple error found by checkpatch.pl in the
> greybus drivers.
>
> Kamal Heib (4):
> staging: greybus: authentication.c: Fix alignment should match open
> parenthesis
> staging: greybus: bootrom.c: Fix alig
On Tue, Dec 19, 2017 at 09:55:06PM +0200, Kamal Heib wrote:
> This patch fixes the following errors found by checkpatch:
> 1- Prefer kernel type 'u32' over 'uint32_t'.
> 2- Alignment should match open parenthesis.
Same comment here. Also please properly cc: the needed maintainers, the
get_maintai
On Tue, Dec 19, 2017 at 09:55:05PM +0200, Kamal Heib wrote:
> This patch fixes the following errors found by checkpatch:
> 1- Prefer kernel type 'u32' over 'uint32_t'.
> 2- Space required around that ':'.
> 3- Alignment should match open parenthesis.
> 4- Don't use multiple blank lines.
When you h
On Thu, Dec 21, 2017 at 02:31:20PM +0100, Arnd Bergmann wrote:
> __dump_byte_array used to be hidden, but is now visible to the compiler
> and causes a harmless warning:
>
> drivers/staging/ccree/ssi_driver.c:82:6: error: conflicting types for
> '__dump_byte_array'
> drivers/staging/ccree/ssi_dri
On Thu, Dec 21, 2017 at 11:25:47AM +, Jeremy Sowden wrote:
> Changed the types of a number of index and length variables from int to
> unsigned int. Fixes a number of warnings arising from their addresses
> being passed to functions expecting pointers to unsigned ints.
>
> Signed-off-by: Jere
On Wed, Dec 20, 2017 at 06:16:08PM +, Corentin Labbe wrote:
> This patch corrects the type of the size argument in __dump_byte_array()
> from unsigned long to size_t as done only in
> drivers/staging/ccree/ssi_driver.c
>
> This fix also a build error:
> drivers/staging/ccree/ssi_driver.c:82:6
Fix these checkpatch.pl warnings in comedidev.h:
WARNING: function definition argument '' should also have an identifier
name
Introduces this checkpatch.pl warning in lines 195 and 205:
WARNING: line over 80 characters
Breaking these lines would make the code less compact.
Signed-off-by: Michael
This is a duplicate patch. We fixed a typo and this was still left as a
temporary file. (emacs…) Sorry. The patch with Message-Id
<1513869932-27407-3-git-send-email-fabian_hue...@web.de> is the right
one.
We can provide a new patch series without the fix, if needed.
Thanks
Christoph
Checkpat
Checkpatch wants complex macros to be enclosed in parantheses, so we
put parantheses around these four macros.
Signed-off-by: Fabian Huegel
Signed-off-by: Christoph Volkert
---
drivers/staging/lustre/lustre/include/obd_class.h | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff
Fixed four lines that went over the 80 character limit
to reduce checkpatch warnings.
Signed-off-by: Fabian Huegel
Signed-off-by: Christoph Volkert
---
drivers/staging/lustre/lustre/include/obd_class.h | 14 ++
1 file changed, 10 insertions(+), 4 deletions(-)
diff --git a/drivers/s
Checkpatch was complaining about missing identifier names in function
declarations. So we added the missing names according to the names in
the respective function implementation. *obd_import* was sometimes named
*import* and sometimes *imp* (in genops.c), so to avoid confusion we just
named it imp
We cleaned up a lot of checkpatch errors and warnings in obd_class.h,
but there are still some CHECKs and two warnings about flow control
inside macros left.
Changing those macros to inline functions would probably
be a good idea, unfortunatly it's not straightforward since they use
'#op' to print
Most multi-line comments started on the first line, but the preferred
linux kernel style is to start multi-line comments on the second line.
Some comments became less readable after the change, so we changed them
to single-line comments.
Signed-off-by: Fabian Huegel
Signed-off-by: Christoph Volke
Some complex multi-line macros were not enclosed by a do-while(0),
so we fixed that.
Signed-off-by: Fabian Huegel
Signed-off-by: Christoph Volkert
---
drivers/staging/lustre/lustre/include/obd_class.h | 16
1 file changed, 12 insertions(+), 4 deletions(-)
diff --git a/drivers/
This macro was only used in four places to declare two variables.
It saved one line of code, but in our opinion hurt readability.
So we removed the macro, substituting every occurrence with the
declaration of the two variables (like the preprocessor would have done).
Signed-off-by: Fabian Huegel
This patch right aligns all backslashes in multi-line macros
in obd_class.h for better readability.
Signed-off-by: Fabian Huegel
Signed-off-by: Christoph Volkert
---
drivers/staging/lustre/lustre/include/obd_class.h | 166 +++---
1 file changed, 83 insertions(+), 83 deletions(-)
This patch properly left aligns all member identifiers in every
struct defined in obd_class.h for better readability.
Signed-off-by: Fabian Huegel
Signed-off-by: Christoph Volkert
---
drivers/staging/lustre/lustre/include/obd_class.h | 44 +++
1 file changed, 22 insertions(+
Checkpatch wants complex macros to be enclosed in parentheses, so we
put parentheses around these four macros.
Signed-off-by: Fabian Huegel
Signed-off-by: Christoph Volkert
---
drivers/staging/lustre/lustre/include/obd_class.h | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff
Paolo Bonzini writes:
> On 21/12/2017 13:50, Vitaly Kuznetsov wrote:
>> I'm back with (somewhat frustrating) results (E5-2603):
>
> v4 (that would be Broadwell)?
>
Sorry, v3, actually. Haswell. (the first one supporting vmcs shadowing afaiu).
>> 1) Windows on Hyper-V (no nesting): 1350 cycles
>
On 21/12/2017 13:50, Vitaly Kuznetsov wrote:
> I'm back with (somewhat frustrating) results (E5-2603):
v4 (that would be Broadwell)?
> 1) Windows on Hyper-V (no nesting): 1350 cycles
>
> 2) Windows on Hyper-V on Hyper-V: 8600
>
> 3) Windows on KVM (no nesting): 1150 cycles
>
> 4) Windows on H
__dump_byte_array used to be hidden, but is now visible to the compiler
and causes a harmless warning:
drivers/staging/ccree/ssi_driver.c:82:6: error: conflicting types for
'__dump_byte_array'
drivers/staging/ccree/ssi_driver.c: In function '__dump_byte_array':
drivers/staging/ccree/ssi_driver.c:
Paolo Bonzini writes:
> On 19/12/2017 13:25, Vitaly Kuznetsov wrote:
>>
>>> At this point in time, I don't think you can just blithely change the
>>> virtual VMCS layout and revision number. Existing VMs using the old
>>> layout and revision number must continue to work on versions of kvm
>>> pa
Vitaly Kuznetsov writes:
> Paolo Bonzini writes:
>
>> On 18/12/2017 18:17, Vitaly Kuznetsov wrote:
>>> The original author of these patches does no longer work at Red Hat, I
>>> agreed to take this over and send upstream. Here is his original
>>> description:
>>>
>>> "Makes KVM implement the en
The driver xmit function chooses an egress FQ based on the current
core id. The network stack itself sets a mapping field in the skb
based on many things - the default one being a hash on packet fields,
which the current driver ignores.
This patch saves the ingress frame flow affinity information
The previous patch ensures Tx flow affinity for forwarded frames,
but for termination traffic the initial flow affinity is determined
based on the skb hash, which is expected to hit only a few Tx queues
when there is a small number of flows.
Instead, use XPS (transmit packet steering) to set netde
Changed the types of a number of index and length variables from int to
unsigned int. Fixes a number of warnings arising from their addresses
being passed to functions expecting pointers to unsigned ints.
Signed-off-by: Jeremy Sowden
---
drivers/staging/ccree/ssi_aead.c | 13 -
Hi Joe,
On Tue, Dec 19, 2017 at 10:15:08AM -0800, Joe Perches wrote:
> diff --git a/drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm.c
> b/drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm.c
> index a1c81c12718c..4338b8a1309f 100644
> --- a/drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm.c
39 matches
Mail list logo