RE: [PATCH 3/6] x86/hyper-v: reenlightenment notifications support

2017-12-12 Thread Michael Kelley (EOSG)
On Fri, Dec 08, 2017 at 11:49:57AM +0100, Vitaly Kuznetsov wrote: > -Original Message- > From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com] > Sent: Friday, December 8, 2017 2:50 AM > To: k...@vger.kernel.org; x...@kernel.org > Cc: Paolo Bonzini ; Radim Krčmář ; > Thomas > Gleixner ; Ingo

[PATCH net-next 6/6] hv_netvsc: empty current transmit aggregation if flow blocked

2017-12-12 Thread Stephen Hemminger
If the transmit queue is known full, then don't keep aggregating data. And the cp_partial flag which indicates that the current aggregation buffer is full can be folded in to avoid more conditionals. Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/hyperv_net.h | 2 +- drivers/net/hype

[PATCH net-next 2/6] hv_netvsc: track memory allocation failures in ethtool stats

2017-12-12 Thread Stephen Hemminger
When skb can not be allocated, update ethtool statisitics rather than rx_dropped which is intended for netif_receive. Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/hyperv_net.h | 1 + drivers/net/hyperv/netvsc_drv.c | 5 +++-- 2 files changed, 4 insertions(+), 2 deletions(-) diff --gi

[PATCH net-next 4/6] hv_netvsc: pass netvsc_device to receive callback

2017-12-12 Thread Stephen Hemminger
The netvsc_receive_callback function was using RCU to find the appropriate underlying netvsc_device. Since calling function already had that pointer, this was unnecessary. Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/hyperv_net.h | 1 + drivers/net/hyperv/netvsc_drv.c | 14 ++

[PATCH net-next 5/6] hv_netvsc: remove open_cnt reference count

2017-12-12 Thread Stephen Hemminger
There is only ever a single instance of network device object referencing the internal rndis object. Therefore the open_cnt atomic is not necessary. Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/hyperv_net.h | 2 -- drivers/net/hyperv/netvsc.c | 2 +- drivers/net/hyperv/rndis

[PATCH net-next 3/6] hv_netvsc: simplify function args in receive status path

2017-12-12 Thread Stephen Hemminger
The caller (netvsc_receive) already has the net device pointer, and should just pass that to functions rather than the hyperv device. This eliminates several impossible error paths in the process. Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/hyperv_net.h | 3 +-- drivers/net/hyperv

[PATCH net-next 1/6] hv_netvsc: copy_to_send buf can be void

2017-12-12 Thread Stephen Hemminger
Since only caller does not care about return value. Signed-off-by: Stephen Hemminger --- drivers/net/hyperv/netvsc.c | 22 -- 1 file changed, 8 insertions(+), 14 deletions(-) diff --git a/drivers/net/hyperv/netvsc.c b/drivers/net/hyperv/netvsc.c index e4bcd202a56a..9407907c4

[PATCH net-next 0/6] hv_netvsc: minor changes

2017-12-12 Thread Stephen Hemminger
This includes minor cleanup of code in send and receive path and also a new statistic to check for allocation failures. This also eliminates some of the extra RCU when not needed. There is a theoritical bug where buffered data could be blocked for longer than necessary if the ring buffer got full.

Re: My Proposal...can we discuss on proposal.

2017-12-12 Thread Ms. Liza Wong
___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

binder epoll bug (was KASAN: use-after-free Read in __lock_acquire (2))

2017-12-12 Thread Eric Biggers
[+Cc binder maintainers and list] [-Cc lockdep maintainers, USB maintainers, and other random people] On Sat, Dec 02, 2017 at 08:08:01AM -0800, syzbot wrote: > BUG: KASAN: use-after-free in __lock_acquire+0x465e/0x47f0 > kernel/locking/lockdep.c:3378 > Read of size 8 at addr 8801cd8e13f0 by ta

[PATCH] staging: pi433: Fix disordered switch case

2017-12-12 Thread Kari Argillander
Case: SHAPING_0_5 is writing DATAMODUL_MODLATION_SHAPE_0_3 value and vice versa Signed-off-by: Kari Argillander --- I have checked that defines are correct accounting to the datasheet. My first patch. Hopefully everything goes like needs to. I do not know if this should go to stable because pat

[PATCH] staging: comedi: s626.c - fix multiline dereference

2017-12-12 Thread Roman Lakeev
staging: comedi: s626.c - fix the following checkpatch issues: WARNING: Avoid multiple line dereference - prefer 'devpriv->rps_buf.logical_base' #1380: FILE: drivers/s626.c:1380: + (unsigned long)devpriv-> +

Re: first try to send data with pi433 on Raspberry Pi

2017-12-12 Thread Marcin Ciupak
On Mon, Dec 11, 2017 at 10:29:54PM +0200, Marcus Wolf wrote: > > Am 11.12.2017 um 20:40 schrieb Oliver Graute: > > Hello list, > > > > I just got my pi433 working somehow on Raspberry Pi Model B Rev 2. > > > > Here are my findings: > > > > first I need to enabling spi in config.txt on boot part

Re: first try to send data with pi433 on Raspberry Pi

2017-12-12 Thread Oliver Graute
On 11/12/17, Marcus Wolf wrote: > > Am 11.12.2017 um 20:40 schrieb Oliver Graute: > >Hello list, > > > >I just got my pi433 working somehow on Raspberry Pi Model B Rev 2. > > > >Here are my findings: > > > >first I need to enabling spi in config.txt on boot partition. > > > >dtparam=spi=on > > > >

[PATCH 24/24] staging: ccree: fix FIPS mgr naming convention

2017-12-12 Thread Gilad Ben-Yossef
The FIPS manager files were using a naming convention which was inconsistent (ssi vs. cc) and often too long. Make the code more readable by switching to a simpler, consistent naming convention. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_driver.c | 6 +++--- drivers/staging/c

[PATCH 20/24] staging: ccree: rename vars/structs/enums from ssi_ to cc_

2017-12-12 Thread Gilad Ben-Yossef
Unify naming convention by renaming all ssi_ vars/structs/enums and variables to cc_* Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_aead.c| 82 +-- drivers/staging/ccree/ssi_aead.h| 14 ++-- drivers/staging/ccree/ssi_buffer_mgr.c | 30 +++

[PATCH 23/24] staging: ccree: simplify freeing SRAM memory address

2017-12-12 Thread Gilad Ben-Yossef
The code freeing the SRAM memory address was zeroing the address on release although there is nothing secret about it. Simplify the code by simply calling kfree directly. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_sram_mgr.c | 7 +-- 1 file changed, 1 insertion(+), 6 delet

[PATCH 22/24] staging: ccree: fix sram mgr naming convention

2017-12-12 Thread Gilad Ben-Yossef
The SRAM manager files were using a naming convention which was inconsistent (ssi vs. cc) and often too long. Make the code more readable by switching to a simpler, consistent naming convention. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_driver.c | 8 drivers/stag

[PATCH 21/24] staging: ccree: fix buf mgr naming convention

2017-12-12 Thread Gilad Ben-Yossef
The buffer manager files were using a func naming convention which was inconsistent (ssi vs. cc) and often too long. Make the code more readable by switching to a simpler, consistent naming convention. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_buffer_mgr.c | 28 -

[PATCH 18/24] staging: ccree: rename all SSI to CC

2017-12-12 Thread Gilad Ben-Yossef
Unify naming convention by renaming all SSI macros to CC. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_aead.c| 26 +-- drivers/staging/ccree/ssi_aead.h| 6 +-- drivers/staging/ccree/ssi_buffer_mgr.c | 78 - drivers/stagin

[PATCH 19/24] staging: ccree: rename all DX to CC

2017-12-12 Thread Gilad Ben-Yossef
Unify naming convention by renaming all DX macros to CC. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/cc_hw_queue_defs.h | 4 +- drivers/staging/ccree/cc_lli_defs.h | 2 +- drivers/staging/ccree/dx_crys_kernel.h | 314 +++ drivers/staging/ccree

[PATCH 15/24] staging: ccree: fix ivgen func def coding style

2017-12-12 Thread Gilad Ben-Yossef
Fix ivgen functions definition indentation according to coding style guide lines for better code readability Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_ivgen.c | 16 +--- drivers/staging/ccree/ssi_ivgen.h | 10 +++--- 2 files changed, 8 insertions(+), 18 deleti

[PATCH 17/24] staging: ccree: remove SSI_CC_HAS_ macros

2017-12-12 Thread Gilad Ben-Yossef
Remove macro controlling build of various features. This needs to happen dynamically in registration time. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_aead.c | 33 - drivers/staging/ccree/ssi_buffer_mgr.c | 4 drivers/staging/ccree/ss

[PATCH 10/24] staging: ccree: fix req mgr func def coding style

2017-12-12 Thread Gilad Ben-Yossef
Fix request manager functions definition indentation according to coding style guide lines for better code readability Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_request_mgr.c | 21 + drivers/staging/ccree/ssi_request_mgr.h | 9 - 2 files changed,

[PATCH 12/24] staging: ccree: fix cipher naming convention

2017-12-12 Thread Gilad Ben-Yossef
The blkcipher files were using a func naming convention which was inconsistent (ssi vs. cc), included a long prefix (ssi_ablkcipher) and often too long. Make the code more readable by switching to a simpler, consistent naming convention. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree

[PATCH 16/24] staging: ccree: drop unsupported MULTI2 mode code

2017-12-12 Thread Gilad Ben-Yossef
Remove the code support for MULTI2 mode which is not supported by the current hardware. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/cc_crypto_ctx.h| 17 drivers/staging/ccree/cc_hw_queue_defs.h | 2 - drivers/staging/ccree/ssi_cipher.c | 167 --

[PATCH 13/24] staging: ccree: fix cipher func def coding style

2017-12-12 Thread Gilad Ben-Yossef
Fix cipher functions definition indentation according to coding style guide lines for better code readability Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_cipher.c | 38 +++--- 1 file changed, 15 insertions(+), 23 deletions(-) diff --git a/driver

[PATCH 14/24] staging: ccree: fix ivgen naming convention

2017-12-12 Thread Gilad Ben-Yossef
The ivgen files were using a func naming convention which was inconsistent (ssi vs. cc), included a long prefix (ssi_ivgen) and often too long. Make the code more readable by switching to a simpler, consistent naming convention. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_driv

[PATCH 11/24] staging: ccree: remove cipher sync blkcipher remains

2017-12-12 Thread Gilad Ben-Yossef
Remove the remains of no longer existing support for running blkcipher is sync mode. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_cipher.c | 156 - 1 file changed, 51 insertions(+), 105 deletions(-) diff --git a/drivers/staging/ccree/ssi_ciph

[PATCH 08/24] staging: ccree: fix func call param indentation

2017-12-12 Thread Gilad Ben-Yossef
Fix function call parameter indentation according to coding style guide lines. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_buffer_mgr.c | 28 +++- drivers/staging/ccree/ssi_hash.c | 10 -- 2 files changed, 15 insertions(+), 23 deletions(-)

[PATCH 07/24] staging: ccree: simplify expression with local var

2017-12-12 Thread Gilad Ben-Yossef
Simplify expression by using a local variable for better code readability. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_buffer_mgr.c | 22 ++ 1 file changed, 10 insertions(+), 12 deletions(-) diff --git a/drivers/staging/ccree/ssi_buffer_mgr.c b/drivers/sta

[PATCH 09/24] staging: ccree: fix reg mgr naming convention

2017-12-12 Thread Gilad Ben-Yossef
The request manager files were using a func naming convention which was inconsistent (ssi vs. cc), included a useless prefix (ssi_request_mgr) and often too long. Make the code more readable by switching to a simpler, consistent naming convention. Signed-off-by: Gilad Ben-Yossef --- drivers/sta

[PATCH 06/24] staging: ccree: fix func def and decl coding style

2017-12-12 Thread Gilad Ben-Yossef
Fix functions definition and declaration indentation according to coding style guide lines for better code readability Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_aead.c | 5 +- drivers/staging/ccree/ssi_buffer_mgr.c | 144 + drivers/stag

[PATCH 05/24] staging: ccree: shorten parameter name

2017-12-12 Thread Gilad Ben-Yossef
Shorten parameter name for better code readability Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_aead.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/staging/ccree/ssi_aead.c b/drivers/staging/ccree/ssi_aead.c index 75a578e..62d45e9

[PATCH 03/24] staging: ccree: amend hash func def for readability

2017-12-12 Thread Gilad Ben-Yossef
Func definitions in the hash implementation were did not adhere to coding style. Fix them for better readability. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_hash.c | 20 +++- 1 file changed, 7 insertions(+), 13 deletions(-) diff --git a/drivers/staging/ccree/s

[PATCH 04/24] staging: ccree: func params should follow func name

2017-12-12 Thread Gilad Ben-Yossef
Fix some call sites with func params not following func name in AEAD code. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_aead.c | 10 ++ 1 file changed, 6 insertions(+), 4 deletions(-) diff --git a/drivers/staging/ccree/ssi_aead.c b/drivers/staging/ccree/ssi_aead.c index

[PATCH 02/24] staging: ccree: fix hash naming convention

2017-12-12 Thread Gilad Ben-Yossef
The hash files were using a naming convention which was inconsistent (ssi vs. cc), included a useless prefix (ssi_hash) and often used too long function names producing monster such as ssi_ahash_get_initial_digest_len_sram_addr() that made the call site hard to read. Make the code more readable by

[PATCH 00/24] staging: ccree: cleanups and simplification

2017-12-12 Thread Gilad Ben-Yossef
More CCREE code cleanup and simplifications, including: - Drop code supporting long code synch cipher and hash usage - Drop ifdef out code for features not supported by HW - More naming convention and name space cleanup - Coding style fixes This patch set goes on top of Dan Carpenter's patch entit

[PATCH 01/24] staging: ccree: remove ahash wrappers

2017-12-12 Thread Gilad Ben-Yossef
Remove a no longer needed abstraction around ccree hash crypto API internals that used to allow same ops to be used in synchronous and asynchronous fashion. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_hash.c | 260 --- 1 file changed, 76 inse

[PATCH] rtl8188eu: Fix a possible sleep-in-atomic bug in set_tx_beacon_cmd

2017-12-12 Thread Jia-Ju Bai
The driver may sleep under a spinlock. The function call path is: update_beacon (acquire the spinlock) update_BCNTIM set_tx_beacon_cmd kzalloc(GFP_KERNEL) --> may sleep kmemdup(GFP_KERNEL) --> may sleep To fix it, GFP_KERNEL is replaced with GFP_ATOMIC. This bug is found by my s

Re: [PATCH v4 3/5] staging: Introduce NVIDIA Tegra video decoder driver

2017-12-12 Thread Hans Verkuil
On 10/12/17 19:56, Dmitry Osipenko wrote: > On 05.12.2017 16:03, Hans Verkuil wrote: >> On 12/05/17 13:17, Dmitry Osipenko wrote: >>> Hi Hans, >>> >>> On 04.12.2017 17:04, Hans Verkuil wrote: Hi Dmitry, As you already mention in the TODO, this should become a v4l2 codec driver.

[PATCH] vme: Fix a possible sleep-in-atomic bug in vme_tsi148

2017-12-12 Thread Jia-Ju Bai
The driver may sleep under a spinlock. The function call path is: tsi148_master_write \ tsi148_master_read (acquire the spinlock) vme_register_error_handler kmalloc(GFP_KERNEL) --> may sleep To fix it, GFP_KERNEL is replaced with GFP_ATOMIC. This bug is found by my static analysis tool(DSAC

[BUG] vme_ca91cx42: a possible sleep-in-atomic bug in ca91cx42_master_set

2017-12-12 Thread Jia-Ju Bai
According to drivers/vme/bridges/vme_ca91cx42.c, the driver may sleep under a spinlock. The function call path is: ca91cx42_master_set (acquire the spinlock) ca91cx42_alloc_resource ioremap_nocache --> may sleep I do not find a good way to fix it, so I only report. This possible bug is fou

Re: [PATCH] Staging: comedi: drivers: serial2002 fixed a blank line coding style

2017-12-12 Thread Ian Abbott
On 08/12/17 18:56, Vikash Kesarwani wrote: Fixed a blank line coding style after a declaration Signed-off-by: Vikash Kesarwani --- drivers/staging/comedi/drivers/serial2002.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/comedi/drivers/serial2002.c b/drivers/staging/co

Re: [PATCH v2] drivers: visorbus: move driver out of staging

2017-12-12 Thread Christoph Hellwig
Hi David, as said before, please submit the actual files as new code to the kernel. The code will need a full review, and a simple move is not going to cut it. Posting the actual code as patches will allow for the proper review that is needed. ___ deve

Re: [PATCH 6/6] x86/kvm: support Hyper-V reenlightenment

2017-12-12 Thread Vitaly Kuznetsov
Vitaly Kuznetsov writes: > Roman Kagan writes: > >> On Fri, Dec 08, 2017 at 11:50:00AM +0100, Vitaly Kuznetsov wrote: >>> When we run nested KVM on Hyper-V guests we need to update masterclocks for >>> all guests when L1 migrates to a host with different TSC frequency. >>> Implement the procedur

Re: [PATCH 3/6] x86/hyper-v: reenlightenment notifications support

2017-12-12 Thread Vitaly Kuznetsov
Roman Kagan writes: > On Mon, Dec 11, 2017 at 10:56:33AM +0100, Vitaly Kuznetsov wrote: >> Roman Kagan writes: >> > On Fri, Dec 08, 2017 at 11:49:57AM +0100, Vitaly Kuznetsov wrote: >> >> +void register_hv_tsc_update(void (*cb)(void)) >> >> +{ >> > >> > The function name seems unfortunate. IMHO