On Mon, Dec 04, 2017 at 03:19:39AM +0530, Pravin Shedge wrote:
> These duplicate includes have been found with scripts/checkincludes.pl but
> they have been removed manually to avoid removing false positives.
>
> Unit Testing:
>
> - build successful
> - LTP testsuite passes.
> - checkpatch.pl pas
On Mon, Dec 04, 2017 at 01:17:36AM -0500, Genki Sky wrote:
> In bcm2835-camera, handle the following checkpatch.pl types:
> - EMBEDDED_FUNCTION_NAME
> - MULTILINE_DEREFERENCE
> - SPLIT_STRING
>
> [ note: this is for Task 10 of http://eudyptula-challenge.org/ ]
>
> Signed-off-by: Genki Sky
In bcm2835-camera, handle the following checkpatch.pl types:
- EMBEDDED_FUNCTION_NAME
- MULTILINE_DEREFERENCE
- SPLIT_STRING
[ note: this is for Task 10 of http://eudyptula-challenge.org/ ]
Signed-off-by: Genki Sky
---
.../vc04_services/bcm2835-camera/bcm2835-camera.c | 23 +-
On Mon, 2017-12-04 at 03:19 +0530, Pravin Shedge wrote:
> These duplicate includes have been found with scripts/checkincludes.pl but
> they have been removed manually to avoid removing false positives.
Can you list the duplicates that were not removed as well please?
_
On Mon, Dec 04, 2017 at 03:19:39AM +0530, Pravin Shedge wrote:
> These duplicate includes have been found with scripts/checkincludes.pl but
> they have been removed manually to avoid removing false positives.
>
> Unit Testing:
>
> - build successful
> - LTP testsuite passes.
> - checkpatch.pl pas
These duplicate includes have been found with scripts/checkincludes.pl but
they have been removed manually to avoid removing false positives.
Unit Testing:
- build successful
- LTP testsuite passes.
- checkpatch.pl passes
Signed-off-by: Pravin Shedge
---
arch/arm/crypto/aes-ce-glue.c
No need to get into the submenu to disable all ANDROID-related config entries
Signed-off-by: Vincent Legoll
---
drivers/android/Kconfig | 6 +-
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/drivers/android/Kconfig b/drivers/android/Kconfig
index 7dce3795b887..e9434777acba 1006
On 12/03/2017 03:47 AM, Dilger, Andreas wrote:
On Dec 2, 2017, at 11:40, Aliaksei Karaliou wrote:
Lustre code lacks checking the result of register_shrinker()
in several places. register_shrinker() was tagged __must_check
recently so that sparse has started reporting it.
Thank you for your pa
Am 03.12.2017 um 17:17 schrieb Simon Sandström:
Renames the enum optionOnOff and its values optionOn, optionOff to enum
option_on_off and OPTION_ON, OPTION_OFF. Fixes checkpatch.pl warnings:
"Avoid CamelCase: , , ".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 34 +
These patches fixes a bunch of code style issues in staging/pi433. The
first patch fixes indentation in rf69_enum.h and the rest of the patches
fixes CamelCase issues in all of staging/pi433.
In total the patches get rids of around 140 warnings generated by
checkpatch.pl.
- Simon
---
Simon Sand
Renames variable thresholdDecrement in struct pi433_rx_cfg to
threshold_decrement to get rid of checkpatch.pl warning
"Avoid CamelCase: ".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 2 +-
drivers/staging/pi433/pi433_if.h | 2 +-
2 files changed, 2 insertions(+), 2 dele
Fixes checkpatch.pl warnings "Avoid CamelCase ".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 32 -
drivers/staging/pi433/rf69_registers.h | 44 +-
2 files changed, 38 insertions(+), 38 deletions(-)
diff --gi
Renames enum dataMode and its values packet, continuous, continuousNoSync
to enum data_mode and PACKET, CONTINUOUS, CONTINUOUS_NO_SYNC. Fixes
checkpatch.pl warnings: "Avoid CamelCase: , ".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 2 +-
drivers/staging/pi433/rf69.c
Renames enum modShaping and its values to get rid of checkpatch.pl
warnings: "Avoid CamelCase: ".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 2 +-
drivers/staging/pi433/pi433_if.h | 2 +-
drivers/staging/pi433/rf69.c | 21 +++--
drivers/staging
Basically just 's//\t/', to fix checkpatch.pl warnings:
"please, no spaces at the start of a line".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/rf69_enum.h | 207 +++---
1 file changed, 103 insertions(+), 104 deletions(-)
diff --git a/drivers/sta
Renames the enum optionOnOff and its values optionOn, optionOff to enum
option_on_off and OPTION_ON, OPTION_OFF. Fixes checkpatch.pl warnings:
"Avoid CamelCase: , , ".
Signed-off-by: Simon Sandström
---
drivers/staging/pi433/pi433_if.c | 34 ++---
drivers/staging/pi433/p
From: Stephen Hemminger
Date: Fri, 1 Dec 2017 11:01:43 -0800
> These are a set of local optimizations the Hyper-V networking driver.
> Also include a vmbus patch in this set, because it depends on the
> netvsc that last used that function.
Series applied.
For the ring percentage stuff, I would
Func definitions in the aead implementation were did not adhere to
coding style. Fix them for better readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c | 141 ++-
1 file changed, 51 insertions(+), 90 deletions(-)
diff --git a/dr
The aead files was using a func naming convention which was inconsistent
(ssi vs. cc), included a useless prefix (ssi_aead) and often used
too long function names producing monster func names such as
ssi_aead_gcm_setup_ghash_desc() that made the call site code hard
to read.
Make the code more read
The ccree drivers was marking a lot of big functions in C file as
static inline for no good reason. Remove the inline qualifier from
any but the few truly single line functions.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 40 -
dr
backup_info field is only allocated for decrypt code path.
The field was not nullified when not used causing a kfree
in an error handling path to attempt to free random
addresses as uncovered in stress testing.
Fixes: 737aed947f9b ("staging: ccree: save ciphertext for CTS IV")
Cc: sta...@vger.kern
The removal of likely/unlikely unearthed some more
unnecessary parentheses. Remove them for better readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 4 ++--
drivers/staging/ccree/ssi_driver.c | 6 +++---
drivers/staging/ccree/ssi_request_mgr.c | 2 +-
Another batch of ccree work. Includes the usual mix of mostly cleanups
and one fix. Also includes an updated TODO to reflect recent progress
and removal of interim documentation of device tree strings as the
official string and documentation thereof got blessed into the crypto tree.
Gilad Ben-Yoss
Update the ccree staging TODO list in light of recent work.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/TODO | 23 ++-
1 file changed, 2 insertions(+), 21 deletions(-)
diff --git a/drivers/staging/ccree/TODO b/drivers/staging/ccree/TODO
index c9f5754..f44edcd 1
Remove braces from single statement if clause.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_request_mgr.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/ccree/ssi_request_mgr.c
b/drivers/staging/ccree/ssi_request_mgr.c
index e890cb6..5f343
Fix indentation of var assignment split across lines for
better readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ccree/ssi_aead.c b/drivers/staging/ccree/ssi_aead.c
index 0b08
As proper DT bindings doc where submitted and ACKed,
remove the interim one.
Signed-off-by: Gilad Ben-Yossef
---
.../devicetree/bindings/crypto/arm-cryptocell.txt | 27 --
1 file changed, 27 deletions(-)
delete mode 100644
drivers/staging/ccree/Documentation/devicetree/bin
The ccree code made a lot of use of likely/unlikely qualifiers without
proven measurements showing any benefits. Remove them all until we
see what is justified and what is not.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 57 ++--
drivers/staging/ccree/s
Am 03.12.2017 um 11:56 schrieb Marcin Ciupak:
On Sat, Dec 02, 2017 at 08:46:15AM -0800, Joe Perches wrote:
On Sat, 2017-12-02 at 17:20 +0200, Marcus Wolf wrote:
rf69_set_dc_cut_off_frequency_intern is used by rf69.c internally only.
Therefore removed the function from header and declared it sta
On 2017-12-03, at 08:39:21 +0300, Dan Carpenter wrote:
> On Sat, Dec 02, 2017 at 08:41:48PM +, Jeremy Sowden wrote:
> > On 2017-12-02, at 10:35:06 +, Jeremy Sowden wrote:
> > > On 2017-12-02, at 13:20:09 +0300, Dan Carpenter wrote:
> > > > On Fri, Dec 01, 2017 at 05:19:37PM +, Jeremy So
On Sat, Dec 02, 2017 at 08:46:15AM -0800, Joe Perches wrote:
> On Sat, 2017-12-02 at 17:20 +0200, Marcus Wolf wrote:
> > rf69_set_dc_cut_off_frequency_intern is used by rf69.c internally only.
> > Therefore removed the function from header and declared it staic in
> > the implemtation.
> > Signed-o
On 12/02/2017 10:50 PM, Joe Perches wrote:
> On Sat, 2017-12-02 at 22:05 +0100, Tomas Marek wrote:
>> This patch fix several brace on next line, braces not necessary, space
>> around =/<, and space before/after open/close parenthesis coding style
>> errors find by checkpatch in pi433_if.c.
>>
>> Si
32 matches
Mail list logo