On Thu, Nov 30, 2017 at 10:39:48AM -0500, Joshua Abraham wrote:
> diff --git a/drivers/staging/xgifb/XGI_main_26.c
> b/drivers/staging/xgifb/XGI_main_26.c
> index 6feecc55d2bc..6de66eaad96b 100644
> --- a/drivers/staging/xgifb/XGI_main_26.c
> +++ b/drivers/staging/xgifb/XGI_main_26.c
> @@ -34,16 +
2017-12-01 2:01 GMT+09:00 Miquel Raynal :
> From: Boris Brezillon
>
> The core currently send the READ0 and SEQIN+PAGEPROG commands in
> nand_do_read/write_ops(). This is inconsistent with
> ->read/write_oob[_raw]() hooks behavior which are expected to send
> these commands.
>
> There's already a
2017-12-01 2:01 GMT+09:00 Miquel Raynal :
> From: Boris Brezillon
>
> This is part of the process of removing direct calls to ->cmdfunc()
> outside of the core in order to introduce a better interface to execute
> NAND operations.
>
> Here we provide several helpers and make use of them to remove
2017-12-01 7:02 GMT+09:00 Miquel RAYNAL :
>> > diff --git a/drivers/mtd/nand/nand_base.c
>> > b/drivers/mtd/nand/nand_base.c index 630048f5abdc..4d1f2bda6095
>> > 100644 --- a/drivers/mtd/nand/nand_base.c
>> > +++ b/drivers/mtd/nand/nand_base.c
>> > @@ -3077,7 +3077,7 @@ int nand_erase_nand(struct
On 11/30/2017 02:53 PM, James Hogan wrote:
On Tue, Nov 28, 2017 at 04:55:35PM -0800, David Daney wrote:
From: Carlos Munoz
Add a global resource manager to manage tagged pointers within
bootmem allocated memory. This is used by various functional
blocks in the Octeon core like the FPA, Etherne
On Thu, Nov 30, 2017 at 03:09:33PM -0800, David Daney wrote:
> On 11/30/2017 02:56 PM, James Hogan wrote:
> > On Thu, Nov 30, 2017 at 01:49:43PM -0800, David Daney wrote:
> >> On 11/30/2017 01:36 PM, James Hogan wrote:
> >>> On Tue, Nov 28, 2017 at 04:55:34PM -0800, David Daney wrote:
> Signed
On 11/30/2017 02:56 PM, James Hogan wrote:
On Thu, Nov 30, 2017 at 01:49:43PM -0800, David Daney wrote:
On 11/30/2017 01:36 PM, James Hogan wrote:
On Tue, Nov 28, 2017 at 04:55:34PM -0800, David Daney wrote:
Signed-off-by: Carlos Munoz
Signed-off-by: Steven J. Hill
Signed-off-by: David Daney
On Thu, Nov 30, 2017 at 01:49:43PM -0800, David Daney wrote:
> On 11/30/2017 01:36 PM, James Hogan wrote:
> > On Tue, Nov 28, 2017 at 04:55:34PM -0800, David Daney wrote:
> >> Signed-off-by: Carlos Munoz
> >> Signed-off-by: Steven J. Hill
> >> Signed-off-by: David Daney
> >> ---
> >> arch/mips
On Tue, Nov 28, 2017 at 04:55:35PM -0800, David Daney wrote:
> From: Carlos Munoz
>
> Add a global resource manager to manage tagged pointers within
> bootmem allocated memory. This is used by various functional
> blocks in the Octeon core like the FPA, Ethernet nexus, etc.
>
> Signed-off-by: Ca
> > diff --git a/drivers/mtd/nand/nand_base.c
> > b/drivers/mtd/nand/nand_base.c index 52965a8aeb2c..46bf31aff909
> > 100644 --- a/drivers/mtd/nand/nand_base.c
> > +++ b/drivers/mtd/nand/nand_base.c
> > @@ -689,6 +689,59 @@ static void nand_wait_status_ready(struct
> > mtd_info *mtd, unsigned long
> > diff --git a/drivers/mtd/nand/nand_base.c
> > b/drivers/mtd/nand/nand_base.c index 630048f5abdc..4d1f2bda6095
> > 100644 --- a/drivers/mtd/nand/nand_base.c
> > +++ b/drivers/mtd/nand/nand_base.c
> > @@ -3077,7 +3077,7 @@ int nand_erase_nand(struct mtd_info *mtd,
> > struct erase_info *instr, st
On 11/30/2017 01:36 PM, James Hogan wrote:
On Tue, Nov 28, 2017 at 04:55:34PM -0800, David Daney wrote:
From: Carlos Munoz
LMTDMA/LMTST operations move data between cores and I/O devices:
* LMTST operations can send an address and a variable length
(up to 128 bytes) of data to an I/O devic
The CSS API uses a lot of nested anonymous structs defined in object
macros to assign default values to its data-structures. These have been
changed to use compound-literals and designated initializers to make
them more comprehensible and less fragile.
The compound-literals can also be used in as
Removing zero-valued struct-members left a number of the default
struct-values empty. These values have now been removed.
Signed-off-by: Jeremy Sowden
---
.../atomisp/pci/atomisp2/css2400/ia_css_pipe.h | 1 -
.../atomisp/pci/atomisp2/css2400/ia_css_types.h| 1 -
.../isp/kernels/s3a/s3
The CSS API uses a lot of nested anonymous structs defined in object
macros to assign default values to its data-structures. These have been
changed to use compound-literals and designated initializers to make
them more comprehensible and less fragile.
The compound-literals can also be used in as
A lot of the members of the default struct values used by the CSS API
were explicitly initialized to zero values. Designated initializers
have allowed these members to be removed.
Signed-off-by: Jeremy Sowden
---
.../hive_isp_css_common/input_formatter_global.h | 17
.../pci/atomisp2/cs
Fix checkpatch warning and add result holder variable to reduce overhead
since the macro is called on functions.
Signed-off-by: Nguyen Phan Quang Minh
---
Since SET_CHECKED has a return statement, I'm very tempted to straight
up remove it and do the checking inline. But the macro is used a lot
(~
On Tue, Nov 28, 2017 at 04:55:34PM -0800, David Daney wrote:
> From: Carlos Munoz
>
> LMTDMA/LMTST operations move data between cores and I/O devices:
>
> * LMTST operations can send an address and a variable length
> (up to 128 bytes) of data to an I/O device.
> * LMTDMA operations can send a
On Thu, 30 Nov 2017 18:01:28 +0100
Miquel Raynal wrote:
> Avoid using specific defined values for checking returned status of the
> ->erase() hook. Instead, use usual negative error values on failure,
> zero otherwise.
>
> Signed-off-by: Miquel Raynal
> ---
> drivers/mtd/nand/denali.c| 2
On Thu, 30 Nov 2017 18:01:32 +0100
Miquel Raynal wrote:
> Introduce a new interface to instruct NAND controllers to send specific
> NAND operations. The new interface takes the form of a single method
> called ->exec_op(). This method is designed to replace ->cmd_ctrl(),
> ->cmdfunc() and ->read/
Change 0 to NULL in lov_object_fiemap() in order to fix warning produced
by sparse
Signed-off-by: Andrii Vladyka
diff --git a/drivers/staging/lustre/lustre/lov/lov_object.c
b/drivers/staging/lustre/lustre/lov/lov_object.c
index 105b707..897cf2c 100644
--- a/drivers/staging/lustre/lustre/lov/
Thomas Gleixner writes:
> On Tue, 31 Oct 2017, mikel...@exchange.microsoft.com wrote:
> > diff --git a/arch/x86/include/uapi/asm/hyperv.h
> > b/arch/x86/include/uapi/asm/hyperv.h
> > index f65d125..408cf3e 100644
> > --- a/arch/x86/include/uapi/asm/hyperv.h
> > +++ b/arch/x86/include/uapi/asm/hyp
Vitaly Kuznetsov writes:
> Vitaly Kuznetsov writes:
>
> > mikel...@exchange.microsoft.com writes:
> >
> >> From: Michael Kelley
> >>
> >> The 2016 version of Hyper-V offers the option to operate the guest VM
> >> per-vcpu stimer's in Direct Mode, which means the timer interupts on
> >> its own
This patch fixes the following checkpatch.pl error:
ERROR: spaces required around that '=' (ctx:VxV)
#912: FILE: pi433_if.c:912:
+ for (i=0; i
---
drivers/staging/pi433/pi433_if.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/pi433/pi433_if.c b/drivers/
This patch fixes the following checkpatch.pl errors:
ERROR: that open brace { should be on the previous line
#344: FILE: pi433_if.c:344:
+ if(retval) /* wait was interrupted */
+ {
ERROR: space required before the open parenthesis '('
#344: FILE: pi433_if.c:344:
+ if(retval) /*
This patch fixes the following checkpatch.pl error:
ERROR: space required after that ',' (ctx:VxV)
#342: FILE: pi433_if.c:342:
+ dev_dbg(dev->dev,"rx: going to wait for any tx to finish");
Signed-off-by: Oliver Graute
---
drivers/staging/pi433/pi433_if.c | 2 +-
1 file changed, 1 insertio
Hi Greg,
don't know, wether that's best option.
With that procedure, it will be very hard, to integrate large patches,
if the owner of the patch isn't dealing with kernel source in his daily
business and thus isn't able to react on new releases within no time.
I've seen the release of 4.15rc
On Thu, Nov 30, 2017 at 09:00:03AM -0800, Randy Dunlap wrote:
> From: Randy Dunlap
>
> IPX depends on NET, so add that to the Kconfig file.
>
> Fixes Kconfig warning and build errors:
>
> warning: (IPX) selects LLC which has unmet direct dependencies (NET)
> and 94 "undefined reference" build e
On Thu, Nov 30, 2017 at 06:01:46PM +0100, Marcin Ciupak wrote:
> On Sat, Nov 11, 2017 at 01:51:10PM +0200, Marcus Wolf wrote:
> Hi Marcus,
>
> since 4.15-rc1 is out I would like to ask if you are going to provide
> your changes anytime soon?
>
> I would like to send a few patches as well and do n
From: Boris Brezillon
The core currently send the READ0 and SEQIN+PAGEPROG commands in
nand_do_read/write_ops(). This is inconsistent with
->read/write_oob[_raw]() hooks behavior which are expected to send
these commands.
There's already a flag (NAND_ECC_CUSTOM_PAGE_ACCESS) to inform the core
th
From: Boris Brezillon
This is part of the process of removing direct calls to ->cmdfunc()
outside of the core in order to introduce a better interface to execute
NAND operations.
Here we provide several helpers and make use of them to remove all
direct calls to ->cmdfunc(). This way, we can easi
Introduce a new interface to instruct NAND controllers to send specific
NAND operations. The new interface takes the form of a single method
called ->exec_op(). This method is designed to replace ->cmd_ctrl(),
->cmdfunc() and ->read/write_byte/word/buf() hooks.
->exec_op() is passed a set of instr
Change the nand_chip structure, to embed the nand_data_interface object.
Also remove the nand_get_default_data_interface() function that become
useless but add the initialization of the data_interface at the very
beginning of nand_scan_ident() to be sure core functions using timings
may be used sa
Hi,
This series adds the implementation of the NAND framework ->exec_op()
interface with all the related hooks and helpers. The reasons for adding
it are explained in details in the commit log:
"mtd: nand: add ->exec_op() implementation"
Long story short: it will ease later expansion of
On Sat, Nov 11, 2017 at 01:51:10PM +0200, Marcus Wolf wrote:
Hi Marcus,
since 4.15-rc1 is out I would like to ask if you are going to provide
your changes anytime soon?
I would like to send a few patches as well and do not want to block your
work.
Thanks,
Marcin
> Hi Greg,
>
> ok.
>
> I'll po
Avoid using specific defined values for checking returned status of the
->erase() hook. Instead, use usual negative error values on failure,
zero otherwise.
Signed-off-by: Miquel Raynal
---
drivers/mtd/nand/denali.c| 2 +-
drivers/mtd/nand/docg4.c | 7 ++-
drivers/mtd/nand/nand_base.
fig |1 +
1 file changed, 1 insertion(+)
--- linux-next-20171130.orig/drivers/staging/ipx/Kconfig
+++ linux-next-20171130/drivers/staging/ipx/Kconfig
@@ -3,6 +3,7 @@
#
config IPX
tristate "The IPX protocol"
+ depends on NET
select LLC
---help---
Hi Greg,
On Thursday 30 November 2017 10:11 PM, Greg KH wrote:
On Thu, Nov 30, 2017 at 09:13:35PM +0530, Arvind Yadav wrote:
platform_get_irq() can fail here and we must check its return value.
Signed-off-by: Arvind Yadav
---
drivers/staging/irda/drivers/pxaficp_ir.c | 10 ++
1 fil
On Thu, Nov 30, 2017 at 09:13:35PM +0530, Arvind Yadav wrote:
> platform_get_irq() can fail here and we must check its return value.
>
> Signed-off-by: Arvind Yadav
> ---
> drivers/staging/irda/drivers/pxaficp_ir.c | 10 ++
> 1 file changed, 10 insertions(+)
Did you read drivers/staging
The platform_get_irq() function returns negative if an error occurs.
zero or positive number on success. platform_get_irq() error checking
for zero is not correct.
Remove unnecessary 'err' initialization for irda driver.
Arvind Yadav (3):
[PATCH 1/3] iio: trigger: Fix platform_get_irq's error c
Here, variable 'err' is already initialised. So no need to reinitialize.
Signed-off-by: Arvind Yadav
---
drivers/staging/irda/drivers/pxaficp_ir.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/irda/drivers/pxaficp_ir.c
b/drivers/staging/irda/drivers/pxaficp_ir.c
index a97ce
The platform_get_irq() function returns negative if an error occurs.
zero or positive number on success. platform_get_irq() error checking
for zero is not correct.
Signed-off-by: Arvind Yadav
---
drivers/staging/iio/trigger/iio-trig-bfin-timer.c | 4 ++--
1 file changed, 2 insertions(+), 2 delet
platform_get_irq() can fail here and we must check its return value.
Signed-off-by: Arvind Yadav
---
drivers/staging/irda/drivers/pxaficp_ir.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/drivers/staging/irda/drivers/pxaficp_ir.c
b/drivers/staging/irda/drivers/pxaficp_ir.c
in
This patch removes macros in XGI_main.h that contain a xgifb_info
variable. These macros hurt readability by hiding said variable
behind a define.
Signed-off-by: Joshua Abraham
---
drivers/staging/xgifb/XGI_main.h| 13 ---
drivers/staging/xgifb/XGI_main_26.c | 227 +
On Thu, Nov 30, 2017 at 08:55:44AM +0300, Dan Carpenter wrote:
> On Wed, Nov 29, 2017 at 09:53:48PM -0500, Joshua Abraham wrote:
> > Signed-off-by: Joshua Abraham
> >
> > This patch removes the unused macro XGIPART3.
> >
>
> The Signed-off-by line goes after the changelog.
>
> > ---
> > drive
45 matches
Mail list logo