* Ian Abbott [2017-11-20 10:46:36 +]:
On 20/11/17 10:29, Ian Abbott wrote:
On 20/11/17 07:50, Jesse Chan wrote:
This change resolves a new compile-time warning
when built as a loadable module:
WARNING: modpost: missing MODULE_LICENSE() in
drivers/staging/comedi/drivers/ni_atmio.o
see i
pci_get_bus_and_slot() is restrictive such that it assumes domain=0 as
where a PCI device is present. This restricts the device drivers to be
reused for other domain numbers.
Use pci_get_domain_bus_and_slot() with a domain number of 0 where we can't
extract the domain number. Other places, use the
pci_get_bus_and_slot() is restrictive such that it assumes domain=0 as
where a PCI device is present. This restricts the device drivers to be
reused for other domain numbers.
Use pci_get_domain_bus_and_slot() with a domain number of 0 where we can't
extract the domain number. Other places, use the
Missing subsystem in subject line. Please use the same git brief
description format that has been used previously for files you want to
patch. You can view previous commits for a file using
git log --pretty=oneline --abbrev --reverse
On Mon, Nov 20, 2017 at 03:14:21PM -0600, zebmccor...@d
You may like to limit the git log brief description to 50 characters
(this is going to be hard with such a long pre-fix though :)
Brief description should be in imperative mood i.e 'Fix foo' instead of
'fixed foo'.
On Tue, Nov 21, 2017 at 05:17:53PM -0200, Guilherme Tadashi Maeoka wrote:
> Fixed
On Tue, Nov 21, 2017 at 10:35:23AM +0530, Bharat Bhushan wrote:
> According to MC APIs, size of mc-portal in 32bit.
> Also fsl_create_mc_io() storing 32 bit mc-portal size.
>" mc_io->portal_size = mc_portal_size;"
>While "mc_io->portal_size" is u16 type and
>"mc_portal_size" is u32 type
From: Zebulon McCorkle
Line up arguments to opening parentheses and ensure lines stay under 80
columns, since checkpatch.pl was complaining about incorrect indentation
in function calls and definitions.
Signed-off-by: Zebulon McCorkle
---
drivers/staging/olpc_dcon/olpc_dcon.c | 30 +++
From: Zebulon McCorkle
checkpatch.pl was complaining about style issues in the olpc_dcon driver.
I've split this into two patches at the request of Greg Kroah-Hartman's
patch-bot.
Zebulon McCorkle (2):
olpc_dcon: Change bitshifts to BIT macro
olpc_dcon: Line up parentheses in func calls and
From: Zebulon McCorkle
checkpatch.pl reported the bitshifts (1<
---
drivers/staging/olpc_dcon/olpc_dcon.h | 30 +++---
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/olpc_dcon/olpc_dcon.h
b/drivers/staging/olpc_dcon/olpc_dcon.h
index 8fbd
From: Haiyang Zhang
On Hyper-V the VF NIC has the same MAC as the related synthetic NIC.
VF NIC can work under the synthetic NIC transparently, without its
own IP address. The existing KVP daemon only gets IP from the first
NIC matching a MAC address, and may not be able to find the IP in
this ca
Fixed some code style issues.
Signed-off-by: Guilherme Tadashi Maeoka
---
drivers/staging/comedi/drivers/adl_pci9118.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/comedi/drivers/adl_pci9118.c
b/drivers/staging/comedi/drivers/adl_pci9118.c
ind
This patch takes the 'aim' prefixes and variable names off the module and
uses component instead. It is needed because userspace interfacing modules
are referred to as components.
Signed-off-by: Christian Gromm
---
drivers/staging/most/video/video.c | 152 ++---
1
This patch updates and corrects the comment sections of the code.
Signed-off-by: Christian Gromm
---
drivers/staging/most/cdev/cdev.c | 4 +-
drivers/staging/most/core.c| 108 -
drivers/staging/most/core.h| 39 ++
drivers/stagi
From: Andrey Shvetsov
This patch keeps the usage file up to date.
Signed-off-by: Christian Gromm
---
.../staging/most/Documentation/driver_usage.txt| 192 +++--
1 file changed, 105 insertions(+), 87 deletions(-)
diff --git a/drivers/staging/most/Documentation/driver_usage.
This patch fixes coding style violations.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c| 7 +--
drivers/staging/most/video/video.c | 2 +-
2 files changed, 2 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/most/core.c b/drivers/staging/most/core.c
index b
This patchg adds the sysfs-bus-most.txt file to the source tree.
It is needed to have an ABI description of the driver's sysfs
interface.
Signed-off-by: Christian Gromm
---
.../most/Documentation/ABI/sysfs-bus-most.txt | 313 +
1 file changed, 313 insertions(+)
create m
This patch fixes the type used to manage the channels of an
registered MOST interface.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/most/core.h b/drivers/staging/most/core.h
index d6e9b87..7c447
This patch renames the show/store functions of the USB module.
It is needed to make the module meet the established naming
convention.
Signed-off-by: Christian Gromm
---
drivers/staging/most/usb/usb.c | 34 +-
1 file changed, 17 insertions(+), 17 deletions(-)
dif
This patch creates the structure comp to put the module variables for
encapsulation purposes. For an improved readability some variables are
renamed.
Signed-off-by: Christian Gromm
---
drivers/staging/most/cdev/cdev.c | 88
1 file changed, 43 insertions(+
This patch adds a check for the pointer returned by the function
match_component. It is needed to prevent a NULL pointer dereference in
case the provided component name does not match any list entry.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 4
1 file changed, 4 inser
From: Andrey Shvetsov
This patch fixes the offset and data handling when traversing
the list of devices that are attached to the bus.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 17 +
1 file changed, 13 insertions(+), 4 deletions(-)
diff --git a/drivers/st
This patch stops the core from generating a module owned class and
registering it with the kernel. It is needed, because there is no need for
a default MOST class to be present in the kernel.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 13 +
1 file changed, 1 ins
For the MOST packet channel there are two dedicated USB endpoints. But
internally the hardware has actually one channel for data forwarding from
and to MOST. To have the hardware clean up its state machine correctly in
case of an error, both USB pipes need to be reset. This patch triggers the
host
The designator of a module that proivdes means to interface userspace is
called an AIM. Since this name seems to be unappropiate, this kind of
moduels are going to be referred to as componetns. This is done because
such modules function as components to enhance the core with new features.
This patc
This patch renames the variable mod_list to comp_list. It is needed
because modules that interface userspace are referred to as components.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/stagi
This patch replaces the 'aim' substrings of variable names with 'comp'.
It is needed because of the renaming of AIM modules to components.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 172 ++--
1 file changed, 87 insertions(+), 85 delet
The core module used to have two functions to find a certain
channel. One by name and one by interface. Since no channel is
searched by its interface name anymore the by_name suffix is
rendered redundant. This patch renames the function accordingly.
Signed-off-by: Christian Gromm
---
drivers/sta
This patch replaces the function prefixes aim_* with comp_*. It is needed
to complete the process of changing the module designator from AIM to
Component.
Signed-off-by: Christian Gromm
---
drivers/staging/most/cdev/cdev.c | 58
1 file changed, 29 inserti
This patch removes all 'aim' designators and replaces them with 'comp'. It
is needd because userspace interfacing modules are referred to as
components.
Signed-off-by: Christian Gromm
---
drivers/staging/most/sound/sound.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
Substrings containing 'module' are replaced with 'component' by this patch.
It is needed to complete the process of changing the module designator from
AIM to Component.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 24
1 file changed, 12 insertions(+)
This patch renames the instance aim_class of struct class to comp_class.
It is needed to complete the process of changing the module designator from
AIM to Component.
Signed-off-by: Christian Gromm
---
drivers/staging/most/cdev/cdev.c | 16
1 file changed, 8 insertions(+), 8 de
This patch renames the variable cdev_aim to cdev_comp. It is needed to
complete the process of changing the module designator from AIM to
Component.
Signed-off-by: Christian Gromm
---
drivers/staging/most/cdev/cdev.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff
This patch renames the variable aim_devno to comp_devno. It is needed
to complete the process of changing the module designator from AIM to
Component.
Signed-off-by: Christian Gromm
---
drivers/staging/most/cdev/cdev.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git
This patch renames the structure aim_channel to comp_channel. It is needed
to complete the process of changing the module designator from AIM to
Component.
Signed-off-by: Christian Gromm
---
drivers/staging/most/cdev/cdev.c | 38 +++---
1 file changed, 19 insertio
The core needs to know what modules are registered. This patch makes the
core keep track of the registered modules.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 6 --
drivers/staging/most/core.h | 1 +
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/drivers
This patch creates a new attribute group to manage the attributes
of a registered aim module in sysfs and changes the show and store
functions accordingly.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 109 +---
1 file changed, 73 insert
This patch stores a channel's name inside the most_channel structure. It
is needed to have the channel attributes tied together.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 13 ++---
1 file changed, 6 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/most/c
This patch renames the functions to register and deregister a component
module with the core. It is needed because the modules that interface the
userspace are referred to as components.
Signed-off-by: Christian Gromm
---
drivers/staging/most/cdev/cdev.c | 4 ++--
drivers/staging/most/core.c
This patch renames the all aim designators with comp. It is needed because
userspace interfacing modules are referred to as components.
Signed-off-by: Christian Gromm
---
drivers/staging/most/net/net.c | 44 +-
1 file changed, 22 insertions(+), 22 deletion
This patch introduces the structure "mostcore" to bundle core specific
data structures.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 73 +
1 file changed, 34 insertions(+), 39 deletions(-)
diff --git a/drivers/staging/most/core.c b
This patch renames the function link_channel_to_aim to
link_channel_to_component. It is needed because userspace
interfacing modules are referred to as components.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff -
This patch introduces struct interface_private as a replacement for
the struct most_inst_obj. This structure holds private data that is
only needed by the core module and will be accessed by a pointer from
within the most_interface structure. As a result of this replacement
the bus helper functions
This patch removes the initialization of the priv pointer of the
most_interface structure.
Signed-off-by: Christian Gromm
---
drivers/staging/most/usb/usb.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/most/usb/usb.c b/drivers/staging/most/usb/usb.c
index da2fc54..acd0a36
This patch removes the unused context pointer that was meant to provide the
opportunity to store context information.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/most/core.h b/drivers/staging/most/core.h
index
This patch renames the folder of the usb module. It is needed
to clean up the directory layout of the driver.
Signed-off-by: Christian Gromm
---
drivers/staging/most/Kconfig | 2 +-
drivers/staging/most/{hdm-usb => usb}/Kconfig | 7 +++
drivers/staging/most/
This patch renames the struct members "aim0" and "aim0" to "pipe0" and
"pipe1". It is needed to have a conclusive nomenclature of the struct and
its instances.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 104 ++--
1 file changed, 52 i
This patch takes out the struct device of struct most_aim, because it is
not needed.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 17 -
drivers/staging/most/core.h | 1 -
2 files changed, 18 deletions(-)
diff --git a/drivers/staging/most/core.c b/drivers/sta
This patch renames the member "ptr" of struct pipe to "aim". This is needed
to increase the readability of the code.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 78 ++---
1 file changed, 39 insertions(+), 39 deletions(-)
diff --git a/
This patch renames the folder and source files of the dim2 module. It is
needed to clear the directory layout of the driver.
Signed-off-by: Christian Gromm
---
drivers/staging/most/Kconfig | 2 +-
drivers/staging/most/{hdm-dim2 => dim2}/Kconfig|
This patch adds the function most_match. It is needed to accociate
registered devices and drivers with the bus.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 9 +
1 file changed, 9 insertions(+)
diff --git a/drivers/staging/most/core.c b/drivers/staging/most/core.c
in
This patch replaces the confusing name of struct "most_c_aim_obj" with
"pipe" to better express the function that is behind the structure.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/most
This patch renames the structure most_c_obj to most_channel. This is needed
to enhance readability.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 104 ++--
1 file changed, 52 insertions(+), 52 deletions(-)
diff --git a/drivers/staging/m
This patch renames the folder and the source file of the networking module.
It is needed to clean up the directory layout of the driver.
Signed-off-by: Christian Gromm
---
drivers/staging/most/Kconfig | 2 +-
drivers/staging/most/{aim-network => net}/Kconfig
This patch removes the function get_channel_by_iface that walks a list of
all registered interfaces and returns a pointer to a channel when matched.
Instead the private field of the interface structure is used to directly
access the channel via the id. The patch is needed to remove unnecessary
list
This patch renames the folder of the video module. It is needed
to clean up the directory layout of the driver.
Signed-off-by: Christian Gromm
---
drivers/staging/most/Kconfig | 2 +-
drivers/staging/most/{aim-v4l2 => video}/Kconfig | 6 +++---
drivers/staging/most/video/Make
This patch adds the function link_channel_to_aim to increase readability
of the function add_link_store.
Signed-off-by: Christian Gromm
---
drivers/staging/most/core.c | 39 ++-
1 file changed, 26 insertions(+), 13 deletions(-)
diff --git a/drivers/staging/mo
This patch moves the core files to the root dir of the driver.
This is needed to clean up the directory layout.
Signed-off-by: Christian Gromm
---
drivers/staging/most/Kconfig | 13 -
drivers/staging/most/Makefile| 5 -
drivers/sta
This patch renames the folder of the i2c module. It is needed
to clear the directory layout.
Signed-off-by: Christian Gromm
---
drivers/staging/most/Kconfig | 2 +-
drivers/staging/most/{hdm-i2c => i2c}/Kconfig | 6 +++---
drivers/staging/most/i2c/Makefile
This patch removes the proprietary kobjects used by the driver modules and
replaces them with device structs. The patch is needed to have the driver
being integrated into the kernel's device model.
Signed-off-by: Christian Gromm
---
drivers/staging/most/cdev/cdev.c | 6 +-
drivers/staging/mo
This patch renames the folder of the cdev module. This is needed
to clear the directory layout.
Signed-off-by: Christian Gromm
---
drivers/staging/most/Kconfig| 2 +-
drivers/staging/most/{aim-cdev => cdev}/Kconfig | 6 +++---
drivers/staging/most/cdev/Makefile |
This patch renames the folder of the sound module. It is needed
to clean up the directory layout of the driver.
Signed-off-by: Christian Gromm
---
drivers/staging/most/Kconfig | 2 +-
drivers/staging/most/{aim-sound => sound}/Kconfig | 6 +++---
drivers/staging/most/sound/Ma
This patch set fixes bugs and integrates the driver to the kernel's device
model by revising its architecture. Part of this change is rearranging the
directory layout, renaming of files and folders and thereby creating a
clean driver structure.
Andrey Shvetsov (2):
staging: most: update driver
62 matches
Mail list logo