Re: staging: pi433: Possible bug in rf69.c

2017-11-10 Thread Marcus Wolf
Hi Dan, I checked it on my local SVN. You are right. I submitted the code with '&'. Accodring to a check-in message on my SVN, there was a bugreport end of July and most probably a patch - either from me, you, Joseph Wright, Colin King or Julia Lawall, changing '&' to '|'. I guess the patch for so

Re: [PATCH 1/9] include: Move compat_timespec/ timeval to compat_time.h

2017-11-10 Thread Steven Rostedt
On Fri, 10 Nov 2017 14:42:51 -0800 Deepa Dinamani wrote: > diff --git a/arch/x86/include/asm/ftrace.h b/arch/x86/include/asm/ftrace.h > index 09ad88572746..db25aa15b705 100644 > --- a/arch/x86/include/asm/ftrace.h > +++ b/arch/x86/include/asm/ftrace.h > @@ -49,7 +49,7 @@ int ftrace_int3_handler(s

Re: [PATCH] staging: speakup: selection: replace _manual_ swap with swap macro

2017-11-10 Thread Samuel Thibault
Gustavo A. R. Silva, on ven. 10 nov. 2017 16:13:03 -0600, wrote: > Make use of the swap macro instead of _manually_ swapping values > and remove unnecessary variable tmp. > > This makes the code easier to read and maintain. > > This code was detected with the help of Coccinelle. > > Signed-off-b

[PATCH 1/9] include: Move compat_timespec/ timeval to compat_time.h

2017-11-10 Thread Deepa Dinamani
All the current architecture specific defines for these are the same. Refactor these common defines to a common header file. The new common linux/compat_time.h is also useful as it will eventually be used to hold all the defines that are needed for compat time types that support non y2038 safe typ

[PATCH 0/9] posix_clocks: Prepare syscalls for 64 bit time_t conversion

2017-11-10 Thread Deepa Dinamani
The series is a preparation series for individual architectures to use 64 bit time_t syscalls in compat and 32 bit emulation modes. This is a follow up to the series Arnd Bergmann posted: https://sourceware.org/ml/libc-alpha/2015-05/msg00070.html Big picture is as per the lwn article: https://lwn

[PATCH] staging: speakup: selection: replace _manual_ swap with swap macro

2017-11-10 Thread Gustavo A. R. Silva
Make use of the swap macro instead of _manually_ swapping values and remove unnecessary variable tmp. This makes the code easier to read and maintain. This code was detected with the help of Coccinelle. Signed-off-by: Gustavo A. R. Silva --- drivers/staging/speakup/selection.c | 9 ++--- 1

RE: [PATCH v2 2/5] x86: add enum for hypervisors to replace x86_hyper

2017-11-10 Thread KY Srinivasan
> -Original Message- > From: Dmitry Torokhov [mailto:dmitry.torok...@gmail.com] > Sent: Friday, November 10, 2017 10:26 AM > To: Juergen Gross > Cc: linux-ker...@vger.kernel.org; t...@linutronix.de; mi...@redhat.com; > h...@zytor.com; x...@kernel.org; KY Srinivasan ; > Haiyang Zhang ; St

Re: staging: pi433: Possible bug in rf69.c

2017-11-10 Thread Dan Carpenter
On Fri, Nov 10, 2017 at 06:23:32PM +0100, Marcus Wolf wrote: > Hi everybody! > > Just comparing the master of Gregs statging of pi433 with my local SVN > to review all changes, that were done the last monthes. > > I am not sure, but maybe we imported a bug in rf69.c lines 378 and > following: >

Re: [PATCH v2 2/5] x86: add enum for hypervisors to replace x86_hyper

2017-11-10 Thread Dmitry Torokhov
On Thu, Nov 09, 2017 at 02:27:36PM +0100, Juergen Gross wrote: > The x86_hyper pointer is only used for checking whether a virtual > device is supporting the hypervisor the system is running on. > > Use an enum for that purpose instead and drop the x86_hyper pointer. > > Cc: k...@microsoft.com >

Re: [PATCH] PCI: hv: use effective affinity mask

2017-11-10 Thread Bjorn Helgaas
On Fri, Nov 10, 2017 at 08:55:07AM +, Adrian Suhov (Cloudbase Solutions SRL) wrote: > Hi, > > I've also tested this and it's working good. Kernels tested: > - next-20171109 on top of Ubuntu 16.04 > - MSFT kernel - 4.14.0-rc5 with patch applied - on top of RHEL 7.3 > > Adrian Thanks, Adria

staging: pi433: Possible bug in rf69.c

2017-11-10 Thread Marcus Wolf
Hi everybody! Just comparing the master of Gregs statging of pi433 with my local SVN to review all changes, that were done the last monthes. I am not sure, but maybe we imported a bug in rf69.c lines 378 and following: Gregs repo: case automatic: return WRITE_REG(REG_LNA, ( (READ_REG(RE

Re: [PATCH] staging: pi433: fix missing break in switch statement.

2017-11-10 Thread Marcus Wolf
Hi Colin, thanks for clarification. Should I switch to that repo for further work, too? If so, can anybody provide me the link? Do I need Gregs staging any longer, or is it kind of dead for devel on pi433 driver? Thank you so much! Marcus Am 10.11.2017 um 18:04 schrieb Colin Ian King: > On 1

Re: [PATCH] staging: pi433: fix missing break in switch statement.

2017-11-10 Thread Colin Ian King
On 10/11/17 16:49, Marcus Wolf wrote: > Hi all! > > Tryed to cross check... > > Don't get it, sorry. > > On my private version control (my SVN), where I initially developed the > driver the break isn't missing. > Same with my git copy of Gregs staging tree. Break is there... > > Who removed it,

Re: [PATCH] staging: pi433: fix missing break in switch statement.

2017-11-10 Thread Marcus Wolf
Hi all! Tryed to cross check... Don't get it, sorry. On my private version control (my SVN), where I initially developed the driver the break isn't missing. Same with my git copy of Gregs staging tree. Break is there... Who removed it, why is it missing in Colins copy? Am I working on a wro

Re: [RFC] hv_netvsc: safer orderly shutdown

2017-11-10 Thread Vitaly Kuznetsov
Stephen Hemminger writes: > Several types of control operations require that the underlying RNDIS > infrastructure be restarted. This patch changes the ordering of the > shutdown to avoid race conditions. > Stop all transmits before doing RNDIS halt. This involves stopping the > network device tr

RE: [PATCH] PCI: hv: use effective affinity mask

2017-11-10 Thread Adrian Suhov (Cloudbase Solutions SRL)
Hi, I've also tested this and it's working good. Kernels tested: - next-20171109 on top of Ubuntu 16.04 - MSFT kernel - 4.14.0-rc5 with patch applied - on top of RHEL 7.3 Adrian -Original Message- From: Bjorn Helgaas [mailto:helg...@kernel.org] Sent: Wednesday, November 8, 2017 3:08 A