Hi Christian,
It has been a couple of years since most was added to the staging
tree. Except for review the TODO list does not mention things that are
required to destage it. Wondering why most is still in staging tree.
Thanks,
PrasannaKumar
___
devel m
Hi Srishti,
[auto build test WARNING on staging/staging-testing]
[also build test WARNING on v4.14-rc5 next-20171018]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Srishti-Sharma/Staging-rtl818
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-next
head: 4bdd439fe2a7ce14f2b86bf138b24e2fa3615507
commit: 95b3b4238581e72756505d601948f955e8baccf7 [256/294] staging: rtl8723bs:
remove ternary operators in assignmet statments
config: x86_64-randconfig-v0-1020
> On Tue, Oct 17, 2017 at 01:35:21PM -0400, Cathy Avery wrote:
> > + /*
> > +* Set the error handler work queue.
> > +*/
> > + snprintf(host_dev->work_q_name, sizeof(host_dev-
> >work_q_name),
> > +"storvsc_error_wq_%d", host->host_no);
> > + host_dev->handle_error_wq =
>
VDE driver provides accelerated video decoding to NVIDIA Tegra SoC's,
it is a result of reverse-engineering efforts. Driver has been tested on
Toshiba AC100 and Acer A500, it should work on any Tegra20 device.
In userspace this driver is utilized by libvdpau-tegra [0] that implements
VDPAU interfa
From: Vladimir Zapolskiy
All Tegra SoCs contain 256KiB IRAM, which is used to store CPU resume code
and by hardware engines like a video decoder.
Signed-off-by: Vladimir Zapolskiy
---
arch/arm/boot/dts/tegra114.dtsi | 8
arch/arm/boot/dts/tegra124.dtsi | 8
arch/arm/boot/dts/
NVIDIA Tegra20/30/114/124/132 SoC's have video decoder engine that
supports standard set of video formats like H.264 / MPEG-4 / WMV / VC1.
Currently implemented decoding of CAVLC H.264 on Tegra20 only.
Signed-off-by: Dmitry Osipenko
---
drivers/staging/Kconfig|2 +
drivers/stagin
Add Video Decoder Engine device node.
Signed-off-by: Dmitry Osipenko
---
arch/arm/boot/dts/tegra20.dtsi | 27 +++
1 file changed, 27 insertions(+)
diff --git a/arch/arm/boot/dts/tegra20.dtsi b/arch/arm/boot/dts/tegra20.dtsi
index aaf32f96f1e8..6b2d7bf5c707 100644
--- a/a
Compile Tegra VDE driver as a module.
Signed-off-by: Dmitry Osipenko
---
arch/arm/configs/tegra_defconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/configs/tegra_defconfig b/arch/arm/configs/tegra_defconfig
index 6678f2929356..c931bd48f7fd 100644
--- a/arch/arm
Add binding documentation for the Video Decoder Engine which is found
on NVIDIA Tegra20/30/114/124/132 SoC's.
Signed-off-by: Dmitry Osipenko
---
.../devicetree/bindings/media/nvidia,tegra-vde.txt | 55 ++
1 file changed, 55 insertions(+)
create mode 100644 Documentation/devi
On Tue, Oct 17, 2017 at 4:26 PM, Dmitry Osipenko wrote:
> On 18.10.2017 00:13, Rob Herring wrote:
>> On Tue, Oct 17, 2017 at 3:24 PM, Thierry Reding
>> wrote:
>>> On Tue, Oct 17, 2017 at 03:13:54PM -0500, Rob Herring wrote:
>>> [...]
> diff --git
> a/Documentation/devicetree/bindings/arm
Here are some cleanup patches to work towards eventually moving this
driver out of staging. The most interesting changes are converting
in_intensity0_thresh_period and in_proximity0_thresh_period to be
created by the IIO core instead of directly by the driver. The rest of
the changes are trivial co
The LED power defines are named like TSL2X7X_mAXXX. Rename these values
to TSL2X7X_XXX_mA to improve code readability.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/iio/light/tsl2
Correct error from checkpatch.pl to improve code readibility: Alignment
should match open parenthesis. An unnecessary cast to 'struct
tsl2x7x_lux *' was removed and the return value of static definition of
in_illuminance0_calibscale_available_show() was put on its own line
due to the length of that
Sort the #include statements for increased code readability.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/iio/light/tsl2x7x.c
b/drivers/staging/iio/light/tsl2x7x.c
index 094ab76
Some of the existing #defines have tabs between the name, and the value,
while others have spaces. The alignment of the values mostly has a
consistent layout, but there are some that don't. Change all of the
defines so that the name and value is separated by tabs and all of the
values start on the
tsl2x7x.h has a blank definition for 'struct iio_dev' that is not
needed. This patch removes that definition.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/iio/light/tsl2x7x.h
b/drivers/staging/iio/light/
Correct the alignment of the break statements to match the alignment of
the rest of the code within the case statements.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/iio/light/tsl2x7x.c
Correct error from checkpatch.pl to improve code readibility: Alignment
should match open parenthesis. This involved shortening the name of
tsl2x7x_als_gainadj and tsl2x7x_prx_gainadj to tsl2x7x_als_gain and
tsl2x7x_prx_gain respectively. This also required removing the
ch0lux and ch1lux local vari
This patch fixes the error 'Unnecessary parentheses around 'XXX' from
checkpatch.pl. It also fixes several other places with unnecessary
parentheses that checkpatch.pl did not detect.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 16
1 file changed, 8 ins
The sysfs attributes in_intensity0_thresh_period and
in_proximity0_thresh_period are currently directly created by the driver.
This patch migrates the creation of these sysfs attributes from the driver
to using the IIO core via iio_event_spec.
Signed-off-by: Brian Masney
---
Changes since v1:
- U
The sysfs attribute in_proximity0_calibscale_available is currently
created by using DEVICE_ATTR_RO(). Convert this over to use
IIO_CONST_ATTR().
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 15 ---
1 file changed, 4 insertions(+), 11 deletions(-)
diff --git
This patch adds a return_max label for the two cases that need to set
the lux to TSL2X7X_LUX_CALC_OVER_FLOW and return.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 9 -
1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/iio/light/tsl2x
The functions tsl2x7x_invoke_change() and tsl2x7x_prox_calculate() are
short enough that the return value and static declaration can be moved
onto the same line with the function name. This patch makes that change
to increase code readability.
Signed-off-by: Brian Masney
---
drivers/staging/iio/
The structure tsl2x7x_parse_result is not used so this patch removes its
definition.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/iio/light/tsl2x7x.c
b/drivers/staging/iio/light/tsl2x7x.c
index 2dd8c5
On Tue, Oct 17, 2017 at 01:35:21PM -0400, Cathy Avery wrote:
> + /*
> + * Set the error handler work queue.
> + */
> + snprintf(host_dev->work_q_name, sizeof(host_dev->work_q_name),
> + "storvsc_error_wq_%d", host->host_no);
> + host_dev->handle_error_wq =
> +
Hi Frank,
[auto build test WARNING on staging/staging-testing]
[also build test WARNING on v4.14-rc5 next-20171018]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Frank-A-Cancio-Bello/staging-wl
On Thu, Oct 19, 2017 at 01:01:14AM +0530, Srishti Sharma wrote:
> This is a cleanup patch and doesn't change runtime behaviour. It
> changes an open coded list traversal to use list_for_each_entry_safe.
> Done using the following semantic patch by coccinelle.
>
> @r@
> struct list_head* l;
> expre
On Thu, Oct 19, 2017 at 01:01:39AM +0530, Srishti Sharma wrote:
> This is a cleanup patch and doesn't change runtime behaviour. It
> changes an open coded list traversal to use list_for_each_entry_safe.
> Done using the following semantic patch by coccinelle.
>
> @r@
> struct list_head* l;
> expre
On Wed, 18 Oct 2017 16:36:23 +0200
Miquel Raynal wrote:
> +
> +enum marvell_nfc_variant {
> + MARVELL_NFC_VARIANT_PXA3XX,
> + MARVELL_NFC_VARIANT_ARMADA370,
> + MARVELL_NFC_VARIANT_ARMADA_8K,
> +};
> +
> +/*
> + * NAND controller capabilities for distinction between compatible string
30 matches
Mail list logo