Re: [PATCH 00/18] use ARRAY_SIZE macro

2017-10-01 Thread Greg KH
On Sun, Oct 01, 2017 at 08:52:20PM -0400, Jérémy Lefaure wrote: > On Mon, 2 Oct 2017 09:01:31 +1100 > "Tobin C. Harding" wrote: > > > > In order to reduce the size of the To: and Cc: lines, each patch of the > > > series is sent only to the maintainers and lists concerned by the patch. > > > This

Re: [PATCH 00/18] use ARRAY_SIZE macro

2017-10-01 Thread Jérémy Lefaure
On Mon, 2 Oct 2017 09:01:31 +1100 "Tobin C. Harding" wrote: > > In order to reduce the size of the To: and Cc: lines, each patch of the > > series is sent only to the maintainers and lists concerned by the patch. > > This cover letter is sent to every list concerned by this series. > > Why don

Re: [PATCH v2 01/16] hyper-v: trace vmbus_on_msg_dpc()

2017-10-01 Thread kbuild test robot
Hi Vitaly, [auto build test WARNING on linus/master] [also build test WARNING on v4.14-rc3 next-20170929] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/commits/Vitaly-Kuznetsov/hyper-v-trace-vmbus_on_m

Re: [PATCH RFC] media: staging/imx: fix complete handler

2017-10-01 Thread Russell King - ARM Linux
On Sun, Oct 01, 2017 at 01:16:53PM -0700, Steve Longerbeam wrote: > Right, imx_media_add_vdev_to_pa() has followed a link to an > entity that imx is not aware of. > > The only effect of this patch (besides allowing the driver to load > with smiapp cameras), is that no controls from the unknown ent

[PATCH v2] staging: android: TODO: Removing an invalid issue

2017-10-01 Thread Joaquin Garmendia Cabrera
The first line of TODO is invalid because no file has an error or warning when running checkpatch.pl Signed-off-by: Joaquin Garmendia Cabrera --- Changes in v2: - Fixing a Typo. drivers/staging/android/TODO | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/android/TODO b/driv

Re: [PATCH 00/18] use ARRAY_SIZE macro

2017-10-01 Thread Tobin C. Harding
On Sun, Oct 01, 2017 at 03:30:38PM -0400, Jérémy Lefaure wrote: > Hi everyone, > Using ARRAY_SIZE improves the code readability. I used coccinelle (I > made a change to the array_size.cocci file [1]) to find several places > where ARRAY_SIZE could be used instead of other macros or sizeof > divisio

Re: [PATCH RFC] media: staging/imx: fix complete handler

2017-10-01 Thread Steve Longerbeam
Hi Russell, On 09/29/2017 02:38 PM, Russell King wrote: The complete handler walks all entities, expecting to find an imx subdevice for each and every entity. However, camera drivers such as smiapp can themselves contain multiple entities, for which there will not be an imx subdevice. This ca

[PATCH 17/18] staging: rtl8723bs: use ARRAY_SIZE

2017-10-01 Thread Jérémy Lefaure
Using the ARRAY_SIZE macro improves the readability of the code. Also, it is not always useful to use a variable to store this constant calculated at compile time. Found with Coccinelle with the following semantic patch: @r depends on (org || report)@ type T; T[] E; position p; @@ ( (sizeof(E)@p

[PATCH 18/18] staging: rtlwifi: use ARRAY_SIZE

2017-10-01 Thread Jérémy Lefaure
Using the ARRAY_SIZE macro improves the readability of the code. Also, it is useless to use a variable to store this constant calculated at compile time. Found with Coccinelle with the following semantic patch: @r depends on (org || report)@ type T; T[] E; position p; @@ ( (sizeof(E)@p /sizeof(*E

[PATCH 16/18] media: staging: atomisp: use ARRAY_SIZE

2017-10-01 Thread Jérémy Lefaure
Using the ARRAY_SIZE macro improves the readability of the code. Also, it is useless to use a variable to store this constant calculated at compile time. Found with Coccinelle with the following semantic patch: @r depends on (org || report)@ type T; T[] E; position p; @@ ( (sizeof(E)@p /sizeof(*E

[PATCH 00/18] use ARRAY_SIZE macro

2017-10-01 Thread Jérémy Lefaure
Hi everyone, Using ARRAY_SIZE improves the code readability. I used coccinelle (I made a change to the array_size.cocci file [1]) to find several places where ARRAY_SIZE could be used instead of other macros or sizeof division. I tried to divide the changes into a patch per subsystem (excepted for

[PATCH] staging: android: TODO: Removing an invalid issue

2017-10-01 Thread Joaquin Garmendia Cabrera
The first line of TODO is invalid because no file has an error or warning when running checkpatch.pl Signed-off-by: Joaquin Garmendia Cabrera --- drivers/staging/android/TODO | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/android/TODO b/drivers/staging/andr

Re: [PATCH] vme: Fix integer overflow checking in vme_check_window()

2017-10-01 Thread Dmitry Kalinkin
> On 30 Sep 2017, at 07:27, Dan Carpenter wrote: > > The controversial part of this patch is that I've changed it so we now > prevent integer overflows for VME_USER types and before we didn't. I > view it as kernel-hardening. I looked at a couple places that used > VME_USER types and they seem

Re: [PATCH 3/3] staging: iio: tsl2x7x: migrate *_thresh_period sysfs attributes to iio_event_spec

2017-10-01 Thread Brian Masney
On Sun, Oct 01, 2017 at 11:14:46AM +0100, Jonathan Cameron wrote: > On Fri, 29 Sep 2017 21:09:21 -0400 > Brian Masney wrote: > > > The sysfs attributes in_intensity0_thresh_period and > > in_proximity0_thresh_period are currently directly created by the driver. > > This patch migrates the creatio

Re: [PATCH v2] staging: atomisp: add a driver for ov5648 camera sensor

2017-10-01 Thread Andy Shevchenko
On Sun, Sep 24, 2017 at 5:59 PM, Devid Antonio Floni wrote: > The ov5648 5-megapixel camera sensor from OmniVision supports up to 2592x1944 > resolution and MIPI CSI-2 interface. Output format is raw sRGB/Bayer with > 10 bits per colour (SGRBG10_1X10). > > This patch is a port of ov5648 driver aft

Re: [PATCH 1/3] staging: iio: tsl2x7x: rename tsl2x7x_settings variable to settings

2017-10-01 Thread Jonathan Cameron
On Fri, 29 Sep 2017 21:09:19 -0400 Brian Masney wrote: > The length of the 'tsl2x7x_settings' variable within the tsl2X7X_chip > structure makes some of the line lengths greater than 80 characters for > upcoming patches. This patch shortens the name of the 'tsl2x7x_settings' > variable in this st

Re: [PATCH 3/3] staging: iio: tsl2x7x: migrate *_thresh_period sysfs attributes to iio_event_spec

2017-10-01 Thread Jonathan Cameron
On Fri, 29 Sep 2017 21:09:21 -0400 Brian Masney wrote: > The sysfs attributes in_intensity0_thresh_period and > in_proximity0_thresh_period are currently directly created by the driver. > This patch migrates the creation of these sysfs attributes from the driver > to using the IIO core via iio_ev

Re: [PATCH 2/3] staging: iio: tsl2x7x: migrate in_illuminance0_integration_time sysfs attribute to iio_chan_spec

2017-10-01 Thread Jonathan Cameron
On Fri, 29 Sep 2017 21:09:20 -0400 Brian Masney wrote: > The driver explicitly creates the in_illuminance0_integration_time sysfs > attribute outside the IIO core. This attribute is available in the IIO > core so this patches migrates the attribute to be created by > the iio_chan_spec. > > Signe

Re: [PATCH v3] Staging: rtl8723bs: Remove unnecessary comments.

2017-10-01 Thread Shreeya Patel
On Sun, 2017-10-01 at 09:42 +1100, Tobin C. Harding wrote: > On Sat, Sep 30, 2017 at 07:41:11PM +0530, Shreeya Patel wrote: > > > > Remove unnecessary comments which are there > > to explain why call to memset is in comments. Both of the > > comments are not needed as they are not very useful. > >

[PATCH v4] Staging: rtl8723bs: Remove unnecessary comments

2017-10-01 Thread Shreeya Patel
Remove unnecessary comments which are there to explain why call to memset is in comments. Both of the comments are not needed as they are not very useful. Signed-off-by: Shreeya Patel --- Changes in v2: -Remove some more unnecessary comments and make the commit message more appropriate. C