On Sat, Sep 30, 2017 at 11:51 AM, Julia Lawall wrote:
>
>
> On Sat, 30 Sep 2017, Srishti Sharma wrote:
>
>> On Sat, Sep 30, 2017 at 11:36 AM, Julia Lawall wrote:
>> >
>> >
>> > On Sat, 30 Sep 2017, Srishti Sharma wrote:
>> >
>> >> On Sat, Sep 30, 2017 at 10:35 AM, Julia Lawall
>> >> wrote:
>> >
On Sat, 30 Sep 2017, Srishti Sharma wrote:
> On Sat, Sep 30, 2017 at 11:36 AM, Julia Lawall wrote:
> >
> >
> > On Sat, 30 Sep 2017, Srishti Sharma wrote:
> >
> >> On Sat, Sep 30, 2017 at 10:35 AM, Julia Lawall
> >> wrote:
> >> >
> >> >
> >> > On Sat, 30 Sep 2017, Srishti Sharma wrote:
> >> >
On Sat, Sep 30, 2017 at 11:36 AM, Julia Lawall wrote:
>
>
> On Sat, 30 Sep 2017, Srishti Sharma wrote:
>
>> On Sat, Sep 30, 2017 at 10:35 AM, Julia Lawall wrote:
>> >
>> >
>> > On Sat, 30 Sep 2017, Srishti Sharma wrote:
>> >
>> >> For variables of the type struct list_head* use list_entry to acce
On Sat, 30 Sep 2017, Srishti Sharma wrote:
> On Sat, Sep 30, 2017 at 10:35 AM, Julia Lawall wrote:
> >
> >
> > On Sat, 30 Sep 2017, Srishti Sharma wrote:
> >
> >> For variables of the type struct list_head* use list_entry to access
> >> the current list element instead of using container_of.
>
On Sat, Sep 30, 2017 at 10:35 AM, Julia Lawall wrote:
>
>
> On Sat, 30 Sep 2017, Srishti Sharma wrote:
>
>> For variables of the type struct list_head* use list_entry to access
>> the current list element instead of using container_of.
>> Done using the following semantic patch by coccinelle.
>>
>
On Sat, 30 Sep 2017, Shreeya Patel wrote:
> On Fri, 2017-09-29 at 23:10 +0200, Julia Lawall wrote:
> >
> > On Sat, 30 Sep 2017, Shreeya Patel wrote:
> >
> > >
> > > The comments regarding memset are not needed in the
> > > files which have been modified since the necessary changes
> > > are alre
On Sat, 30 Sep 2017, Srishti Sharma wrote:
> For variables of the type struct list_head* use list_entry to access
> the current list element instead of using container_of.
> Done using the following semantic patch by coccinelle.
>
> @r@
> identifier e;
> struct list_head* l;
> @@
>
> <... when !
From: "K. Y. Srinivasan"
This patch addresses the following bugs in the current rescind handling code:
1. Fixes a race condition where we may be invoking hv_process_channel_removal()
on an already freed channel.
2. Prevents indefinite wait when rescinding sub-channels by correctly setting
the p
For variables of the type struct list_head* use list_entry to access
the current list element instead of using container_of.
Done using the following semantic patch by coccinelle.
@r@
identifier e;
struct list_head* l;
@@
<... when != l == NULL
l;
...>
(
e =
-container_of
+list_entry
(
The sysfs attributes in_intensity0_thresh_period and
in_proximity0_thresh_period are currently directly created by the driver.
This patch migrates the creation of these sysfs attributes from the driver
to using the IIO core via iio_event_spec.
Signed-off-by: Brian Masney
---
drivers/staging/iio/
This patch set converts several sysfs attributes from directly being
created by the driver to be created by iio_chan_spec and iio_event_spec.
There is also a patch to shorten the length of a variable to fix an
issue that I encountered with some lines that were over 80 characters
with this refactori
The driver explicitly creates the in_illuminance0_integration_time sysfs
attribute outside the IIO core. This attribute is available in the IIO
core so this patches migrates the attribute to be created by
the iio_chan_spec.
Signed-off-by: Brian Masney
---
Changes since v1 (Jul 9 2017):
- Use MIN_
The length of the 'tsl2x7x_settings' variable within the tsl2X7X_chip
structure makes some of the line lengths greater than 80 characters for
upcoming patches. This patch shortens the name of the 'tsl2x7x_settings'
variable in this structure to just 'settings' to improve code
readability.
Signed-o
For variables that have type struct list_head* use list_entry to
access current list element instead of using container_of.
Done using the following semantic patch by coccinelle.
@r@
identifier e;
struct list_head* l;
@@
<... when != l == NULL
l;
...>
(
e=
-container_of
+list_entry
(
..
User-space normally keeps the node alive when creating a transaction
since it has a reference to the target. The local strong ref keeps it
alive if the sending process dies before the target process processes
the transaction. If the source process is malicious or has a reference
counting bug, this
Hi Mauro,
(Removing the non-list recipients.)
On Fri, Sep 29, 2017 at 06:27:13AM -0300, Mauro Carvalho Chehab wrote:
> Em Thu, 28 Sep 2017 15:09:21 +0300
> Sakari Ailus escreveu:
>
> > Hi Mauro,
> >
> > On Wed, Sep 27, 2017 at 06:46:56PM -0300, Mauro Carvalho Chehab wrote:
> > > The V4L2_ASYNC
Setting a burst size of "8" doesn't work for IMX219 with 8-bit bayer,
but a burst size of "16" does. Fix this.
Signed-off-by: Russell King
---
drivers/staging/media/imx/imx-media-csi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/media/imx/imx-media-csi.c
The complete handler walks all entities, expecting to find an imx
subdevice for each and every entity.
However, camera drivers such as smiapp can themselves contain multiple
entities, for which there will not be an imx subdevice. This causes
imx_media_find_subdev_by_sd() to fail, making the imx c
On Fri, 2017-09-29 at 23:10 +0200, Julia Lawall wrote:
>
> On Sat, 30 Sep 2017, Shreeya Patel wrote:
>
> >
> > The comments regarding memset are not needed in the
> > files which have been modified since the necessary changes
> > are already there in the files.
> The comments don't look very use
On Sat, 30 Sep 2017, Shreeya Patel wrote:
> The comments regarding memset are not needed in the
> files which have been modified since the necessary changes
> are already there in the files.
The comments don't look very useful, but I don't understand "since the
necessary changes are alread ther
The comments regarding memset are not needed in the
files which have been modified since the necessary changes
are already there in the files.
Signed-off-by: Shreeya Patel
---
drivers/staging/rtl8723bs/core/rtw_mlme.c | 3 ---
drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 3 ---
drivers/st
On September 29, 2017 6:59:18 AM PDT, Razvan Stefanescu
wrote:
>
>
>> -Original Message-
>> From: Bogdan Purcareata
>> Sent: Friday, September 29, 2017 16:36
>> To: Razvan Stefanescu ;
>> gre...@linuxfoundation.org
>> Cc: de...@driverdev.osuosl.org; linux-ker...@vger.kernel.org;
>> net...
On 09/29/2017 02:51 AM, Dan Carpenter wrote:
I'm not totally certain that it's necessary to put an upper limit here.
I think it happens at lower levels. But if we are going to do that then
we should have a lower bound as well.
Signed-off-by: Dan Carpenter
diff --git a/drivers/staging/rtlwifi/
> -Original Message-
> From: Bogdan Purcareata
> Sent: Friday, September 29, 2017 16:36
> To: Razvan Stefanescu ;
> gre...@linuxfoundation.org
> Cc: de...@driverdev.osuosl.org; linux-ker...@vger.kernel.org;
> net...@vger.kernel.org; ag...@suse.de; a...@arndb.de; Alexandru Marginean
> ; Ru
> Introduce the DPAA2 Ethernet Switch driver, which manages Datapath Switch
> (DPSW) objects discovered on the MC bus.
>
> Suggested-by: Alexandru Marginean
> Signed-off-by: Razvan Stefanescu
> ---
> drivers/staging/fsl-dpaa2/ethsw/Makefile |2 +-
> drivers/staging/fsl-dpaa2/ethsw/ethsw.c
Add tracepoint to CHANNELMSG_TL_CONNECT_REQUEST sender.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel.c | 7 ++-
drivers/hv/hv_trace.h | 20
2 files changed, 26 insertions(+), 1 deletion(-)
diff --git a/drivers/hv/channel.c b/drivers/hv/channel.c
index 9cb818
Add tracepoint to CHANNELMSG_INITIATE_CONTACT sender.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/connection.c | 3 +++
drivers/hv/hv_trace.h | 26 ++
2 files changed, 29 insertions(+)
diff --git a/drivers/hv/connection.c b/drivers/hv/connection.c
index f41901f80b6
Add tracepoint to CHANNELMSG_OPENCHANNEL_RESULT handler.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 2 ++
drivers/hv/hv_trace.h | 17 +
2 files changed, 19 insertions(+)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/channel_mgmt.c
index 563653a02a
Add tracepoint to CHANNELMSG_CLOSECHANNEL sender.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel.c | 2 ++
drivers/hv/hv_trace.h | 15 +++
2 files changed, 17 insertions(+)
diff --git a/drivers/hv/channel.c b/drivers/hv/channel.c
index 82cb57e2d6bd..f919d9dd984b 100644
---
Add tracepoint to CHANNELMSG_GPADL_HEADER/CHANNELMSG_GPADL_BODY sender.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel.c | 6 ++
drivers/hv/hv_trace.h | 42 ++
2 files changed, 48 insertions(+)
diff --git a/drivers/hv/channel.c b/drivers/hv/
Add tracing subsystem to Hyper-V VMBus module and add tracepoint
to vmbus_on_msg_dpc() which is called when we receive a message from host.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/Makefile | 4 +++-
drivers/hv/hv_trace.c | 4
drivers/hv/hv_trace.h | 29 +++
Add tracepoint to CHANNELMSG_GPADL_CREATED handler.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 2 ++
drivers/hv/hv_trace.h | 17 +
2 files changed, 19 insertions(+)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/channel_mgmt.c
index 2abe0563876b..a
Add tracepoint to CHANNELMSG_RESCIND_CHANNELOFFER handler.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 2 ++
drivers/hv/hv_trace.h | 8
2 files changed, 10 insertions(+)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/channel_mgmt.c
index 290ea25ce409..56365
Add tracepoint to CHANNELMSG_VERSION_RESPONSE handler.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 3 +++
drivers/hv/hv_trace.h | 11 +++
2 files changed, 14 insertions(+)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/channel_mgmt.c
index 1ff2cc064850..a9a
Add tracepoint to CHANNELMSG_OPENCHANNEL sender.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel.c | 2 ++
drivers/hv/hv_trace.h | 27 +++
2 files changed, 29 insertions(+)
diff --git a/drivers/hv/channel.c b/drivers/hv/channel.c
index efd5db743319..82cb57e2d6bd
Add tracepoint to CHANNELMSG_GPADL_TEARDOWN sender.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel.c | 2 ++
drivers/hv/hv_trace.h | 18 ++
2 files changed, 20 insertions(+)
diff --git a/drivers/hv/channel.c b/drivers/hv/channel.c
index cf6bc0667cde..9cb81838e7bb 10064
Add tracepoint to CHANNELMSG_REQUESTOFFERS sender.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 4 +++-
drivers/hv/hv_trace.h | 8
2 files changed, 11 insertions(+), 1 deletion(-)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/channel_mgmt.c
index a9a1fc1424
Add tracepoint to CHANNELMSG_RELID_RELEASED sender.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 7 +--
drivers/hv/hv_trace.h | 16
2 files changed, 21 insertions(+), 2 deletions(-)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/channel_mgmt.c
i
Add tracepoint to vmbus_on_message() which is called when we start
processing a blocking from work context.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 2 ++
drivers/hv/hv_trace.h | 5 +
2 files changed, 7 insertions(+)
diff --git a/drivers/hv/channel_mgmt.c b/driver
Add tracepoint to CHANNELMSG_OFFERCHANNEL handler.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 2 ++
drivers/hv/hv_trace.h | 37 +
2 files changed, 39 insertions(+)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/channel_mgmt.c
in
Add tracepoint to CHANNELMSG_GPADL_TORNDOWN handler.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 2 ++
drivers/hv/hv_trace.h | 8
2 files changed, 10 insertions(+)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/channel_mgmt.c
index af2448e245ca..1ff2cc06485
Changes since v1:
- Use DECLARE_EVENT_CLASS/DEFINE_EVENT_PRINT for vmbus_on_msg_dpc/
vmbus_onmessage tracing (Steven Rostedt)
Messages between guest and host are used in Hyper-V as control flow. To
simplify debugging various issues which are often hard to reproduce add
tracepoints to all message
Someone already sent this. Work against linux-next or staging-next.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Em Thu, 28 Sep 2017 15:09:21 +0300
Sakari Ailus escreveu:
> Hi Mauro,
>
> On Wed, Sep 27, 2017 at 06:46:56PM -0300, Mauro Carvalho Chehab wrote:
> > The V4L2_ASYNC_MATCH_FWNODE match criteria requires just one
> > struct to be filled (struct fwnode_handle). The V4L2_ASYNC_MATCH_DEVNAME
> > match
I'm not totally certain that it's necessary to put an upper limit here.
I think it happens at lower levels. But if we are going to do that then
we should have a lower bound as well.
Signed-off-by: Dan Carpenter
diff --git a/drivers/staging/rtlwifi/core.c b/drivers/staging/rtlwifi/core.c
index 4
45 matches
Mail list logo