On Sat, 9 Sep 2017, Srishti Sharma wrote:
> On Sat, Sep 9, 2017 at 2:28 AM, Julia Lawall wrote:
> >
> >
> > On Sat, 9 Sep 2017, Srishti Sharma wrote:
> >
> >> Merge the assignment and return statements to return the value
> >> directly. Done using coccinelle.
> >>
> >> @@
> >> local idexpressio
On Sat, 9 Sep 2017, Srishti Sharma wrote:
> Merge the assignment and return statements to return the value
> directly. Done using coccinelle.
>
> @@
> local idexpression ret;
> expression e;
> @@
>
> -ret =
> +return
> e;
> -return ret;
>
> Signed-off-by: Srishti Sharma
> ---
> Changes in
From: "K. Y. Srinivasan"
Allocate the hypervisor callback IDT entry early in the boot sequence.
Signed-off-by: K. Y. Srinivasan
---
arch/x86/kernel/cpu/mshyperv.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/x86/kernel/cpu/mshyperv.c b/arch/x86/kernel/cpu/mshype
Drop the global lru lock in isolate callback
before calling zap_page_range which calls
cond_resched, and re-acquire the global lru
lock before returning. Also change return
code to LRU_REMOVED_RETRY.
Use mmput_async when fail to acquire mmap sem
in an atomic context.
Fix "BUG: sleeping function c
Allocate the hypervisor callback IDT entry early in the boot sequence.
Signed-off-by: K. Y. Srinivasan
---
arch/x86/kernel/cpu/mshyperv.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/x86/kernel/cpu/mshyperv.c b/arch/x86/kernel/cpu/mshyperv.c
index 3b3f713e15e5..23
On Fri, Sep 08, 2017 at 10:27:27AM -0700, Badhri Jagan Sridharan wrote:
> >> +
> >> + for (i = 1; i < nr_pdo; i++) {
> >> + if (pdo_type(pdo[i]) < pdo_type(pdo[i - 1])) {
> >> + tcpm_log_force(port,
> >> +" err:PDOs should be i
Merge the assignment and return statements to return the value
directly. Done using coccinelle.
@@
local idexpression ret;
expression e;
@@
-ret =
+return
e;
-return ret;
Signed-off-by: Srishti Sharma
---
Changes in v3:
-Edit commit message so that it respects 80 character limit.
-Remove
On Sat, Sep 9, 2017 at 2:28 AM, Julia Lawall wrote:
>
>
> On Sat, 9 Sep 2017, Srishti Sharma wrote:
>
>> Merge the assignment and return statements to return the value
>> directly. Done using coccinelle.
>>
>> @@
>> local idexpression ret;
>> expression e;
>> @@
>>
>> -ret =
>> +return
>> e;
On Sat, 9 Sep 2017, Srishti Sharma wrote:
> Merge the assignment and return statements to return the value
> directly. Done using coccinelle.
>
> @@
> local idexpression ret;
> expression e;
> @@
>
> -ret =
> +return
> e;
> -return ret;
>
> Signed-off-by: Srishti Sharma
> ---
> Changes in
Merge the assignment and return statements to return the value
directly. Done using coccinelle.
@@
local idexpression ret;
expression e;
@@
-ret =
+return
e;
-return ret;
Signed-off-by: Srishti Sharma
---
Changes in v2:
- Edit commit message so that it respects the 80 character limit.
d
On Sat, 9 Sep 2017, Srishti Sharma wrote:
> On Sat, Sep 9, 2017 at 1:42 AM, Julia Lawall wrote:
> >
> >
> > On Sat, 9 Sep 2017, Srishti Sharma wrote:
> >
> >> Return the return value of a function directly, instead of first saving it
> >> in a variable and then returning it. This change was ma
On Sat, Sep 9, 2017 at 1:42 AM, Julia Lawall wrote:
>
>
> On Sat, 9 Sep 2017, Srishti Sharma wrote:
>
>> Return the return value of a function directly, instead of first saving it
>> in a variable and then returning it. This change was made using the following
>
> Your commit message should respe
On Sat, 9 Sep 2017, Srishti Sharma wrote:
> Return the return value of a function directly, instead of first saving it in
> a variable and then returning it. This change was made using the following
Your commit message should respect the 80 character limit. The above is
one very long line.
>
Return the return value of a function directly, instead of first saving it in a
variable and then returning it. This change was made using the following
semantic patch by coccinelle.
@@
local idexpression ret;
expression e;
@@
-ret =
+return
e;
-return ret;
Signed-off-by: Srishti Sharma
-
On Fri, Sep 08, 2017 at 10:29:52AM -0700, Badhri Jagan Sridharan wrote:
> On Fri, Sep 8, 2017 at 2:45 AM, Greg Kroah-Hartman
> wrote:
> > On Thu, Sep 07, 2017 at 06:22:13PM -0700, Badhri Jagan Sridharan wrote:
> >> The source and sink caps should follow the following rules.
> >> This patch validat
On Fri, 8 Sep 2017, Harsha Sharma wrote:
> Make code more concise and readable
>
> Signed-off-by: Harsha Sharma
Acked-by: Julia Lawall
> ---
> Change in v3:
> -Change in subject and log message
> Change in v2:
> -Change in subject
> -Change in log message
> drivers/staging/typec/tcpm.c |
Make code more concise and readable
Signed-off-by: Harsha Sharma
---
Change in v3:
-Change in subject and log message
Change in v2:
-Change in subject
-Change in log message
drivers/staging/typec/tcpm.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/type
Maybe "Rewrite comparison to NULL pointer" in the subject to include what
was done, not just code was touched.
On Fri, 8 Sep 2017, Harsha Sharma wrote:
> Makes code more concise and readable
Makes -> Make. Commit logs should be written in the imperative, like you
are telling someone what to do.
Makes code more concise and readable
Signed-off-by: Harsha Sharma
---
Change in v2:
-Change in subject
-Change in log message
drivers/staging/typec/tcpm.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/typec/tcpm.c b/drivers/staging/typec/tcpm.c
index 630
On Fri, Sep 8, 2017 at 2:45 AM, Greg Kroah-Hartman
wrote:
> On Thu, Sep 07, 2017 at 06:22:13PM -0700, Badhri Jagan Sridharan wrote:
>> The source and sink caps should follow the following rules.
>> This patch validates whether the src_caps/snk_caps adheres
>> to it.
>>
>> 6.4.1 Capabilities Messag
Hi,
On 08-09-17 17:47, Peter Rosin wrote:
On 2017-09-05 18:42, Hans de Goede wrote:
Add MUX_USB_* and MUX_TYPEC_* state constant defines, which can be used by
USB device/host, resp. Type-C polarity/role/altmode mux drivers and
consumers to ensure that they agree on the meaning of the
mux_contro
On 2017-09-08 17:45, Peter Rosin wrote:
> From: Stephen Boyd
>
> Sometimes drivers only use muxes under certain scenarios. For
> example, the chipidea usb controller may be connected to a usb
> switch on some platforms, and connected directly to a usb port on
> others. The driver won't know one w
On Fri, Sep 8, 2017 at 8:59 PM, Sean Paul wrote:
> On Fri, Sep 8, 2017 at 11:11 AM, Srishti Sharma wrote:
>> Use BIT(x) instead of (1<>
>> Signed-off-by: Srishti Sharma
>> ---
>> drivers/staging/media/imx/imx-media.h | 16
>> 1 file changed, 8 insertions(+), 8 deletions(-)
>>
>
On 2017-09-05 18:42, Hans de Goede wrote:
> Add MUX_USB_* and MUX_TYPEC_* state constant defines, which can be used by
> USB device/host, resp. Type-C polarity/role/altmode mux drivers and
> consumers to ensure that they agree on the meaning of the
> mux_control_select() state argument.
>
> Signed
From: Stephen Boyd
Sometimes drivers only use muxes under certain scenarios. For
example, the chipidea usb controller may be connected to a usb
switch on some platforms, and connected directly to a usb port on
others. The driver won't know one way or the other though, so add
a mux_control_get_opt
On 2017-09-05 18:42, Hans de Goede wrote:
> The Intel cherrytrail xhci controller has an extended cap mmio-range
> which contains registers to control the muxing to the xhci (host mode)
> or the dwc3 (device mode) and vbus-detection for the otg usb-phy.
>
> Having a mux driver included in the xhci
A board may need a mux controller to stay as-is for a while longer, e.g.
if setting the normally preferred idle state destroys booting.
The mechanism provided here is not perfect in two ways.
1. As soon as the mux controller is registered, some mux consumer can
access it and set a state that de
On 2017-09-05 18:42, Hans de Goede wrote:
> Intel Cherrytrail SoCs have an internal USB mux for muxing the otg-port
> USB data lines between the xHCI host controller and the dwc3 gadget
> controller. On some Cherrytrail systems this mux is controlled through
> AML code reacting on a GPIO IRQ connec
On Fri, Sep 8, 2017 at 11:11 AM, Srishti Sharma wrote:
> Use BIT(x) instead of (1<
> Signed-off-by: Srishti Sharma
> ---
> drivers/staging/media/imx/imx-media.h | 16
> 1 file changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/staging/media/imx/imx-media.h
> b/dr
Use BIT(x) instead of (1<
---
drivers/staging/media/imx/imx-media.h | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/media/imx/imx-media.h
b/drivers/staging/media/imx/imx-media.h
index d409170..e5b8d29 100644
--- a/drivers/staging/media/imx/imx-
On Fri, Sep 8, 2017 at 8:08 PM, Dan Carpenter wrote:
> On Fri, Sep 08, 2017 at 07:38:18PM +0530, Srishti Sharma wrote:
>> Use WARN_ON() instead of BUG_ON() to avoid crashing the kernel.
>>
>> Signed-off-by: Srishti Sharma
>> ---
>> drivers/staging/media/omap4iss/iss.c | 2 +-
>> 1 file changed,
On Fri, 8 Sep 2017, Harsha Sharma wrote:
> Fixes coding style issue
Good job on getting the From issue sorted out.
The subject line change description is a bit verbose. One doesn't want
to see the whole code, but rather the concept of what has changed. If you
were going to tell someone about
On Fri, Sep 08, 2017 at 07:38:18PM +0530, Srishti Sharma wrote:
> Use WARN_ON() instead of BUG_ON() to avoid crashing the kernel.
>
> Signed-off-by: Srishti Sharma
> ---
> drivers/staging/media/omap4iss/iss.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/stagi
Fixes coding style issue
Signed-off-by: Harsha Sharma
---
drivers/staging/typec/tcpm.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/typec/tcpm.c b/drivers/staging/typec/tcpm.c
index 630fe75..9f4a5a5 100644
--- a/drivers/staging/typec/tcpm.c
+++ b/drivers/st
Fixes checkpatch warning -- "occured" and "succesfully" are misspelled
Signed-off-by: Harsha Sharma
---
Changes in v6:
-Added changes from other versions
Changes in v5:
-Signed-off properly with correct author name in .gitconfig
Changes in v4:
-Correct the format of the subject.
-Signed-off w
On Fri, Sep 8, 2017 at 7:40 PM, Julia Lawall wrote:
>
>
> On Fri, 8 Sep 2017, Srishti Sharma wrote:
>
>> Use WARN_ON() instead of BUG_ON() to avoid crashing the kernel.
>>
>> Signed-off-by: Srishti Sharma
>> ---
>> drivers/staging/media/omap4iss/iss.c | 2 +-
>> 1 file changed, 1 insertion(+), 1
On Fri, 8 Sep 2017, Srishti Sharma wrote:
> Use WARN_ON() instead of BUG_ON() to avoid crashing the kernel.
>
> Signed-off-by: Srishti Sharma
> ---
> drivers/staging/media/omap4iss/iss.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/media/omap4iss/iss
Use WARN_ON() instead of BUG_ON() to avoid crashing the kernel.
Signed-off-by: Srishti Sharma
---
drivers/staging/media/omap4iss/iss.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/media/omap4iss/iss.c
b/drivers/staging/media/omap4iss/iss.c
index c26c99fd..
On Fri, Sep 08, 2017 at 03:48:58PM +0200, walter harms wrote:
> > - while (i < (TSL2X7X_MAX_LUX_TABLE_SIZE * 3)) {
> > + while (i < TSL2X7X_MAX_LUX_TABLE_SIZE) {
> > offset += snprintf(buf + offset, PAGE_SIZE, "%u,%u,%u,",
> > chip->tsl2x7x_device_lux[i].ratio,
>
From: Colin Ian King
The call to _rtl_dbg_trace via macro HALMAC_RT_TRACE will trigger a null
pointer deference on a null driver_adapter. Fix this by assigning
driver_adapter earlier to halmac_adapter->driver_adapter before the tracing
call so that a non-null driver_adapter is passed instead.
I
On 08/09/17 14:52, Colin King wrote:
> From: Colin Ian King
>
> The call to _rtl_dbg_trace via macro HALMAC_RT_TRACE will trigger a null
> pointer deference on a null driver_adapter. Fix this by assigning
> driver_adapter earlier to halmac_adapter->driver_adapter before the tracing
> call so tha
From: Colin Ian King
The call to _rtl_dbg_trace via macro HALMAC_RT_TRACE will trigger a null
pointer deference on a null driver_adapter. Fix this by assigning
driver_adapter earlier to halmac_adapter->driver_adapter before the tracing
call so that a non-null driver_adapter is passed instead.
I
Am 08.09.2017 12:53, schrieb Dan Carpenter:
> The background of this code is that we can either use the default
> tables or load our own table with sysfs. The default tables are three
> element arrays of struct tsl2x7x_lux. If we load the table with sysfs
> then we can have as many as nine elem
On Fri, Sep 08, 2017 at 03:31:57PM +0530, Harsha Sharma wrote:
> Fixes checkpatch warning -- "occured" and "succesfully" are misspelled
>
> Signed-off-by: Harsha Sharma
> ---
> Changes in v5:
> -Correct the format of the subject.
> -Signed-off properly with correct author name in .gitconfig
Wh
The background of this code is that we can either use the default
tables or load our own table with sysfs. The default tables are three
element arrays of struct tsl2x7x_lux. If we load the table with sysfs
then we can have as many as nine elements. Which ever way we do it, the
last element is al
True.
Of course, normally the from line means you're forwarding a patch from
someone else and then it's totally appropriate. I don't like From lines
because it's just an extra thing to check. How do we know that they're
not just pretending to be someone from @MajorCorporation.com?
regards,
dan
On Fri, 8 Sep 2017, Lars-Peter Clausen wrote:
> On 09/08/2017 11:59 AM, Julia Lawall wrote:
> >
> >
> > On Fri, 8 Sep 2017, Lars-Peter Clausen wrote:
> >
> >> On 09/08/2017 11:32 AM, Jonathan Cameron wrote:
> >>> On Fri, 8 Sep 2017 07:29:06 +0100
> >>> Jonathan Cameron wrote:
> >>>
> On 8
On 09/08/2017 11:59 AM, Julia Lawall wrote:
>
>
> On Fri, 8 Sep 2017, Lars-Peter Clausen wrote:
>
>> On 09/08/2017 11:32 AM, Jonathan Cameron wrote:
>>> On Fri, 8 Sep 2017 07:29:06 +0100
>>> Jonathan Cameron wrote:
>>>
On 8 September 2017 05:47:52 BST, Himanshi Jain
wrote:
> Add
Fixes checkpatch warning -- "occured" and "succesfully" are misspelled
Signed-off-by: Harsha Sharma
---
Changes in v5:
-Correct the format of the subject.
-Signed-off properly with correct author name in .gitconfig
drivers/staging/pi433/pi433_if.c | 4 ++--
1 file changed, 2 insertions(+), 2 d
On Fri, 8 Sep 2017, Lars-Peter Clausen wrote:
> On 09/08/2017 11:32 AM, Jonathan Cameron wrote:
> > On Fri, 8 Sep 2017 07:29:06 +0100
> > Jonathan Cameron wrote:
> >
> >> On 8 September 2017 05:47:52 BST, Himanshi Jain
> >> wrote:
> >>> Added space around(one on each side of) binary
> >>> ope
On Fri, 8 Sep 2017, Dan Carpenter wrote:
> On Fri, Sep 08, 2017 at 11:45:20AM +0200, Julia Lawall wrote:
> >
> >
> > On Fri, 8 Sep 2017, harsha wrote:
> >
> > > From: Harsha Sharma
> > >
> > > Fixes checkpatch warning -- "occured" and "succesfully" are misspelled
> > >
> > > Signed-off-by: Hars
On Fri, Sep 08, 2017 at 11:45:20AM +0200, Julia Lawall wrote:
>
>
> On Fri, 8 Sep 2017, harsha wrote:
>
> > From: Harsha Sharma
> >
> > Fixes checkpatch warning -- "occured" and "succesfully" are misspelled
> >
> > Signed-off-by: Harsha Sharma
> > ---
> > Changes in v4:
> > -Correct the forma
On Fri, 8 Sep 2017 11:37:56 +0200
Lars-Peter Clausen wrote:
> On 09/08/2017 11:32 AM, Jonathan Cameron wrote:
> > On Fri, 8 Sep 2017 07:29:06 +0100
> > Jonathan Cameron wrote:
> >
> >> On 8 September 2017 05:47:52 BST, Himanshi Jain
> >> wrote:
> >>> Added space around(one on each side of
On Fri, 8 Sep 2017, harsha wrote:
> From: Harsha Sharma
>
> Fixes checkpatch warning -- "occured" and "succesfully" are misspelled
>
> Signed-off-by: Harsha Sharma
> ---
> Changes in v4:
> -Correct the format of the subject.
> -Signed-off properly.
It's not signed off properly. Like Greg j
On Thu, Sep 07, 2017 at 06:22:13PM -0700, Badhri Jagan Sridharan wrote:
> The source and sink caps should follow the following rules.
> This patch validates whether the src_caps/snk_caps adheres
> to it.
>
> 6.4.1 Capabilities Message
> A Capabilities message (Source Capabilities message or Sink
>
On Fri, 8 Sep 2017 07:29:06 +0100
Jonathan Cameron wrote:
> On 8 September 2017 05:47:52 BST, Himanshi Jain
> wrote:
> >Added space around(one on each side of) binary
> >operator(-) as preferred according to kernel
> >coding style.
> >
> >Signed-off-by: Himanshi Jain
>
> Take a closer look
From: Harsha Sharma
Fixes checkpatch warning -- "occured" and "succesfully" are misspelled
Signed-off-by: Harsha Sharma
---
Changes in v4:
-Correct the format of the subject.
-Signed-off properly.
drivers/staging/pi433/pi433_if.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
dif
On Thu, Sep 07, 2017 at 06:22:13PM -0700, Badhri Jagan Sridharan wrote:
> +static int tcpm_validate_caps(struct tcpm_port *port, const u32 *pdo,
> + unsigned int nr_pdo)
> +{
> + unsigned int i;
> +
> + /* Should at least contain vSafe5v */
> + if (nr_pdo < 1)
Your From email header says "harsha" but it should match your signed off
by line which says "Harsha Sharma".
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-de
On 09/08/2017 11:32 AM, Jonathan Cameron wrote:
> On Fri, 8 Sep 2017 07:29:06 +0100
> Jonathan Cameron wrote:
>
>> On 8 September 2017 05:47:52 BST, Himanshi Jain
>> wrote:
>>> Added space around(one on each side of) binary
>>> operator(-) as preferred according to kernel
>>> coding style.
>>>
On Thu, Sep 07, 2017 at 06:22:14PM -0700, Badhri Jagan Sridharan wrote:
> diff --git a/drivers/staging/typec/tcpm.c b/drivers/staging/typec/tcpm.c
> index 58a2c279f7d1..df0986d9f756 100644
> --- a/drivers/staging/typec/tcpm.c
> +++ b/drivers/staging/typec/tcpm.c
> @@ -262,6 +262,9 @@ struct tcpm_po
On Fri, Sep 08, 2017 at 02:42:14PM +0530, harsha wrote:
> Fixes checkpatch warning -- "occured" and "succesfully" are misspelled
>
> Signed-off-by: Harsha Sharma
> ---
> drivers/staging/pi433/pi433_if.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
{sigh}
Ok, last time for me, I
On Fri, 8 Sep 2017, Harsha Sharma wrote:
> Hi,Thanks for your feedback.
> I will take care about readability from next time.
Don't top post. You should respond to comments underneath the comment you
are responding to. The person will have to go find that anyway, to
understand what your commen
Fixes checkpatch warning -- "occured" and "succesfully" are misspelled
Signed-off-by: Harsha Sharma
---
drivers/staging/pi433/pi433_if.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/pi433/pi433_if.c b/drivers/staging/pi433/pi433_if.c
index 6b9b7df..6a10
On Fri, 8 Sep 2017, harsha wrote:
> Fixed coding style issue
>
> Signed-off-by: Harsha Sharma
> ---
> drivers/staging/rtl8712/xmit_linux.c | 6 --
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/rtl8712/xmit_linux.c
> b/drivers/staging/rtl8712/xmit_linux
The subject line above is still not what is shown with git log --oneline
for this file. Also, this patch fixes a previous submission so it should
be v2.
I suggest to read through the tutorial carefully again to get these small
details.
julia
On Fri, 8 Sep 2017, harsha wrote:
> Fixes checkpatch
Fixed coding style issue
Signed-off-by: Harsha Sharma
---
drivers/staging/rtl8712/xmit_linux.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8712/xmit_linux.c
b/drivers/staging/rtl8712/xmit_linux.c
index d13fd15..03c6b0c 100644
--- a/drivers/stagin
Fixes checkpatch warning -- "occured" and "succesfully" are misspelled
Signed-off-by: Harsha Sharma
---
drivers/staging/pi433/pi433_if.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/pi433/pi433_if.c b/drivers/staging/pi433/pi433_if.c
index 6b9b7df..6a10
68 matches
Mail list logo