[PATCH net-next 0/1] netvsc: fix deadlock in VF unregister

2017-08-04 Thread Stephen Hemminger
There was a race in VF unregister (in net-next only) which can be triggered if SR-IOV is disabled on host side, which causes PCI hotplug removal. Stephen Hemminger (1): netvsc: fix rtnl deadlock on unregister of vf drivers/net/hyperv/netvsc_drv.c | 12 ++-- 1 file changed, 10 insertion

[PATCH net-next 1/1] netvsc: fix rtnl deadlock on unregister of vf

2017-08-04 Thread Stephen Hemminger
With new transparent VF support, it is possible to get a deadlock when some of the deferred work is running and the unregister_vf is trying to cancel the work element. The solution is to use trylock and reschedule (similar to bonding and team device). Reported-by: Vitaly Kuznetsov Fixes: 0c195567

Re: [PATCH] mtd: nand: Rename nand.h into rawnand.h

2017-08-04 Thread Vladimir Zapolskiy
Hi Boris, On 04.08.2017 18:29, Boris Brezillon wrote: > We are planning to share more code between different NAND based > devices (SPI NAND, OneNAND and raw NANDs), but before doing that > we need to move the existing include/linux/mtd/nand.h file into > include/linux/mtd/rawnand.h so we can later

Re: [PATCH] mtd: nand: Rename nand.h into rawnand.h

2017-08-04 Thread Uwe Kleine-König
Hello Boris, you could easily split this patch per architecture/subsystem if you in a first patch move the content of nand.h to rawnand.h and make nand.h just #include rawnand.h. Then you can switch one user at a time and when all are converted to use rawnand.h you can drop the #include. Best reg

Re: [PATCH 1/2] wireless: move prism54 out to staging

2017-08-04 Thread Luis R. Rodriguez
On Thu, Aug 03, 2017 at 05:42:15PM -0700, Greg KH wrote: > On Thu, Aug 03, 2017 at 04:59:36PM -0700, Luis R. Rodriguez wrote: > > prism54 is deprecated in favor of the p54pci device driver. Although > > only *one soul* had reported issues with it long ago Linux most Linux > > distributions these da

Re: [PATCH] mtd: nand: Rename nand.h into rawnand.h

2017-08-04 Thread Neil Armstrong
On 08/04/2017 05:29 PM, Boris Brezillon wrote: > We are planning to share more code between different NAND based > devices (SPI NAND, OneNAND and raw NANDs), but before doing that > we need to move the existing include/linux/mtd/nand.h file into > include/linux/mtd/rawnand.h so we can later create

Re: [PATCH] mtd: nand: Rename nand.h into rawnand.h

2017-08-04 Thread Gregory CLEMENT
Hi Boris, On ven., août 04 2017, Boris Brezillon wrote: > We are planning to share more code between different NAND based > devices (SPI NAND, OneNAND and raw NANDs), but before doing that > we need to move the existing include/linux/mtd/nand.h file into > include/linux/mtd/rawnand.h so we ca

[PATCH] mtd: nand: Rename nand.h into rawnand.h

2017-08-04 Thread Boris Brezillon
We are planning to share more code between different NAND based devices (SPI NAND, OneNAND and raw NANDs), but before doing that we need to move the existing include/linux/mtd/nand.h file into include/linux/mtd/rawnand.h so we can later create a nand.h header containing all common structure and fun

[PATCH] mtd: nand: Rename nand.h into rawnand.h

2017-08-04 Thread Boris Brezillon
We are planning to share more code between different NAND based devices (SPI NAND, OneNAND and raw NANDs), but before doing that we need to move the existing include/linux/mtd/nand.h file into include/linux/mtd/rawnand.h so we can later create a nand.h header containing all common structure and fun

[PATCH] Staging: bcm2048: fix bare use of 'unsigned' in radio-bcm2048.c

2017-08-04 Thread Branislav Radocaj
This is a patch to the radio-bcm2048.c file that fixes up a warning found by the checkpatch.pl tool. Signed-off-by: Branislav Radocaj --- drivers/staging/media/bcm2048/radio-bcm2048.c | 50 +-- 1 file changed, 25 insertions(+), 25 deletions(-) diff --git a/drivers/stagin

[PATCH 0/5] constify videobuf_queue_ops structures

2017-08-04 Thread Julia Lawall
These videobuf_queue_ops structures are only passed as the second argument to videobuf_queue_vmalloc_init, which is declared as const. Thus the videobuf_queue_ops structures themselves can be const. Done with the help of Coccinelle. --- drivers/media/pci/cx18/cx18-streams.c

[PATCH 2/5] [media] atomisp: constify videobuf_queue_ops structures

2017-08-04 Thread Julia Lawall
These videobuf_queue_ops structures are only passed as the second argument to videobuf_queue_vmalloc_init, which is declared as const. Thus the videobuf_queue_ops structures themselves can be const. Done with the help of Coccinelle. // @r disable optional_qualifier@ identifier i; position p; @@

[RESEND PATCH] staging: vboxvideo: remove dead gamma lut code

2017-08-04 Thread Peter Rosin
The redundant fb helpers .load_lut, .gamma_set and .gamma_get are no longer used. Remove the dead code that was not doing anything sensible anyway. Signed-off-by: Peter Rosin --- drivers/staging/vboxvideo/vbox_fb.c | 15 --- drivers/staging/vboxvideo/vbox_mode.c | 5 - 2 files

[PATCH] staging: vboxvideo: remove dead gamma lut code

2017-08-04 Thread Peter Rosin
The redundant fb helpers .load_lut, .gamma_set and .gamma_get are no longer used. Remove the dead code that was not doing anything sensible anyway. Signed-off-by: Peter Rosin --- drivers/staging/vboxvideo/vbox_fb.c | 15 --- drivers/staging/vboxvideo/vbox_mode.c | 5 - 2 files

Re: [PATCH] staging: lustre: grab the cld->cld_lock mutex unconditionally

2017-08-04 Thread Cihangir Akturk
On Thu, Aug 03, 2017 at 08:31:15PM +0300, Cihangir Akturk wrote: > On Thu, Aug 03, 2017 at 05:52:44PM +0100, James Simmons wrote: > > > > > Instead of using the locked variable as a helper to determine the state > > > of the mutex cld->cld_lock, expand the scope of the recover_cld variable > > > a