Hi Greg,
Is the reason Sudip gave you for the question of "why" sufficient ?
This patch is very important for the driver running in the X86 platform.
Without this patch, many SM750 graphic chip customers complain the Ubuntu OS
can't run well. When they install the OS, the screen will b
Replace the literal function name "visorbus_create_instance" with the format
specifier "%s" so it can be dynamically filled by the __func__ macro.
Signed-off-by: Quytelda Kahja
---
drivers/staging/unisys/visorbus/visorbus_main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a
> -Original Message-
> From: Quytelda Kahja [mailto:quyte...@tamalin.org]
> Sent: Tuesday, June 27, 2017 5:18 PM
> To: Kershner, David A ;
> gre...@linuxfoundation.org
> Cc: de...@driverdev.osuosl.org; linux-ker...@vger.kernel.org; Quytelda
> Kahja
> Subject: [PATCH] Replace the literal
This patch replaces several instances where a pointer is compared to NULL
(i.e., `ptr == NULL`) with `!ptr`, which is preferred.
Signed-off-by: Quytelda Kahja
---
drivers/staging/android/ion/ion.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/android/i
Signed-off-by: Quytelda Kahja
---
drivers/staging/unisys/visorbus/visorbus_main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/unisys/visorbus/visorbus_main.c
b/drivers/staging/unisys/visorbus/visorbus_main.c
index 1c785dd19ddd..1c6dc3a3e64a 100644
--- a/dr
> -Original Message-
> From: Quytelda Kahja [mailto:quyte...@tamalin.org]
> Sent: Monday, June 26, 2017 7:32 PM
> To: Kershner, David A ;
> gre...@linuxfoundation.org; Sell, Timothy C ;
> Binder, David Anthony
> Cc: de...@driverdev.osuosl.org; linux-ker...@vger.kernel.org; Quytelda
> Kahja
On Tue, Jun 27, 2017 at 6:00 PM, gregkh wrote:
> On Tue, Jun 27, 2017 at 05:33:21PM +0200, Arnd Bergmann wrote:
>> On Tue, Jun 27, 2017 at 4:41 PM, wrote:
>> > From: Laurentiu Tudor
>> >
>> > This patch series contain mainly clean-ups of the mc-bus header files
>> > with the final goal of reorg
On Tue, 2017-06-27 at 11:18 -0400, Benjamin Coddington wrote:
> In the previous patch, the locks API will expect that if a filesystem
> returns a remote pid as opposed to a local pid for F_GETLK, that remote pid
> will be <= 0. This signifies that the pid is remote, and the locks API
> will forego
> -Original Message-
> From: devel [mailto:driverdev-devel-boun...@linuxdriverproject.org] On
> Behalf Of Arvind Yadav
> Sent: Friday, June 23, 2017 2:31 AM
> To: gre...@linuxfoundation.org; Sell, Timothy C
> ; Wadgaonkar, Sameer Laxmikant
> ; jon.fri...@unisys.com
> Cc: de...@driverdev.osu
> -Original Message-
> From: Arvind Yadav [mailto:arvind.yadav...@gmail.com]
> Sent: Friday, June 23, 2017 3:37 AM
> To: Kershner, David A ;
> gre...@linuxfoundation.org; Thompson, Bryan E.
> ; Wadgaonkar, Sameer Laxmikant
> ; jon.fri...@unisys.com
> Cc: *S-Par-Maintainer ;
> de...@driverde
On Tue, Jun 27, 2017 at 05:33:21PM +0200, Arnd Bergmann wrote:
> On Tue, Jun 27, 2017 at 4:41 PM, wrote:
> > From: Laurentiu Tudor
> >
> > This patch series contain mainly clean-ups of the mc-bus header files
> > with the final goal of reorganizing them in just 2 files: a public
> > and a privat
On Tue, Jun 27, 2017 at 4:41 PM, wrote:
> From: Laurentiu Tudor
>
> This patch series contain mainly clean-ups of the mc-bus header files
> with the final goal of reorganizing them in just 2 files: a public
> and a private one, as per GregKH suggestion [1].
> Here's a summary of the header reorg
Removing the file causes a build failure:
make[5]: *** No rule to make target 'drivers/staging/fsl-mc/bus/dpmng.o',
needed by 'drivers/staging/fsl-mc/bus/mc-bus-driver.o'.
This adapts the Makefile as needed.
Fixes: b065307fe0ad ("staging: fsl-mc: remove dpmng API files")
Signed-off-by: Arnd Ber
Struct file_lock is fairly large, so let's save some space on the stack by
using an allocation for struct file_lock in fcntl_getlk(), just as we do
for fcntl_setlk().
Signed-off-by: Benjamin Coddington
---
fs/locks.c | 46 ++
1 file changed, 26 inserti
LTP fcntl tests (fcntl11 fcntl14 fcntl17 fcntl19 fcntl20 fcntl21) have been
failing for NFSv4 mounts due to an unexpected l_pid. What follows are some
fixups:
v2: - Rebase onto linux-next
- Revert back to using the stack in locks_mandatory_area(), and fixup
patch description for 1/3
In the previous patch, the locks API will expect that if a filesystem
returns a remote pid as opposed to a local pid for F_GETLK, that remote pid
will be <= 0. This signifies that the pid is remote, and the locks API
will forego translating that pid into the pid namespace of the local
calling proc
Since commit c69899a17ca4 "NFSv4: Update of VFS byte range lock must be
atomic with the stateid update", NFSv4 has been inserting locks in rpciod
worker context. The result is that the file_lock's fl_nspid is the
kworker's pid instead of the original userspace pid.
The fl_nspid is only used to re
From: Laurentiu Tudor
Few files using byte order macros but did not explicitly
included the required kernel header, so add it.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-mc/bus/dpbp.c | 1 +
drivers/staging/fsl-mc/bus/dpcon.c | 1 +
drivers/staging/fsl-m
From: Laurentiu Tudor
All the mc-bus.h contents is only used privately in the bus driver so
move everything to the private header and get rid of the mc-bus.h
header file.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-mc/bus/dprc-driver.c | 1 -
drivers/st
From: Laurentiu Tudor
dprc.h is only used in the mc bus driver so move it together with the
sources thus making it private.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-mc/bus/dprc.c | 2 +-
drivers/staging/fsl-mc/{include => bus}/dprc.h | 0
drivers/s
From: Laurentiu Tudor
mc-cmd.h contains some low level functions used to encode and decode
commands to the MC. They are used by the drivers so move them to the
public headers and get rid of the mc-cmd.h header.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-dpaa2/eth
From: Laurentiu Tudor
dpmng.h & dpmng.c files expose an API of just one function which is only
used by the bus driver. Move that single API in the bus source as static
and remove the two files.
Signed-off-by: Laurentiu Tudor
---
v2:
- fix compile error by removing dpmng.c from Makefile
drive
From: Laurentiu Tudor
Define dev_is_fsl_mc() and the bus type definition (fsl_mc_bus_type)
are used externally so move them to the public header.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-mc/include/mc-bus.h | 9 -
drivers/staging/fsl-mc/include/mc.h
From: Laurentiu Tudor
mc-sys.h contains the API to send commands to the MC and is used
by drivers. Move it to the public headers and get rid of the mc-sys.h
header.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-dpaa2/ethernet/dpaa2-eth.c | 1 -
drivers/staging/fsl-
From: Laurentiu Tudor
They are never used outside the source they are implemented in and very
likely never will, so it's safe to make them static.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-mc/bus/dprc-driver.c | 8 +++-
drivers/staging/fsl-mc/bus/fsl-mc-bus.
From: Laurentiu Tudor
The function fsl_mc_bus_exists() has a prototype but is never
implemented so delete it from the header file.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-mc/include/mc-bus.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/
From: Laurentiu Tudor
fsl_mc_msi_create_irq_domain() will is used from the irqchip glue code
so it needs to be in the public headers.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-mc/include/mc-bus.h | 7 ---
drivers/staging/fsl-mc/include/mc.h | 7 +++
From: Laurentiu Tudor
These functions already have their prototypes in fsl-mc-private.h
header file so delete them from mc-bus.h.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-mc/include/mc-bus.h | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/sta
From: Laurentiu Tudor
In its current form, the public headers of the mc-bus depend only on a
structure "dprc_obj_desc" defined in dprc.h. Move it to the bus public
header together with its associated defines and, in order to keep the
naming prefixes consistent rename it to "fsl_mc_obj_desc".
This
From: Laurentiu Tudor
These couple of header files are not needed in the source
so remove them.
Signed-off-by: Laurentiu Tudor
---
v2:
- no changes
drivers/staging/fsl-mc/bus/fsl-mc-allocator.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/fsl-mc/bus/fsl-mc-allocator.c
From: Laurentiu Tudor
Stick to one way of checking the return code of strcmp(): use '!'.
This was suggested in a review comment.
Signed-off-by: Laurentiu Tudor
---
v2:
- new patch
drivers/staging/fsl-mc/bus/fsl-mc-allocator.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff
From: Laurentiu Tudor
This patch series contain mainly clean-ups of the mc-bus header files
with the final goal of reorganizing them in just 2 files: a public
and a private one, as per GregKH suggestion [1].
Here's a summary of the header reorganizing:
- existing mc.h used as public header (cont
From: Laurentiu Tudor
Move comparison before the strcmp() in this if statement, and slightly
increase efficiency by not making the strcmp() each time the if gets
evaluated but only when the comparison is true.
This was suggested in a review comment.
Signed-off-by: Laurentiu Tudor
---
v2:
- new
From: Colin Ian King
Trivial fix to spelling mistake in netdev_info message and split
line to clean up an checkpatch line too wide warning.
Signed-off-by: Colin Ian King
---
drivers/staging/rtl8192e/rtllib_softmac.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/
Hello Hans,
26.06.2017 18:06, Hans de Goede wrote:
> Hi,
>
> On 23-06-17 11:31, Daniel Vetter wrote:
>> On Thu, Jun 22, 2017 at 11:11:37AM +0200, Hans de Goede wrote:
[vboxvideo driver submission information to staging.]
>>
>> In the end it's up to you, but our experience in drm with -staging has
The following variables and struct name
are renamed to avoid camelcase issue
Configuration to configuration
BeaconPeriod to beacon_period
DSConfig to ds_config
ATIMWindowto atim_window
pnic_Config to pnic_config
FHConfig to fh_config
HopPatternto hop_pattern
HopSetto h
On Tue, Jun 27, 2017 at 9:48 AM, Jaya Durga wrote:
> Fix checkpatch.pl warning of the form "CHECK" Macro argument 'x'
> may be better as '(x)' to avoid precedence issues.
>
> Signed-off-by: Jaya Durga
> ---
> drivers/staging/rtl8712/osdep_intf.h | 5 -
> 1 file changed, 4 insertions(+), 1 de
From: Colin Ian King
Trivial fix to spelling mistake in netdev_err error message
Signed-off-by: Colin Ian King
---
drivers/staging/wilc1000/host_interface.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b/drivers/staging/wilc1000
Fix checkpatch.pl warning of the form "CHECK" Macro argument 'x'
may be better as '(x)' to avoid precedence issues.
Signed-off-by: Jaya Durga
---
drivers/staging/rtl8712/osdep_intf.h | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8712/osdep_intf.h
b/d
Fix checkpatch.pl Warning: Symbolic permissions 'S_IRUGO | S_IWUSR' are not
preferred.
Consider using octal permissions '0644'.
Signed-off-by: Jaya Durga
---
drivers/staging/rtl8712/os_intfs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8712/os_intfs.c
Align block comments according to coding style.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_hw_queue_defs.h | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ccree/cc_hw_queue_defs.h
b/drivers/staging/ccree/cc_hw_queue_defs.h
index f114
Remove or add blank lines as needed to match coding style.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 20 +--
drivers/staging/ccree/ssi_aead.h| 4
drivers/staging/ccree/ssi_buffer_mgr.c | 7 ---
drivers/staging/ccree/ssi_buff
Fix location of pointer in variables definitions and dereference.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.h| 4 ++--
drivers/staging/ccree/ssi_buffer_mgr.c | 12 ++--
drivers/staging/ccree/ssi_cipher.c | 8
drivers/staging/ccree/ssi_fip
The CCFipsSyncStatus_t type was not being used in the code.
Remove it.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_fips_local.h | 10 --
1 file changed, 10 deletions(-)
diff --git a/drivers/staging/ccree/ssi_fips_local.h
b/drivers/staging/ccree/ssi_fips_local.h
index
Replace custom type ssi_fips_error_t with underlying enum.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_fips.c | 4 ++--
drivers/staging/ccree/ssi_fips.h | 6 +++---
drivers/staging/ccree/ssi_fips_ext.c | 6 +++---
drivers/staging/ccree/ssi_fips_ll.c| 30 +++
Replace references to type tdes_keys_t with struct tdes_keys.
_
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_cipher.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/ccree/ssi_cipher.c
b/drivers/staging/ccree/ssi_cipher.c
index b4fc9a6..
Replace custom type ssi_fips_state_t with underlying enum.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_fips.c | 4 ++--
drivers/staging/ccree/ssi_fips.h | 6 +++---
drivers/staging/ccree/ssi_fips_ext.c | 6 +++---
drivers/staging/ccree/ssi_fips_local.c | 8 ---
Fix several cases of needless braces around single statement blocks.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 38 +++---
drivers/staging/ccree/ssi_buffer_mgr.c | 70 ++---
drivers/staging/ccree/ssi_cipher.c | 41 +
Fix mismatched braces between if and else.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 3 ++-
drivers/staging/ccree/ssi_cipher.c | 7 +++
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/ccree/ssi_buffer_mgr.c
b/drivers/stag
Remove explicit comparisons to NULL in ccree driver.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 34 -
drivers/staging/ccree/ssi_buffer_mgr.c | 44 -
drivers/staging/ccree/ssi_cipher.c | 12 -
Remove redundant blank lines in brace blocks
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 2 --
drivers/staging/ccree/ssi_buffer_mgr.c | 8
drivers/staging/ccree/ssi_cipher.c | 5 -
drivers/staging/ccree/ssi_driver.c | 1 -
drivers/staging
Fix cases where the else clause was not located correctly after the if
brace.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 3 +--
drivers/staging/ccree/ssi_pm.c | 3 +--
2 files changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ccree/s
Add and/or remove redundant and/or missing spaces in ccree source
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/Kconfig | 2 +-
drivers/staging/ccree/ssi_aead.c| 38
drivers/staging/ccree/ssi_aead.h| 12 +--
drivers/staging/ccree/ssi_buffer_mgr.
Fix cases in ccree where explicit comparsion to true/false
was made.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c | 18 +-
drivers/staging/ccree/ssi_buffer_mgr.c | 20 ++--
drivers/staging/ccree/ssi_cipher.c | 2 +-
drivers/stagi
Fix a bunch of coding style across the whole ccree driver
Gilad Ben-Yossef (14):
staging: ccree: fix missing or redundant spaces
staging: ccree: drop comparsion to true/false
staging: ccree: fix else placement
staging: ccree: remove redundant blank lines
staging: ccree: no need for brace
55 matches
Mail list logo