From: Suniel Mahesh
le16_to_cpu() accepts argument of type __le16 and cpu_to_le16()
returns an argument of type __le16. This patch fixes:
(a) the type of the variable that end's up getting return from
cpu_to_le16().
(b) the member types of struct hfa384x_host_scan_request_data,
struct hfa
> On Thu, 2017-06-15 at 17:57 +0100, James Simmons wrote:
> > > On Thu, 2017-06-15 at 17:03 +0100, James Simmons wrote:
> > > > > On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> > > > > > Due to the way the DFID was embedded in our debug strings checkpatch
> > > > > > would report the fo
On Thu, 2017-06-15 at 17:57 +0100, James Simmons wrote:
> > On Thu, 2017-06-15 at 17:03 +0100, James Simmons wrote:
> > > > On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> > > > > Due to the way the DFID was embedded in our debug strings checkpatch
> > > > > would report the following err
On Thu, 2017-06-15 at 17:38 +0100, James Simmons wrote:
> > On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> > > Cleanup all braces that was reported by checkpatch. The only
> > > issue not fixed up is in mdc_lock.c. Removing the braces in
> > > the case of mdc_lock.c will break the build.
> On Thu, 2017-06-15 at 17:03 +0100, James Simmons wrote:
> > > On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> > > > Due to the way the DFID was embedded in our debug strings checkpatch
> > > > would report the following error:
> > >
> > > unrelated trivia
> > >
> > > > diff --git a/d
On Thu, Jun 15, 2017 at 04:48:20PM +0100, James Simmons wrote:
> So this is coming from trying to understand the "merge them together"
> part. Some people reading this it implies all the headers would be
> eventually merged into one big header and placed into include/uapi/linux.
Sounds like a g
> On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> > Cleanup all braces that was reported by checkpatch. The only
> > issue not fixed up is in mdc_lock.c. Removing the braces in
> > the case of mdc_lock.c will break the build.
>
> []
>
> > diff --git a/drivers/staging/lustre/lustre/llit
On Thu, Jun 15, 2017 at 12:29 AM, Joe Perches wrote:
> On Wed, 2017-06-14 at 19:36 +0530, srishti sharma wrote:
>> Fixed alignment so that it matched open paranthesis.
>
> Please try to avoid typos in your commit message and as
> well try to do all of alignment warnings in a single patch.
>
> Idea
On Thu, 2017-06-15 at 17:03 +0100, James Simmons wrote:
> > On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> > > Due to the way the DFID was embedded in our debug strings checkpatch
> > > would report the following error:
> >
> > unrelated trivia
> >
> > > diff --git a/drivers/staging/lu
On Thu, 2017-06-15 at 17:06 +0100, James Simmons wrote:
> > On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> > > Cleanup many of the over 80 characters reported by checkpatch
> >
> > Please don't let checkpatch get in the way of lustre
> > readability.
> >
> > lustre commonly uses very l
> On Mon, Jun 12, 2017 at 08:20:15PM +, Dilger, Andreas wrote:
> > On Jan 21, 2017, at 02:24, Greg Kroah-Hartman
> > wrote:
> > >
> > > On Fri, Jan 20, 2017 at 11:33:11PM +, James Simmons wrote:
> > >>
> > > On Mon, Dec 19, 2016 at 12:06:47PM -0500, James Simmons wrote:
> > >>
> On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> > Cleanup many of the over 80 characters reported by checkpatch
>
> Please don't let checkpatch get in the way of lustre
> readability.
>
> lustre commonly uses very long identifiers.
> Long identifiers and 80 columns don't mix well.
>
> On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> > Due to the way the DFID was embedded in our debug strings checkpatch
> > would report the following error:
>
> unrelated trivia
>
> > diff --git a/drivers/staging/lustre/lustre/include/lustre/lustre_user.h
> > b/drivers/staging/lustr
On Thu, Jun 15, 2017 at 10:52:03PM +0800, jm wrote:
> ---
> drivers/staging/android/ion/ion.c | 8
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/android/ion/ion.c
> b/drivers/staging/android/ion/ion.c
> index 43ecb4a..a2d36b3 100644
> --- a/drivers/s
> Subject: [PATCH v2] staging: wlan-ng: Amend type mismatch warnings
I think it would be better to state that you fix the types of some
struct fields. That's a much more important goal of this patch than
getting sparse to spout slightly fewer warnings.
On Thu, Jun 15, 2017 at 8:41 AM, wrote:
>
> -Original Message-
> From: Ioana Radulescu [mailto:ruxandra.radule...@nxp.com]
> Sent: Thursday, June 15, 2017 11:55 AM
> To: gre...@linuxfoundation.org
> Cc: de...@driverdev.osuosl.org; linux-ker...@vger.kernel.org;
> ag...@suse.de; a...@arndb.de; linux-arm-ker...@lists.infradead.org; Bo
Clip longer than 80 chars lines.
Fix more "80 char" warnings than [PATCH v1].
Keep 4 "80 char" warnings for readability.
Signed-off-by: Gao Zhuang
---
.../staging/vc04_services/bcm2835-audio/bcm2835-ctl.c | 18 +-
1 file changed, 13 insertions(+), 5 deletions(-)
diff --git a/dr
I have updated the comments here and resend the new patch
On 13/06/17 18:07, Greg KH wrote:
On Tue, Jun 13, 2017 at 03:45:32PM +0530, bincy_k_phi...@yahoo.co.in wrote:
From: bincy
trivial fix for space alignment error
Signed-off-by: bincy k philip
---
drivers/staging/octeon-usb/octeon-hcd.
dpaa2_io_service_register() returns zero even if
qbman_swp_CDAN_set() encountered an error. Fix this
by propagating the error code so the caller is informed
data availability notifications are not properly set
for a channel.
Signed-off-by: Ioana Radulescu
---
drivers/staging/fsl-mc/bus/dpio/dpio
Hi,
On Wed, Jun 14, 2017 at 9:23 AM, Dan Carpenter wrote:
[...]
>
> Could you call it "dev_name" instead? I normally expect "dev" to be a
> device struct.
Thanks for the feedback. Will keep these in mind for next version of the patch.
Okash
___
devel
20 matches
Mail list logo