Hi,
On Wed, Jun 14, 2017 at 03:04:18PM +0200, Greg Kroah-Hartman wrote:
> The console stuff is odd though, but that is each driver defining the
> name for itself, major/minor does not apply. Also, a separate driver is
> not having to figure this all out. I wonder if we could just add a tty
> co
From: Suniel Mahesh
le16_to_cpu() accepts argument of type __le16 and cpu_to_le16()
returns an argument of type __le16. This patch fixes warnings
related to incorrect type in assignment and changes the types
in the corresponding header file.
The following type mismatch warnings reported by sparse
From: bincy k philip
trivial fix for extra space error
Signed-off-by: bincy k philip
---
drivers/staging/octeon-usb/octeon-hcd.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.c
b/drivers/staging/octeon-usb/octeon-hcd.c
index 068aece.
.
> >
> > It's a makefile, not a "program", so why is all of this here?
>
> I followed ath6kl for much of the time while writing this, ath6kl does
> this. I will remove it and resubmit.
>
> > > +#---
Stephen Hemminger writes:
> On Wed, 14 Jun 2017 04:31:32 +
> Jork Loeser wrote:
>
>> > From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
>> > Sent: Tuesday, June 13, 2017 19:29
>> >
>> > Stephen Hemminger writes:
>> >
>> > > On Fri, 9 Jun 2017 15:27:33 +0200
>> > > Vitaly Kuznetsov
Hi Tobin,
[auto build test ERROR on staging/staging-testing]
[also build test ERROR on v4.12-rc5 next-20170614]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Tobin-C-Harding/staging-ks7010
On Wed, Jun 14, 2017 at 12:24:21PM +0200, Greg Kroah-Hartman wrote:
> On Wed, Jun 14, 2017 at 04:30:37PM +1000, Tobin C. Harding wrote:
> > Currently we are in the process of replacing the WEXT interface with
> > the cfg80211 API. WEXT code is currently within a sub directory and
> > not included i
On Wed, Jun 14, 2017 at 12:22:31PM +0200, Greg Kroah-Hartman wrote:
> On Wed, Jun 14, 2017 at 04:30:35PM +1000, Tobin C. Harding wrote:
> > Current driver implements the WEXT interface. WEXT is in maintenance
> > mode, we need to re-write the driver using the cfg80211 API. The current
> > driver is
Remove unnecassary casts in the argument to kfree.
Found using Coccinelle. The semantic patch used to find this is as
follows:
//
@@
type T;
expression *f;
@@
- kfree((T *)(f));
+ kfree(f);
//
Signed-off-by: Amitoj Kaur Chawla
---
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 14 +++---
On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> Due to the way the DFID was embedded in our debug strings checkpatch
> would report the following error:
unrelated trivia
> diff --git a/drivers/staging/lustre/lustre/include/lustre/lustre_user.h
> b/drivers/staging/lustre/lustre/include/
Fixed alignment so that it matched open parenthesis.
Signed-off-by: srishti sharma
---
.../staging/vc04_services/bcm2835-audio/bcm2835-ctl.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/vc04_services/bcm2835-audio/bcm2835-ctl.c
b/driver
Following removal of _rtl92e_ioctl this function along with associated
macros, structure ieee_param and functions become dead code.
Remove functions rtllib_wpa_enable, rtllib_wpa_assoc_frame, rtllib_wpa_mlme,
rtllib_wpa_set_wpa_ie, rtllib_wpa_set_auth_algs, rtllib_wpa_set_param,
rtllib_wpa_set_enc
On Wed, 2017-06-14 at 19:36 +0530, srishti sharma wrote:
> Fixed alignment so that it matched open paranthesis.
Please try to avoid typos in your commit message and as
well try to do all of alignment warnings in a single patch.
Ideally, all the files in a driver would be modified.
$ ./scripts/ch
A RTL_IOCTL_WPA_SUPPLICANT call is a proprietary version of
wpa supplicant.
All kernel calls use SIOCSIWENCODEEXT call via wireless handlers
already used in this driver.
Remove dead code.
Signed-off-by: Malcolm Priestley
---
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 126 --
On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> Cleanup all braces that was reported by checkpatch. The only
> issue not fixed up is in mdc_lock.c. Removing the braces in
> the case of mdc_lock.c will break the build.
[]
> diff --git a/drivers/staging/lustre/lustre/llite/vvp_dev.c
> b/
On Wed, 2017-06-14 at 11:01 -0400, James Simmons wrote:
> Cleanup many of the over 80 characters reported by checkpatch
Please don't let checkpatch get in the way of lustre
readability.
lustre commonly uses very long identifiers.
Long identifiers and 80 columns don't mix well.
It might be simple
On Wed, 14 Jun 2017 04:31:32 +
Jork Loeser wrote:
> > From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
> > Sent: Tuesday, June 13, 2017 19:29
> >
> > Stephen Hemminger writes:
> >
> > > On Fri, 9 Jun 2017 15:27:33 +0200
> > > Vitaly Kuznetsov wrote:
> > >
> > >> To support impleme
On Wed, Jun 14, 2017 at 07:08:39AM +0200, Greg Kroah-Hartman wrote:
> On Tue, Jun 13, 2017 at 09:17:05PM +0300, Gleb Fotengauer-Malinovskiy wrote:
> > On Tue, May 30, 2017 at 04:33:57PM -0700, Laura Abbott wrote:
> > > On 05/30/2017 07:11 AM, Gleb Fotengauer-Malinovskiy wrote:
> > > > This problem
Due to the way the DFID was embedded in our debug strings checkpatch
would report the following error:
CHECK: Concatenated strings should use spaces between elements
This patch introduces proper space to resolve these reports.
Signed-off-by: James Simmons
---
drivers/staging/lustre/lustre/fid/
Cleanup many of the over 80 characters reported by checkpatch
Signed-off-by: James Simmons
---
drivers/staging/lustre/lustre/include/cl_object.h | 2 +-
.../staging/lustre/lustre/include/lprocfs_status.h | 3 +-
drivers/staging/lustre/lustre/ldlm/ldlm_extent.c | 5 ++--
drivers/staging/lus
This patch series covers a good chunk of the checkpatch issues in the
current lustre client code.
James Simmons (6):
staging: lustre: lustre: resolve "use spaces between elements" checkpatch
errors
staging: lustre: lustre: make all struct file_operations constant
staging: lustre: lustre: fi
Turn all bare unsigned usage in the lustre code to proper
unsigned int.
Signed-off-by: James Simmons
---
drivers/staging/lustre/lustre/include/cl_object.h | 4 ++--
drivers/staging/lustre/lustre/include/lu_object.h | 4 ++--
drivers/staging/lustre/lustre/llite/namei.c | 2 +-
drivers/stagi
Cleanup all braces that was reported by checkpatch. The only
issue not fixed up is in mdc_lock.c. Removing the braces in
the case of mdc_lock.c will break the build.
Signed-off-by: James Simmons
---
drivers/staging/lustre/lustre/fld/fld_cache.c | 3 ++-
drivers/staging/lustre/lustre/ldlm/ldlm_l
Checkpatch reported several cases of struct file_operations
not being const. This resolves those warnings.
Signed-off-by: James Simmons
---
drivers/staging/lustre/lustre/fld/lproc_fld.c | 2 +-
drivers/staging/lustre/lustre/include/lprocfs_status.h | 8
drivers/staging/lustre
Create identifier names missing from function prototypes as
reported by checkpatch.
Signed-off-by: James Simmons
---
.../staging/lustre/lustre/include/lprocfs_status.h | 4 ++--
drivers/staging/lustre/lustre/ldlm/ldlm_internal.h | 27 --
.../staging/lustre/lustre/llite/llite
Hi,
On 14-06-17 15:40, Michael Thayer wrote:
Hello Hans,
14.06.2017 15:30, Hans de Goede wrote:
[Discussion of vboxvideo and vboxguest driver clean-up.]
As I already mentioned in previous mails on this, for the vboxguest driver
my plan is to simply do a fork and remove anything related to the
14.06.2017 16:42, Sean Paul wrote:
[Discussion of vboxvideo driver kernel integration and clean-up.]
> Once the code is upstream, it's going to be difficult to motivate developers
> to
> keep the driver close to your downstream version. If I'm working on feature X
> which touches your driver, I'm
On Wed, Jun 14, 2017 at 11:34:10AM +0200, Michael Thayer wrote:
> Hello Sean,
>
> 13.06.2017 20:03, Sean Paul wrote:
> [Discussion of vboxvideo driver clean-up.]
>
> > First, thank you for your submission.
>
> Thank you for your feedback.
>
> [Discussion of the OS-independent code in the driver
Fixed alignment so that it matched open paranthesis.
Signed-off-by: srishti sharma
---
drivers/staging/vc04_services/bcm2835-audio/bcm2835-ctl.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/vc04_services/bcm2835-audio/bcm2835-ctl.c
b/drivers/staging/vc04_s
On Wed, Jun 14, 2017 at 7:19 PM, Greg KH wrote:
> On Wed, Jun 14, 2017 at 07:11:01PM +0530, srishti sharma wrote:
>> On Wed, Jun 14, 2017 at 10:39 AM, Greg KH wrote:
>> > On Wed, Jun 14, 2017 at 03:15:11AM +0530, srishti sharma wrote:
>> >> On Tue, Jun 13, 2017 at 8:17 PM, Dan Carpenter
>> >> w
On Wed, Jun 14, 2017 at 07:11:01PM +0530, srishti sharma wrote:
> On Wed, Jun 14, 2017 at 10:39 AM, Greg KH wrote:
> > On Wed, Jun 14, 2017 at 03:15:11AM +0530, srishti sharma wrote:
> >> On Tue, Jun 13, 2017 at 8:17 PM, Dan Carpenter
> >> wrote:
> >> > On Tue, Jun 13, 2017 at 08:07:14PM +0530,
On Wed, Jun 14, 2017 at 01:38:04PM +, Laurentiu Tudor wrote:
> Hi Greg,
>
> On 06/13/2017 01:22 PM, Greg KH wrote:
> > On Thu, Jun 08, 2017 at 05:28:55PM +0300, laurentiu.tu...@nxp.com wrote:
> >> From: Stuart Yoder
> >>
> >> Move the source files out of staging into their final locations:
>
On Wed, Jun 14, 2017 at 10:39 AM, Greg KH wrote:
> On Wed, Jun 14, 2017 at 03:15:11AM +0530, srishti sharma wrote:
>> On Tue, Jun 13, 2017 at 8:17 PM, Dan Carpenter
>> wrote:
>> > On Tue, Jun 13, 2017 at 08:07:14PM +0530, srishti sharma wrote:
>> >> On Tue, Jun 13, 2017 at 6:30 PM, Greg KH
>>
Hello Hans,
14.06.2017 15:30, Hans de Goede wrote:
[Discussion of vboxvideo and vboxguest driver clean-up.]
> As I already mentioned in previous mails on this, for the vboxguest driver
> my plan is to simply do a fork and remove anything related to the
> portability. It currently weighs in at 1000
Hi Greg,
On 06/13/2017 01:22 PM, Greg KH wrote:
> On Thu, Jun 08, 2017 at 05:28:55PM +0300, laurentiu.tu...@nxp.com wrote:
>> From: Stuart Yoder
>>
>> Move the source files out of staging into their final locations:
>>-include files in drivers/staging/fsl-mc/include go to include/linux/fsl
>>
On Wed, 2017-06-14 at 15:19 +0300, Dan Carpenter wrote:
> On Wed, Jun 14, 2017 at 09:49:10PM +1000, Ian W MORRISON wrote:
> > On 14 June 2017 at 00:36, Dan Carpenter wrote:
> > > Kernel style is to have spaces around the operators. This is staging
> > > code so we do all the style fixes. We don'
Hi all,
On 14-06-17 11:34, Michael Thayer wrote:
Hello Sean,
13.06.2017 20:03, Sean Paul wrote:
[Discussion of vboxvideo driver clean-up.]
First, thank you for your submission.
Thank you for your feedback.
[Discussion of the OS-independent code in the driver submission.]
I took a quick s
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Tuesday, June 13, 2017 1:04 PM
> To: Ruxandra Ioana Radulescu
> Cc: de...@driverdev.osuosl.org; stuyo...@gmail.com; a...@arndb.de;
> linux-ker...@vger.kernel.org; ag...@suse.de; Bharat Bhushan
> ; Bogdan Purca
On Wed, Jun 14, 2017 at 03:36:30PM +0300, Andy Shevchenko wrote:
> On Wed, Jun 14, 2017 at 3:18 PM, Samuel Thibault
> wrote:
> > Greg KH, on mer. 14 juin 2017 13:48:02 +0200, wrote:
> >> On Wed, Jun 14, 2017 at 01:26:09PM +0200, Samuel Thibault wrote:
> >> > Greg KH, on mer. 14 juin 2017 12:15:41
Andy Shevchenko, on mer. 14 juin 2017 15:36:30 +0300, wrote:
> On Wed, Jun 14, 2017 at 3:18 PM, Samuel Thibault
> wrote:
> > Greg KH, on mer. 14 juin 2017 13:48:02 +0200, wrote:
> >> On Wed, Jun 14, 2017 at 01:26:09PM +0200, Samuel Thibault wrote:
> >> > Greg KH, on mer. 14 juin 2017 12:15:41 +020
On Wed, Jun 14, 2017 at 3:18 PM, Samuel Thibault
wrote:
> Greg KH, on mer. 14 juin 2017 13:48:02 +0200, wrote:
>> On Wed, Jun 14, 2017 at 01:26:09PM +0200, Samuel Thibault wrote:
>> > Greg KH, on mer. 14 juin 2017 12:15:41 +0200, wrote:
>> And trying to have the kernel do the mapping based on str
On 06/13/2017 01:12 PM, Greg KH wrote:
> On Thu, Jun 08, 2017 at 05:28:47PM +0300, laurentiu.tu...@nxp.com wrote:
>> From: Laurentiu Tudor
>>
>> Several macros were triggering this checkpatch.pl warning:
>>"Macro argument reuse '$arg' - possible side-effects?"
>> Fix the warning by avoiding
Greg KH, on mer. 14 juin 2017 13:48:02 +0200, wrote:
> On Wed, Jun 14, 2017 at 01:26:09PM +0200, Samuel Thibault wrote:
> > Greg KH, on mer. 14 juin 2017 12:15:41 +0200, wrote:
> > > Ah, no, nevermind, you just need the major/minor. So why not just take
> > > that as the input here, and not a stri
On Wed, Jun 14, 2017 at 09:49:10PM +1000, Ian W MORRISON wrote:
> On 14 June 2017 at 00:36, Dan Carpenter wrote:
> > Kernel style is to have spaces around the operators. This is staging
> > code so we do all the style fixes. We don't always update older drivers
> > but sometimes we do. No one i
On 14 June 2017 at 00:36, Dan Carpenter wrote:
> Kernel style is to have spaces around the operators. This is staging
> code so we do all the style fixes. We don't always update older drivers
> but sometimes we do. No one is planning to change those drivers though
> so I guess the answer is no
On Wed, Jun 14, 2017 at 01:26:09PM +0200, Samuel Thibault wrote:
> Greg KH, on mer. 14 juin 2017 12:15:41 +0200, wrote:
> > Ah, no, nevermind, you just need the major/minor. So why not just take
> > that as the input here, and not a string?
>
> Because real users don't know about major/minor numb
Greg KH, on mer. 14 juin 2017 12:15:41 +0200, wrote:
> Ah, no, nevermind, you just need the major/minor. So why not just take
> that as the input here, and not a string?
Because real users don't know about major/minor numbers.
Samuel
___
devel mailing
On Wed, 2017-06-14 at 12:48 +0200, Greg Kroah-Hartman wrote:
> On Wed, Jun 14, 2017 at 03:38:21AM -0700, Joe Perches wrote:
> > On Wed, 2017-06-14 at 12:18 +0200, Greg Kroah-Hartman wrote:
> > > On Tue, Jun 13, 2017 at 02:12:56PM -0700, Joe Perches wrote:
> > > > These are similar macros so use the
On Wed, Jun 14, 2017 at 03:38:21AM -0700, Joe Perches wrote:
> On Wed, 2017-06-14 at 12:18 +0200, Greg Kroah-Hartman wrote:
> > On Tue, Jun 13, 2017 at 02:12:56PM -0700, Joe Perches wrote:
> > > These are similar macros so use the normal kernel one.
> > >
> > > As well, there are odd games being p
On Wed, 2017-06-14 at 12:18 +0200, Greg Kroah-Hartman wrote:
> On Tue, Jun 13, 2017 at 02:12:56PM -0700, Joe Perches wrote:
> > These are similar macros so use the normal kernel one.
> >
> > As well, there are odd games being played with casting a plist to
> > a union recv_frame by using LIST_CONT
On Wed, Jun 14, 2017 at 04:30:37PM +1000, Tobin C. Harding wrote:
> Currently we are in the process of replacing the WEXT interface with
> the cfg80211 API. WEXT code is currently within a sub directory and
> not included in the module build.
>
> The driver is designed with various layers of abstr
On Wed, Jun 14, 2017 at 04:30:35PM +1000, Tobin C. Harding wrote:
> Current driver implements the WEXT interface. WEXT is in maintenance
> mode, we need to re-write the driver using the cfg80211 API. The current
> driver is handy as a reference for the new implementation, we can keep
> it in tree f
On Tue, Jun 13, 2017 at 02:12:56PM -0700, Joe Perches wrote:
> These are similar macros so use the normal kernel one.
>
> As well, there are odd games being played with casting a plist to
> a union recv_frame by using LIST_CONTAINOR. Just use a direct cast
> to union recv_frame instead.
>
> Sign
On Wed, Jun 14, 2017 at 12:13:26PM +0200, Greg Kroah-Hartman wrote:
> On Tue, Jun 13, 2017 at 11:37:03PM +0100, okash.khaw...@gmail.com wrote:
> > The function converts strings like ttyS0 and ttyUSB0 to dev_t like
> > (4, 64) and (188, 0). Subsequent patch in this set will call it to
> > convert us
On Tue, Jun 13, 2017 at 11:37:03PM +0100, okash.khaw...@gmail.com wrote:
> The function converts strings like ttyS0 and ttyUSB0 to dev_t like
> (4, 64) and (188, 0). Subsequent patch in this set will call it to
> convert user-supplied device into device number. The function does
> some basic sanity
Hello Sean,
13.06.2017 20:03, Sean Paul wrote:
[Discussion of vboxvideo driver clean-up.]
> First, thank you for your submission.
Thank you for your feedback.
[Discussion of the OS-independent code in the driver submission.]
> I took a quick skim through your driver, and there doesn't seem to
The caller only cares about zero vs non-zero so this code actually works
fine but we should be returning a negative error code instead of a valid
pointer casted to int.
Fixes: 554c0a3abf21 ("staging: Add rtl8723bs sdio wifi driver")
Signed-off-by: Dan Carpenter
diff --git a/drivers/staging/rtl87
13.06.2017 17:41, Greg Kroah-Hartman wrote:
[...]
> And why is the closed vbox-devel list still on the cc: here, the bounces
> from it are getting annoying.
[...]
Not sure why you are still getting them, but we added you to the
white-list as well. I would prefer the list to stay on as the subject
On Tue, Jun 13, 2017 at 11:37:03PM +0100, okash.khaw...@gmail.com wrote:
> The function converts strings like ttyS0 and ttyUSB0 to dev_t like
> (4, 64) and (188, 0). Subsequent patch in this set will call it to
> convert user-supplied device into device number. The function does
> some basic sanity
59 matches
Mail list logo