On Mon, 29 May 2017 02:06:41 +0800
Chen Guanqiao wrote:
> Fix "symbol 'xxx' was not declared. Should it be static?" sparse warnings.
>
> Signed-off-by: Chen Guanqiao
> ---
Reviewed-by: Alan Cox
___
devel mailing list
de...@linuxdriverproject.or
Fixes code alignment issue in ion/ion.h
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion.h | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/android/ion/ion.h
b/drivers/staging/android/ion/ion.h
index ace8416..4f04f65 100644
--- a/dr
Use BIT macro instead of left shifting in android/ion/ion.h
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/android/ion/ion.h
b/drivers/staging/android/ion/ion.h
index 4f04f65..6cc720b
Fixes code alignment issue in ion/ion_carveout_heap.c
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion_carveout_heap.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion_carveout_heap.c
b/drivers/staging/android/ion/ion_carveo
Removes unnecessary blank lines in android/ion/ion.c
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/android/ion/ion.c
b/drivers/staging/android/ion/ion.c
index e10c696..11acbe2 100644
--- a/drivers/stag
Fixes code alignment style issues in android/ion/ion.c
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/android/ion/ion.c
b/drivers/staging/android/ion/ion.c
index 73f90e6..e10c696 10
Removes unnecessary blank lines in android/ion/ion_system_heap.c
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion_system_heap.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/android/ion/ion_system_heap.c
b/drivers/staging/android/ion/ion_system_heap.c
Fixes NULL comparison coding style issues in
android/ion/ion.c file
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/android/ion/ion.c
b/drivers/staging/android/ion/ion.c
index 03d3a4
This is patch fixing code alignment style issue in
android/ion/ion-ioctl.c file
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion-ioctl.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/android/ion/ion-ioctl.c
b/drivers/staging/android/
Converts sizeof(type) to sizeof(variable) in android/ion/ion_system_heap.c
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion_system_heap.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/android/ion/ion_system_heap.c
b/drivers/staging
Converts sizeof(type) to sizeof(variable) in android/ion/ion_cma_heap.c
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion_cma_heap.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion_cma_heap.c
b/drivers/staging/android/ion/io
Removes unnecessary blank lines in android/ion/ion_cma_heap.c
Signed-off-by: Mateusz Nowotyński
---
drivers/staging/android/ion/ion_cma_heap.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion_cma_heap.c
b/drivers/staging/android/ion/ion_cma_heap.c
index a0949bc.
Fix "symbol 'xxx' was not declared. Should it be static?" sparse warnings.
Signed-off-by: Chen Guanqiao
---
drivers/staging/media/atomisp/i2c/lm3554.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/media/atomisp/i2c/lm3554.c
b/drivers/staging/media/a
On Sun, 28 May 2017 11:47:04 +0200
Lars-Peter Clausen wrote:
> On 05/27/2017 12:53 AM, Alexey Khoroshilov wrote:
> > ad7152_write_raw_samp_freq() is called by ad7152_write_raw() with
> > chip->state_lock held. So, there is unavoidable deadlock when
> > ad7152_write_raw_samp_freq() locks the mutex
MSB64 macro is no longer used or needed. Drop it.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_hw_queue_defs.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/ccree/cc_hw_queue_defs.h
b/drivers/staging/ccree/cc_hw_queue_defs.h
index ec2113a..f12761a 100644
-
Hash enum were named using CamelCase, move over to snake_case.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_hw_queue_defs.h | 4 ++--
drivers/staging/ccree/hash_defs.h| 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ccree/cc_hw_queu
A bunch of whitespace fixes pointed to by checkpatch.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_regs.h| 4 +-
drivers/staging/ccree/dx_crys_kernel.h | 308 -
drivers/staging/ccree/dx_host.h| 256 +--
3 f
request_mgr was using custom bit field macros. move over to
standard kernel bitfield ops.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_regs.h | 5 +
drivers/staging/ccree/ssi_request_mgr.c | 19 +--
2 files changed, 14 insertions(+), 10 deletions(-)
With all users removed or re-factored to use the standard
kernel bit fields ops we can now drop the custom
bit field macros.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_bitops.h| 40
drivers/staging/ccree/cc_hw_queue_defs.h | 2 +-
drivers/staging/c
Remove some unused macro definitions from hash definitions.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/hash_defs.h | 31 +++
1 file changed, 3 insertions(+), 28 deletions(-)
diff --git a/drivers/staging/ccree/hash_defs.h
b/drivers/staging/ccree/hash_d
struct SepHashPrivateContext is not used anywhere in the code.
Remove it.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/hash_defs.h | 17 -
1 file changed, 17 deletions(-)
diff --git a/drivers/staging/ccree/hash_defs.h
b/drivers/staging/ccree/hash_defs.h
index 61389
The ccree driver had support for rough performance debugging
via cycle counting which has bit rotted and can easily be
replcaed with perf. Remove it from the driver.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_hw_queue_defs.h | 13
drivers/staging/ccree/ssi_aead.c
The Linked List Item descriptors were being accessed via
a baroque set of defines and macro. Re-factor for structs
and inline function for readability and sanity.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_lli_defs.h| 65 +++---
drivers/staging/c
Remove no longer needed code used to simulate 48 bit dma addresses
on 32 bit platforms for development purposes.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 19
drivers/staging/ccree/ssi_buffer_mgr.c | 83 -
drivers/stag
This is another batch of clean ups for the ccree driver.
Mostly comprised of:
- Coding Style fixes
- Move to kernel infrastructure from custom constructs
- Removal of dead code
Gilad Ben-Yossef (12):
staging: ccree: correct coding style violations
staging: ccree: move to kernel bitfields/bitop
cc_crypto_ctx.h had multiple coding style violations reported by
checkpatch. Fix them all.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_crypto_ctx.h | 66 +--
1 file changed, 32 insertions(+), 34 deletions(-)
diff --git a/drivers/staging/ccree/cc_
On Sun, May 28, 2017 at 3:31 PM, Hans de Goede wrote:
> Do not call dev_warn with a NULL device, this silence the following 2
> warnings:
>
> [ 14.392194] (NULL device *): Failed to find gmin variable gmin_V2P8GPIO
> [ 14.392257] (NULL device *): Failed to find gmin variable gmin_V1P8GPIO
>
>
As the existing comment in the driver indicates the sensor has only 1 pin,
but some boards may have 2 gpios defined and we toggle both as we we don't
know which one is the right one. However if the ACPI resources table
defines only 1 gpio (as expected) the gpio1_ctrl call will always fail,
causing
Signed-off-by: Hans de Goede
---
drivers/staging/media/atomisp/i2c/gc0310.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/media/atomisp/i2c/gc0310.c
b/drivers/staging/media/atomisp/i2c/gc0310.c
index 1ec616a15086..350fd7fd5b86 100644
--- a/drivers/staging/media/atomisp/i2c/
Signed-off-by: Hans de Goede
---
drivers/staging/media/atomisp/i2c/ov2680.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/media/atomisp/i2c/ov2680.c
b/drivers/staging/media/atomisp/i2c/ov2680.c
index 566091035c64..449aa2aa276f 100644
--- a/drivers/staging/media/atomisp/i2c/
There is no reason for all this printk spamming and certainly
not at an error log level.
Signed-off-by: Hans de Goede
---
drivers/staging/media/atomisp/i2c/ov2680.c | 7 ++-
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/media/atomisp/i2c/ov2680.c
b/drivers/st
Do not call dev_warn with a NULL device, this silence the following 2
warnings:
[ 14.392194] (NULL device *): Failed to find gmin variable gmin_V2P8GPIO
[ 14.392257] (NULL device *): Failed to find gmin variable gmin_V1P8GPIO
We could switch to using pr_warn for dev == NULL instead, but as co
menu controls are not allowed to have a step size, set step to 0 to
fix an oops from the WARN_ON in v4l2_ctrl_new_custom() triggering
because of this.
Signed-off-by: Hans de Goede
---
drivers/staging/media/atomisp/i2c/mt9m114.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/
efivar_entry_get has certain alignment requirements and the atomisp
platform code was not honoring these, causing an oops by triggering the
WARN_ON in arch/x86/platform/efi/efi_64.c: virt_to_phys_or_null_size().
This commit fixes this by using the members of the efivar struct embedded
in the efiva
Hi All,
I've been trying to get the atomisp driver from staging to work
on a couple of devices I have.
I started with an Asus T100TA after fixing 2 oopses in the sensor
driver there I found out that the BIOS does not allow to put the
ISP in PCI mode and that there is no code to drive it in ACPI
On 05/27/2017 12:53 AM, Alexey Khoroshilov wrote:
> ad7152_write_raw_samp_freq() is called by ad7152_write_raw() with
> chip->state_lock held. So, there is unavoidable deadlock when
> ad7152_write_raw_samp_freq() locks the mutex itself.
>
> The patch removes unneeded locking.
>
> Found by Linux D
36 matches
Mail list logo