Fix sparse warning "warning: Variable length array is used." by using
kmalloc_array to allocate the required amount of memory instead and
kfree to deallocate memory after use.
Signed-off-by: Guru Das Srinagesh
---
drivers/staging/lustre/lustre/llite/xattr.c | 17 +
1 file changed
Introduces a local var to collect flags and convert
them to le32.
Fixes the following sparse warnings:
drivers/staging/lustre/lustre/lmv/lmv_obd.c:2305:23: warning: invalid
assignment: |=
drivers/staging/lustre/lustre/lmv/lmv_obd.c:2305:23:left side has type
restricted __le32
drivers/stagin
Fixed coding style issue
Signed-off-by: Jaya Durga
---
drivers/staging/rtl8712/ieee80211.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8712/ieee80211.c
b/drivers/staging/rtl8712/ieee80211.c
index d84da2b..512bf16 100644
--- a/drivers/staging/rtl8712/
Hi Jamie,
[auto build test ERROR on staging/staging-testing]
[also build test ERROR on next-20170504]
[cannot apply to v4.11]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Jamie-Huang/staging
Hi Laura,
On 2017/5/5 1:47, Laura Abbott wrote:
> On 05/04/2017 07:45 AM, Yisheng Xie wrote:
>> From: Yisheng Xie
>>
>> It should check ipdev->heaps[i] whether it is error or null instead of
>> ipdev->heaps, after ion_heap_create() for ipdev->heaps[i].
>>
>> Signed-off-by: Yisheng Xie
>> ---
>>
This patch renames the tsl2x7x_core.c file to tsl2x7x.c so that the
naming convention is consistent with other IIO light drivers outside
of staging.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/Makefile | 2 +-
drivers/staging/iio/light/{tsl2x7x_core.c => tsl2x7
There is a tsl2x7x.h header that is only used by tsl2x7x.c. This patch
moves the contents of the header file into the C code with the driver.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 76 ++-
drivers/staging/iio/light/tsl2x7x.h | 100 -
The two patches in this series begin my work to move this driver out
of staging. Before I start working on the meat of the changes that
are necessary for a staging graduation, I want to get these two
trivial patches out and merged first in case there are any concerns
with these changes.
Brian Masn
Fix checkpatch warning: removed unnecessary initialization of
static variable "skip_fwload" to 0 in source atomisp_v4l2.c
Signed-off-by: Fabrizio Perria
---
drivers/staging/media/atomisp/pci/atomisp2/atomisp_v4l2.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/stagi
FUSB_REG_STATUS0 & FUSB_REG_STATUS0_VBUSOK = 0x40 & 0x80 is always
zero. Fix the code to what it is intended to be: check the VBUSOK
bit of the value read from address FUSB_REG_STATUS0.
Reported-by: Dan Carpenter
Cc: Guenter Roeck
Signed-off-by: Yueyao Zhu
---
drivers/staging/typec/fusb302/fus
Do not include the paragraph about writing to the Free Software
Foundation's mailing address from the sample GPL notice. The FSF
has changed addresses in the past, and may do so again. Linux
already includes a copy of the GPL.
Signed-off-by: Enric Balletbo i Serra
---
drivers/staging/iio/light/t
Fix the output from checkpatch.pl like:
Symbolic permissions 'S_IRUSR' are not preferred.
Consider using octal permissions '0400'.
Also fix the alignment DEVICE_ATTR variables as should match open
parenthesis.
Signed-off-by: Enric Balletbo i Serra
---
drivers/staging/iio/light/tsl2x7x_core.
Fixed a brace coding style issue, found via checkpatch.
Signed-off-by: Riccardo Marotti
---
drivers/staging/rtl8192u/ieee80211/ieee80211_module.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_module.c
b/drivers/staging/rtl8192
> -Original Message-
> From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
> Sent: Wednesday, April 12, 2017 3:43 AM
> To: de...@linuxdriverproject.org; x...@kernel.org
> Cc: linux-ker...@vger.kernel.org; KY Srinivasan ;
> Haiyang Zhang ; Stephen Hemminger
> ; Thomas Gleixner ; Ingo
> Mol
ERROR: Macros with multiple statements should be enclosed in a do - while loop
Detected by scripts/checkpatch.pl -f
Signed-off-by: Jamie Huang
---
drivers/staging/rtl8723bs/core/rtw_security.c | 34 +++
1 file changed, 24 insertions(+), 10 deletions(-)
diff --git a/drive
On Thu, May 04, 2017 at 08:33:45AM +0200, Javier Martinez Canillas wrote:
> If the driver is built as a module, autoload won't work because the module
> alias information is not filled. So user-space can't match the registered
> device with the corresponding module.
>
> Export the OF and I2C devic
> Phil Elwell hat am 4. Mai 2017 um 11:58 geschrieben:
>
>
> vchiq_arm supports transfers less than one page and at arbitrary
> alignment, using the dma-mapping API to perform its cache maintenance
> (even though the VPU drives the DMA hardware). Read (DMA_FROM_DEVICE)
> operations use cache in
On 05/04/2017 07:45 AM, Yisheng Xie wrote:
> From: Yisheng Xie
>
> It should check ipdev->heaps[i] whether it is error or null instead of
> ipdev->heaps, after ion_heap_create() for ipdev->heaps[i].
>
> Signed-off-by: Yisheng Xie
> ---
> drivers/staging/android/ion/hisilicon/hi6220_ion.c | 2 +
This patchset fixes two style issues in lprocfs_status.c related to
simple_strtoul and seq_printf (reported by checkpatch).
There's a slight change in lustre debugfs write semantics: Using kstrtox causes
EINVAL when the written number is followed by other (garbage) characters,
whereas previously t
Prefer kstrtouint_from_user to copy_from_user+simple_strtoul.
The helper function lprocfs_wr_uint() is only used to implement
"dump_granted_max" in debugfs.
Note the slight change in semantics: The previous implementation using
simple_strtoul allows garbage after the number, whereas kstrtox only
Replace all occurrences of seq_printf with no formatting directives
in lprocfs_status.c with seq_puts.
Reported by checkpatch.pl: "WARNING: Prefer seq_puts to seq_printf".
Signed-off-by: Mathias Rav
---
.../staging/lustre/lustre/obdclass/lprocfs_status.c | 20 ++--
1 file chang
On Thu, 2017-05-04 at 17:33 +0200, Simo Koskinen wrote:
> Fixed coding style warnings reported by checkpatch.pl.
Please strive to do more than shut up checkpatch.
Think a little about what this code is doing.
Spend the time to analyze the code and improve it.
For instance, this function is curre
On Thu, May 04, 2017 at 08:33:42AM -0500, Dan Naughton wrote:
> First posting - hello all.
>
> I wanted to submit a driver for the linuxdriverproject. The driver is
> contec_fit.c. It's a comedi data acquisition driver. I don't know if this
> mailing list can take attachments, so maybe the foll
Fixed coding style warnings reported by checkpatch.pl.
Signed-off-by: Simo Koskinen
---
drivers/staging/vt6656/rxtx.c | 15 ++-
1 file changed, 10 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/vt6656/rxtx.c b/drivers/staging/vt6656/rxtx.c
index 6341349..2609c1e 100644
-
I'm sorry I screwed up,
this patch got sent twice in the series as I slightly changed the
subject and forgot to remove the old version :-(
Please disregard this one from series, "hv_utils: fix TimeSync work on
pre-TimeSync-v4 hosts" is the right one. Thanks.
--
Vitaly
It was found that ICTIMESYNCFLAG_SYNC packets are handled incorrectly
on WS2012R2, e.g. after the guest is paused and resumed its time is set
to something different from host's time. The problem is that we call
adj_guesttime() with reftime=0 for these old hosts and we don't account
for that in 'if
It was found that ICTIMESYNCFLAG_SYNC packets are handled incorrectly
on WS2012R2, e.g. after the guest is paused and resumed its time is set
to something different from host's time. The problem is that we call
adj_guesttime() with reftime=0 for these old hosts and we don't account
for that in 'if
This series is a succesor of the previously sent "hv_utils: drop
.getcrosststamp() support from PTP driver" patch. A new unrelated issue
with TimeSync on pre-TimeSync-v4 hosts was discovered but as these patches
are tangled I'm sending them out in a single series.
Vitaly Kuznetsov (2):
hv_utils:
Turns out that our implementation of .getcrosststamp() never actually
worked. Hyper-V is sending time samples every 5 seconds and this is
too much for get_device_system_crosststamp() as it's interpolation
algorithm (which nobody is currently using in kernel, btw) accounts
for a 'slow' device but we
On Thu, 4 May 2017 11:57:48 +0300
Dan Carpenter wrote:
> Read the first couple paragraphs of
> Documentation/process/email-clients.rst for how to send patches.
>
> > @@ -2236,10 +2248,12 @@ static void rijndaelEncrypt(u32 rk[/*44*/],
> > u8 pt[16], u8 ct[16]) s3 = GETU32(pt + 12) ^ rk[3];
> >
From: Yisheng Xie
It should check ipdev->heaps[i] whether it is error or null instead of
ipdev->heaps, after ion_heap_create() for ipdev->heaps[i].
Signed-off-by: Yisheng Xie
---
drivers/staging/android/ion/hisilicon/hi6220_ion.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --gi
On Thu, May 04, 2017 at 03:41:12PM +0300, Dan Carpenter wrote:
> It was delayed then eventually deleted by gmail. Maybe it was too large
> and suspicious looking... The problem was on my end anyway.
That's good to know, thanks for the update!
> regards,
> dan carpenter
Cheers,
Timothée Isnard
_
It was delayed then eventually deleted by gmail. Maybe it was too large
and suspicious looking... The problem was on my end anyway.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mail
On Mon, 2017-05-01 at 18:52 -0600, Justin Vreeland wrote:
> Enclosing macros with complex values ensures expression is evaluated
> as
> expected.
>
> Signed-off-by: Justin Vreeland
> ---
> v2:
> - Added spaces around plus signs
> - Fixed line over 80 columns
> - Added commit message
>
> d
On Mon, 2017-05-01 at 18:52 -0600, Justin Vreeland wrote:
> Ensure checkpatch compliance
>
> > Signed-off-by: Justin Vreeland
> ---
> v2:
> - Added commit message
> - Fixed overly long lines
>
> drivers/staging/rtl8723bs/hal/rtl8723b_phycfg.c | 18 --
> drivers/staging/rtl87
On Mon, 2017-05-01 at 18:52 -0600, Justin Vreeland wrote:
> v2:
> Added commit messages
> Fixed overly long lines
> Added Bastien Nocera's Reviewed-by tag
> - Also fixed commit messages marked reviewed, hope that's OK. The
> patch
> contents are identical.
>
> Justin Vreeland (7):
vchiq_arm supports transfers less than one page and at arbitrary
alignment, using the dma-mapping API to perform its cache maintenance
(even though the VPU drives the DMA hardware). Read (DMA_FROM_DEVICE)
operations use cache invalidation for speed, falling back to
clean+invalidate on partial cache
Read the first couple paragraphs of Documentation/process/email-clients.rst
for how to send patches.
> @@ -2236,10 +2248,12 @@ static void rijndaelEncrypt(u32 rk[/*44*/], u8
> pt[16], u8 ct[16])
> s3 = GETU32(pt + 12) ^ rk[3];
>
> #define ROUND(i, d, s) \
> -d##0 = TE0(s##0) ^ TE1(s##1)
fix error: Macros with multiple statements should be enclosed in a do -
while loop Detected by scripts/checkpatch.pl -f
>From b1bcd6f9d31f5ea899799f0f9b4cf04a0558d2d8 Mon Sep 17 00:00:00 2001
From: Jamie Huang
Date: Thu, 4 May 2017 14:49:26 +0800
Subject: [PATCH] staging: fix macros with multiple
That's very strange. It's not in my spam folder either. Sometimes
driver-devel emails get delayed so maybe it will still arrive.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman
On Thu, May 04, 2017 at 11:08:07AM +0300, Gilad Ben-Yossef wrote:
> On Thu, May 4, 2017 at 10:57 AM, Dan Carpenter
> wrote:
> > I don't think the v2 patch made it to the list either.
> >
>
> I see. Well, I'm working on a bigger ccree cruft reducing patch set
> anyway. I'll just carry it as part
On Thu, May 4, 2017 at 10:57 AM, Dan Carpenter wrote:
> I don't think the v2 patch made it to the list either.
>
I see. Well, I'm working on a bigger ccree cruft reducing patch set
anyway. I'll just carry it as part of the set with my SOB and send it
together than.
Timothée, you need to figure
On Wed, May 03, 2017 at 08:19:22PM +0300, Andy Shevchenko wrote:
> On Wed, 2017-05-03 at 20:07 +0300, Andy Shevchenko wrote:
> > Instead of open coded variant use generic helper to convert UUID
> > strings
> > to binary format.
>
> > @@ -677,12 +644,14 @@ static ssize_t remove_id_store(struct
> >
I don't think the v2 patch made it to the list either.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Wed, May 3, 2017 at 11:03 PM, Timothée Isnard
wrote:
> Fix the 994 trailing whitespace checkpatch errors out of 1571
> checkpatch issues in the ccree driver
>
> Signed-off-by: Timothée Isnard
> ---
> v2: Adds some changelog text
>
Patch reviewed, applies and compiles, so
Acked-by: Gilad Ben-
45 matches
Mail list logo