This patch fixes the following sparse warning in fbtft/fbtft-io.c
CHECK drivers/staging/fbtft/fbtft-io.c
drivers/staging/fbtft/fbtft-io.c:74:29: warning: incorrect type in assignment
(different base types)
drivers/staging/fbtft/fbtft-io.c:74:29:expected unsigned long long
[unsigned] [lon
On Sat, Apr 29, 2017 at 01:07:34AM +0200, Shiva Kerdel wrote:
> This patch fixes the following checkpatch.pl warning
> - EXPORT_SYMBOL(foo); should immediately follow its function/variable
>
> Signed-off-by: Shiva Kerdel
> ---
> drivers/staging/fbtft/fbtft-core.c | 25 +++--
>
On Fri, Apr 28, 2017 at 06:53:32PM -0700, Joe Perches wrote:
> On Sat, 2017-04-29 at 09:45 +0800, Geliang Tang wrote:
> > Use memdup_user() helper instead of open-coding to simplify the code.
>
> While I doubt this is a problem, this loses
> the multiplication overflow check for
> sizeof(*insns) *
On Fri, Apr 28, 2017 at 07:12:46PM -0400, Quentin Swain wrote:
> ---
> drivers/staging/iio/light/tsl2x7x_core.c | 20 ++--
> 1 file changed, 10 insertions(+), 10 deletions(-)
>
> diff --git a/drivers/staging/iio/light/tsl2x7x_core.c
> b/drivers/staging/iio/light/tsl2x7x_core.c
>
On Sat, 2017-04-29 at 09:45 +0800, Geliang Tang wrote:
> Use memdup_user() helper instead of open-coding to simplify the code.
While I doubt this is a problem, this loses
the multiplication overflow check for
sizeof(*insns) * insnlist.n_isns
> diff --git a/drivers/staging/comedi/comedi_fops.c
>
Use memdup_user() helper instead of open-coding to simplify the code.
Signed-off-by: Geliang Tang
---
drivers/staging/comedi/comedi_fops.c | 22 +++---
1 file changed, 7 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/comedi/comedi_fops.c
b/drivers/staging/comedi/co
Mistyped the address for the staging list in the first email. Sorry about that.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
---
drivers/staging/iio/light/tsl2x7x_core.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/iio/light/tsl2x7x_core.c
b/drivers/staging/iio/light/tsl2x7x_core.c
index af3910b..c63fe6a 100644
--- a/drivers/staging/iio/light/tsl2x7x_core.c
This patch fixes the following checkpatch.pl warning
- EXPORT_SYMBOL(foo); should immediately follow its function/variable
Signed-off-by: Shiva Kerdel
---
drivers/staging/fbtft/fbtft-core.c | 25 +++--
1 file changed, 15 insertions(+), 10 deletions(-)
diff --git a/drivers/st
On Fri, 2017-04-28 at 17:26 +0300, Dan Carpenter wrote:
> On Fri, Apr 28, 2017 at 04:19:28PM +0200, Ilia Sergachev wrote:
> > Checkpatch emits WARNING: Avoid line continuations in quoted strings.
> >
> > Remove line continuations - split strings using quotes.
> >
> > Signed-off-by: Ilia Sergachev
The code under the error label may not be meaningful if error is reached
from line 495.
julia
-- Forwarded message --
Date: Sat, 29 Apr 2017 01:52:34 +0800
From: kbuild test robot
To: kbu...@01.org
Cc: Julia Lawall
Subject: [staging:staging-testing 393/1005]
drivers/staging
On 28/04/17 11:51 AM, Herbert Xu wrote:
> On Fri, Apr 28, 2017 at 10:53:45AM -0600, Logan Gunthorpe wrote:
>>
>>
>> On 28/04/17 12:30 AM, Herbert Xu wrote:
>>> You are right. Indeed the existing code looks buggy as they
>>> don't take sg->offset into account when doing the kmap. Could
>>> you s
On Fri, Apr 28, 2017 at 10:53:45AM -0600, Logan Gunthorpe wrote:
>
>
> On 28/04/17 12:30 AM, Herbert Xu wrote:
> > You are right. Indeed the existing code looks buggy as they
> > don't take sg->offset into account when doing the kmap. Could
> > you send me some patches that fix these problems f
On 28/04/17 12:30 AM, Herbert Xu wrote:
> You are right. Indeed the existing code looks buggy as they
> don't take sg->offset into account when doing the kmap. Could
> you send me some patches that fix these problems first so that
> they can be easily backported?
Ok, I think the only buggy one
On Fri, Apr 28, 2017 at 05:55:58PM +0200, Sebastian Reichel wrote:
> isl29030 is basically the same chip. The only difference
> is the chip's first pin. For isl29028 its named ADDR0 and
> can be used to change the chip's i2c address. For isl29030
> on the other hand that pin is named Ials and is an
> So are you going to resend this as a non-RFC patch so that I can apply
> it? :)
Yep, apologies for the delay.
Was hoping to get my test setup up and going, but some Errata with
that version of the dev board have complicated access to the SDIO port.
I'll prepare a proper patch and get it sent ou
isl29030 is basically the same chip. The only difference
is the chip's first pin. For isl29028 its named ADDR0 and
can be used to change the chip's i2c address. For isl29030
on the other hand that pin is named Ials and is an analog
current output proportional to ALS/IR. This change is
irrelevant fo
On Fri, Apr 28, 2017 at 06:14:44AM -0700, Guenter Roeck wrote:
> On 04/28/2017 12:28 AM, Greg Kroah-Hartman wrote:
> > On Thu, Apr 27, 2017 at 02:09:56PM -0700, Guenter Roeck wrote:
> > > --- /dev/null
> > > +++ b/drivers/staging/typec/pd.h
> > > @@ -0,0 +1,281 @@
> > > +/*
> > > + * Copyright 2015
Checkpatch emits WARNING: Avoid line continuations in quoted strings.
Remove line continuations - split strings using quotes.
Signed-off-by: Ilia Sergachev
---
Changes for v4:
- improve indentation for better readability
drivers/staging/ks7010/ks_hostif.c | 30 --
While dpaa2_fd.simple structure fields are marked __leXX,
corresponding cpu_to_leXX / leXX_to_cpu conversions are missing.
While here, fix dpaa2_fd_{get,set}_bpid such that BMT, IVP bits
sharing the 16-bit field with BPID are not affected.
Fixes: d3269bdc7ebc ("bus: fsl-mc: dpio: add frame descri
On Fri, Apr 28, 2017 at 04:41:33PM +0300, Dan Carpenter wrote:
Adding Tobin to CC, he is way more into the driver than I am these
days...
> Hello Wolfram Sang,
>
> The patch 13a9930d15b4: "staging: ks7010: add driver from Nanonote
> extra-repository" from May 31, 2016, leads to the following sta
On Fri, Apr 28, 2017 at 04:19:28PM +0200, Ilia Sergachev wrote:
> Checkpatch emits WARNING: Avoid line continuations in quoted strings.
>
> Remove line continuations - split strings using quotes.
>
> Signed-off-by: Ilia Sergachev
> ---
> drivers/staging/ks7010/ks_hostif.c | 20 ++---
Checkpatch emits WARNING: Avoid line continuations in quoted strings.
Remove line continuations - split strings using quotes.
Signed-off-by: Ilia Sergachev
---
drivers/staging/ks7010/ks_hostif.c | 20 ++--
1 file changed, 14 insertions(+), 6 deletions(-)
diff --git a/drivers/st
As far as I can see, the only code that can be executed in line 621 - 635
is ret = rtw_resume_process(padapter);. Perhaps it can be simplified.
julia
-- Forwarded message --
Date: Fri, 28 Apr 2017 22:13:26 +0800
From: kbuild test robot
To: kbu...@01.org
Cc: Julia Lawall
Subject
These sanity checks don't work because they use && instead of ||. It's
impossible to be both negative and greater than 5.
Fixes: a49d25364dfb ("staging/atomisp: Add support for the Intel IPU v2")
Signed-off-by: Dan Carpenter
diff --git a/drivers/staging/media/atomisp/platform/clock/vlv2_plat_cl
Hello Wolfram Sang,
The patch 13a9930d15b4: "staging: ks7010: add driver from Nanonote
extra-repository" from May 31, 2016, leads to the following static
checker warning:
drivers/staging/ks7010/ks_wlan_net.c:1141 ks_wlan_get_range()
warn: dead code because of 'i > 2' and 'i < 13'
On 04/28/2017 12:28 AM, Greg Kroah-Hartman wrote:
On Thu, Apr 27, 2017 at 02:09:56PM -0700, Guenter Roeck wrote:
--- /dev/null
+++ b/drivers/staging/typec/pd.h
@@ -0,0 +1,281 @@
+/*
+ * Copyright 2015-2017 Google, Inc
+ *
+ * This program is free software; you can redistribute it and/or modify
+
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Friday, April 28, 2017 3:24 PM
> To: Ruxandra Ioana Radulescu
> Cc: de...@driverdev.osuosl.org; stuyo...@gmail.com; a...@arndb.de;
> Haiying Wang ; Roy Pledge
> ; Alexandru Marginean
> ; linux-ker...@vger.ke
On Fri, 28 Apr 2017 14:20:21 +0200
Greg Kroah-Hartman wrote:
>
> Nope, the whole thing still doesn't apply:
>
> checking file drivers/staging/ks7010/ks_wlan_net.c
> Hunk #1 FAILED at 230.
> Hunk #2 FAILED at 343.
> Hunk #3 FAILED at 1137.
> Hunk #4 FAILED at 1189.
> Hunk #5 FAILED at 1225.
> Hu
On Fri, Apr 28, 2017 at 04:50:26AM -0500, Ioana Radulescu wrote:
> From: Ioana Radulescu
>
> This patch adds the command building/parsing wrapper functions
> for the DPCON object. The binary interface version is v3.2.
The subject should have "staging: fsl-mc: bus: ..." to match the other
ones (a
On Fri, Apr 28, 2017 at 10:47:14AM +, Horia Geantă wrote:
> On 4/28/2017 1:32 PM, Greg KH wrote:
> > On Sat, Apr 22, 2017 at 09:44:49AM +0300, Horia Geantă wrote:
> >> When checking the response verb, the valid bit should be masked out,
> >> since its value flips depending on what Response Regi
On Fri, Apr 28, 2017 at 12:35:55PM +0200, Ilia Sergachev wrote:
> Checkpatch was showing:
> WARNING: Block comments use a trailing */ on a separate line.
>
> Move trailing */ to a separate line.
>
> Signed-off-by: Ilia Sergachev
> ---
> Changes for v4:
> - remove one trailing whitespace in the
On 4/28/2017 1:32 PM, Greg KH wrote:
> On Sat, Apr 22, 2017 at 09:44:49AM +0300, Horia Geantă wrote:
>> When checking the response verb, the valid bit should be masked out,
>> since its value flips depending on what Response Register
>> (RR0 /RR1) it's been read from.
>>
>> Fixes: 321eecb06bfb ("bu
Fix checkpatch warning: removed unnecessary initialization of
static variable "heap_id" to 0 in source file "ioc.c".
Signed-off-by: Fabrizio Perria
---
drivers/staging/android/ion/ion.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion.c
b/drive
On Tue, Apr 25, 2017 at 03:53:02PM +, Lynn Lei wrote:
> Combine two separate set GPIO(30 & 31) operations into one statement.
Why?
>
> Signed-off-by: Lynn Lei
> ---
> drivers/staging/sm750fb/ddk750_hwi2c.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/
Fix a checkpatch error: CODE_INDENT (code indent should use tabs where
possible).
Signed-off-by: Juan Antonio Pedreira Martos
---
drivers/staging/vt6656/rxtx.c | 32
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/vt6656/rxtx.c b/d
On Fri, Apr 28, 2017 at 12:29:55PM +0200, Greg Kroah-Hartman wrote:
> On Sun, Apr 23, 2017 at 05:51:17PM -0300, Marcos Paulo de Souza wrote:
> > Fix the following sparse warning:
> > rtl8192u/ieee80211/ieee80211_rx.c:1489:45: warning: incorrect type in
> > assignment (different base types)
> > rtl
Checkpatch was showing:
WARNING: Block comments use a trailing */ on a separate line.
Move trailing */ to a separate line.
Signed-off-by: Ilia Sergachev
---
Changes for v4:
- remove one trailing whitespace in the last hunk,
which was corrupting the patch
Changes for v3:
- improve the c
On Sat, Apr 22, 2017 at 09:44:49AM +0300, Horia Geantă wrote:
> When checking the response verb, the valid bit should be masked out,
> since its value flips depending on what Response Register
> (RR0 /RR1) it's been read from.
>
> Fixes: 321eecb06bfb ("bus: fsl-mc: dpio: add QBMan portal APIs for
On Sun, Apr 23, 2017 at 05:51:17PM -0300, Marcos Paulo de Souza wrote:
> Fix the following sparse warning:
> rtl8192u/ieee80211/ieee80211_rx.c:1489:45: warning: incorrect type in
> assignment (different base types)
> rtl8192u/ieee80211/ieee80211_rx.c:1489:45:expected restricted __le16
>
> rt
On Sat, Apr 22, 2017 at 11:55:23PM +0100, Tuomo Rinne wrote:
> This patch fixes following sparse warnings:
>
> drivers/staging/rtl8192u//r8192U_dm.c:2307:49: warning: cast from restricted
> __le16
> drivers/staging/rtl8192u//r8192U_dm.c:2308:44: warning: cast from restricted
> __le16
> drivers/s
On Fri, Apr 21, 2017 at 09:24:57AM +0530, surenderpolsani wrote:
> kernel coding style doesn't allow the return statement
> in void function.
>
> Signed-off-by: Surenderp
Your "From" line does not match this line.
And I need a "full" name here.
thanks,
greg k-h
___
Fixed the following sparse warning:
CHECK drivers/staging/lustre/lustre/llite//file.c
drivers/staging/lustre/lustre/llite//file.c:441:24: warning: incorrect
type in assignment (different base types)
drivers/staging/lustre/lustre/llite//file.c:441:24:expected
restricted fmode_t [use
On Sun, Apr 23, 2017 at 03:21:31PM +0100, Eric Curtin wrote:
> checkpatch spits out a warning about the 80 character line limit. Split
> the parameters of these functions onto different lines. Put the ; with
> the macro caller instead. Lined up parameters as there was another
> CHECK warning about
On Fri, Apr 21, 2017 at 05:54:47PM +0200, Cezary Gapinski wrote:
> Sparse reports the following in fb_watterott.c:
>
> warning: incorrect type in assignment (different base types)
> expected unsigned short [unsigned] [short] [usertype]
> got restricted __be16 [usertype]
>
> Use __be16 types for
Add a list of TODO items for the Ethernet driver
Signed-off-by: Ioana Radulescu
---
v3: Add contact info
v2: Add note
drivers/staging/fsl-dpaa2/ethernet/TODO | 14 ++
1 file changed, 14 insertions(+)
create mode 100644 drivers/staging/fsl-dpaa2/ethernet/TODO
diff --git a/drivers/s
On Sat, Apr 22, 2017 at 11:14:57AM +0100, Malcolm Priestley wrote:
> Since 4.9 mandated USB buffers be heap allocated this causes the driver
> to fail.
It's really been a requirement since the 2.2 days, it's just that not
many people ran USB drivers on the platforms that required it :)
thanks,
g
On Tue, Apr 25, 2017 at 10:46:25PM -0600, Jason Litzinger wrote:
> The patch with this RFC addresses the following sparse warnings:
So are you going to resend this as a non-RFC patch so that I can apply
it? :)
thanks,
greg k-h
___
devel mailing list
On Wed, Apr 26, 2017 at 04:16:58PM -0700, Chandra Annamaneni wrote:
>
> Change video.c to use %s, __func__ instead of function names.
> Warnings flagged by checkpatch.pl
>
> Signed-off-by: Chandra Annamaneni
This patch does not apply to my staging-next branch at all :(
_
On Thu, 2017-04-27 at 18:09 -0600, Justin Vreeland wrote:
> Justin Vreeland (7):
>
> staging: rtl8723bs: Fix pointer style
> staging: rtl8723bs: Fix spacing around '<'
> staging: rtl8723bs: Do not use assignment in if condition
You can add:
Reviewed-By: Bastien Nocera
To those last 3 patc
Add the command build/parse APIs for operating on DPNI objects through
the DPAA2 Management Complex.
Signed-off-by: Ioana Radulescu
---
v3: no changes
v2: update #include paths
drivers/staging/Kconfig |2 +
drivers/staging/Makefile |1 +
driver
Introduce the DPAA2 Ethernet driver, which manages Datapath
Network Interface (DPNI) objects discovered on the MC bus.
In addition to DPNIs, the Ethernet driver uses several other
MC objects to build a network interface abstraction: buffer
pools (DPBPs), I/O Portals (DPIOs) and concentrators (DPCO
Add trace events in significant places of the data path.
Useful for debuggging.
Signed-off-by: Ioana Radulescu
---
v3: no changes
v2: no changes
drivers/staging/fsl-dpaa2/ethernet/Makefile| 3 +
.../staging/fsl-dpaa2/ethernet/dpaa2-eth-trace.h | 185 +
drivers/st
From: Ioana Radulescu
This patch adds the command building/parsing wrapper functions
for the DPCON object. The binary interface version is v3.2.
A DPCON (DataPath Concentrator) is an aggregator object that
allows ingress frames from multiple hardware queues to be seen
as coming from a single sou
Add a README file describing the driver architecture, components
and I/O interface.
Signed-off-by: Ioana Radulescu
---
v3: no changes
v2: no changes
drivers/staging/fsl-dpaa2/ethernet/README | 186 ++
1 file changed, 186 insertions(+)
create mode 100644 drivers/stag
Add custom statistics to be reported via ethtool -S. These include
driver specific per-cpu statistics as well as queue and channel
counters.
Signed-off-by: Ioana Radulescu
---
v3: no changes
v2: no changes
drivers/staging/fsl-dpaa2/ethernet/dpaa2-eth.c | 42 ++-
drivers/stag
This patchset introduces the Ethernet driver for Freescale/NXP SoCs
with DPAA2 (DataPath Acceleration Architecture v2). The driver manages
network objects discovered on the fsl-mc bus. A description of the
driver can be found in the associated README file.
The patchset consists of:
* A set of libr
Add support for several ethtool operations: show hardware statistics,
get/set link settings, get hash configuration.
Signed-off-by: Ioana Radulescu
Signed-off-by: Bogdan Hamciuc
---
v3: no changes
v2: no changes
drivers/staging/fsl-dpaa2/ethernet/Makefile| 2 +-
drivers/staging/fsl-d
Signed-off-by: Ioana Radulescu
---
v3: no changes
v2: Remove "Freescale" from the driver name
MAINTAINERS | 6 ++
1 file changed, 6 insertions(+)
diff --git a/MAINTAINERS b/MAINTAINERS
index b38b42f96e6a..4368f67bb261 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -4109,6 +4109,12 @@ L:
On Wed, Apr 26, 2017 at 01:00:23PM +0200, Ilia Sergachev wrote:
> Checkpatch was showing:
> WARNING: Block comments use a trailing */ on a separate line.
>
> Move trailing */ to a separate line.
>
> Signed-off-by: Ilia Sergachev
> Reviewed-by: Tobin C. Harding
This patch does not apply to my t
On Tue, Apr 18, 2017 at 08:24:01PM +0200, Johan Svensson wrote:
> Change capability field to __le16 in struct ap_info_t,
> struct link_ap_info_t, and struct local_ap_t.
> This fixes a sparse warning.
>
> Signed-off-by: Johan Svensson
> ---
> drivers/staging/ks7010/ks_hostif.h | 4 ++--
> drivers
On Wed, Apr 19, 2017 at 03:50:05PM +, Rishiraj Manwatkar wrote:
> Add parenthesis to cl_io_for_each() macro to avoid potential issues with
> unexpected argument expansion in CPP.
>
> Signed-off-by: Rishiraj Manwatkar
> ---
> v1 -> v2: Added mailing list in cc.
> v2 -> v3: Changed From: to b
On Thu, Apr 27, 2017 at 04:59:40PM +0200, Juan Antonio Pedreira Martos wrote:
> Fix checkpatch warning: unnecessary whitespace before a quoted newline.
>
> Signed-off-by: Juan Antonio Pedreira Martos
> ---
> drivers/staging/android/ion/ion_chunk_heap.c | 2 +-
> 1 file changed, 1 insertion(+), 1
Replace a couple of function names embedded in trace messages
with __func__. One of them had a typo anyway.
Signed-off-by: Ian Chard
---
drivers/staging/rtl8188eu/core/rtw_cmd.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_cmd.c
b/d
On Mon, Apr 24, 2017 at 07:53:11AM +0100, Andrea della Porta wrote:
> fixed a couple of sparse warning complaining about type mismatch.
That's really vague, please be specific.
>
> Signed-off-by: Andrea della Porta
> ---
> drivers/staging/lustre/lustre/include/lustre_intent.h | 2 +-
> 1 file
On Thu, Apr 27, 2017 at 07:29:53PM -0400, Fabrizio Perria wrote:
> From: Fabrizio
I need a full name here.
>
> Signed-off-by: Fabrizio
And here.
Also, I can not take patches without any changelog text, please fix, and
fix up your subject to say what part of the kernel you are working with
(l
On Thu, Apr 27, 2017 at 02:09:56PM -0700, Guenter Roeck wrote:
> --- /dev/null
> +++ b/drivers/staging/typec/pd.h
> @@ -0,0 +1,281 @@
> +/*
> + * Copyright 2015-2017 Google, Inc
> + *
> + * This program is free software; you can redistribute it and/or modify
> + * it under the terms of the GNU Gene
67 matches
Mail list logo