On Wed, Apr 26, 2017 at 12:11:33PM -0600, Logan Gunthorpe wrote:
> Ok, well for starters I think you are mistaken about kmap being able to
> fail. I'm having a hard time finding many users of that function that
> bother to check for an error when calling it.
A quick audit of the arch code shows yo
On Wed, Apr 26, 2017 at 06:15:08PM -0700, Guenter Roeck wrote:
> On Wed, Apr 26, 2017 at 03:26:11PM -0700, Guenter Roeck wrote:
> > From: Guenter Roeck
> >
> > This driver implements the USB Type-C Power Delivery state machine
> > for both source and sink ports. Alternate mode support is not
> >
On Wed, Apr 26, 2017 at 11:08:46PM -0300, Tiago Shibata wrote:
> On Wed, 26 Apr 2017 22:19:59 +0200
> Greg KH wrote:
>
> > On Wed, Apr 26, 2017 at 01:57:14PM -0300, Tiago Koji Castro Shibata wrote:
> > > Fix checkpatch.pl "WARNING: line over 80 characters"
> > >
> > > Signed-off-by: Tiago Koji C
On Tue, Apr 25, 2017 at 12:20:54PM -0600, Logan Gunthorpe wrote:
> Very straightforward conversion to the new function in the caam driver
> and shash library.
>
> Signed-off-by: Logan Gunthorpe
> Cc: Herbert Xu
> Cc: "David S. Miller"
> ---
> crypto/shash.c| 9 ++---
> driv
On Wed, 26 Apr 2017 22:19:59 +0200
Greg KH wrote:
> On Wed, Apr 26, 2017 at 01:57:14PM -0300, Tiago Koji Castro Shibata wrote:
> > Fix checkpatch.pl "WARNING: line over 80 characters"
> >
> > Signed-off-by: Tiago Koji Castro Shibata
> > ---
> > drivers/staging/emxx_udc/emxx_udc.c | 6 --
>
Checkpatch emits CHECK: Please don't use multiple blank lines.
Remove multiple blank lines.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_hostif.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7010/ks_hostif.c
index 81
The returned pointer from netdev_priv() (void *) does not need to be
cast.
Remove unnecessary cast of void * returned by netdev_priv().
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_wlan_net.c | 184 ---
1 file changed, 64 insertions(+), 120 delet
Driver header declares enumeration types without tags. Using
informative tags makes the code easier to understand and
eliminates the need to comment the enum.
Add tags to enumeration types.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_hostif.h | 9 -
1 file changed, 4 i
Driver uses preprocessor directives to define multicast filter
constants. These can be defined using an enumeration type. Doing so
adds to the readability and gives the assists the compiler.
Add enumeration type multicast_filter_type to replace preprocessor
defined constants.
Signed-off-by: Tobin
Driver uses preprocessor directives to define SLP_ASLEEP and
SLP_ACTIVE. These can be defined using an enumeration type. Doing so
adds to the readability and gives the usual compiler benefits of
having an enum. Functions that currently accept integer types can now
use the new enumeration type, furt
Macro includes commented out code. Removing dead code line enables
braces to be removed. Macro is easier to read if the code is clean.
Clean up macro ps_confirm_wait_inc.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_hostif.c | 10 +-
1 file changed, 5 insertions(+), 5 d
Driver currently uses abbreviations 'mgt' and 'mngmt' for
'management'. Also 'power' is sometimes abbreviated to 'pow' and other
times not. It makes the code easier to read and easier to modify if
one abbreviation is used throughout the driver. 'mgmt' is widely
accepted as an abbreviation of 'manag
Inside loop, code block is guarded with an 'if' statement. Instead of
guarding the block we can invert the 'if' statement conditional and
continue the loop. Doing so allows subsequent code indentation to be
reduced and aids the readability of the code.
Invert 'if' statement conditional, continue l
Host interface connection status is handled using a 32 bit type. Top
byte is used as for FORCE_DISCONNECT status, low bits are used for
connect/disconnect status. Driver masks and checks integers to
ascertain status. If functions are defined to do the masking and
equality check then the details of
Current switch statement has duplicate code in branches. This code can
be put after the switch statement so as to remove the duplication.
Move code to after switch statement, remove duplicate code. Make error
branch return so as not to execute the moved code block. Do not change
the program logic.
Driver contains duplicate code. Host interface has numerous request
functions which allocate memory for a request header. Each request
header is different but all contain, as the first member, a hostif_hdr
structure. This structure has size and event members which need to be
set. By defining a help
Memory allocation code contains unneeded debug statements, failed
kmalloc() calls typically do not require a debug message. Introduction
of a local 'size' variable allows kmalloc() call to be marginally
cleaner, still uses magic numbers but these require a more substantial
fix. Moving the magic num
Code declares and assigns to a local variable that is never used, it
can be safely removed.
Remove unused local variable.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_hostif.c | 9 ++---
1 file changed, 2 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/ks7010/ks
Driver includes magic numbers. Defining constants or using existing
constants aids the readability of the code.
Magic number '12' is used for two ethernet addresses (6 bytes
each). ETH_ALEN is already defined within the kernel to 6. We can us
the expression '2 * ETH_ALEN' to make this code explici
This is a re-submission of previous patch series with the same subject
but different number of patches. Hence v1.
Driver ks7010 is currently using the WEXT interface, hopefully soon it
will be converted to use CFG80211. This series is an attempt to clean
up the host interface code in preparation f
Currently source and destination ethernet addresses are checked twice,
once in hostif_data_indication() and then again in
hostif_data_indication_wpa(). The second of these functions is called
from the first right after the address check is done. This check is a
duplicate and is unnecessary.
Remove
Currently, after allocating an sk_buff, driver fills the sk_buff
within code block guarded by a NULL check on the sk_buff. If a NULL
check is done immediately after the allocation, and code returns on
error, then the subsequent code need not be guarded and the level of
indentation may be reduced. T
On Wed, Apr 26, 2017 at 03:26:11PM -0700, Guenter Roeck wrote:
> From: Guenter Roeck
>
> This driver implements the USB Type-C Power Delivery state machine
> for both source and sink ports. Alternate mode support is not
> fully implemented.
>
> The driver attaches to the USB Type-C class code im
On Wed, Apr 26, 2017 at 10:55:05AM +1000, Tobin C. Harding wrote:
[snip]
Please drop this series. Will re-submit. Apologies for the noise, bad
newbie - no biscuit.
thanks,
Tobin.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linux
On Wed, Apr 26, 2017 at 10:55:23AM +1000, Tobin C. Harding wrote:
[snip]
Please drop from the series this patch on wards (patch 18 and patch 19).
Is it easier for you if I resubmit the whole series?
Reason :
I just found the original GPL driver source released in 2009 by
Renesas and file naming
On Wed, Apr 26, 2017 at 10:55:24AM +1000, Tobin C. Harding wrote:
[snip]
Please drop this patch.
thanks,
Tobin.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On 26/04/17 02:59 AM, wrote:
> Good to know that somebody is working on this. Those problems troubled
> us as well.
Thanks Christian. It's a daunting problem and a there's a lot of work to
do before we will ever be where we need to be so any help, even an ack,
is greatly appreciated.
Logan
_
On Fri, Mar 31, 2017 at 12:42:22PM +0200, Wolfram Sang wrote:
> Hi,
>
> > The card I have is a Spectec FCC ID: S2Y-WLAN-11B-G which I believe is
> > a SDW-823 and should use the ks7010 driver.
>
> Sorry, likely not. It is an early SDW-821 and has a MediaTek chipset for
> which no driver is known:
Change video.c to use %s, __func__ instead of function names.
Warnings flagged by checkpatch.pl
Signed-off-by: Chandra Annamaneni
diff --git a/drivers/staging/most/aim-v4l2/video.c
b/drivers/staging/most/aim-v4l2/video.c
index e074841..59e861e 100644
--- a/drivers/staging/most/aim-v4l2/video.
From: Guenter Roeck
This driver implements the USB Type-C Power Delivery state machine
for both source and sink ports. Alternate mode support is not
fully implemented.
The driver attaches to the USB Type-C class code implemented in
the following patches.
usb: typec: add driver for Intel
From: Guenter Roeck
The port controller interface driver interconnects the Type-C Port
Manager with a Type-C Port Controller Interface (TCPCI) compliant
port controller.
Signed-off-by: Guenter Roeck
Signed-off-by: Guenter Roeck
---
v6:
- Move to drivers/staging
- Use PTR_ERR_OR_ZERO()
v5:
- AP
On Wed, Apr 26, 2017 at 01:00:23PM +0200, Ilia Sergachev wrote:
> Checkpatch was showing:
> WARNING: Block comments use a trailing */ on a separate line.
>
> Move trailing */ to a separate line.
>
> Signed-off-by: Ilia Sergachev
Reviewed-by: Tobin C. Harding
> ---
> Changes for v3:
> - impr
Sorry!
And thanks for pointing it out.
regards
Chandra
On Wed, 26 Apr 2017, Dan Carpenter wrote:
> On Wed, Apr 26, 2017 at 06:02:29AM -0700, Chandra Annamaneni wrote:
> >
> > Change video.c to use %s, __func__ instead of function names.
> > Warnings flagged by checkpatch.pl
> >
> > Signed-off-
On Wed, Apr 26, 2017 at 01:57:14PM -0300, Tiago Koji Castro Shibata wrote:
> Fix checkpatch.pl "WARNING: line over 80 characters"
>
> Signed-off-by: Tiago Koji Castro Shibata
> ---
> drivers/staging/emxx_udc/emxx_udc.c | 6 --
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git
On 26/04/17 01:44 AM, Christoph Hellwig wrote:
> I think we'll at least need a draft of those to make sense of these
> patches. Otherwise they just look very clumsy.
Ok, I'll work up a draft proposal and send it in a couple days. But
without a lot of cleanup such as this series it's not going t
Fix checkpatch.pl "WARNING: line over 80 characters"
Signed-off-by: Tiago Koji Castro Shibata
---
drivers/staging/emxx_udc/emxx_udc.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/emxx_udc/emxx_udc.c
b/drivers/staging/emxx_udc/emxx_udc.c
index 77b242e
On Wed, Apr 26, 2017 at 12:26 AM, Greg KH wrote:
> On Sun, Apr 23, 2017 at 03:37:29PM +0530, Adheer Chandravanshi wrote:
>> Use tab instead of spaces for indentation, as reported by checkpatch.pl
>>
>> Signed-off-by: Adheer Chandravanshi
>> ---
>> drivers/staging/android/ion/ion_cma_heap.c | 6 +
On Wed, Apr 26, 2017 at 06:02:29AM -0700, Chandra Annamaneni wrote:
>
> Change video.c to use %s, __func__ instead of function names.
> Warnings flagged by checkpatch.pl
>
> Signed-off-by: Chandra Annamaneni
>
> diff --git a/drivers/staging/most/aim-v4l2/video.c
> b/drivers/staging/most/aim-v4
Change video.c to use %s, __func__ instead of function names.
Warnings flagged by checkpatch.pl
Signed-off-by: Chandra Annamaneni
diff --git a/drivers/staging/most/aim-v4l2/video.c
b/drivers/staging/most/aim-v4l2/video.c
index 59e861e..e074841 100644
--- a/drivers/staging/most/aim-v4l2/video.
Checkpatch was showing:
WARNING: Block comments use a trailing */ on a separate line.
Move trailing */ to a separate line.
Signed-off-by: Ilia Sergachev
---
Changes for v3:
- improve the commit message even more
Changes for v2:
- improve the commit message
drivers/staging/ks7010/ks_wlan_n
All statements removed from the end of void functions
as reported by checkpatch.
Signed-off-by: Valentin Vidic
---
Changes in v2: updated recipient list and subject
drivers/staging/lustre/lustre/lmv/lmv_obd.c | 1 -
drivers/staging/lustre/lustre/lmv/lproc_lmv.c | 1 -
drivers/staging/lustre/l
On Wed, Apr 26, 2017 at 08:37:56PM +1000, Tobin C. Harding wrote:
> On Wed, Apr 26, 2017 at 10:38:54AM +0200, Ilia Sergachev wrote:
> > Fix the style of block comments.
> > Move trailing */ to a separate line.
> > Checkpatch was showing:
> > WARNING: Block comments use a trailing */ on a separate l
On Wed, Apr 26, 2017 at 10:38:54AM +0200, Ilia Sergachev wrote:
> Fix the style of block comments.
> Move trailing */ to a separate line.
> Checkpatch was showing:
> WARNING: Block comments use a trailing */ on a separate line.
You are doing well Ilia. A few nitpicks
- Your first subject was bett
Make sure to deregister the USB driver before releasing the tty driver
to avoid use-after-free in the USB disconnect callback where the tty
devices are deregistered.
Fixes: 61e121047645 ("staging: gdm7240: adding LTE USB driver")
Cc: stable # 3.12
Cc: Won Kang
Signed-off-by: Johan Hovold
--
Am 25.04.2017 um 20:20 schrieb Logan Gunthorpe:
This patch introduces functions which kmap the pages inside an sgl.
These functions replace a common pattern of kmap(sg_page(sg)) that is
used in more than 50 places within the kernel.
The motivation for this work is to eventually safely support sg
Fix the style of block comments.
Move trailing */ to a separate line.
Checkpatch was showing:
WARNING: Block comments use a trailing */ on a separate line.
Signed-off-by: Ilia Sergachev
---
Changes for v2:
- improve the commit message
drivers/staging/ks7010/ks_wlan_net.c | 43
On Wed, Apr 26, 2017 at 10:18:14AM +0200, Ilia Sergachev wrote:
> Fix the style of block comments.
> Move trailing */ to a separate line.
> Checkpatch was showing:
> WARNING: Block comments use a trailing */ on a separate line.
>
> Signed-off-by: Ilia Sergachev
> ---
> drivers/staging/ks7010/ks_
This seems nice, yes.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Fix the style of block comments.
Move trailing */ to a separate line.
Checkpatch was showing:
WARNING: Block comments use a trailing */ on a separate line.
Signed-off-by: Ilia Sergachev
---
drivers/staging/ks7010/ks_wlan_net.c | 43 ++--
1 file changed, 27 inserti
On Tue, Apr 25, 2017 at 12:20:49PM -0600, Logan Gunthorpe wrote:
> This is a prep patch to add a new error code to libiscsi. We want to
> rework some kmap calls to be able to fail. When we do, we'd like to
> use this error code.
The kmap case in iscsi_tcp_segment_map can already fail. Please add
On Tue, Apr 25, 2017 at 12:21:02PM -0600, Logan Gunthorpe wrote:
> Straightforward conversion to the new helper, except due to the lack
> of error path, we have to use SG_MAP_MUST_NOT_FAIL which may BUG_ON in
> certain cases in the future.
>
> Signed-off-by: Logan Gunthorpe
> Cc: Boris Ostrovsky
On Tue, Apr 25, 2017 at 12:20:48PM -0600, Logan Gunthorpe wrote:
> This patch introduces functions which kmap the pages inside an sgl.
> These functions replace a common pattern of kmap(sg_page(sg)) that is
> used in more than 50 places within the kernel.
>
> The motivation for this work is to eve
52 matches
Mail list logo