On 04/19/2017 12:36 PM, Logan Gunthorpe wrote:
Seeing the kunmap_atomic dma_buf_ops share the same name with a macro
in highmem.h, the former can be aliased if any dma-buf user includes
that header.
I'm personally trying to include highmem.h inside scatterlist.h and this
breaks the dma-buf code
Cathy,
> The updated patch set provides a way for drivers ( specifically
> storvsc in this case ) that expose virturalized fc devices
> but that do not expose rports to be manually scanned. This is
> done via creating a pseudo rport in storvsc and a
> corresponding dummy initiator rport role in t
From: K. Y. Srinivasan
We will not be able to send packets over a channel that has been
rescinded. Make necessary adjustments so we can properly cleanup
even when the channel is rescinded. This issue can be trigerred
in the NIC hot-remove path.
Signed-off-by: K. Y. Srinivasan
---
drivers/net/h
> -Original Message-
> From: k...@exchange.microsoft.com [mailto:k...@exchange.microsoft.com]
> Sent: Wednesday, April 19, 2017 1:49 PM
> To: da...@davemloft.net; net...@vger.kernel.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; j
From: K. Y. Srinivasan
We will not be able to send packets over a channel that has been
rescinded. Make necessary adjustments so we can properly cleanup
even when the channel is rescinded. This issue can be trigerred
in the NIC hot-remove path.
Signed-off-by: K. Y. Srinivasan
---
drivers/net/h
Seeing the kunmap_atomic dma_buf_ops share the same name with a macro
in highmem.h, the former can be aliased if any dma-buf user includes
that header.
I'm personally trying to include highmem.h inside scatterlist.h and this
breaks the dma-buf code proper.
Christoph Hellwig suggested [1] renaming
The newly added driver causes lots of warnings like
drivers/staging/rtl8723bs/core/rtw_recv.c: In function 'validate_recv_frame':
drivers/staging/rtl8723bs/core/rtw_recv.c:1602:4: error: suggest braces around
empty body in an 'else' statement [-Werror=empty-body]
DBG_COUNTER(adapter->rx_logs.
Minor nits, otherwise the vmwgfx part,
Reviewed-by: Sinclair Yeh
On Tue, Apr 18, 2017 at 06:17:00PM -0600, Logan Gunthorpe wrote:
> Seeing the kunmap_atomic dma_buf_op shares the same name with a macro
s^
> in higmem.h, the former can be aliased if any dma-b
Turns out that our implementation of .getcrosststamp() never actually
worked. Hyper-V is sending time samples every 5 seconds and this is
too much for get_device_system_crosststamp() as it's interpolation
algorithm (which nobody is currently using in kernel, btw) accounts
for a 'slow' device but we
Add parenthesis to cl_io_for_each() macro to avoid potential issues with
unexpected argument expansion in CPP.
Signed-off-by: Rishiraj Manwatkar
---
v1 -> v2: Added mailing list in cc.
v2 -> v3: Changed From: to be same as Signed-off-by:.
v3 -> v4: Changed Subject line and patch description as
On Tue, Apr 18, 2017 at 6:43 PM, Mark Rutland wrote:
...
>> >>
>> >> The code still needs some cleanup before maturing to a proper
>> >> upstream driver, which I am in the process of doing. However,
>> >> as discussion of some of the capabilities of the hardware and
>> >> its application to some d
On Tue, Apr 18, 2017 at 6:39 PM, Greg Kroah-Hartman
wrote:
> On Tue, Apr 18, 2017 at 05:07:50PM +0300, Gilad Ben-Yossef wrote:
>> Arm TrustZone CryptoCell 700 is a family of cryptographic hardware
>> accelerators. It is supported by a long lived series of out of tree
>> drivers, which I am now in
I have a proposal for you, Kindly contact me via: mrsyuhuh7...@gmail.com
---
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
This fix "overrided", the correct past tense form of "override" is
"overridden".
Signed-off-by: Luis Oliveira
---
drivers/staging/media/atomisp/i2c/ov2680.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/media/atomisp/i2c/ov2680.c
b/drivers/staging/media/ato
Hi Daniel,
On Wednesday 19 Apr 2017 10:36:55 Daniel Vetter wrote:
> On Tue, Apr 18, 2017 at 11:27:14AM -0700, Laura Abbott wrote:
> > Most of the items have been taken care of by a clean up series. Remove
> > the completed items and add a few new ones.
> >
> > Signed-off-by: Laura Abbott
> > ---
Em Wed, 05 Apr 2017 18:01:01 +0100
David Howells escreveu:
> When the kernel is running in secure boot mode, we lock down the kernel to
> prevent userspace from modifying the running kernel image. Whilst this
> includes prohibiting access to things like /dev/mem, it must also prevent
> access by
On Tue, Apr 18, 2017 at 11:27:14AM -0700, Laura Abbott wrote:
> Most of the items have been taken care of by a clean up series. Remove
> the completed items and add a few new ones.
>
> Signed-off-by: Laura Abbott
> ---
> drivers/staging/android/TODO | 21 -
> 1 file changed,
On Tue, Apr 18, 2017 at 11:27:12AM -0700, Laura Abbott wrote:
> ion_handle was introduced as an abstraction to represent a reference to
> a buffer via an ion_client. As frameworks outside of Ion evolved, the dmabuf
> emerged as the preferred standard for use in the kernel. This has made
> the ion_h
On Tue, Apr 18, 2017 at 11:27:07AM -0700, Laura Abbott wrote:
> Several of the Ion ioctls were designed in such a way that they
> necessitate compat ioctls. We're breaking a bunch of other ABIs and
> cleaning stuff up anyway so let's follow the ioctl guidelines and clean
> things up while everyone
Fix checkpatch.pl warning about unnecessary whitespace before a
quoted newline.
Signed-off-by: Paolo Cretaro
---
drivers/staging/android/ion/ion_chunk_heap.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion_chunk_heap.c
b/drivers/staging/andro
Removed the usb_device_reset(), replace with call to usb_reset_device()
directly. Plus it removes the confusing function name and addressed
the checkpatch warning. This change also swaps string in the dev_warn() call
with __func__ argument to "vt6656_probe" instead of literal string
"usb_reset_d
>-邮件原件-
>发件人: Laura Abbott [mailto:labb...@redhat.com]
>发送时间: 2017年4月18日 23:56
>收件人: Zengtao (B) ; sumit.sem...@linaro.org
>抄送: gre...@linuxfoundation.org; a...@android.com;
>riandr...@android.com; de...@driverdev.osuosl.org;
>linux-ker...@vger.kernel.org
>主题: Re: 答复: Using ion memory for d
22 matches
Mail list logo