On Thu, Apr 13, 2017 at 04:05:18PM -0600, Logan Gunthorpe wrote:
> This is a single straightforward conversion from kmap to sg_map.
>
> Signed-off-by: Logan Gunthorpe
Acked-by: Daniel Vetter
Probably makes sense to merge through some other tree, but please be aware
of the considerable churn ra
On Tue, Apr 18, 2017 at 06:14:11AM +0200, Greg KH wrote:
> On Mon, Apr 17, 2017 at 04:58:48PM -0700, Chewie Lin wrote:
> > Swap string in the dev_warn() call with __func__ argument, instead of
> > explicitly calling the function name in the string:
> >
> > WARNING: Prefer using "%s", __fun
On Mon, Apr 17, 2017 at 04:58:48PM -0700, Chewie Lin wrote:
> Swap string in the dev_warn() call with __func__ argument, instead of
> explicitly calling the function name in the string:
>
> WARNING: Prefer using "%s", __func__ to embedded function names
> #417: FILE: main_usb.c:417
Hi Laura:
>-邮件原件-
>发件人: Laura Abbott [mailto:labb...@redhat.com]
>发送时间: 2017年4月18日 0:14
>收件人: Zengtao (B) ; sumit.sem...@linaro.org
>抄送: gre...@linuxfoundation.org; a...@android.com;
>riandr...@android.com; de...@driverdev.osuosl.org;
>linux-ker...@vger.kernel.org
>主题: Re: Using ion memory
Checkpatch emits WARNING: quoted string split across lines.
Concatenate string onto single line.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/stagi
Checkpatch emits CHECK: Please don't use multiple blank lines.
Remove multiple blank lines.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/staging/ks7010/ks7010_sdio.c
in
SDIO code currently has a number of unneeded comments. Following
kernel coding style we do not need extraneous comments, especially on
code where it is clear what is being done. Spelling typos can be
fixed.
Remove unnecessary comments, fix typos in comments.
Signed-off-by: Tobin C. Harding
---
ks_sdio_card structure description does not have a kernel doc format
comment.
Add kernel doc format comment to struct ks_sdio_card.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.h | 8
1 file changed, 8 insertions(+)
diff --git a/drivers/staging/ks7010/ks7010_
Driver SDIO code is currently in files name ks7010_sdio.[ch]. These
names are not uniform with the rest of the files in this driver. This
driver only covers a single chipset, the file prefix does not add any
extra information. Other in-tree SDIO drivers typically call these
files sdio.[ch]. This is
Currently driver uses a hardware information struct description to
group some SDIO related functionality (work, work queue, sdio private
data pointer). This structure is then embedded in the device private
data structure. Having nested structures described in different header
files means that to vi
Currently a pointer to the tasklet_struct used for bottom half
processing on the receive path is within the hw_info_t structure. This
structure is then embedded in the device private data
structure. Having the tasklet_struct nested does not add meaning to
the device private data, device private dat
goto label includes 'err_' suffix but is executed on non-error paths.
Remove err_ suffix from goto label.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
complete_handler() takes void * types as parameters. void * parameters are then
cast to struct types. Call sites for this function either pass in NULL
or pointers to the struct types cast to void *. This casting is
unnecessary and can be removed.
Struct tx_device_buffer (which contains a pointer m
Header has multiple constants defined using preprocessor
directive. In the cases where these are an integer progression an
enumeration type can be used. Doing so adds documentation to the code
and makes the usage explicit. Maintain original constant value, this
value is returned by the device.
Rep
Checkpatch emits WARNING: please, no space before tabs.
Remove space before tabs.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/staging/ks7010/ks7010_sd
Driver SDIO code uses helper functions to do IO to the SDIO
device. Current helpers handle IO of a single byte as well as
multi-byte. Driver predominately uses single byte IO. If the
common case is made simple it simplifies the whole driver. The common
case can be made simple by splitting the multi
struct work_struct uses identifier ks_wlan_wakeup_task, this is
confusing because the 'task' suffix implies that this is a
tasklet_struct instead of a work struct. Suffix 'work' would be more
clear. The code would be easier to read if it followed the principle
of least surprise and used the 'work'
SDIO header file does not use kernel doc format struct
comments. Adding them aids readability and enables documentation to be
built from the source code. Other comments may be tidied up as we do this.
Add kernel format struct comments. Tidy up comments.
Signed-off-by: Tobin C. Harding
---
drive
SDIO header currently defines unused constants READ_STATUS_BUSY and
WRITE_STATUS_IDLE. There are reciprocal constants that are used
READ_STATUS_IDLE and WRITE_STATUS_BUSY. We can roll these into a
single enumeration type and remove the two that are unused.
Add enumeration type containing IDLE/BUSY
This is a rework of a partially applied series with the same subject
text (originally containing 18 patches). This is version 1 because the
subject is not identical.
The purpose of this patch set is to improve the readability of the
SDIO code within the driver. Refactorings only, there are no chan
Swap string in the dev_warn() call with __func__ argument, instead of
explicitly calling the function name in the string:
WARNING: Prefer using "%s", __func__ to embedded function names
#417: FILE: main_usb.c:417:
+"usb_device_reset fail status=%d\n"
Hi All,
I'm submitting this patch as part of Eudyptula challenge to fix a
coding style problem. Thanks for taking time on this trivial patch.
linsh
Chewie Lin (1):
drivers/staging/vt6656/main_usb.c: checkpatch warning
drivers/staging/vt6656/main_usb.c | 2 +-
1 file changed, 1 insertion(+),
On 04/15/2017 10:06 AM, Christoph Hellwig wrote:
Just add a singlethreaded workqueue for storvsc_handle_error and you'll
get serialization for all error handling for free.
The problem I am seeing is that many work items can be queued up for the
same lun before it goes away. The single threaded
Included in the current storvsc driver for Hyper-V is the ability
to access luns on an FC fabric via a virtualized fiber channel
adapter exposed by the Hyper-V host. The driver also attaches to
the FC transport to allow host and port names to be published under
/sys/class/fc_host/hostX. Current cus
This patch allows scsi drivers that expose virturalized fibre channel
devices but that do not expose rports to successfully rescan the scsi
bus via echo "- - -" > /sys/class/scsi_host/hostX/scan.
Drivers can create a pseudo rport and indicate
FC_PORT_ROLE_FCP_DUMMY_INITIATOR as the rport's role in
The updated patch set provides a way for drivers ( specifically
storvsc in this case ) that expose virturalized fc devices
but that do not expose rports to be manually scanned. This is
done via creating a pseudo rport in storvsc and a
corresponding dummy initiator rport role in the fc transport.
C
This patch fixes the following sparse warning:
ieee80211_tx.c:174:36: incorrect type in assignment (different base types)
ieee80211_tx.c:174:36: expected unsigned short [unsigned] [short] [usertype]
ieee80211_tx.c:174:36: got restricted __be16 [usertype]
by adding left side cast to __be16.
Sig
On 04/14/2017 02:18 AM, Zengtao (B) wrote:
> Hi
>
> Currently, the ion mapped to userspace will be forced with VM_IO and
> VM_PFNMAP flags.
> When I use the ion memory to do the direct-io, it will fail when reaching the
> get_user_pages,
>
> Back to the VM_IO and VM_PFNMAP flag, there two flag
On Mon, 17 Apr 2017 09:04:03 +0200, Greg KH wrote:
> On Mon, Apr 17, 2017 at 02:47:34AM +0200, Karim Eshapa wrote:
>>
>> Macros more related to BLK operations.
>
> That doesn't make any sense to me, can you be more explicit?.
skein_block.h contains all fn's related to processing on
different blo
On Mon, Apr 17, 2017 at 02:47:34AM +0200, Karim Eshapa wrote:
> Macros more related to BLK operations.
That doesn't make any sense to me, can you be more explicit?
> Signed-off-by: Karim Eshapa
> ---
> drivers/staging/skein/skein_base.h | 28
> drivers/staging/skei
30 matches
Mail list logo