On Fri, Mar 31, 2017 at 12:32:26AM +0530, simran singhal wrote:
> Change the name of function from adis16060_spi_write_than_read()
> to adis16060_spi_write_then_read(). change "than" to "then" as
> its time depended.
> ---
> drivers/staging/iio/gyro/adis16060_core.c | 4 ++--
> 1 file changed, 2 i
On Thu, Mar 30, 2017 at 05:43:17PM -0400, David Kershner wrote:
> Fixes: 5b6f9b95f7ae ("staging: unisys: visorbus: get rid of create_bus_type.")
>
> Kernel day0 testing robot reported a kernel BUG at drivers/base/driver.c!
> with the following call stack:
>
> [ 14.963563] [ cut here
On Thu, Mar 30, 2017 at 10:09:19PM -0700, skanda.kash...@gmail.com wrote:
> From: Skanda Guruanand
>
> ---
> drivers/staging/lustre/lustre/include/lustre/lustre_idl.h | 8
> 1 file changed, 4 insertions(+), 4 deletions(-)
Hi,
This is the friendly patch-bot of Greg Kroah-Hartman. You
On Fri, 2017-03-31 at 15:47 +1100, Tobin C. Harding wrote:
> ks7010 currently uses a custom implementation of the Michael MIC
> algorithm. The kernel has an implementation of this algorithm
> already, we should use it.
ok, trivia:
Do please run your patch through checkpatch and fix a few style ni
From: Skanda Guruanand
---
drivers/staging/lustre/lustre/include/lustre/lustre_idl.h | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/lustre/lustre/include/lustre/lustre_idl.h
b/drivers/staging/lustre/lustre/include/lustre/lustre_idl.h
index 60b827e..d
I have modified struct lu_dirpage as suggested to remove the below warnings.
CHECK drivers/staging/lustre/lustre/mdc/mdc_request.c
drivers/staging/lustre/lustre/mdc/mdc_request.c:958:42: warning: cast
to restricted __le64
drivers/staging/lustre/lustre/mdc/mdc_request.c:959:42: warning: cast
to r
This RFC can be applied on op on Linus' tree 89970a0
Configuration options needed to build are
CONFIG_STAGING=y
CONFIG_KS7010=m
The ks7010 driver currently uses a custom implementation of the
Michael MIC algorithm. The kernel has an implementation of this
algorithm already. This patch is an atte
ks7010 currently uses a custom implementation of the Michael MIC
algorithm. The kernel has an implementation of this algorithm
already, we should use it.
Remove the custom implementation. Implement helper functions that call
the in-tree implementation through the crypto API. Update the
makefile. R
The driver needs to insure atomicity during frequency
changes of bus and device. The iiodev->mlock as used
was not doing that. Replace it with the drivers existing
buffer lock and execute spi_write directly.
Signed-off-by: Arushi Singhal
---
drivers/staging/iio/meter/ade7759.c | 9 ++---
1 f
Define new local variable to reduce the number of reference.
The new local variable is added to save the addess of dfs
and used in atomisp_freq_scaling() function.
Signed-off-by: Daeseok Youn
---
V2: this patch was rebased since the patch 1/2 was improved.
.../media/atomisp/pci/atomisp2/atomisp
The condition line in if-statement is needed to be shorthen to
improve readability.
Add a new definition to check the CHT with atomisp_device structure.
Signed-off-by: Daeseok Youn
---
V2: replace the assigment line with macro to check CHT type.
drivers/staging/media/atomisp/pci/atomisp2/atomi
Checkpatch emits multiple CHECK: Logical continuations should be on the
previous line. In one instance, logical continuation involves three
key length checks, these can be assigned to a suitably named variable to
make the code more readable.
Move logical continuations to the end of the previous li
Macro CHECK_ALINE is defined and never used.
Remove unused macro.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_hostif.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7010/ks_hostif.c
index c4de0f3..0598796 100644
--
Function uses an if statement within a for loop to guard a block of
code. If 'if' statement conditional evaluates to false, loop breaks. The
same logic can be expressed by inverting the conditional and breaking
when new conditional evaluates to true. This allows the subsequent code
to be indented o
Checkpatch emits WARNING: Avoid multiple line dereference.
Fix up layout of function call, move dereference to single line.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_hostif.c | 12 +++-
1 file changed, 7 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/ks7
Kernel networking code predominately uses the identifier 'skb' for a struct
sk_buff pointer. Of 8088 instances of 'struct sk_buff *' within
net/ 6670 are named 'skb'. Following the principle of least surprise,
new networking code should use the identifier 'skb' for variables of
type 'struct sk_buff
Function uses multi-way decision for control flow. Final statement of
function is spin_unlock(). Code can be simplified by adding a goto label
labelling the call to spin_unlock() and jumping to label instead of
using multi-way decision. This allows the code to be indented one
level less which also
Identifier uses camel case, standard kernel style does not use camel
case.
Rename buffer 'RecvMIC' to 'recv_mic'.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_hostif.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
If statement conditional is comprised of a logical continuation that
contains the same truth value check multiple times. This conditional
can be more succinctly expressed by splitting the conditional into two
separate statements, this makes the code easier to read.
Move truth values out of complex
Driver uses custom Michael MIC implementation. There is already an
implementation within the kernel. There is at least one other driver
already using the kernel implementation
(drivers/net/wireless/intersil/orinoco).
Add task to TODO file.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7
Function contains a local pointer variable defined to a memory location
within a structure. This memory location is later used by
dereferencing the struct instead of using the local pointer. The code
is cleaner if all references of the same memory location use the
local variable.
Utilize existing
Checkpatch emits WARNING: else is not generally useful after a break
or return. Two warnings of this type are emitted for this code block,
in both cases 'else' statements are unnecessary.
Remove unnecessary 'else' statements, reduce indentation in subsequent
code.
Signed-off-by: Tobin C. Harding
Checkpatch emits CHECK: Alignment should match open parenthesis.
Align argument to open parenthesis.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_wlan_net.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_wlan_net.c
b/drivers/stagi
Function uses overly complex calls to memcpy(). Code may be simplified
by the use of a local variable. Address of first element of an array
is explicitly taken, this is unnecessary since the address of the
first element is the same as the address (value) assigned to the array
identifier. The code i
Multi-way decision contains two anomalies.
Firstly, a local variable is defined to be the inverse truth variable
of a struct member. This local variable is used as the conditional to
the multi-way decision. This is unnecessary, the same logic can be
expressed using the struct member directly.
Sec
Function contains compound statement delineated by lone braces. This
statement represents a discreet set of functionality and thus can be
factored out into a separate function. Using a separate function
instead of a compound statement increases readability, reduces code
indentation, reduces functio
Function parameter is cast to a local pointer which is then
dereferenced before it is checked to be non-NULL.
Move pointer null check to be before the pointer is dereferenced.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks_wlan_net.c | 5 ++---
1 file changed, 2 insertions(+), 3
Function has duplicate code clean up sequences; identical function
call followed by return. This would be better expressed with the use
of a goto statement, as is typical with the kernel code base. One call
site places the clean up code within the 'else' branch of an multi-way
decision. This can be
Function contains a list of four checks, for no apparent reason two of them
are OR'ed together. Having two OR'ed together and the other two not
implies some connection between the two that are combined. It is
easier to read this code if the four unrelated checks are done as
separate statements.
Mo
A number of functions have blocks of code guarded by an if statement.
if (foo) {
/* block of code */
}
This can, on occasion, be more succinctly be expressed as
if (!foo)
return
/* block of code */
This change will mean a number of whitespace issues need to be
addressed/fixed.
Function has return type 'int'. Function has internal linkage. Function
returns 0 on all execution paths. Function is called only once in the
driver and the return value is not checked. Removal of this return
value does not change the program logic. The 'int' return type is not
adding any informati
Function uses identifier 'retval' to hold the error return value. The
rest of the driver uses 'ret' for this purpose. Being uniform in the
choice of identifiers generally adds to the cleanliness of the code,
also it is arguably easier to follow the code if one name is used for
one task.
Rename ide
Driver uses identifier 'rc' to hold the value for error return
code. The rest of the driver predominately uses 'ret' for this
purpose. It is easier to follow the code if one name is used for one
task.
Rename identifier 'rc' to 'ret'.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks
Functions accept a parameter of type 'void *', this is then cast to a
struct ks_wlan_private pointer. All call sites have a struct
ks_wlan_private pointer and cast it to 'void *'. We can remove the
unnecessary casting by changing the parameter type to match the
usage. Functions changed all have int
Function ks7010_upload_firmware() takes as parameters, two struct
pointers, one of which is a member of the other. This is unnecessary
since one can be accessed via the other.
Remove function parameter and fix all call sites.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sd
The purpose of this patch series is to remove all the remaining
*trivial* checkpatch errors, warnings, and checks from the ks7010
driver.
Series does not remove warnings generated by DPRINTK statements,
does not fully tidy up the comments, and does not touch line over 80
warnings of any sort.
The
Constant is used to allocate memory for a buffer, then buffer is
filled upto 'size' which is passed as a parameter. If 'size' is bigger
than the constant then the buffer will overflow. Function has internal
linkage so this can only happen due to programmer error. BUG_ON() is
designed for catching t
Fixes: 5b6f9b95f7ae ("staging: unisys: visorbus: get rid of create_bus_type.")
Kernel day0 testing robot reported a kernel BUG at drivers/base/driver.c!
with the following call stack:
[ 14.963563] [ cut here ]
[ 14.967298] kernel BUG at drivers/base/driver.c:153!
[ 1
Coding style problem detected by checkpatch.pl
ERROR: space prohibited before that ','
Signed-off-by: Alfonso Lima Astor
---
drivers/staging/rtl8188eu/hal/Hal8188ERateAdaptive.c | 2 +-
drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c| 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
On Fri, Mar 31, 2017 at 1:18 AM, Jonathan Cameron
wrote:
>
>
> On 30 March 2017 19:44:26 BST, SIMRAN SINGHAL
> wrote:
>>On Fri, Mar 31, 2017 at 12:02 AM, Jonathan Cameron
>>wrote:
>>> On 28/03/17 19:37, Alison Schofield wrote:
On Tue, Mar 28, 2017 at 10:55:17PM +0530, SIMRAN SINGHAL wrote:
On 30 March 2017 19:44:26 BST, SIMRAN SINGHAL wrote:
>On Fri, Mar 31, 2017 at 12:02 AM, Jonathan Cameron
>wrote:
>> On 28/03/17 19:37, Alison Schofield wrote:
>>> On Tue, Mar 28, 2017 at 10:55:17PM +0530, SIMRAN SINGHAL wrote:
On Fri, Mar 24, 2017 at 12:51 AM, Alison Schofield
> wrote:
>>>
Change the name of function from adis16060_spi_write_than_read()
to adis16060_spi_write_then_read(). change "than" to "then" as
its time depended.
---
drivers/staging/iio/gyro/adis16060_core.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/iio/gyro/adis1606
On Fri, Mar 31, 2017 at 12:02 AM, Jonathan Cameron wrote:
> On 28/03/17 19:37, Alison Schofield wrote:
>> On Tue, Mar 28, 2017 at 10:55:17PM +0530, SIMRAN SINGHAL wrote:
>>> On Fri, Mar 24, 2017 at 12:51 AM, Alison Schofield
>>> wrote:
On Fri, Mar 24, 2017 at 12:05:20AM +0530, simran singha
On 28/03/17 19:37, Alison Schofield wrote:
> On Tue, Mar 28, 2017 at 10:55:17PM +0530, SIMRAN SINGHAL wrote:
>> On Fri, Mar 24, 2017 at 12:51 AM, Alison Schofield
>> wrote:
>>> On Fri, Mar 24, 2017 at 12:05:20AM +0530, simran singhal wrote:
The IIO subsystem is redefining iio_dev->mlock to b
The TVP5150 DT bindings specify a single output port (port 0) that
corresponds to the video output pad (pad 1, DEMOD_PAD_VID_OUT).
Signed-off-by: Philipp Zabel
---
I'm trying to get this to work with a TVP5150 analog TV decoder, and the
first problem is that this device doesn't have pad 0 as its
On Thu, Mar 30, 2017 at 09:12:29AM -0700, Steve Longerbeam wrote:
>
>
> On 03/30/2017 04:02 AM, Russell King - ARM Linux wrote:
> >This fails at step 1. The removal of the frame interval support now
> >means my setup script fails when trying to set the frame interval on
> >the camera:
> >
> >Enu
On 03/30/2017 04:02 AM, Russell King - ARM Linux wrote:
This fails at step 1. The removal of the frame interval support now
means my setup script fails when trying to set the frame interval on
the camera:
Enumerating pads and links
Setting up format SRGGB8_1X8 816x616 on pad imx219 0-0010/0
F
2017-03-30 19:52 GMT+09:00 Alan Cox :
> On Thu, 2017-03-30 at 15:24 +0900, Daeseok Youn wrote:
>> The condition line in if-statement is needed to be shorthen to
>> improve readability.
>>
>> Signed-off-by: Daeseok Youn
>> ---
>
> How about a define for ATOMISP_IS_CHT(isp) instead - as we will need
From: Tejaswini Poluri
Fixed the warnings from checkpatch.pl on file rtl8712/mlme_linux.c
Avoided multiple line dereferences in the code
Signed-off-by: Tejaswini Poluri
---
drivers/staging/rtl8712/mlme_linux.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drive
Hi,
So which commit is moving forward and which one is not?
f1c635b439a5c01776fe3a25b1e2dc546ea82e6f or
40630f462824ee24bc00d692865c86c3828094e0?
We have backported 40630f462824ee24bc00d692865c86c3828094e0 and I am
unclear if this is a regression and must be removed or it is a
regression bu
This fails at step 1. The removal of the frame interval support now
means my setup script fails when trying to set the frame interval on
the camera:
Enumerating pads and links
Setting up format SRGGB8_1X8 816x616 on pad imx219 0-0010/0
Format set: SRGGB8_1X8 816x616
Setting up frame interval 1/25
On 29/03/17 22:10, Arnd Bergmann wrote:
When COMEDI_NI_LABPC is built-in and COMEDI_NI_LABPC_ISA is a loadable
module, thhe ISA DMA code is not reachable by the common module, causing
a link error:
drivers/staging/built-in.o: In function `labpc_interrupt':
ni_labpc_common.c:(.text+0x1d178): unde
On Thu, 2017-03-30 at 15:24 +0900, Daeseok Youn wrote:
> The condition line in if-statement is needed to be shorthen to
> improve readability.
>
> Signed-off-by: Daeseok Youn
> ---
How about a define for ATOMISP_IS_CHT(isp) instead - as we will need
these tests in other places where there are IS
As some USB documentation files got moved, adjust their
cross-references to their new place.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/ABI/stable/sysfs-bus-usb| 2 +-
Documentation/driver-api/usb/URB.rst | 2 ++
Documentation/driver-api/usb/callbacks.rst
2017-03-30 16:19 GMT+09:00 walter harms :
>
>
> Am 30.03.2017 08:25, schrieb Daeseok Youn:
>> Define new local variable to reduce the number of reference.
>> The new local variable is added to save the addess of dfs
>> and used in atomisp_freq_scaling() function.
>>
>> Signed-off-by: Daeseok Youn
This fixes the coding style issue of using S_IWUSR in place of 4-digit
octal numbers.
Issue detected by checkpatch.
Signed-off-by: Guru Das Srinagesh
---
drivers/staging/iio/frequency/ad9832.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/sta
From: Colin Ian King
trivial fix to spelling mistake in dev_err error message
Signed-off-by: Colin Ian King
---
drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm_bo_dev.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/media/atomisp/pci/atomisp2/hmm/hmm_bo_
From: Colin Ian King
trivial fix to spelling mistake in various comments and pr_debug messages
Signed-off-by: Colin Ian King
---
drivers/staging/vc04_services/bcm2835-camera/mmal-msg.h | 2 +-
drivers/staging/vc04_services/bcm2835-camera/mmal-vchiq.c | 6 +++---
drivers/staging/vc04_services
On Tue, Mar 28, 2017 at 04:14:09PM +, Stephen Hemminger wrote:
> I decided not to send it to stable since problem was only observed on
> 4.11 but it is probably endemic to all GEN2 VM's
So, what does this mean? What should stable@ do? Nothing? Ok, now
dropped this from my patch queue :)
th
Am 30.03.2017 08:25, schrieb Daeseok Youn:
> Define new local variable to reduce the number of reference.
> The new local variable is added to save the addess of dfs
> and used in atomisp_freq_scaling() function.
>
> Signed-off-by: Daeseok Youn
> ---
> .../media/atomisp/pci/atomisp2/atomisp_cm
Sparse spits out a warning that a __be16 was being assigned to a u16.
Change the type of txbuf16 to __be16 b/c it's a restricted type and
prevents mixing endianness.
Signed-off-by: Alex Wilson
---
drivers/staging/fbtft/fbtft-bus.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git
61 matches
Mail list logo