Removing use of deprecated macros(S_IRUGO, SIWUGO, S_IXUGO), and replaced with
4 gidit octal.
Signed-off-by: Chen Guanqiao
---
drivers/staging/iio/meter/ade7759.c | 26 ++
1 file changed, 14 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/iio/meter/ade7759.c
Define new local variable to reduce the number of reference.
The new local variable is added to save the addess of dfs
and used in atomisp_freq_scaling() function.
Signed-off-by: Daeseok Youn
---
.../media/atomisp/pci/atomisp2/atomisp_cmd.c | 37 --
1 file changed, 20 i
The condition line in if-statement is needed to be shorthen to
improve readability.
Signed-off-by: Daeseok Youn
---
drivers/staging/media/atomisp/pci/atomisp2/atomisp_cmd.c | 7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/media/atomisp/pci/atomisp2/atomi
Fixed the followinf checkpatch warning:
WARNING: braces {} are not necessary for single statement blocks
#258: FILE: drivers/staging/iio/accel/adis16209.c:258:
+ if (ret) {
+ return ret;
+ }
Signed-off-by: Andrea della Porta
---
drivers/staging/i
Hi Vaibhav,
[auto build test ERROR on staging/staging-testing]
[also build test ERROR on v4.11-rc4 next-20170329]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/vaibhavddit-gmail-com/drivers
On 28/03/17 13:01, Andrea della Porta wrote:
> Coding style issue resolved.
>
> Signed-off-by: Andrea della Porta
Please include the driver name in the title. Subsystem also good.
staging:iio:accel:adis16029 drop braces around single element if block
or something along those lines would be good.
On 28/03/17 18:37, Arushi Singhal wrote:
> The IIO subsystem is redefining iio_dev->mlock to be used by
> the IIO core only for protecting device operating mode changes.
> ie. Changes between INDIO_DIRECT_MODE, INDIO_BUFFER_* modes.
>
> In this driver, mlock was being used to protect hardware stat
In combination with CONFIG_PROFILE_ANNOTATED_BRANCHES=y, the unlikely()
inside of the WARN() macro becomes too complex for gcc to see that
we don't use the output arguments of mt9m114_to_res() are used
correctly:
drivers/staging/media/atomisp/i2c/mt9m114.c: In function 'mt9m114_get_fmt':
drivers/s
Fix style issues by adding parenthesis around macros
arguments
Signed-off-by: Aviya Erenfeld
---
drivers/staging/goldfish/goldfish_audio.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/goldfish/goldfish_audio.c
b/drivers/staging/goldfish/goldfish_aud
When COMEDI_NI_LABPC is built-in and COMEDI_NI_LABPC_ISA is a loadable
module, thhe ISA DMA code is not reachable by the common module, causing
a link error:
drivers/staging/built-in.o: In function `labpc_interrupt':
ni_labpc_common.c:(.text+0x1d178): undefined reference to
`labpc_handle_dma_stat
When COMEDI_NI_LABPC is built-in and COMEDI_NI_LABPC_ISA is a loadable
module, thhe ISA DMA code is not reachable by the common module, causing
a link error:
drivers/staging/built-in.o: In function `labpc_interrupt':
ni_labpc_common.c:(.text+0x1d178): undefined reference to
`labpc_handle_dma_stat
On Wed, 29 Mar 2017, Arushi Singhal wrote:
> Remove the extra parenthesis remove the checkpatch issue.
The patch replaces 1 << x by calls to BIT. That doesn't correspond to the
commit message.
julia
>
> Signed-off-by: Arushi Singhal
> ---
> changes in v2
> -done the changes according to th
This macro is not used and also had a style error. I have run
grep and compiled the module to be sure.
Signed-off-by: Alfonso Lima Astor
---
drivers/staging/rtl8188eu/include/rtw_ioctl.h | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/rtw_ioctl.h
b/dri
As some USB documentation files got moved, adjust their
cross-references to their new place.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/ABI/stable/sysfs-bus-usb| 2 +-
Documentation/driver-api/usb/URB.rst | 2 ++
Documentation/driver-api/usb/callbacks.rst
Removed an extra spaces at the end of the line
Signed-off-by: Andrea della Porta
---
drivers/staging/vc04_services/bcm2835-audio/bcm2835-pcm.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/vc04_services/bcm2835-audio/bcm2835-pcm.c
b/drivers/staging/vc04_ser
Fixed issue:
WARNING: line over 80 characters
#545: FILE: drivers/staging/vc04_services/bcm2835-audio/bcm2835-pcm.c:545:
+ snd_bcm2835_playback_spdif_hw.buffer_bytes_max,
snd_bcm2835_playback_spdif_hw.buffer_bytes_max);
Signed-off-by: Andrea della Porta
---
drivers/staging/vc04_se
Fixed issues:
CHECK: Alignment should match open parenthesis
#71: FILE: drivers/staging/vc04_services/bcm2835-audio/bcm2835-pcm.c:71:
+ audio_info("alsa_stream=%p substream=%p\n", alsa_stream,
+ alsa_stream ? alsa_stream->substream : 0);
CHECK: Alignment should match open paren
Fixed several chekpatch warnign about alignment of function parameters,
removed spaces after a cast, split one line that was over 80 chars
.../vc04_services/bcm2835-audio/bcm2835-pcm.c | 48 +++---
1 file changed, 23 insertions(+), 25 deletions(-)
___
Fix style error pointed out by checkpatch.pl:
ERROR: Macros with complex values should be enclosed in
parentheses
I have compiled the module just to be sure. I haven't run it
because I haven't changed any funcionality.
Signed-off-by: Alfonso Lima Astor
---
drivers/staging/rtl8188eu/include/odm_
Checkpatch emits WARNING: Avoid multiple line dereference.
Trivial indentation improvement helps fix the checkpatch warning.
Signed-off-by: Prasant Jalan
---
drivers/staging/rtl8712/rtl871x_xmit.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/r
On Wed, 2017-03-29 at 09:57 -0700, Daniel Cashman wrote:
> From: Dan Cashman
>
> Signed-off-by: Dan Cashman
As the TODO asks - please no whitespace cleanups yet. They make it
harder to keep other cleanups that fix (or mostly remove) code
applying.
Nothing wrong with the patch otherwise - but
Hi Boris,
On 03/29/2017 10:14 AM, Borislav Petkov wrote:
On Thu, Mar 02, 2017 at 10:16:05AM -0500, Brijesh Singh wrote:
From: Tom Lendacky
When a guest causes a NPF which requires emulation, KVM sometimes walks
the guest page tables to translate the GVA to a GPA. This is unnecessary
most of t
From: Dan Cashman
Signed-off-by: Dan Cashman
---
drivers/staging/media/atomisp/i2c/ap1302.c | 4 ++--
drivers/staging/media/atomisp/i2c/gc0310.c | 2 +-
drivers/staging/media/atomisp/i2c/gc2235.c | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/media/atomis
On 29 March 2017 17:05:51 BST, Arushi Singhal
wrote:
>Remove the extra parenthesis remove the checkpatch issue.
>
>Signed-off-by: Arushi Singhal
Patch doesn't need resending as already applied.
If it did the description is now incorrect!
>---
>changes in v2
> -done the changes according to th
On 29 March 2017 16:38:28 BST, Julia Lawall wrote:
>
>
>On Wed, 29 Mar 2017, Arushi Singhal wrote:
>
>> Remove the extra parenthesis remove the checkpatch issue.
>
>Is this a patch on the current state of the staging tree? When I do a
>pull and then look at the code, the line numbers are all of
Remove the extra parenthesis remove the checkpatch issue.
Signed-off-by: Arushi Singhal
---
changes in v2
-done the changes according to the current tree
drivers/staging/iio/cdc/ad7746.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/iio/cd
On Wed, 29 Mar 2017, Arushi Singhal wrote:
> Remove the extra parenthesis remove the checkpatch issue.
Is this a patch on the current state of the staging tree? When I do a
pull and then look at the code, the line numbers are all off.
Furthermore, there are not calls to BIT with parentheses ar
On Wed, Mar 29, 2017 at 05:21:13PM +0200, Paolo Bonzini wrote:
> The GHCB would have to be allocated much earlier, possibly even by
> firmware depending on how things will be designed.
How about a statically allocated page like we do with the early
pagetable pages in head_64.S?
> I think it's pre
On 28/03/2017 20:39, Borislav Petkov wrote:
>> 2) Since the encryption attributes works on PAGE_SIZE hence add some extra
>> padding to 'struct kvm-steal-time' to make it PAGE_SIZE and then at runtime
>> clear the encryption attribute of the full PAGE. The downside of this was
>> now we need to m
Remove the extra parenthesis remove the checkpatch issue.
Signed-off-by: Arushi Singhal
---
drivers/staging/iio/cdc/ad7746.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/iio/cdc/ad7746.c b/drivers/staging/iio/cdc/ad7746.c
index 033a41fd9bee
On Thu, Mar 02, 2017 at 10:16:05AM -0500, Brijesh Singh wrote:
> From: Tom Lendacky
>
> When a guest causes a NPF which requires emulation, KVM sometimes walks
> the guest page tables to translate the GVA to a GPA. This is unnecessary
> most of the time on AMD hardware since the hardware provides
This patch replaces bit shifting on 1 with the BIT(x) macro.
This was done with coccinelle:
@@
constant c;
@@
-1 << c
+BIT(c)
Signed-off-by: Arushi Singhal
---
drivers/staging/media/davinci_vpfe/dm365_ipipe.c | 2 +-
drivers/staging/media/davinci_vpfe/dm365_ipipeif.c | 2 +-
drivers/staging
This patch replaces bit shifting on 1 with the BIT(x) macro.
This was done with coccinelle:
@@
constant c;
@@
-1 << c
+BIT(c)
Signed-off-by: Arushi Singhal
---
drivers/staging/media/omap4iss/iss_csi2.c| 2 +-
drivers/staging/media/omap4iss/iss_ipipe.c | 2 +-
drivers/staging/media/omap4is
On Wed, Mar 29, 2017 at 09:43:38PM +1100, Tobin C. Harding wrote:
> On Wed, Mar 29, 2017 at 09:21:20AM +0200, Greg Kroah-Hartman wrote:
> > On Sun, Mar 26, 2017 at 07:45:12PM +1100, Tobin C. Harding wrote:
> > > Function tx_device_task() is a candidate for refactoring. Checkpatch
> > > emits a numb
On Wed, Mar 29, 2017 at 12:29:30AM +0100, Andrea della Porta wrote:
> Fixed several chekpatch warnign about alignment of function parameters,
> removed spaces after a cast, split one line that was over 80 chars
Only do one thing per patch, please fix this up as a patch series.
thanks,
greg k-h
_
Paths can be up to PATH_MAX long and PATH_MAX is usually greater than 256.
While on it, simplify path reconstruction to a simple snprintf(), define
and reuse KVP_NET_DIR.
Suggested-by: Tomas Hozza
Signed-off-by: Vitaly Kuznetsov
---
tools/hv/hv_kvp_daemon.c | 44 ++--
Fixed several chekpatch warnign about alignment of function parameters,
removed spaces after a cast, split one line that was over 80 chars
Signed-off-by: Andrea della Porta
---
.../vc04_services/bcm2835-audio/bcm2835-pcm.c | 47 ++
1 file changed, 22 insertions(+), 25 de
From: Andrea della Porta
Subject: staging: xgifb: added blankline after decl.
Fixed checkpatch warning:
WARNING: Missing a blank line after declarations
#882: FILE: drivers/staging/xgifb/XGI_main_26.c:882:
+ const u8 *f =
XGI_TV_filter[filter_tb].filter[filter];
+
On Wed, Mar 29, 2017 at 12:34:05PM +0200, Greg KH wrote:
> On Thu, Mar 23, 2017 at 04:09:03PM -0300, Marcos Paulo de Souza wrote:
> > On Wed, Mar 29, 2017 at 09:31:14AM +0200, Greg KH wrote:
> > > On Tue, Mar 28, 2017 at 11:14:06PM -0300, Marcos Paulo de Souza wrote:
> > > > head_up parameter is ma
On Wed, Mar 29, 2017 at 09:21:20AM +0200, Greg Kroah-Hartman wrote:
> On Sun, Mar 26, 2017 at 07:45:12PM +1100, Tobin C. Harding wrote:
> > Function tx_device_task() is a candidate for refactoring. Checkpatch
> > emits a number of warnings/checks for this function.
> >
> > Patch 01 inverts if stat
On Thu, Mar 23, 2017 at 04:09:03PM -0300, Marcos Paulo de Souza wrote:
> On Wed, Mar 29, 2017 at 09:31:14AM +0200, Greg KH wrote:
> > On Tue, Mar 28, 2017 at 11:14:06PM -0300, Marcos Paulo de Souza wrote:
> > > head_up parameter is marked with __user attribute, tmp is filled
> > > by a copy_from_us
On Wed, Mar 29, 2017 at 09:31:14AM +0200, Greg KH wrote:
> On Tue, Mar 28, 2017 at 11:14:06PM -0300, Marcos Paulo de Souza wrote:
> > head_up parameter is marked with __user attribute, tmp is filled
> > by a copy_from_user from next, that is also marked as __user, so
> > tmp.next needs to be "caste
2017-03-18 1:54 GMT+01:00 Laura Abbott :
>
> Hi,
>
> This is v2 of the series to do some serious Ion clean up in preparation for
> moving out of staging. I got good feedback last time so this series mostly
> attempts to address that feedback and do more still more cleanup. Highlights:
>
> - All cal
2017-03-18 1:54 GMT+01:00 Laura Abbott :
>
> Frameworks (e.g. Ion) may want to iterate over each possible CMA area to
> allow for enumeration. Introduce a function to allow a callback.
even outside ION rework that could be useful
Reviewed-by: Benjamin Gaignard
>
> Signed-off-by: Laura Abbott
>
On Thu, Mar 16, 2017 at 11:27:21PM +1100, Tobin C. Harding wrote:
> Sparse emits numerous warnings highlighting endian issues. The
> endianess is deterministic because the function calls that are causing
> the issues either accept as parameters, or return as results, types of
> specific size and en
On Tue, Mar 28, 2017 at 07:21:34PM -0500, Rob Herring wrote:
> On Mon, Mar 27, 2017 at 7:40 PM, Steve Longerbeam
> wrote:
> > Add bindings documentation for the i.MX media driver.
> >
> > Signed-off-by: Steve Longerbeam
> > ---
> > Documentation/devicetree/bindings/media/imx.txt | 74
> > +
isp_capture_defs.h: clean up ERROR: Macros with complex values should be
enclosed in parentheses
Signed-off-by: Haim Daniel
---
.../pci/atomisp2/css2400/css_2401_csi2p_system/hrt/isp_capture_defs.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git
a/drivers/staging/media/atom
On Wed, Mar 29, 2017 at 08:36:27AM +0300, Haim Daniel wrote:
> >From 41d35b455f8eb139912909639e914469ef5e06fb Mon Sep 17 00:00:00 2001
> From: Haim Daniel
> Date: Tue, 28 Mar 2017 19:27:57 +0300
> Subject: [PATCH] [media] staging: css2400: fix checkpatch error
>
> isp_capture_defs.h:
What is th
On Mon, Mar 27, 2017 at 05:20:29PM +1100, Eddie Youseph wrote:
> This reverts previous changes to checkpatch warning:
> WARNING: Prefer 'unsigned int' to bare use of 'unsigned'
> ---
> Changes in v2:
> - Added changelog
>
> Changes in v3:
> - Revert changes to using bare unsigned
I do
On Sat, Mar 25, 2017 at 12:05:03AM -0300, Guillermo O. Freschi wrote:
> Made tagged `index` as `__user` to remove warning from
> `obd_iocontrol` call.
Your subject line is odd, please make it match other changes for this
driver.
> Signed-off-by: Guillermo O. Freschi
> ---
> drivers/staging/lust
On Sun, Mar 12, 2017 at 05:30:09PM +0200, Andrii wrote:
> Fixed three code style warnings (multiple line dereference) reported
> by checkpatch.pl script.
>
> Signed-off-by: Andrii Vladyka
> diff --git a/drivers/staging/wlan-ng/hfa384x_usb.c
> b/drivers/staging/wlan-ng/hfa384x_usb.c
> index 6134e
On Sun, Mar 12, 2017 at 06:52:26PM +0200, Andrii wrote:
> Signed-off-by: Andrii Vladyka
I can't take a patch without any changelog text :(
Also, your From: line does not match your signed-off-by line :(
___
devel mailing list
de...@linuxdriverproject.o
On Tue, Mar 28, 2017 at 11:14:06PM -0300, Marcos Paulo de Souza wrote:
> head_up parameter is marked with __user attribute, tmp is filled
> by a copy_from_user from next, that is also marked as __user, so
> tmp.next needs to be "casted" as __user to make sparse happy.
But is it the correct change?
On Wed, Mar 29, 2017 at 10:12:28AM +0300, Haim Daniel wrote:
> isp_capture_defs.h:
What is this line for?
> fix checkpatch ERROR:
Trailing whitespace?
> Macros with complex values should be enclosed in parentheses
>
> Signed-off-by: Haim Daniel
> ---
> .../pci/atomisp2/css2400/css_2401_csi2
On Tue, Mar 28, 2017 at 09:56:19PM +0100, Alfonso Lima Astor wrote:
> Fix coding style issue
>
> Signed-off-by: Alfonso Lima Astor
> ---
> drivers/staging/rtl8188eu/include/rtw_ioctl.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/rtl8188eu/include
On Sun, Mar 26, 2017 at 07:45:12PM +1100, Tobin C. Harding wrote:
> Function tx_device_task() is a candidate for refactoring. Checkpatch
> emits a number of warnings/checks for this function.
>
> Patch 01 inverts if statement conditional and reduces the level of
> nesting.
>
> Patch 02 renames rc
On Mon, Mar 27, 2017 at 03:19:06PM +0300, aviyae wrote:
> Fix coding style issues in macros:
> 1. Add parenthesis around macro arguments
> 2. Avoid arguments reuse in macro
That's different things, please make different patches for this.
Remember, only one patch per "thing" and "fix all style iss
On Mon, Mar 27, 2017 at 03:34:47PM +0100, sfaragnaus wrote:
> This patch fix a minor coding style issue.
You need to be a lot more specific here, and in your subject line.
> Signed-off-by: sfaragnaus
I also need a "real name" here and in the from: line please.
thanks,
greg k-h
___
isp_capture_defs.h:
fix checkpatch ERROR:
Macros with complex values should be enclosed in parentheses
Signed-off-by: Haim Daniel
---
.../pci/atomisp2/css2400/css_2401_csi2p_system/hrt/isp_capture_defs.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git
a/drivers/staging/med
On Wed, Mar 29, 2017 at 12:23:01PM +0530, vaibhavd...@gmail.com wrote:
> From: Vaibhav Kothari
>
> Removed whitespace & comma in fbtft-bus.c as a part of
> checkpatch.pl fix-up.
Did you test build this? Always do so, otherwise you will get grumpy
emails saying you need to test-build your change
On Tue, Mar 28, 2017 at 08:31:37PM -0700, Daniel Cashman wrote:
> From: Dan Cashman
Please list what the issue you fixed in the subject line.
Also change the subject to match others for this driver, a 'git log'
will show you what to do there.
>
> Remove two ' , ' issues and change spaces to ta
On Tue, Mar 28, 2017 at 11:02:45AM +0530, vaibhavd...@gmail.com wrote:
> From: Vaibhav Kothari
>
> Removed extra space before comma in memset() as a part of
> checkpatch.pl fix-up.
>
> Signed-off-by: Vaibhav Kothari
> ---
> drivers/staging/media/atomisp/i2c/gc2235.c | 2 +-
> 1 file changed, 1
62 matches
Mail list logo