Re: git email From: parsing (was Re: [GIT PULL] Staging/IIO driver patches for 4.11-rc1)

2017-02-22 Thread Simon Sandström
On Thu, Feb 23, 2017 at 01:17:02AM -0500, Jeff King wrote: > On Thu, Feb 23, 2017 at 07:04:44AM +0100, Greg KH wrote: > > > > > I don't know what happened, I used git for this, I don't use quilt for > > "normal" patches accepted into my trees anymore, only for stable kernel > > work. > > > > So

[PATCH 2/2] staging: fbtft: Make some s16 arrays const

2017-02-22 Thread Joe Perches
Using const reduces data size. $ size drivers/staging/fbtft/built-in.o* textdata bss dec hex filename 89909 415842928 134421 20d15 drivers/staging/fbtft/built-in.o.new 88053 433922928 134373 20ce5 drivers/staging/fbtft/built-in.o.old Signed-off-by: Joe Per

Re: [PATCH v2] staging: wilc1000: renames struct tstrRSSI and its members u8Index, u8Full

2017-02-22 Thread Joe Perches
On Wed, 2017-02-22 at 20:50 +0100, Arend Van Spriel wrote: > On 22-2-2017 18:14, Tahia Khan wrote: > > Fixes multiple camel case checks on struct tstrRSSI from checkpatch.pl: [] > Just a generic remark that may help you with other changes you will be > making in the linux kernel. Warnings from chec

Re: git email From: parsing (was Re: [GIT PULL] Staging/IIO driver patches for 4.11-rc1)

2017-02-22 Thread Jeff King
On Thu, Feb 23, 2017 at 07:04:44AM +0100, Greg KH wrote: > > Poor Simon Sandström. > > > > Funnily enough, this only exists for one commit. You've got several > > other commits from Simon that get his name right. > > > > What happened? > > I don't know what happened, I used git for this, I don'

git email From: parsing (was Re: [GIT PULL] Staging/IIO driver patches for 4.11-rc1)

2017-02-22 Thread Greg KH
On Wed, Feb 22, 2017 at 11:59:01AM -0800, Linus Torvalds wrote: > On Wed, Feb 22, 2017 at 6:56 AM, Greg KH wrote: > > > > =?UTF-8?q?Simon=20Sandstr=C3=B6m?= (1): > > staging: vt6656: Add missing identifier names > > Wow, your scripts really screwed up that name. > > I'm assuming this is qu

[PATCH 1/2] staging: fbtft: Make the pointers to s16 init arrays const

2017-02-22 Thread Joe Perches
This allows making some of the actual arrays const. Signed-off-by: Joe Perches --- drivers/staging/fbtft/fbtft-core.c | 2 +- drivers/staging/fbtft/fbtft.h | 4 ++-- drivers/staging/fbtft/flexfb.c | 4 ++-- 3 files changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/f

[PATCH 0/2] staging: fbtft: Make s16 arrays const

2017-02-22 Thread Joe Perches
Joe Perches (2): staging: fbtft: Make the pointers to s16 init arrays const staging: fbtft: Make some s16 arrays const drivers/staging/fbtft/fb_ili9481.c | 2 +- drivers/staging/fbtft/fb_ili9486.c | 2 +- drivers/staging/fbtft/fb_s6d02a1.c | 2 +- drivers/staging/fbtft/fb_st7735r.c

Re: [PATCH v3] staging: xgifb: function prototype argument should also have an identifier name

2017-02-22 Thread Tobin C. Harding
Please use the imperative mood in the subject line i.e the short form of git commit log. A couple of example Subjects:: Subject: [PATCH 2/5] ext2: improve scalability of bitmap searching Subject: [PATCH v2 01/27] x86: fix eflags tracking Awesome work on you patches! thanks, Tobin. _

Re: [Linaro-mm-sig] [RFCv3][PATCH 3/5] arm64: Implement ARCH_HAS_FORCE_CACHE

2017-02-22 Thread Chen Feng
On 2017/2/22 3:29, Laura Abbott wrote: > On 02/20/2017 10:05 PM, Chen Feng wrote: >> Hi Laura, >> >> When we enable kernel v4.4 or newer version on our platform, we meet the >> issue >> of flushing cache without reference device. It seems that this patch set is >> a solution. I'm curious the pro

Re: [PATCH v4 23/36] media: imx: Add MIPI CSI-2 Receiver subdev driver

2017-02-22 Thread Steve Longerbeam
On 02/22/2017 04:06 PM, Steve Longerbeam wrote: On 02/17/2017 03:06 AM, Russell King - ARM Linux wrote: On Fri, Feb 17, 2017 at 11:47:59AM +0100, Philipp Zabel wrote: On Wed, 2017-02-15 at 18:19 -0800, Steve Longerbeam wrote: +static void csi2_dphy_init(struct csi2_dev *csi2) +{ +/* +

Re: [PATCH v4 23/36] media: imx: Add MIPI CSI-2 Receiver subdev driver

2017-02-22 Thread Steve Longerbeam
On 02/17/2017 03:06 AM, Russell King - ARM Linux wrote: On Fri, Feb 17, 2017 at 11:47:59AM +0100, Philipp Zabel wrote: On Wed, 2017-02-15 at 18:19 -0800, Steve Longerbeam wrote: +static void csi2_dphy_init(struct csi2_dev *csi2) +{ + /* +* FIXME: 0x14 is derived from a fixed D-P

Re: [PATCH v4 17/36] media: Add userspace header file for i.MX

2017-02-22 Thread Steve Longerbeam
On 02/16/2017 03:33 AM, Philipp Zabel wrote: On Wed, 2017-02-15 at 18:19 -0800, Steve Longerbeam wrote: +/* + * events from the subdevs + */ +#define V4L2_EVENT_IMX_CLASS V4L2_EVENT_PRIVATE_START +#define V4L2_EVENT_IMX_NFB4EOF(V4L2_EVENT_IMX_CLASS + 1) +#define V4L2_EVENT_IM

Re: [PATCH v4 33/36] media: imx: redo pixel format enumeration and negotiation

2017-02-22 Thread Steve Longerbeam
Hi Philipp, On 02/16/2017 03:32 AM, Philipp Zabel wrote: On Wed, 2017-02-15 at 18:19 -0800, Steve Longerbeam wrote: The previous API and negotiation of mbus codes and pixel formats was broken, and has been completely redone. The negotiation of media bus codes should be as follows: CSI: sink

Re: [PATCH v4 23/36] media: imx: Add MIPI CSI-2 Receiver subdev driver

2017-02-22 Thread Steve Longerbeam
On 02/22/2017 03:38 PM, Steve Longerbeam wrote: On 02/17/2017 03:38 AM, Philipp Zabel wrote: On Fri, 2017-02-17 at 11:06 +, Russell King - ARM Linux wrote: On Fri, Feb 17, 2017 at 11:47:59AM +0100, Philipp Zabel wrote: On Wed, 2017-02-15 at 18:19 -0800, Steve Longerbeam wrote: +static

Re: [PATCH v4 23/36] media: imx: Add MIPI CSI-2 Receiver subdev driver

2017-02-22 Thread Steve Longerbeam
On 02/17/2017 03:38 AM, Philipp Zabel wrote: On Fri, 2017-02-17 at 11:06 +, Russell King - ARM Linux wrote: On Fri, Feb 17, 2017 at 11:47:59AM +0100, Philipp Zabel wrote: On Wed, 2017-02-15 at 18:19 -0800, Steve Longerbeam wrote: +static void csi2_dphy_init(struct csi2_dev *csi2) +{ +

Re: Comedi use of standard types

2017-02-22 Thread Dan Carpenter
On Thu, Feb 23, 2017 at 07:48:59AM +1100, Tobin C. Harding wrote: > On Wed, Feb 22, 2017 at 04:51:05PM +0300, Dan Carpenter wrote: > > On Wed, Feb 22, 2017 at 11:46:07AM +, Ian Abbott wrote: > > > On 21/02/17 21:27, Tobin C. Harding wrote: > > > >Comedi drivers make heavy use of standard types

[PATCHv2] Checkpatch fixes for staging/drivers/ks7010.

2017-02-22 Thread Matthew Giassa
Wrapping complex macros with parentheses. Adding extra spaces between macros and integer literals. Indentation changes to remove checkpatch warnings. Swapping out C++-style comments with C-style comments. Signed-off-by: Matthew Giassa --- drivers/staging/ks7010/ks_wlan_ioctl.h | 74 +

Re: Comedi use of standard types

2017-02-22 Thread Tobin C. Harding
On Wed, Feb 22, 2017 at 04:51:05PM +0300, Dan Carpenter wrote: > On Wed, Feb 22, 2017 at 11:46:07AM +, Ian Abbott wrote: > > On 21/02/17 21:27, Tobin C. Harding wrote: > > >Comedi drivers make heavy use of standard types i.e unsigned > > >short. According to Linux Device Drivers standard C data

Re: [PATCH 2/3] staging: comedi: Remove level of indentation

2017-02-22 Thread Tobin C. Harding
On Wed, Feb 22, 2017 at 11:52:49AM +, Ian Abbott wrote: > On 21/02/17 20:32, Tobin C. Harding wrote: > >On Tue, Feb 21, 2017 at 03:55:18PM +, Ian Abbott wrote: > >>On 21/02/17 11:18, Tobin C. Harding wrote: > >> > >>For comedi patches affecting a single driver, we prefer the driver name to

Re: [GIT PULL] Staging/IIO driver patches for 4.11-rc1

2017-02-22 Thread Linus Torvalds
On Wed, Feb 22, 2017 at 6:56 AM, Greg KH wrote: > > =?UTF-8?q?Simon=20Sandstr=C3=B6m?= (1): > staging: vt6656: Add missing identifier names Wow, your scripts really screwed up that name. I'm assuming this is quilt not doing proper character set handling.. Because if it's git, we need to g

Re: [PATCH v2] staging: wilc1000: renames struct tstrRSSI and its members u8Index, u8Full

2017-02-22 Thread Arend Van Spriel
On 22-2-2017 18:14, Tahia Khan wrote: > Fixes multiple camel case checks on struct tstrRSSI from checkpatch.pl: > > Avoid CamelCase: > Avoid CamelCase: > Avoid CamelCase: Just a generic remark that may help you with other changes you will be making in the linux kernel. Warnings from checkpatch

[PATCH 2/2] Staging: xgifb:XGI_main_26: Added braces to the conditional statement

2017-02-22 Thread Georgios Emmanouil
Coding style issue. Added brances to the conditional statement. Signed-off-by: Georgios Emmanouil --- drivers/staging/xgifb/XGI_main_26.c | 11 ++- 1 file changed, 6 insertions(+), 5 deletions(-) diff --git a/drivers/staging/xgifb/XGI_main_26.c b/drivers/staging/xgifb/XGI_main_26.c ind

[PATCH 1/2] Staging: xgifb:XGI_main_26: Added braces to the 'if' statement

2017-02-22 Thread Georgios Emmanouil
Coding style issue. Added brances to the 'if' statement. Signed-off-by: Georgios Emmanouil --- drivers/staging/xgifb/XGI_main_26.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/xgifb/XGI_main_26.c b/drivers/staging/xgifb/XGI_main_26.c index 6930f7e..c4f

[PATCH v3] staging: xgifb: function prototype argument should also have an identifier name

2017-02-22 Thread Arushi Singhal
function prototype argument 'struct vb_device_info *' and 'unsigned long' should also have an identifier name. Signed-off-by: Arushi Singhal --- changes in v3 -make the subject title more relevant. -change the identifier of struct vb_device_info to XGI_Pr. --- drivers/staging/xgifb/vb_init.h |

Re: [PATCH v2] staging: xgifb: function definition argument should also have an identifier name'

2017-02-22 Thread Greg Kroah-Hartman
On Sat, Feb 18, 2017 at 07:16:11PM +0530, Arushi Singhal wrote: > function definition argument 'struct vb_device_info *' and 'unsigned > long' should also have an identifier name. > > Signed-off-by: Arushi Singhal > --- > drivers/staging/xgifb/vb_init.h | 3 +-- > 1 file changed, 1 insertion(+),

Re: [PATCH] Staging: xgifb:XGI_main_26: Fixed coding style issues

2017-02-22 Thread Greg KH
On Sat, Feb 18, 2017 at 11:29:46AM +0200, Georgios Emmanouil wrote: > Fixed coding style issues. Patch applies to linux-next-20170217 tree. > > Signed-off-by: Georgios Emmanouil _what_ coding style issues did you fix? Please be specific and do not try to fix more than one "type" of issue in a s

Re: [PATCH v4 12/36] add mux and video interface bridge entity functions

2017-02-22 Thread Steve Longerbeam
On 02/19/2017 01:28 PM, Pavel Machek wrote: On Wed 2017-02-15 18:19:14, Steve Longerbeam wrote: From: Philipp Zabel Signed-off-by: Philipp Zabel - renamed MEDIA_ENT_F_MUX to MEDIA_ENT_F_VID_MUX Signed-off-by: Steve Longerbeam This is slightly "interesting" format of changelog. Normally

[PATCH v2] staging: wilc1000: renames struct tstrRSSI and its members u8Index, u8Full

2017-02-22 Thread Tahia Khan
Fixes multiple camel case checks on struct tstrRSSI from checkpatch.pl: Avoid CamelCase: Avoid CamelCase: Avoid CamelCase: Signed-off-by: Tahia Khan --- drivers/staging/wilc1000/coreconfigurator.h | 8 drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 10 +- 2 files

[GIT PULL] Staging/IIO driver patches for 4.11-rc1

2017-02-22 Thread Greg KH
The following changes since commit d5adbfcd5f7bcc6fa58a41c5c5ada0e5c826ce2c: Linux 4.10-rc7 (2017-02-05 15:10:58 -0800) are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git/ tags/staging-4.11-rc1 for you to fetch changes up to 0a441275018

Re: Comedi use of standard types

2017-02-22 Thread Dan Carpenter
On Wed, Feb 22, 2017 at 04:51:05PM +0300, Dan Carpenter wrote: > > >Is the choice (size) of type in a struct (eg struct ni_private, > > >comedi/drivers/ni_stc.h) a kernel design issue or is it a hardware > > >issue and should I be reading the manual to find it. > > > > It's mostly a design issue.

Re: Comedi use of standard types

2017-02-22 Thread Dan Carpenter
On Wed, Feb 22, 2017 at 11:46:07AM +, Ian Abbott wrote: > On 21/02/17 21:27, Tobin C. Harding wrote: > >Comedi drivers make heavy use of standard types i.e unsigned > >short. According to Linux Device Drivers standard C data types are not > >the same size of all architectures. > > > >Should we

[PATCH v3 2/2] staging: ks7010: Unnecessary parentheses are removed and also improved coding style.

2017-02-22 Thread Arushi Singhal
Unnecessary parentheses are removed as reported by checkpatch.pl to make coder nicer and to improve readability. Also coding style is improved.For example:- It's often nicer to read if &(foo[0]) is converted to foo like: memcpy(&(ap->bssid[0]), &(ap_info->bssid[0]), ETH_ALEN); memcpy(ap->

[PATCH] staging, android: remove lowmemory killer from the tree

2017-02-22 Thread Michal Hocko
From: Michal Hocko Lowmemory killer is sitting in the staging tree since 2008 without any serious interest for fixing issues brought up by the MM folks. The main objection is that the implementation is basically broken by design: - it hooks into slab shrinker API which is not suitable for

Re: [PATCH 2/3] staging: comedi: Remove level of indentation

2017-02-22 Thread Ian Abbott
On 21/02/17 20:32, Tobin C. Harding wrote: On Tue, Feb 21, 2017 at 03:55:18PM +, Ian Abbott wrote: On 21/02/17 11:18, Tobin C. Harding wrote: For comedi patches affecting a single driver, we prefer the driver name to be mentioned in the patch subject, like... staging: comedi: cb_pcidas64:

[PATCH v3 1/1] staging: ks7010: Unnecessary parentheses are removed and also improved coding style.

2017-02-22 Thread Arushi Singhal
Unnecessary parentheses are removed as reported by checkpatch.pl to make coder nicer and to improve readability. Also coding style is improved.For example:- It's often nicer to read if &(foo[0]) is converted to foo like: memcpy(&(ap->bssid[0]), &(ap_info->bssid[0]), ETH_ALEN); memcpy(ap->

Re: Comedi use of standard types

2017-02-22 Thread Ian Abbott
On 21/02/17 21:27, Tobin C. Harding wrote: Comedi drivers make heavy use of standard types i.e unsigned short. According to Linux Device Drivers standard C data types are not the same size of all architectures. Should we be converting comedi/drivers to use kernel types u8, u16 etc Linux kernel

Re: [Outreachy kernel] [PATCH v2 2/7] staging: most: Using macro DIV_ROUND_UP

2017-02-22 Thread Julia Lawall
On Wed, 22 Feb 2017, SIMRAN SINGHAL wrote: > > > On Wednesday, February 22, 2017 at 2:57:17 PM UTC+5:30, Julia Lawall wrote: > > @@ -117,7 +118,7 @@ static int alloc_dbr(u16 size) > >  return DBR_SIZE; /* out of memory */ > > > >  for (i = 0; i < D

[PATCH] staging: xgifb: function prototype argument should have an identifier name

2017-02-22 Thread Arushi Singhal
function prototype arguments like 'struct vb_device_info *','unsigned long' etc. should have an identifier name. Signed-off-by: Arushi Singhal --- Changes in v3: - By mistake one irrelevant line was added which is removed in this patch. - write the changes done in previous version in corr

Re: [PATCH] staging: comedi: s626: Kernel doc format comments

2017-02-22 Thread Ian Abbott
On 21/02/17 22:45, Tobin C. Harding wrote: Checkpatch emits WARNING: Block comments use a trailing */ on a separate line. Offending comments are commenting variables within the main data structure of s626 driver. We can move these comments to kernel doc format with the benefit of clearing the war

Re: [PATCH v2] Staging: comedi: drivers: comedi_test: Avoid multiple line dereference

2017-02-22 Thread Ian Abbott
On 21/02/17 17:25, Cheah Kok Cheong wrote: Fix checkpatch warning "Avoid multiple line dereference" using a pointer variable to avoid line wrap. Signed-off-by: Cheah Kok Cheong --- V2: -Use pointer instead of normal variable - Ian -Variable is to be used as "write destination" and not as "rea

Re: [PATCH-SPEAKUP 2/2] remove unecessary initial allocation of vc

2017-02-22 Thread Samuel Thibault
Pranay Kr. Srivastava, on mer. 22 févr. 2017 12:50:27 +0530, wrote: > This patch removes the unnecessary allocation of > current foreground vc during initialization. > > This initialization is already handled in the loop > that follows it for all available virtual consoles. > > Also change the pr

Re: [PATCH-SPEAKUP 1/2] return same error value from spk_set_key_info

2017-02-22 Thread Samuel Thibault
Pranay Kr. Srivastava, on mer. 22 févr. 2017 12:50:26 +0530, wrote: > This patch makes spk_set_key_info return -EINVAL > in case of failure instead of returning 4 different > values for the type of error that occurred. > > Print the offending values instead as debug message. > > Signed-off-by: Pr

Re: [Outreachy kernel] [PATCH v2 2/7] staging: most: Using macro DIV_ROUND_UP

2017-02-22 Thread Joe Perches
On Wed, 2017-02-22 at 10:27 +0100, Julia Lawall wrote: > > @@ -117,7 +118,7 @@ static int alloc_dbr(u16 size) > > return DBR_SIZE; /* out of memory */ > > > > for (i = 0; i < DBR_MAP_SIZE; i++) { > > - u32 const blocks = (size + DBR_BLOCK_SIZE - 1) / DBR_BLOCK_SIZE; > > +

[PATCH v2 5/6] staging: lustre: Using macro DIV_ROUND_UP

2017-02-22 Thread simran singhal
The macro DIV_ROUND_UP performs the computation (((n) + (d) - 1) /(d)). It clarifies the divisor calculations. This occurence was detected using the coccinelle script: @@ expression e1; expression e2; @@ ( - ((e1) + e2 - 1) / (e2) + DIV_ROUND_UP(e1,e2) | - ((e1) + (e2 - 1)) / (e2) + DIV_ROUND_UP(e

Re: [Outreachy kernel] [PATCH v2 2/7] staging: most: Using macro DIV_ROUND_UP

2017-02-22 Thread Julia Lawall
> @@ -117,7 +118,7 @@ static int alloc_dbr(u16 size) > return DBR_SIZE; /* out of memory */ > > for (i = 0; i < DBR_MAP_SIZE; i++) { > - u32 const blocks = (size + DBR_BLOCK_SIZE - 1) / DBR_BLOCK_SIZE; > + u32 const blocks = DIV_ROUND_UP(size, DBR_BLOCK_S

[PATCH v2 2/7] staging: most: Using macro DIV_ROUND_UP

2017-02-22 Thread simran singhal
The macro DIV_ROUND_UP performs the computation (((n) + (d) - 1) /(d)). It clarifies the divisor calculations. This occurence was detected using the coccinelle script: @@ expression e1; expression e2; @@ ( - ((e1) + e2 - 1) / (e2) + DIV_ROUND_UP(e1,e2) | - ((e1) + (e2 - 1)) / (e2) + DIV_ROUND_UP(e

Re: [PATCH] Staging: comedi: drivers: comedi_test: Avoid multiple line dereference

2017-02-22 Thread Valentin Rothberg
On Feb 21 '17 09:22, Joe Perches wrote: > On Wed, 2017-02-22 at 00:31 +0800, Cheah Kok Cheong wrote: > > > Another option could be using the typedefs from include/linux/types.h, > > > e.g. ushort. However, this might require changing other declarations as > > > well to keep consistency. > > > > T