Hi Arushi,
[auto build test ERROR on staging/staging-testing]
[also build test ERROR on v4.10 next-20170217]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Arushi-Singhal/staging-ks7010-Unnecess
On Mon, 20 Feb 2017, Arushi Singhal wrote:
> Unnecessary parentheses should be avoided as reported by checkpatch.pl.
> Remove unnecessary parentheses, as reported by checkpatch as are nicer
> to read.For example:-
> It's often nicer to read if &(foo[0]) is converted to foo like:
> memcpy(&(
Unnecessary parentheses should be avoided as reported by checkpatch.pl.
Remove unnecessary parentheses, as reported by checkpatch as are nicer
to read.For example:-
It's often nicer to read if &(foo[0]) is converted to foo like:
memcpy(&(ap->bssid[0]), &(ap_info->bssid[0]), ETH_ALEN);
mem
On Sun, 19 Feb 2017, Katie Dunne wrote:
> Remove spaces after casts found by checkpatch.pl. In some cases,
> remove returns after casts and place them on a single line.
What do you mean by "returns after casts"? I didn't see anything like
that.
julia
>
> Signed-off-by: Katie Dunne
> ---
> dr
Checkpatch emits messages relating to macro definition
CHECK: spaces preferred around that '*' (ctx:VxV)
ERROR: Macros with complex values should be enclosed in parentheses
Add space around '*'. Add parentheses to macro definition.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks70
Checkpatch emits various whitespace messages;
ERROR: trailing whitespace
WARNING: Unnecessary space before function pointer arguments
CHECK: Please use a blank line after function/struct/union/enum
Remove trailing whitespace. Remove unnecessary space. Add blank line
after struct definition.
Sign
Checkpatch emits various messages. Struct ks_stdio_card contains a
spinlock. It is never used. The data structure contains two fields,
both of which are accessed in ways that don't seem to allow use of a
spinlock. I am not fully qualified however to analyse this.
Spinlock is either not correctly u
Code may be refactored to take advantage of previous commit.
Refactor code. Introduce four new line over 80 warnings. Make code
more legible.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 31 +--
1 file changed, 9 insertions(+), 22 deleti
Checkpatch emits warning that code is too deeply nested.
Remove one level of nesting by inverting if statement conditional
and using goto to maintain program logic.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 151 ++-
1 file changed
Checkpatch emits warning because string is split over two lines.
Concatenate string onto single line.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/
Code is able to be refactored. Various assignments have the assigning
value on a separate line.
Refactor code bring it closer to kernel standards.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 29 +
1 file changed, 9 insertions(+), 20 del
Checkpatch emits two CHECK messages;
CHECK: Logical continuations should be on the previous line
CHECK: Alignment should match open parenthesis
Move logical continuations onto the previous line. Add whitespace to
align code with parenthesis.
Signed-off-by: Tobin C. Harding
---
drivers/staging/k
Code can be refactored to take advantage of indentation removal in
previous commit. Code is still nested quite deeply. Variable name
retval takes up six characters, this is significant because 80
character line limit is being hit frequently.
Change variable name retval to ret to get an extra three
Checkpatch emits WARNING: Too many leading tabs - consider code
refactoring. Code in question is nested under two if statements.
Outside of if statements there is the return statement. If statement
conditionals can be inverted and function made to return immediately
without changing program logic.
There are multiple line dereferences. This leaves a '.' as the
last character of the line and makes the code hard to read.
Move variable dereference onto single line. Even if this causes line
over 80 warning.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 16 ++--
There are blocks of code that are commented out.
Remove commented out code. Fix two small spelling typo's.
Signed-off-by: Tobin C. Harding
---
drivers/staging/ks7010/ks7010_sdio.c | 8 +++-
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
Checkpatch emits numerous warnings and checks. Line over 80 warnings
are not touched. Each patch addresses an individual checkpatch warning
(or check). Code is refactored over a series of patches in an effort
to modularize the changes. When a patch reduces the indentation no
other changes are made
From: Julián de Gortari
__be16 type variables should be used with return value of macro
cpu_to_be16()
Signed-off-by: Julián de Gortari
---
drivers/staging/fbtft/fb_watterott.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fb_watterott.c
b/driv
Remove spaces after casts found by checkpatch.pl. In some cases,
remove returns after casts and place them on a single line.
Signed-off-by: Katie Dunne
---
drivers/staging/ks7010/ks_hostif.c | 206 ++---
1 file changed, 102 insertions(+), 104 deletions(-)
diff --
> This is unbreaking another of those "stealth" janitor
> patches that got in and subtly broke some things.
>
> sv_cpt_data is a pointer to pointer, so need to
> dereference it twice to allocate the correct structure size.
>
> Fixes: 9899cb68c6c23d58b27035c237b2d425f4c6133c
> CC: Sandhya Bankar
> In Linux kernel 4.9-rc1, the function ib_get_dma_mr()
> was removed and a second parameter was added to ib_alloc_pd().
> As this broke the building of the ko2iblnd module in
> staging, the Kconfig for LNet has marked ko2iblnd as broken
> and stopped building it.
>
> This patch fixes this breaka
Hi!
> From: Philipp Zabel
>
> This driver can handle SoC internal and external video bus multiplexers,
> controlled either by register bit fields or by a GPIO. The subdevice
> passes through frame interval and mbus configuration of the active input
> to the output side.
>
> Signed-off-by: Sasch
Unnecessary parentheses should be avoided as reported by checkpatch.pl.
Remove unnecessary parentheses, as reported by checkpatch as are nicer
to read.For example:-
It's often nicer to read if &(foo[0]) is converted to foo like:
memcpy(&(ap->bssid[0]), &(ap_info->bssid[0]), ETH_ALEN);
mem
Change null comparisons of the form x == NULL to !x.
This was done using Coccinelle.
@@ expression e;
@@
- e == NULL
+ !e
Signed-off-by: simran singhal
---
drivers/staging/rtl8192e/rtl819x_TSProc.c| 2 +-
drivers/staging/rtl8192e/rtllib_crypt_ccmp.c | 2 +-
drivers/staging/rtl8192e/rtllib_c
This is unbreaking another of those "stealth" janitor
patches that got in and subtly broke some things.
sv_cpt_data is a pointer to pointer, so need to
dereference it twice to allocate the correct structure size.
Fixes: 9899cb68c6c23d58b27035c237b2d425f4c6133c
CC: Sandhya Bankar
Signed-off-by: O
On Wed 2017-02-15 18:19:16, Steve Longerbeam wrote:
> v4l2_pipeline_inherit_controls() will add the v4l2 controls from
> all subdev entities in a pipeline to a given video device.
>
> Signed-off-by: Steve Longerbeam
Reviewed-by: Pavel Machek
--
(english) http://www.livejournal.com/~pavelmache
On Wed 2017-02-15 18:19:14, Steve Longerbeam wrote:
> From: Philipp Zabel
>
> Signed-off-by: Philipp Zabel
>
> - renamed MEDIA_ENT_F_MUX to MEDIA_ENT_F_VID_MUX
>
> Signed-off-by: Steve Longerbeam
This is slightly "interesting" format of changelog. Normally signoffs
go below.
> diff --git a/
On Sun, 19 Feb 2017, Joe Perches wrote:
> On Sun, 2017-02-19 at 19:58 +0100, Julia Lawall wrote:
> > On Sun, 19 Feb 2017, Joe Perches wrote:
> > > On Sun, 2017-02-19 at 23:56 +0530, Arushi Singhal wrote:
> > > > Unnecessary parentheses should be avoided as reported by checkpatch.pl.
> > > > Remo
On Sun, 2017-02-19 at 19:58 +0100, Julia Lawall wrote:
> On Sun, 19 Feb 2017, Joe Perches wrote:
> > On Sun, 2017-02-19 at 23:56 +0530, Arushi Singhal wrote:
> > > Unnecessary parentheses should be avoided as reported by checkpatch.pl.
> > > Remove unnecessary parentheses, as reported by checkpatch
On Sun, 19 Feb 2017, Joe Perches wrote:
> On Sun, 2017-02-19 at 23:56 +0530, Arushi Singhal wrote:
> > Unnecessary parentheses should be avoided as reported by checkpatch.pl.
> > Remove unnecessary parentheses, as reported by checkpatch as are nicer
> > to read.For example:-
> > It's often nicer
On Sun, 19 Feb 2017, Arushi Singhal wrote:
> Unnecessary parentheses should be avoided as reported by checkpatch.pl.
> Remove unnecessary parentheses, as reported by checkpatch as are nicer
> to read.For example:-
> It's often nicer to read if &(foo[0]) is converted to foo like:
> memcpy(&(
On Sat, 2017-02-18 at 18:00 +0100, Julia Lawall wrote:
> On Sat, 18 Feb 2017, Arushi Singhal wrote:
> > The following patch the checkpatch.pl warning:
> > drivers/staging/ks7010/ks_hostif.c warning: please, no spaces at the
> > start of a line
[]
> > diff --git a/drivers/staging/ks7010/ks_hostif.c
Unnecessary parentheses should be avoided as reported by checkpatch.pl.
Remove unnecessary parentheses, as reported by checkpatch as are nicer
to read.For example:-
It's often nicer to read if &(foo[0]) is converted to foo like:
memcpy(&(ap->bssid[0]), &(ap_info->bssid[0]), ETH_ALEN);
mem
On Sun, 2017-02-19 at 23:56 +0530, Arushi Singhal wrote:
> Unnecessary parentheses should be avoided as reported by checkpatch.pl.
> Remove unnecessary parentheses, as reported by checkpatch as are nicer
> to read.For example:-
> It's often nicer to read if &(foo[0]) is converted to foo like:
>
Unnecessary parentheses should be avoided as reported by checkpatch.pl.
Remove unnecessary parentheses, as reported by checkpatch as are nicer
to read.For example:-
It's often nicer to read if &(foo[0]) is converted to foo like:
memcpy(&(ap->bssid[0]), &(ap_info->bssid[0]), ETH_ALEN);
mem
On Sun, 19 Feb 2017, Arushi Singhal wrote:
> Unnecessary parentheses should be avoided as reported by checkpatch.pl
>
> Signed-off-by: Arushi Singhal
> ---
If you send a v2 for a patch, then you need to say below the --- what the
v2 changes. Also, you need to resend all the patches in the ser
Unnecessary parentheses should be avoided as reported by checkpatch.pl
Signed-off-by: Arushi Singhal
---
drivers/staging/ks7010/ks_hostif.c | 24
drivers/staging/ks7010/ks_wlan_net.c | 20 ++--
2 files changed, 22 insertions(+), 22 deletions(-)
diff --
On Sun, 19 Feb 2017, Arushi Singhal wrote:
> Unnecessary parentheses should be avoided as reported by checkpatch.pl
The commit message should be written in a positive way, to say what you
are doing, and not in a negative way, saying what you are avoiding. So
here you could say "Remove unnecess
Unnecessary parentheses should be avoided as reported by checkpatch.pl
Signed-off-by: Arushi Singhal
---
drivers/staging/ks7010/ks_hostif.c | 24
drivers/staging/ks7010/ks_wlan_net.c | 20 ++--
2 files changed, 22 insertions(+), 22 deletions(-)
diff --
On Sun, 19 Feb 2017, Arushi Singhal wrote:
>
> Hi Greg
> I think we cannot indent the text otherwise, the print statement will be
> different as it should be
There are newlines in the printed string. I suspect that there is no need
to print them all at once.
Actually, your change removed spac
On 12/02/17 11:04, Brian Masney wrote:
> On Sun, Feb 12, 2017 at 05:55:34AM -0500, Brian Masney wrote:
>> Move ISL29028 ALS / Proximity Sensor out of staging and into mainline.
>>
>> Signed-off-by: Brian Masney
>
> Sorry, Jonathan, I forgot to run git format-patch with --no-renames and
> didn't r
On 12/02/17 10:55, Brian Masney wrote:
> The sysfs attribute in_proximity_sampling_frequency_available currently
> shows the values 1 3 5 10 13 20 83 100. These values are supposed to
> correspond to the sleep values 800 400 200 100 75 50 12 0 (all in ms).
> When passing in a sampling frequency of
On 12/02/17 07:22, Derek Robson wrote:
> Change permissions to octal style.
> Found using checkpatch
>
> Signed-off-by: Derek Robson
Applied to the togreg branch of iio.git and pushed out as testing for the
autobuilders
to play with it.
Jonathan
> ---
> drivers/staging/iio/impedance-analyzer/a
If 'kzalloc()' fails, we should release resources allocated so far, just as
done in all other cases in this function.
Signed-off-by: Christophe JAILLET
---
Not sure that the error handling path is correct.
Is 'gdev[0]' freed? Should it be?
---
drivers/staging/media/platform/bcm2835/bcm2835-camer
44 matches
Mail list logo