On Fri, 2017-02-03 at 22:26 -0600, Parav Pandit wrote:
> This patch makes use of is_vlan_dev() function instead of flag
> comparison which is exactly done by is_vlan_dev() helper function.
Thanks.
btw: after applying this patch, there is one left
$ git grep -E -n "&\s*IFF_802_1Q_VLAN\b" -- "*.c
(adding Julia Lawall)
On Fri, 2017-02-03 at 20:44 -0800, Guenter Roeck wrote:
> On Sat, Jan 28, 2017 at 07:05:09PM +1300, Derek Robson wrote:
> > A style fix across whole driver.
> > changed permissions to octal style, found using checkpatch
> >
> > Signed-off-by: Derek Robson
>
> FWIW, I think
Changed function definition argument to have identifier name.
found using checkpatch
Signed-off-by: Derek Robson
---
Version 1 had missing ; and so broke the build
drivers/staging/speakup/spk_priv.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/speakup
On Sat, Jan 28, 2017 at 07:05:09PM +1300, Derek Robson wrote:
> A style fix across whole driver.
> changed permissions to octal style, found using checkpatch
>
> Signed-off-by: Derek Robson
FWIW, I think changes like this are best done using coccinelle.
That ensures that the results can be repro
Fix checkpatch error:
ERROR: space prohibited before that close parenthesis ')'
Signed-off-by: Youngdo Lee
---
drivers/staging/fbtft/fbtft-bus.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft-bus.c
b/drivers/staging/fbtft/fbtft-bus.c
index e
This patch makes use of is_vlan_dev() function instead of flag
comparison which is exactly done by is_vlan_dev() helper function.
Signed-off-by: Parav Pandit
Reviewed-by: Daniel Jurgens
---
drivers/infiniband/core/cma.c| 6 ++
drivers/infiniband/sw/rxe/rxe_net.c
On Sat, Feb 04, 2017 at 12:56:41PM +1300, Derek Robson wrote:
> Changed function definition argument to have identifier name.
> found using checkpatch
>
> Signed-off-by: Derek Robson
> ---
> drivers/staging/speakup/spk_priv.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff
On Sat, 2017-02-04 at 16:31 +1300, Derek Robson wrote:
> On Sat, Feb 04, 2017 at 10:41:20AM +0800, kbuild test robot wrote:
> > Hi Derek,
> >
> > [auto build test ERROR on staging/staging-testing]
> > [also build test ERROR on v4.10-rc6 next-20170203]
> > [if y
On Sat, Feb 04, 2017 at 10:41:20AM +0800, kbuild test robot wrote:
> Hi Derek,
>
> [auto build test ERROR on staging/staging-testing]
> [also build test ERROR on v4.10-rc6 next-20170203]
> [if your patch is applied to the wrong git tree, please drop us a note to
> help
Hi Derek,
[auto build test ERROR on staging/staging-testing]
[also build test ERROR on v4.10-rc6 next-20170203]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Derek-Robson/Drivers-staging
Hi Derek,
[auto build test ERROR on staging/staging-testing]
[also build test ERROR on v4.10-rc6 next-20170203]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Derek-Robson/Drivers-staging
On 02/03/2017 12:44 PM, Greg KH wrote:
> On Fri, Feb 03, 2017 at 12:38:45PM -0800, Florian Fainelli wrote:
>> On 02/03/2017 12:36 PM, Greg KH wrote:
>>> On Fri, Feb 03, 2017 at 10:57:16AM -0800, Joe Perches wrote:
On Fri, 2017-02-03 at 10:50 -0800, Florian Fainelli wrote:
> (with JC's ot
Changed symbolic permissions to octal permissions.
Found using checkpatch
Signed-off-by: Derek Robson
---
drivers/staging/iio/resolver/ad2s1210.c | 24
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/iio/resolver/ad2s1210.c
b/drivers/stag
Changed function definition argument to have identifier name.
found using checkpatch
Signed-off-by: Derek Robson
---
drivers/staging/speakup/spk_priv.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/speakup/spk_priv.h
b/drivers/staging/speakup/spk_priv.h
On Fri, Feb 03, 2017 at 07:49:26PM +0530, Abhijit Naik wrote:
> This patch will increase readability of xmit_linux.c file.
>
> Removed following type of coding style warnings generated for xmit_linux.c,
> 1. Braces {} are not necessary for single statement blocks
> 2. Block comments us
On 02/03/2017 12:36 PM, Greg KH wrote:
> On Fri, Feb 03, 2017 at 10:57:16AM -0800, Joe Perches wrote:
>> On Fri, 2017-02-03 at 10:50 -0800, Florian Fainelli wrote:
>>> (with JC's other email)
>>
>> And now with Greg's proper email too
>>
>>> On 02/03/2017 10:47 AM, Joe Perches wrote:
64 bit st
On Fri, Feb 03, 2017 at 12:38:45PM -0800, Florian Fainelli wrote:
> On 02/03/2017 12:36 PM, Greg KH wrote:
> > On Fri, Feb 03, 2017 at 10:57:16AM -0800, Joe Perches wrote:
> >> On Fri, 2017-02-03 at 10:50 -0800, Florian Fainelli wrote:
> >>> (with JC's other email)
> >>
> >> And now with Greg's pro
On Fri, Feb 03, 2017 at 10:57:16AM -0800, Joe Perches wrote:
> On Fri, 2017-02-03 at 10:50 -0800, Florian Fainelli wrote:
> > (with JC's other email)
>
> And now with Greg's proper email too
>
> > On 02/03/2017 10:47 AM, Joe Perches wrote:
> > > 64 bit stats isn't implemented, but is that really
On Fri, 2017-02-03 at 13:10 +0100, Slawomir Stepien wrote:
> On Feb 03, 2017 11:27, Greg KH wrote:
> > On Fri, Feb 03, 2017 at 11:11:35AM +0100, Slawomir Stepien wrote:
> > > Hi all
> > >
> > > There is a "false positive" error reported by checkpatch.pl:
> > >
> > > ERROR: Use 4 digit octal (0777
On Fri, 2017-02-03 at 10:50 -0800, Florian Fainelli wrote:
> (with JC's other email)
And now with Greg's proper email too
> On 02/03/2017 10:47 AM, Joe Perches wrote:
> > 64 bit stats isn't implemented, but is that really necessary?
> > Anything else?
>
> Joe, do you have such hardware that you
64 bit stats isn't implemented, but is that really necessary?
Anything else?
It seems like the driver doesn't need to be there anymore.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverd
Em Fri, 27 Jan 2017 13:55:00 -0800
Eric Anholt escreveu:
> This is derived from the downstream tree's build system, but with just
> a single Kconfig option.
>
> For now the driver only builds on 32-bit arm -- the aarch64 build
> breaks due to the driver using arm-specific cache flushing function
(with JC's other email)
On 02/03/2017 10:47 AM, Joe Perches wrote:
> 64 bit stats isn't implemented, but is that really necessary?
> Anything else?
Joe, do you have such hardware that you are interested in getting
supported, or was that just to reduce the amount of drivers in staging?
I am really
The VC_AUDIO_MAX_MSG_LEN macro is not used anywhere and has coding style
violations.
Signed-off-by: Hendrik v. Raven
---
drivers/staging/bcm2835-audio/vc_vchi_audioserv_defs.h | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/bcm2835-audio/vc_vchi_audioserv_defs.h
b/drivers/
On 02/02/2017 02:29 PM, Russell King - ARM Linux wrote:
On Thu, Feb 02, 2017 at 11:12:41AM -0800, Steve Longerbeam wrote:
Here is the current .queue_setup() op in imx-media-capture.c:
static int capture_queue_setup(struct vb2_queue *vq,
unsigned int *nbuffers,
On Fri, 2017-02-03 at 17:17 +0100, Hendrik v. Raven wrote:
> VC_AUDIO_MAX_MSG_LEN
This macro seems unused and might as well be removed.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev
On 02/03/2017 06:41 AM, Laurent Pinchart wrote:
Hello,
On Wednesday 01 Feb 2017 16:19:27 Steve Longerbeam wrote:
On 02/01/2017 01:30 AM, Philipp Zabel wrote:
media-ctl propagates the output pad format to all remote subdevices'
input pads for all enabled links:
https://git.linuxtv.org/v4l-u
Removed unnecessary spaces around parenthesis as reported by checkpatch.pl
Signed-off-by: Michael Rupprecht
---
drivers/staging/bcm2835-audio/bcm2835-vchiq.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/bcm2835-audio/bcm2835-vchiq.c
b/driv
removes the unwanted spaces inside of sizeof( ), removing a complaint of
checkpatch.pl. Also removes the second space behind the macro name.
Signed-off-by: Hendrik v. Raven
---
drivers/staging/bcm2835-audio/vc_vchi_audioserv_defs.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --gi
On 02/03/2017 02:02 AM, Stuart Yoder wrote:
>
>> -Original Message-
>> From: upstream-release-boun...@linux.freescale.net [mailto:upstream-release-
>> boun...@linux.freescale.net] On Behalf Of laurentiu.tu...@nxp.com
>> Sent: Wednesday, February 01, 2017 5:43 AM
>> To: gre...@linuxfoundat
WARNING: Symbolic permissions 'S_IRUGO' are not preferred.
Consider using octal permissions '0444'.
This warning was detected by checkpatch.pl for hdm_i2c.c.
Signed-off-by: Zhengyi Shen
---
drivers/staging/most/hdm-i2c/hdm_i2c.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a
Hello,
On Wednesday 01 Feb 2017 16:19:27 Steve Longerbeam wrote:
> On 02/01/2017 01:30 AM, Philipp Zabel wrote:
> > On Tue, 2017-01-31 at 17:26 -0800, Steve Longerbeam wrote:
> > [...]
> >
> >>> # Set pad formats
> >>> media-ctl --set-v4l2 "'tc358743 1-000f':0[fmt:UYVY/1920x1080]"
> >>> media-ctl
This patch will increase readability of xmit_linux.c file.
Removed following type of coding style warnings generated for xmit_linux.c,
1. Braces {} are not necessary for single statement blocks
2. Block comments use a trailing */ on a separate line
Signed-off-by: Abhijit Naik
---
From: Kamal Heib
This patch fix the line over 80 characters warning that was detected
using checkpatch.pl script.
Fixes: 6fe5efa1415c ('staging: octeon: Convert create_singlethread_workqueue()')
Cc: Bhaktipriya Shridhar
Signed-off-by: Kamal Heib
---
drivers/staging/octeon/ethernet.c | 3 ++-
On Feb 03, 2017 04:39, Joe Perches wrote:
> On Fri, 2017-02-03 at 13:10 +0100, Slawomir Stepien wrote:
> > On Feb 03, 2017 11:27, Greg KH wrote:
> > > On Fri, Feb 03, 2017 at 11:11:35AM +0100, Slawomir Stepien wrote:
> > > > Hi all
> > > >
> > > > There is a "false positive" error reported by chec
On Fri, Feb 03, 2017 at 01:10:20PM +0100, Slawomir Stepien wrote:
> On Feb 03, 2017 11:27, Greg KH wrote:
> > On Fri, Feb 03, 2017 at 11:11:35AM +0100, Slawomir Stepien wrote:
> > > Hi all
> > >
> > > There is a "false positive" error reported by checkpatch.pl:
> > >
> > > ERROR: Use 4 digit octa
On Feb 03, 2017 11:27, Greg KH wrote:
> On Fri, Feb 03, 2017 at 11:11:35AM +0100, Slawomir Stepien wrote:
> > Hi all
> >
> > There is a "false positive" error reported by checkpatch.pl:
> >
> > ERROR: Use 4 digit octal (0777) not decimal permissions
> > #272: FILE: drivers/staging/iio/meter/ade77
On 02/03/2017 02:02 AM, Stuart Yoder wrote:
>
>
>> -Original Message-
>> From: laurentiu.tu...@nxp.com [mailto:laurentiu.tu...@nxp.com]
>> Sent: Wednesday, February 01, 2017 5:43 AM
>> To: gre...@linuxfoundation.org
>> Cc: de...@driverdev.osuosl.org; linux-ker...@vger.kernel.org; ag...@su
On Sat, Jan 28, 2017 at 07:04:28PM -0500, James Simmons wrote:
> Batch of missing fixes for lustre for the upstream client.
I've applied most of these, please fix up the rest, rebase, and resend.
thanks,
greg k-h
___
devel mailing list
de...@linuxdrive
On Sat, Jan 28, 2017 at 07:04:38PM -0500, James Simmons wrote:
> From: Andreas Dilger
>
> Update the sysfs "version" file to print "lustre: " with
> the version number.
>
> Signed-off-by: Andreas Dilger
> Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-5969
> Reviewed-on: http://review.wham
On Fri, Feb 03, 2017 at 10:17:53AM +, Laurentiu Tudor wrote:
> Hi Greg,
>
> Thanks for having a look. Comment below.
>
> On 02/03/2017 11:56 AM, Greg KH wrote:
> > On Wed, Feb 01, 2017 at 05:43:22AM -0600, laurentiu.tu...@nxp.com wrote:
> >> From: Laurentiu Tudor
> >>
> >> Drop unneeded get_
On Fri, Feb 03, 2017 at 11:11:35AM +0100, Slawomir Stepien wrote:
> Hi all
>
> There is a "false positive" error reported by checkpatch.pl:
>
> ERROR: Use 4 digit octal (0777) not decimal permissions
> #272: FILE: drivers/staging/iio/meter/ade7759.c:272:
> +static IIO_DEV_ATTR_CH_OFF(1, S_IWUSR |
Hi all
There is a "false positive" error reported by checkpatch.pl:
ERROR: Use 4 digit octal (0777) not decimal permissions
#272: FILE: drivers/staging/iio/meter/ade7759.c:272:
+static IIO_DEV_ATTR_CH_OFF(1, S_IWUSR | S_IRUGO,
+ ade7759_read_8bit,
+ ade7759_write_8bit,
Hi Greg,
Thanks for having a look. Comment below.
On 02/03/2017 11:56 AM, Greg KH wrote:
> On Wed, Feb 01, 2017 at 05:43:22AM -0600, laurentiu.tu...@nxp.com wrote:
>> From: Laurentiu Tudor
>>
>> Drop unneeded get_device() call at device creation
>> and, as per documentation, drop reference count
On Sat, Dec 03, 2016 at 03:14:26PM +0530, Tabrez khan wrote:
> Add parentheses around variable x for the readability purpose.
>
It's not really about readability...
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driv
Em Sat, 3 Dec 2016 15:14:26 +0530
Tabrez khan escreveu:
> Add parentheses around variable x for the readability purpose.
>
> This warning was found using checkpatch.pl.
>
> Signed-off-by: Tabrez khan
> ---
> drivers/staging/media/bcm2048/radio-bcm2048.c | 2 +-
> 1 file changed, 1 insertion(
On Wed, Feb 01, 2017 at 05:43:22AM -0600, laurentiu.tu...@nxp.com wrote:
> From: Laurentiu Tudor
>
> Drop unneeded get_device() call at device creation
> and, as per documentation, drop reference count
> after using device_find_child() return.
>
> Signed-off-by: Laurentiu Tudor
> ---
> drivers
On Tue, Jan 31, 2017 at 07:37:19PM +0100, Javier Rodriguez wrote:
> drivers/staging/gdm724x/gdm_lte.c:201:33: warning: incorrect type in
> assignment (different base types)
> drivers/staging/gdm724x/gdm_lte.c:201:33:expected unsigned int [unsigned]
> [addressable] [usertype] ph_len
> drivers/
On Tue, Jan 31, 2017 at 09:20:15AM -0500, Maksymilian Piechota wrote:
> Fix checkpatch.pl warning:
Your subject is odd, it leaves something to the imagination :(
>
> WARNING: Statements should start on a tabstop
>
> V2: whole if statement cleared up
Put this below the --- line.
v3?
thanks,
On Thu, Feb 02, 2017 at 08:56:54PM +0800, Zhengyi Shen wrote:
> Fix line over 80 characters.
> Statements longer than 80 columns were broken into sensible chunks.
> Descendants in four different palces were in the same uniform style.
>
> Signed-off-by: Zhengyi Shen
> ---
> drivers/staging/emxx_u
On Fri, Feb 03, 2017 at 10:56:12AM +0530, Arushi wrote:
> This patch fixes the issue by aligning the * on each line in block comments.
> [Patch v1] is rejected as the changes done is not following the linux
> coding style and [Patch v2] is rejected because forgot to mention the
> cause of rejection
51 matches
Mail list logo