Fixed comparison, moved the constant to the right side of the test
Found using checkpatch
Signed-off-by: Derek Robson
---
drivers/staging/rtl8188eu/os_dep/usb_ops_linux.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/os_dep/usb_ops_linux.c
b/drive
Fixed bare use of 'unsigned', Found using checkpatch
Signed-off-by: Derek Robson
---
drivers/staging/greybus/gpio.c | 22 +++---
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/greybus/gpio.c b/drivers/staging/greybus/gpio.c
index 250caa00de5e..e93
Hi Michael,
> Michael Zoran hat am 21. Januar 2017 um 18:48
> geschrieben:
>
>
> These set of changes add compat ioctls for vc04_services. Each ioctl
> modifed is pulled into a compat and native specific wrapper that
> calls a platform neutral handler function.
>
> At this time only the ioctl
Modify all the msg union fields from typedefs to
to proper structures.
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142
Reviewed-on: https://review.whamcloud.com/24566
Reviewed-by: Doug Oucharek
Reviewed-by: Olaf Weber
Reviewed-by: Andreas Dilger
Reviewed-b
Change lnet_ni_status_t from typedef to proper structure.
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142
Reviewed-on: https://review.whamcloud.com/24566
Reviewed-by: Doug Oucharek
Reviewed-by: Olaf Weber
Reviewed-by: Andreas Dilger
Reviewed-by: Dmitry Ere
Change lnet_hdr_t from typedef to proper structure.
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142
Reviewed-on: https://review.whamcloud.com/24566
Reviewed-by: Doug Oucharek
Reviewed-by: Olaf Weber
Reviewed-by: Andreas Dilger
Reviewed-by: Dmitry Eremin
S
Change lnet_ping_info_t from typedef to proper structure.
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142
Reviewed-on: https://review.whamcloud.com/24566
Reviewed-by: Doug Oucharek
Reviewed-by: Olaf Weber
Reviewed-by: Andreas Dilger
Reviewed-by: Dmitry Ere
Change lnet_process_id_packed_t from typedef to proper structure.
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142
Reviewed-on: https://review.whamcloud.com/24566
Reviewed-by: Doug Oucharek
Reviewed-by: Olaf Weber
Reviewed-by: Andreas Dilger
Reviewed-by: Dm
Change lnet_magicversion_t from typedef to proper structure.
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142
Reviewed-on: https://review.whamcloud.com/24566
Reviewed-by: Doug Oucharek
Reviewed-by: Olaf Weber
Reviewed-by: Andreas Dilger
Reviewed-by: Dmitry
Change lnet_handle_wire_t from typedef to proper structure.
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142
Reviewed-on: https://review.whamcloud.com/24566
Reviewed-by: Doug Oucharek
Reviewed-by: Olaf Weber
Reviewed-by: Andreas Dilger
Reviewed-by: Dmitry E
The upstream kernel requires proper structures so
convert nearly all the LNet wire protocols typedefs in
the LNet core.
Signed-off-by: James Simmons
Reviewed-on: https://review.whamcloud.com/24566
Reviewed-by: Doug Oucharek
Reviewed-by: Olaf Weber
Reviewed-by: Andreas Dilger
Reviewed-by: Dmitr
Change lnet_acceptor_connreq_t from typedef to proper structure.
Signed-off-by: James Simmons
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6142
Reviewed-on: https://review.whamcloud.com/24566
Reviewed-by: Doug Oucharek
Reviewed-by: Olaf Weber
Reviewed-by: Andreas Dilger
Reviewed-by: Dmi
Dear Comrade,
I hope that I not offend you. Anyway,i found your email through your country
email data base because of how important is it to me, reaching out to some one
like for something serious, let me introduce myself. My name is Fatima Rukaya
Mohammad, I'm a widow living here in Tartous,
Calling device_init_wakeup in the remove function is unnecessary since the
device is going away, and thus won't be able to cause any wakeups under any
circumstances. Besides, the driver cleanup code already handles the
necessary cleanup.
Similar, disabling wakeup in the probe error path is unneces
Add compat ioctl for get config
Signed-off-by: Michael Zoran
---
.../vc04_services/interface/vchiq_arm/vchiq_arm.c | 97 +-
1 file changed, 74 insertions(+), 23 deletions(-)
diff --git a/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_arm.c
b/drivers/staging/vc04_s
Add compat ioctl for queue bulk
Signed-off-by: Michael Zoran
---
.../vc04_services/interface/vchiq_arm/vchiq_arm.c | 274 ++---
1 file changed, 180 insertions(+), 94 deletions(-)
diff --git a/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_arm.c
b/drivers/staging/vc04_
Add compat ioctl for await completion
Signed-off-by: Michael Zoran
---
.../vc04_services/interface/vchiq_arm/vchiq_arm.c | 498 ++---
1 file changed, 341 insertions(+), 157 deletions(-)
diff --git a/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_arm.c
b/drivers/stagin
Add compat ioctl for dump mem
Signed-off-by: Michael Zoran
---
.../vc04_services/interface/vchiq_arm/vchiq_arm.c | 60 +-
1 file changed, 48 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_arm.c
b/drivers/staging/vc04_ser
This change is the first in a set of changes to add compat ioctls for
vc04_services.
In the change set, each ioctl modifed is pulled into a compat and native
specific
wrapper that calls a platform neutral handler function.
At this time only the ioctls needed for compat are handled, but
a genera
Add compat ioctl for queue message
Signed-off-by: Michael Zoran
---
.../vc04_services/interface/vchiq_arm/vchiq_arm.c | 185 ++---
1 file changed, 129 insertions(+), 56 deletions(-)
diff --git a/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_arm.c
b/drivers/staging/vc
Add compat ioctl for dequeue message
Signed-off-by: Michael Zoran
---
.../vc04_services/interface/vchiq_arm/vchiq_arm.c | 221 +
1 file changed, 137 insertions(+), 84 deletions(-)
diff --git a/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_arm.c
b/drivers/staging/
These set of changes add compat ioctls for vc04_services. Each ioctl
modifed is pulled into a compat and native specific wrapper that
calls a platform neutral handler function.
At this time only the ioctls needed for compat are handled, but
a general pattern is developed that can be used for clean
On 21 January 2017 16:49:09 GMT+00:00, Brian Masney
wrote:
>On Sat, Jan 21, 2017 at 02:58:12PM +, Jonathan Cameron wrote:
>> On 17/01/17 09:25, Brian Masney wrote:
>> > This patch adds runtime power management support to the isl29028
>driver.
>> > It defaults to powering off the device afte
On Sat, Jan 21, 2017 at 02:58:12PM +, Jonathan Cameron wrote:
> On 17/01/17 09:25, Brian Masney wrote:
> > This patch adds runtime power management support to the isl29028 driver.
> > It defaults to powering off the device after two seconds of inactivity.
> >
> > isl29028_chip_init_and_power_o
On 17/01/17 09:25, Brian Masney wrote:
> This patch adds runtime power management support to the isl29028 driver.
> It defaults to powering off the device after two seconds of inactivity.
>
> isl29028_chip_init_and_power_on() currently only zeros the CONFIGURE
> register on the chip, which will ca
On 17/01/17 09:25, Brian Masney wrote:
> isl29028_chip_init_and_power_on() calls isl29028_set_als_scale() and
> this is not needed until the user actually needs to take a reading from
> the ALS/IR sensor. This patch moves the isl29028_set_als_scale() call
> from isl29028_chip_init_and_power_on() to
On 17/01/17 09:25, Brian Masney wrote:
> isl29028_chip_init_and_power_on() calls isl29028_set_proxim_sampling()
> and this is not needed until the user actually needs to take a proximity
> reading. This patch moves the isl29028_set_proxim_sampling() call from
> isl29028_chip_init_and_power_on() to
On 17/01/17 09:24, Brian Masney wrote:
> isl29028_enable_proximity() has a boolean argument named enable. This
> function is only called once and the enable flag is set to true in that
> call. This patch removes the enable parameter from that function.
>
> Signed-off-by: Brian Masney
Applied.
> -
On 17/01/17 09:24, Brian Masney wrote:
> isl29028_write_raw() contains unnecessary parenthesis when checking to
> see if the passed in lux scale is valid. This patch removes the
> unnecessary parenthesis.
>
> Signed-off-by: Brian Masney
hmm. Not sure I really care about this either way.
Ah well,
On 17/01/17 09:24, Brian Masney wrote:
> If the call to devm_iio_device_alloc() fails, then isl29028_probe()
> logs a message saying that memory cannot be allocated. The user's system
> most likely has larger issues at this point. This patch removes that
> error message since the error code is pass
On 17/01/17 09:24, Brian Masney wrote:
> If the call to isl29028_chip_init_and_power_on() in isl29028_probe()
> fails, then isl29028_probe() will log an error message. All of the
> error paths in that call path already have error logging in place. This
> patch removes the unnecessary logging.
>
>
On 17/01/17 09:24, Brian Masney wrote:
> The wording and style of the different error messages was not
> consistent. This patch makes the wording and style consistent
> throughout the driver.
>
> Signed-off-by: Brian Masney
Applied.
> ---
> drivers/staging/iio/light/isl29028.c | 56
> ++
On 17/01/17 09:24, Brian Masney wrote:
> The #define ISL29028_DEV_ATTR was not used so this patch removes the
> unnecessary code.
>
> Signed-off-by: Brian Masney
Applied.
> ---
> drivers/staging/iio/light/isl29028.c | 1 -
> 1 file changed, 1 deletion(-)
>
> diff --git a/drivers/staging/iio/lig
On 17/01/17 09:24, Brian Masney wrote:
> When isl29028_set_als_scale() fails, it was up to both callers to log
> the failure message. This patch moves the logging into
> isl29028_set_als_scale() to reduce the overall amount of code in the
> driver.
>
> Signed-off-by: Brian Masney
Applied
> ---
>
On 17/01/17 09:24, Brian Masney wrote:
> isl29028_proxim_get() checks to see if the promixity needs to be
> enabled on the chip and then calls isl29028_read_proxim(). There
> are no other callers of isl29028_read_proxim(). The naming between
> these two functions can be confusing so this patch comb
On 17/01/17 09:24, Brian Masney wrote:
> Add and remove newlines to improve code readability in preparation for
> moving the driver out of staging.
>
> Signed-off-by: Brian Masney
Applied.
> ---
> drivers/staging/iio/light/isl29028.c | 33 -
> 1 file changed, 24 i
On 17/01/17 09:24, Brian Masney wrote:
> When isl29028_set_proxim_sampling() fails, it was up to both callers to
> log the failure message. This patch moves the logging into
> isl29028_set_proxim_sampling() to reduce the overall amount of code in
> the driver.
>
> Signed-off-by: Brian Masney
I'm
On 17/01/17 09:24, Brian Masney wrote:
> Two separate calls to regmap_update_bits() in isl29028_set_als_scale()
> and isl29028_set_als_ir_mode() did not have their function arguments
> on the next line aligned correctly to the open parenthesis. This patch
> corrects the alignment.
>
> Signed-off-b
On 17/01/17 09:24, Brian Masney wrote:
> The alignment of the variables in the struct isl29028_chip is not
> consistent. This changes all of the variables to use consistent
> alignment to improve the code readability.
>
> Signed-off-by: Brian Masney
Applied to the togreg branch of iio.git and pus
On Fri, Jan 20, 2017 at 11:33:11PM +, James Simmons wrote:
>
> > > > On Mon, Dec 19, 2016 at 12:06:47PM -0500, James Simmons wrote:
> > > > > Not for landing. This is the purposed UAPI headers
> > > > > with the removal of unlikely and debugging macros.
> > > > > This is just for feedback to s
40 matches
Mail list logo