These stand-alone trigger drivers were using iio_trigger_put()
where they should have been using iio_trigger_free(). The
iio_trigger_put() adds a module_put which is bad since they
never did a module_get.
In the sysfs driver, module_get/put's are used as triggers are
added & removed. This extra m
On Thu, 2017-01-19 at 15:56 +0300, Dan Carpenter wrote:
> Hm... I had never used checkpatch.pl --fix until a few minutes ago.
>
> Basically sending a zillion patches is the only way to do anything in
> the linux-kernel. You're not allowed to break the build, introduce
> new compile warnings or b
Fix the following warnings:
Block comments should align the * on each line
Signed-off-by: Abdul Rauf
---
Nine instances of this warning has been removed. Now there
is no warning in staging: skein
---
drivers/staging/skein/skein_base.h | 112 +++-
drivers/staging/
Hi Vitaly,
[auto build test WARNING on linus/master]
[also build test WARNING on v4.10-rc4 next-20170119]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Vitaly-Kuznetsov/hv_util-adjust-system
On 01/19/2017 10:11 AM, Christoph Hellwig wrote:
On Wed, Jan 18, 2017 at 03:28:57PM -0500, Cathy Avery wrote:
The patch provides a means to offer a lightweight option to the
current FC transport class. The new option is selected by a
driver when it indicates it wants the lightweight
transport
On 01/18/2017 06:15 PM, Dan Carpenter wrote:
On Wed, Jan 18, 2017 at 03:28:58PM -0500, Cathy Avery wrote:
Enable FC lightweight host option so that the luns exposed by
the driver may be manually scanned.
Signed-off-by: Cathy Avery
---
drivers/scsi/storvsc_drv.c | 6 +-
1 file changed,
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Thursday, January 19, 2017 10:52 AM
> To: KY Srinivasan
> Cc: o...@aepfle.de; jasow...@redhat.com; linux-ker...@vger.kernel.org;
> a...@canonical.com; de...@linuxdriverproject.org;
> leann.ogasaw...@canonica
On Thu, Jan 19, 2017 at 04:49:35PM +, KY Srinivasan wrote:
>
>
> > -Original Message-
> > From: Greg KH [mailto:gre...@linuxfoundation.org]
> > Sent: Thursday, January 19, 2017 4:59 AM
> > To: KY Srinivasan
> > Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org;
> > o...@
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Thursday, January 19, 2017 4:59 AM
> To: KY Srinivasan
> Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org;
> o...@aepfle.de; a...@canonical.com; vkuzn...@redhat.com;
> jasow...@redhat.com; lean
On Wed, Jan 18, 2017 at 03:28:57PM -0500, Cathy Avery wrote:
> The patch provides a means to offer a lightweight option to the
> current FC transport class. The new option is selected by a
> driver when it indicates it wants the lightweight
> transport via fc_function_template.
This need some real
do_settimeofday() is deprecated, use do_settimeofday64() instead.
Signed-off-by: Vitaly Kuznetsov
Acked-by: John Stultz
Acked-by: Thomas Gleixner
---
drivers/hv/hv_util.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/hv/hv_util.c b/drivers/hv/hv_util.c
index
With TimeSync version 4 protocol support we started updating system time
continuously through the whole lifetime of Hyper-V guests. Every 5 seconds
there is a time sample from the host which triggers do_settimeofday[64]().
While the time from the host is very accurate such adjustments may cause
iss
With TimeSync version 4 protocol support we started updating system time
continuously through the whole lifetime of Hyper-V guests. Every 5 seconds
there is a time sample from the host which triggers do_settimeofday[64]().
While the time from the host is very accurate such adjustments may cause
iss
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Thursday, January 19, 2017 1:34 AM
> To: KY Srinivasan
> Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org;
> o...@aepfle.de; a...@canonical.com; vkuzn...@redhat.com;
> jasow...@redhat.com; lean
On Thu, Jan 19, 2017 at 05:12:11AM -0800, Michael Zoran wrote:
> On Thu, 2017-01-19 at 13:22 +0100, Greg KH wrote:
> > On Thu, Jan 19, 2017 at 04:07:15AM -0800, Michael Zoran wrote:
> > > On Thu, 2017-01-19 at 14:34 +0300, Dan Carpenter wrote:
> > > > On Thu, Jan 19, 2017 at 03:27:56AM -0800, Micha
On Thu, 2017-01-19 at 13:22 +0100, Greg KH wrote:
> On Thu, Jan 19, 2017 at 04:07:15AM -0800, Michael Zoran wrote:
> > On Thu, 2017-01-19 at 14:34 +0300, Dan Carpenter wrote:
> > > On Thu, Jan 19, 2017 at 03:27:56AM -0800, Michael Zoran wrote:
> > > > On Thu, 2017-01-19 at 13:10 +0300, Dan Carpente
Hm... I had never used checkpatch.pl --fix until a few minutes ago.
Basically sending a zillion patches is the only way to do anything in
the linux-kernel. You're not allowed to break the build, introduce
new compile warnings or bugs. We review tons of these patches and
introducing bugs is pret
On Thu, Jan 19, 2017 at 04:07:15AM -0800, Michael Zoran wrote:
> On Thu, 2017-01-19 at 14:34 +0300, Dan Carpenter wrote:
> > On Thu, Jan 19, 2017 at 03:27:56AM -0800, Michael Zoran wrote:
> > > On Thu, 2017-01-19 at 13:10 +0300, Dan Carpenter wrote:
> > > All these silly white space issues in the e
On Thu, 2017-01-19 at 14:34 +0300, Dan Carpenter wrote:
> On Thu, Jan 19, 2017 at 03:27:56AM -0800, Michael Zoran wrote:
> > On Thu, 2017-01-19 at 13:10 +0300, Dan Carpenter wrote:
> > All these silly white space issues in the existing code could be
> > fixed
> > in 10 seconds with netbeans or ecli
On Thu, Jan 19, 2017 at 03:27:56AM -0800, Michael Zoran wrote:
> On Thu, 2017-01-19 at 13:10 +0300, Dan Carpenter wrote:
> > One thing I will say is that I have scripts to review when people
> > pull
> > parts of an ioctl into a separate patch. So when you do that, please
> > don't make too many w
On Thu, 2017-01-19 at 13:10 +0300, Dan Carpenter wrote:
> One thing I will say is that I have scripts to review when people
> pull
> parts of an ioctl into a separate patch. So when you do that, please
> don't make too many white space changes if you can avoid it. Those
> confuse my scripts.
>
On Wed, Jan 18, 2017 at 04:45:04PM -0700, k...@exchange.microsoft.com wrote:
> From: K. Y. Srinivasan
>
> As part of the effort to separate out architecture specific code,
> consolidate all Hyper-V specific clocksource code to an architecture
> specific code.
>
> Signed-off-by: K. Y. Srinivasan
On Thu, 2017-01-19 at 10:49 +0100, Greg Kroah-Hartman wrote:
> On Tue, Jan 03, 2017 at 08:29:45PM +0200, Andy Shevchenko wrote:
> > First of all, fbtft in current state doesn't allow to override GPIOs
> > to be
> > optional, like "reset" one. It might be a bug somewhere, but rather
> > out of
> > s
This series enables 64x48 OLED display and fixes the driver to work with DMA
enabled SPI properly.
Has been tested on Intel Edison board with Adafruit 2'8" and SSD1306 64x48
(Sparkfun for Intel Edison) OLED displays at their maximum speed (25MHz and
10MHz).
Since v3:
- add Noralf's ACKs
- rebased
First of all, fbtft in current state doesn't allow to override GPIOs to be
optional, like "reset" one. It might be a bug somewhere, but rather out of
scope of this fix.
Second, not all GPIOs available on the board would be SoC based, some of them
might sit on I2C GPIO expanders, for example, on In
kstrto*() functions return proper error code.
Do propogate it to the user.
Acked-by: Noralf Trønnes
Signed-off-by: Andy Shevchenko
---
drivers/staging/fbtft/fbtft-sysfs.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft-sysfs.c
b/drivers/st
There is no need to duplicate what SPI core already does, i.e. mapping buffers
for DMA capable transfers.
Remove all related pices of code.
Note, that code, besides its redundancy, was buggy: DMA address potentially can
be 0, SPI slave device has nothing to do with DMA capable device properties a
Refactor write_vmem() for sake of readability.
While here, fix indentation in one comment.
Acked-by: Noralf Trønnes
Signed-off-by: Andy Shevchenko
---
drivers/staging/fbtft/fb_ssd1306.c | 16 +++-
1 file changed, 7 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/fbtft/f
There is 64x48 display exists. In order to support that set multiplexer
to 48 pixels and window address to proper position in the graphic display
data RAM.
Acked-by: Noralf Trønnes
Signed-off-by: Andy Shevchenko
---
drivers/staging/fbtft/fb_ssd1306.c | 21 +
1 file changed,
On Wed, Jan 18, 2017 at 07:04:52AM -0800, Michael Zoran wrote:
> +
> + status = vchiq_get_config(instance, args.config_size, &config);
> +
> + if (status == VCHIQ_SUCCESS) {
> + if (copy_to_user((void __user *)args.pconfig,
> +
This is hard to review because it's moving stuff around, and changing
stuff and adding new features. I'll review the v2 patch.
One thing I will say is that I have scripts to review when people pull
parts of an ioctl into a separate patch. So when you do that, please
don't make too many white spa
On Wed, Jan 18, 2017 at 07:28:04AM +0530, Kartikey Singh wrote:
> Macros with complex values enclosed in parentheses
That does not make sense to me, does it to you? Please write changelogs
that can be understood.
thanks,
greg k-h
___
devel mailing lis
On Thu, 2017-01-19 at 12:14 +0300, Dan Carpenter wrote:
> On Wed, Jan 18, 2017 at 07:04:48AM -0800, Michael Zoran wrote:
> > Add compat handler for "queue message" ioctl.
> >
> > Signed-off-by: Michael Zoran
> > ---
> > .../vc04_services/interface/vchiq_arm/vchiq_arm.c | 36
> >
On Tue, Jan 17, 2017 at 08:46:59PM +0100, Pierre-Yves Kerbrat wrote:
> wpa_ielen was declared u32 when we actually use an int
>
> Fix sparse (-Wtypesign) issues:
> drivers/staging/rtl8188eu/core/rtw_ieee80211.c:1008:60: warning:
> incorrect type in argument 2 (different signedness)
> drivers/stagi
On Tue, Jan 03, 2017 at 08:29:45PM +0200, Andy Shevchenko wrote:
> First of all, fbtft in current state doesn't allow to override GPIOs to be
> optional, like "reset" one. It might be a bug somewhere, but rather out of
> scope of this fix.
>
> Second, not all GPIOs available on the board would be
On Tue, Jan 17, 2017 at 10:56:31PM +0530, simran singhal wrote:
> Fix checkpatch.pl "space required after that ','" errors
>
> Signed-off-by: simran singhal
>
> diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
> b/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
> index
Same stuff, break this into two patches.
On Wed, Jan 18, 2017 at 07:04:49AM -0800, Michael Zoran wrote:
> Add compat handler for "queue bulk" ioctls and move
> parts in common with the regular ioctls to vchiq_ioctl_queue_bulk
>
> Signed-off-by: Michael Zoran
> ---
> .../vc04_services/interface/
On Thu, Jan 19, 2017 at 10:07:42AM +0100, Greg Kroah-Hartman wrote:
> On Wed, Jan 04, 2017 at 12:11:17AM +, Bryan O'Donoghue wrote:
> > V3:
> > Picard: "Let's make sure history never forgets the name ... Enterprise."
> > Drop gb_operation_cancel_async. The sync version works just as well - Joha
On Wed, Jan 18, 2017 at 07:04:48AM -0800, Michael Zoran wrote:
> Add compat handler for "queue message" ioctl.
>
> Signed-off-by: Michael Zoran
> ---
> .../vc04_services/interface/vchiq_arm/vchiq_arm.c | 36
> ++
> 1 file changed, 36 insertions(+)
>
> diff --git a/drivers/
On Wed, Jan 04, 2017 at 12:11:17AM +, Bryan O'Donoghue wrote:
> V3:
> Picard: "Let's make sure history never forgets the name ... Enterprise."
> Drop gb_operation_cancel_async. The sync version works just as well - Johan
Johan and Alex, any thoughts on this series?
thanks,
greg k-h
_
You're not allowed to introduce compiler warnings. Every patch should
make sense on its own and do only one thing.
On Wed, Jan 18, 2017 at 07:04:47AM -0800, Michael Zoran wrote:
> Add compat handler for "create service" ioctl and move
> parts in common with the regular ioctl to vchiq_ioctl_create
On Thu, 2017-01-19 at 11:00 +0300, Dan Carpenter wrote:
> On Wed, Jan 18, 2017 at 11:37:55PM -0800, Michael Zoran wrote:
> > This whole driver is a chicken and egg problem. The existing code
> > is
> > so hard to read and maintain, that it's hard to improve it in a
> > incremental way. Yet, trow
On Wed, Jan 18, 2017 at 06:21:23PM -0800, Igor Pylypiv wrote:
> checkpatch.pl warning:
> Symbolic permissions are not preferred. Consider using octal permissions.
>
> Signed-off-by: Igor Pylypiv
Reviewed-by: Johan Hovold
___
devel mailing list
de...@l
On Wed, Jan 18, 2017 at 11:37:55PM -0800, Michael Zoran wrote:
> This whole driver is a chicken and egg problem. The existing code is
> so hard to read and maintain, that it's hard to improve it in a
> incremental way. Yet, trowing large sections out the door is too hard
> to get seriously revie
44 matches
Mail list logo