On Tue, Dec 20, 2016 at 09:24:53AM -0800, Stephen Hemminger wrote:
> On Tue, 20 Dec 2016 18:55:49 +0300
> Roman Kagan wrote:
>
> > Move definitions related to the Hyper-V SynIC event flags to a header
> > where they can be consumed by userspace.
> >
> > While doing so, also clean up their use by
On Tue, Dec 20, 2016 at 09:25:43AM -0800, Stephen Hemminger wrote:
> On Tue, 20 Dec 2016 18:55:59 +0300
> Roman Kagan wrote:
>
> > Userspace will need them too.
> >
> > Signed-off-by: Roman Kagan
>
> What userspace? I am worried about creating more stable API's that can't
> change.
QEMU in p
On Tue, Dec 20, 2016 at 08:57:28PM +, KY Srinivasan wrote:
>
>
> > -Original Message-
> > From: Roman Kagan [mailto:rka...@virtuozzo.com]
> > Sent: Tuesday, December 20, 2016 7:56 AM
> > To: Paolo Bonzini ; Radim Krčmář
> > ; KY Srinivasan ; Vitaly
> > Kuznetsov
> > Cc: Thomas Gleixn
> On Dec 20, 2016, at 9:23 PM, Joe Perches wrote:
>
>> On Tue, 2016-12-20 at 20:58 -0600, Scott Matheina wrote:
>> Fixed indention and space issues to align the code with the linux style
>> guide.
> []
>> diff --git a/drivers/staging/iio/addac/adt7316.c
>> b/drivers/staging/iio/addac/adt7316.
On Tue, 2016-12-20 at 20:58 -0600, Scott Matheina wrote:
> Fixed indention and space issues to align the code with the linux style guide.
[]
> diff --git a/drivers/staging/iio/addac/adt7316.c
> b/drivers/staging/iio/addac/adt7316.c
[]
> @@ -176,16 +176,16 @@
> */
>
> struct adt7316_chip_info {
From: Florian Fainelli
Date: Tue, 20 Dec 2016 17:02:37 -0800
> On 12/14/2016 05:13 PM, Florian Fainelli wrote:
>> The Octeon driver calls into PHYLIB which now checks for
>> net_device->dev.parent, so make sure we do set it before calling into
>> any MDIO/PHYLIB related function.
>>
>> Fixes: ec
Fixed indention and space issues to align the code with the linux style guide.
Signed-off-by: Scott Matheina
---
drivers/staging/iio/addac/adt7316.c | 603
1 file changed, 266 insertions(+), 337 deletions(-)
diff --git a/drivers/staging/iio/addac/adt7316.c
These changes where identified by checkpatch.pl as needed changes to
align the code with the linux development coding style. The several
lines of text where aligned with the precending parenthesis.
Signed-off-by: Scott Matheina
---
drivers/staging/fbtft/fb_agm1264k-fl.c | 18 ++
On 12/14/2016 05:13 PM, Florian Fainelli wrote:
> The Octeon driver calls into PHYLIB which now checks for
> net_device->dev.parent, so make sure we do set it before calling into
> any MDIO/PHYLIB related function.
>
> Fixes: ec988ad78ed6 ("phy: Don't increment MDIO bus refcount unless it's a
> d
> "kys" == kys writes:
kys> From: K. Y. Srinivasan Miscellaneous fixes and
kys> enhancements.
Applied to 4.11/scsi-queue.
--
Martin K. Petersen Oracle Linux Engineering
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.l
> -Original Message-
> From: Roman Kagan [mailto:rka...@virtuozzo.com]
> Sent: Tuesday, December 20, 2016 7:56 AM
> To: Paolo Bonzini ; Radim Krčmář
> ; KY Srinivasan ; Vitaly
> Kuznetsov
> Cc: Thomas Gleixner ; Ingo Molnar
> ; H. Peter Anvin ; x...@kernel.org;
> Haiyang Zhang ; k...@vge
Add sanity checks for cport_quiesce and cport_clear before invoking the
callbacks as these function pointers are not required during the host
device registration. This follows the logic implemented elsewhere for
various other function pointers.
Signed-off-by: Jason Hrycay
---
drivers/staging/gre
On Tue, Dec 20, 2016 at 11:07 AM, Dan Carpenter
wrote:
> On Tue, Dec 20, 2016 at 02:57:17PM +, Hammond, John wrote:
>> "{ NULL }" is valid ISO C, but unfortunately "{}" is not.
>
> In the kernel we don't care. We use lots of GCC extensions.
We depend on the compiler to do "incomplete zero-in
On Tue, Dec 20, 2016 at 02:57:17PM +, Hammond, John wrote:
> "{ NULL }" is valid ISO C, but unfortunately "{}" is not.
In the kernel we don't care. We use lots of GCC extensions.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproje
On Tue, Dec 20, 2016 at 08:47:51AM -0800, Bruce Korb wrote:
> >
> > "{ NULL }" is valid ISO C, but unfortunately "{}" is not.
>
> Just make the thing "static const" and don't use an initializer.
That also works, of course.
regards,
dan carpenter
___
de
Fixed sparse warnings.
Deleted cpu_to_le32() for enum. I'm not sure why it was there.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/rtl871x_event.h | 2 +-
drivers/staging/rtl8712/rtl871x_mlme.c | 15 +++
drivers/staging/rtl8712/wlan_bssdef.h |
Fixed a sparse warning.
Using be16_to_cpus() to avoid double assignment.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/rtl871x_recv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8712/rtl871x_recv.c
b/drivers/staging/
Fixed sparse warning.
Changed u16 to __le16
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/ieee80211.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8712/ieee80211.c
b/drivers/staging/rtl8712/ieee80211.c
Fixed sparse warning.
Changed uint to __le16 and __le32.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/hal_init.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8712/hal_init.c
b/drivers/staging/rtl8712/hal
Fixed a sparse warning.
Using function le16_to_cpus() to avoid double assignment.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8712/rtl871x_ioctl_linu
Fixed a sparse warning.
Just changed uint to __le32.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/usb_ops_linux.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8712/usb_ops_linux.c
b/drivers/staging/rtl8712/usb_o
Fixed a sparse warning.
GetFrameSubType and GetFrameType should cast to __le16. Furthermore
GetFramSubType should use le16_to_cpu instead of cpu_to_le16.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/rtl871x_security.c | 4 ++--
drivers/staging/rtl8712/wifi.h
Fixed sparse warning.
Just changed u32 to __le32.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/usb_ops.c | 18 --
1 file changed, 8 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/rtl8712/usb_ops.c
b/drivers/staging/rtl8712/usb_o
Fixed sparse warning.
Just changed u16 to __be16 and typecasts.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/rtl8712_recv.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl8712_recv.c
b/drivers/stagin
Fixed a sparse warning "cast to restricted __le32".
Function argument is of type __le32.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/rtl8712_cmd.c | 2 +-
drivers/staging/rtl8712/rtl8712_event.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
dif
Fixed a sparse warning.
Casting __le32 variables to the right type.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/rtl871x_security.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_security.c
b/
Fixed sparse warning "cast to restricted __le32".
Changed struct tx_desc members to __le32 and pcmdbuf to __le32.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/rtl8712_cmd.c | 5 +++--
drivers/staging/rtl8712/rtl8712_xmit.h | 16
2 files cha
In this set of patches I fixed most sparse endian warnings for the rtl8712
driver.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Fixed sparse warning "cast to restricted __le32".
struct sitesurvey_parm uses little endian members.
Signed-off-by: Jannik Becher
Tested-by: Larry Finger
---
drivers/staging/rtl8712/rtl871x_cmd.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8712/r
On Fri, 2016-12-16 at 17:00 -0800, Kees Cook wrote:
> Prepare to mark sensitive kernel structures for randomization by making
sure they're using designated initializers.
About the designated initializer patches,
which by themselves are fine of course,
and the fundamental randomization plugin,
c gu
Move structures for monitored notifications to the uapi header for
userspace to be able to consume. Also observe that hv_monitor_parameter
is by definition the same as hv_input_signal_event so use the latter and
nuke the former.
Signed-off-by: Roman Kagan
---
arch/x86/include/uapi/asm/hyperv.h
There's no need in GFP_ATOMIC when initializing the driver state.
While at this, also rely on free_page() to take null argument.
Signed-off-by: Roman Kagan
---
drivers/hv/hv.c | 23 ++-
1 file changed, 10 insertions(+), 13 deletions(-)
diff --git a/drivers/hv/hv.c b/drivers
Consolidate the guest-side and kvm-side definitions for Hyper-V TSC
reference page.
While at this, rewrite read_hv_clock_tsc using the existing helpers.
Signed-off-by: Roman Kagan
---
arch/x86/include/asm/kvm_host.h| 2 +-
arch/x86/include/uapi/asm/hyperv.h | 4 +--
drivers/hv/hyperv_vmbu
Signed-off-by: Roman Kagan
---
drivers/hv/channel.c| 8 +++-
drivers/hv/connection.c | 9 +++--
2 files changed, 6 insertions(+), 11 deletions(-)
diff --git a/drivers/hv/channel.c b/drivers/hv/channel.c
index 5fb4c6d..f9df275 100644
--- a/drivers/hv/channel.c
+++ b/drivers/hv/channel
Use the definitions already present in the uapi header throughout the
guest driver, too.
Signed-off-by: Roman Kagan
---
drivers/hv/hyperv_vmbus.h | 11 ---
drivers/hv/vmbus_drv.c| 6 +++---
2 files changed, 3 insertions(+), 14 deletions(-)
diff --git a/drivers/hv/hyperv_vmbus.h b/d
Use the definitions already present in the uapi header. Besides, drop
all bitfields for the msr values and use bitwise operations instead.
Signed-off-by: Roman Kagan
---
drivers/hv/hyperv_vmbus.h | 88 ---
drivers/hv/hv.c | 150 ++--
Give a name to the constant (1) already used in the code.
Signed-off-by: Roman Kagan
---
arch/x86/include/uapi/asm/hyperv.h | 2 ++
drivers/hv/connection.c| 2 +-
2 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/arch/x86/include/uapi/asm/hyperv.h
b/arch/x86/include/uapi
Use the definitions already present in the uapi header throughout the
guest driver, too.
Signed-off-by: Roman Kagan
---
drivers/hv/hyperv_vmbus.h | 19 ---
drivers/hv/hv.c | 6 +++---
2 files changed, 3 insertions(+), 22 deletions(-)
diff --git a/drivers/hv/hyperv_vmb
On Tue, 20 Dec 2016 18:55:59 +0300
Roman Kagan wrote:
> Userspace will need them too.
>
> Signed-off-by: Roman Kagan
What userspace? I am worried about creating more stable API's that can't change.
___
devel mailing list
de...@linuxdriverproject.org
On Tue, 20 Dec 2016 18:55:49 +0300
Roman Kagan wrote:
> Move definitions related to the Hyper-V SynIC event flags to a header
> where they can be consumed by userspace.
>
> While doing so, also clean up their use by switching to standard bitops
> and struct-based dereferencing. The latter is al
This brings more symmetry in the API.
The downside is that this changes the userspace-visible structure.
Hopefully no userspace code had a chance to use it yet.
Signed-off-by: Roman Kagan
---
arch/x86/include/uapi/asm/hyperv.h | 32 +---
drivers/hv/hyperv_vmbus.h
Signed-off-by: Roman Kagan
---
drivers/hv/hyperv_vmbus.h | 44
drivers/hv/hv.c | 39 +++
2 files changed, 39 insertions(+), 44 deletions(-)
diff --git a/drivers/hv/hyperv_vmbus.h b/drivers/hv/hyperv_vmbus.
Userspace will need them too.
Signed-off-by: Roman Kagan
---
arch/x86/include/uapi/asm/hyperv.h | 9 +
drivers/hv/hyperv_vmbus.h | 10 --
2 files changed, 9 insertions(+), 10 deletions(-)
diff --git a/arch/x86/include/uapi/asm/hyperv.h
b/arch/x86/include/uapi/asm/hype
None of these is used in the kernel.
Signed-off-by: Roman Kagan
---
drivers/hv/hyperv_vmbus.h | 119 --
1 file changed, 119 deletions(-)
diff --git a/drivers/hv/hyperv_vmbus.h b/drivers/hv/hyperv_vmbus.h
index fcb5d91..8ce6d64 100644
--- a/drivers/hv/
>
> "{ NULL }" is valid ISO C, but unfortunately "{}" is not.
Just make the thing "static const" and don't use an initializer.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Make hypercall and tsc page allocation similar to the rest of the
Hyper-V shared memory stuff instead of vmalloc-ing them.
Also perform cleanup unconditionally which is safe.
TODO: the skipping of free in case of a crash is probably no longer
necessary, too.
Signed-off-by: Roman Kagan
---
driv
Move definitions related to the Hyper-V SynIC event flags to a header
where they can be consumed by userspace.
While doing so, also clean up their use by switching to standard bitops
and struct-based dereferencing. The latter is also done for message
pages.
Signed-off-by: Roman Kagan
---
arch/
Expose more Hyper-V-related definitions in the uapi header for
consumption by userspace.
While doing so, get rid of a number of duplications between the KVM and
the guest driver code. Also a few other cleanups are made which are not
strictly necessary for the main purpose of the series but appear
Expose structures used for PostMessage and SignalEvent hypercalls in a
uapi header. While doing so, simplify alignment handling and drop
unnecessary complications in the connectionid field.
Signed-off-by: Roman Kagan
---
arch/x86/include/uapi/asm/hyperv.h | 18 ++
drivers/hv/hyp
On 12/20/2016 05:21 AM, Kalle Valo wrote:
Larry Finger writes:
With commit e49656147359 {"rtlwifi: Use dev_kfree_skb_irq instead of
kfree_skb"), the method used to free an skb was changed because the
kfree_skb() was inside a spinlock. What was forgotten is that kfree_skb()
guards against a NUL
> On Mon, Dec 19, 2016 at 08:47:50AM -0800, Bruce Korb wrote:
> > On Mon, Dec 19, 2016 at 8:22 AM, James Simmons
> > >> --- a/drivers/staging/lustre/lustre/ldlm/ldlm_flock.c
> > >> +++ b/drivers/staging/lustre/lustre/ldlm/ldlm_flock.c
> > >> @@ -143,7 +143,7 @@ static int ldlm_process_flock_lock(st
Use rb_entry_safe() instead of container_of() to simplify the code.
Signed-off-by: Geliang Tang
---
drivers/staging/lustre/lustre/osc/osc_cache.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/lustre/lustre/osc/osc_cache.c
b/drivers/staging/lustre/lustre
This improves code readability.
Signed-off-by: Afonso Bordado
---
drivers/staging/emxx_udc/emxx_udc.c | 16 +++-
1 file changed, 7 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/emxx_udc/emxx_udc.c
b/drivers/staging/emxx_udc/emxx_udc.c
index 0963533..45808ed 100644
---
Change EP0_out_PIO to use the kernel convention.
Signed-off-by: Afonso Bordado
---
drivers/staging/emxx_udc/emxx_udc.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/emxx_udc/emxx_udc.c
b/drivers/staging/emxx_udc/emxx_udc.c
index 3f42fa8..51ad04b 100644
Fix checkpatch.pl issues with CamelCase.
Improves readability by removing temporary variables.
Afonso Bordado (4):
staging: emxx_udc: Fix CamelCase function name
staging: emxx_udc: Rename CamelCase variable
staging: emxx_udc: Remove unecessary temporary variable
staging: emxx_udc: Fix Came
Changes from CamelCase to a kernel format
Signed-off-by: Afonso Bordado
---
drivers/staging/emxx_udc/emxx_udc.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/emxx_udc/emxx_udc.c
b/drivers/staging/emxx_udc/emxx_udc.c
index 45808ed..c19ce17 100644
---
The new name complies with the kernel styling guidelines and is more
descriptive.
Signed-off-by: Afonso Bordado
---
drivers/staging/emxx_udc/emxx_udc.c | 12
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/emxx_udc/emxx_udc.c
b/drivers/staging/emxx_ud
This patch doesn't apply. Read Documentation/process/email-clients.rst
On Tue, Dec 20, 2016 at 11:49:41AM +0100, Francis Laniel wrote:
> Hello.
>
>
> As asked in the TODO file for this driver I added some goto statements to
> handle errors.
>
> I used Linus Torvalds tree, I compiled it and tes
Larry Finger writes:
> With commit e49656147359 {"rtlwifi: Use dev_kfree_skb_irq instead of
> kfree_skb"), the method used to free an skb was changed because the
> kfree_skb() was inside a spinlock. What was forgotten is that kfree_skb()
> guards against a NULL value for the argument. Routine dev
On 20/12/16 10:28, Johan Hovold wrote:
> On Tue, Dec 20, 2016 at 01:12:08AM +, Bryan O'Donoghue wrote:
>> Currently the greybus-loopback thread logic spins around waiting for
>> send_count == iteration_max which on real hardware doesn't make a
>> difference to us but in simulation is excruciati
Hello.
As asked in the TODO file for this driver I added some goto statements to
handle errors.
I used Linus Torvalds tree, I compiled it and tested it with a virtual
machine, here is the proof :
[ 42.394265] dgnc: module is from the staging directory, ...
[root@vm-nmv ~]# uname -r
4.9.0-11815
On Mon, Dec 19, 2016 at 04:22:58PM +, James Simmons wrote:
>
> > Prepare to mark sensitive kernel structures for randomization by making
> > sure they're using designated initializers. These were identified during
> > allyesconfig builds of x86, arm, and arm64, with most initializer fixes
> >
On Tue, Dec 20, 2016 at 01:12:08AM +, Bryan O'Donoghue wrote:
> Currently the greybus-loopback thread logic spins around waiting for
> send_count == iteration_max which on real hardware doesn't make a
> difference to us but in simulation is excruciatingly slow, anti-social and
> bad manners. Us
On Tue, Dec 20, 2016 at 09:48:48AM +, Afonso Bordado wrote:
> Fix CamelCase styling issues with EP0_out_PIO
> Remove unecessary temporary variables
Only do one-thing-per-patch please.
thanks,
gre gk-h
___
devel mailing list
de...@linuxdriverproject
Fix CamelCase styling issues with EP0_out_PIO
Remove unecessary temporary variables
Signed-off-by: Afonso Bordado
---
drivers/staging/emxx_udc/emxx_udc.c | 29 -
1 file changed, 12 insertions(+), 17 deletions(-)
diff --git a/drivers/staging/emxx_udc/emxx_udc.c
b/dri
65 matches
Mail list logo