> -Original Message-
> From: devel [mailto:driverdev-devel-boun...@linuxdriverproject.org] On
> Behalf Of Greg KH
> Sent: Wednesday, October 26, 2016 10:38 PM
> To: Dan Carpenter
> Cc: de...@driverdev.osuosl.org
> Subject: Re: Patchwork for this mailing list?
>
> On Thu, Oct 27, 2016 at
On Thu, Oct 27, 2016 at 07:37:42AM +0200, Greg KH wrote:
> A whole new list for just a single tiny subsystem? That's crazy too.
> What about the virtualization list instead? That's where the vmware and
> other subsystems that look like this all hang out at.
>
Sounds like a winning idea to me. :
On Thu, Oct 27, 2016 at 11:10:09AM +0530, Souptick Joarder wrote:
> There are few functions where we need to free previously allocated memory
> when kmalloc fails. Else it may lead to memory leakage.
> In _init_cmd_priv() and _r8712_init_xmit_priv(),in few places we are not
> freeing previously al
There are few functions where we need to free previously allocated memory
when kmalloc fails. Else it may lead to memory leakage.
In _init_cmd_priv() and _r8712_init_xmit_priv(),in few places we are not
freeing previously allocated memory when kmalloc fails.
This patch will address it.
Signed-of
On Thu, Oct 27, 2016 at 08:26:20AM +0300, Dan Carpenter wrote:
> On Thu, Oct 27, 2016 at 07:04:22AM +0200, Greg KH wrote:
> > Also, there's no real need for the hyperv patches to be using this list
> > anymore, that codebase has long since "graduated". Feel free to use
> > lkml if you want instead
On Thu, Oct 27, 2016 at 07:04:22AM +0200, Greg KH wrote:
> Also, there's no real need for the hyperv patches to be using this list
> anymore, that codebase has long since "graduated". Feel free to use
> lkml if you want instead.
Ugh... LKML is a terrible list to use unless it's a small driver wi
On Wed, Oct 26, 2016 at 06:13:13PM -0700, Eric Anholt wrote:
> Stefan Wahren writes:
>
> > This fixes the CamelCase of some variables.
> >
> > Signed-off-by: Stefan Wahren
>
> Greg, are these kinds of reformats something that you're looking for in
> the staging tree? I'm fine with the patch bu
On Wed, Oct 26, 2016 at 08:58:56PM -0700, Stephen Hemminger wrote:
> Is there a patchwork project for this mailing list?
Not that I know of.
> If not probably it makes sense to do it.
Why? I don't use it, and without the maintainer using it, it's use can
be limited. But feel free to have it si
On Wed, Oct 26, 2016 at 08:58:56PM -0700, Stephen Hemminger wrote:
> Is there a patchwork project for this mailing list?
> If not probably it makes sense to do it.
>
I don't think there is... I've never used patch-work. I was looking at
https://patchwork.kernel.org/ and most people just seem to
Is there a patchwork project for this mailing list?
If not probably it makes sense to do it.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Wed, Oct 26, 2016 at 06:13:13PM -0700, Eric Anholt wrote:
> Stefan Wahren writes:
>
> > This fixes the CamelCase of some variables.
> >
> > Signed-off-by: Stefan Wahren
>
> Greg, are these kinds of reformats something that you're looking for in
> the staging tree? I'm fine with the patch bu
Stefan Wahren writes:
> This fixes the CamelCase of some variables.
>
> Signed-off-by: Stefan Wahren
Greg, are these kinds of reformats something that you're looking for in
the staging tree? I'm fine with the patch but I didn't see camel case
explicitly called out in CodingStyle after a brief
Michael Zoran writes:
> The original arm implementation uses dmac_map_area which is not
> portable. Replace it with an architecture neutral version
> which uses dma_map_sg.
>
> As you can see that for larger page sizes, the dma_map_sg
> implementation is faster then the original unportable dma_m
On Wed, Oct 26, 2016 at 11:52:41AM +0300, Dan Carpenter wrote:
> So, when I'm reviewing these, there are obviously a lot of patches that
> go through staging and I try to do them as fast as possible and quite
> often make mistakes. Feel free to speak up when that happens, I won't
> be offended.
>
> -Original Message-
> From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
> Sent: Wednesday, October 26, 2016 4:12 AM
> To: de...@linuxdriverproject.org
> Cc: linux-ker...@vger.kernel.org; KY Srinivasan ;
> Haiyang Zhang
> Subject: [PATCH] Drivers: hv: vmbus: Raise retry/wait limits in
This patch adds the missing module description for the driver.
Signed-off-by: Stefan Wahren
---
.../vc04_services/interface/vchiq_arm/vchiq_arm.c |1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_arm.c
b/drivers/staging/vc04_services
Rearrange the polling loops in order to avoid code duplication. Btw we fix
the style of the comments.
Signed-off-by: Stefan Wahren
---
.../vc04_services/interface/vchiq_arm/vchiq_shim.c | 56 +++-
1 file changed, 31 insertions(+), 25 deletions(-)
diff --git a/drivers/staging/v
This fixes the CamelCase of some variables.
Signed-off-by: Stefan Wahren
---
.../vc04_services/interface/vchiq_arm/vchiq_core.c | 26 ++--
.../interface/vchiq_arm/vchiq_kern_lib.c |4 +--
.../interface/vchiq_arm/vchiq_memdrv.h | 12 -
3 files
In Linux Mainline there wasn't a chance to boot the RPi without DT.
So we can make the firmware node mandatory.
Signed-off-by: Stefan Wahren
---
.../vc04_services/interface/vchiq_arm/vchiq_arm.c |3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/vc04_servic
The naming bcm2708 is used only in the vendor kernel, so better
replace it with bcm2835 which is used in mainline in order
to avoid any confusion.
Signed-off-by: Stefan Wahren
---
drivers/staging/Makefile |2 +-
drivers/staging/vc04_services/Kconfig |4 ++--
drivers/stagin
From: Stephen Hemminger
In commit 9a56e5d6a0ba ("Drivers: hv: make VMBus bus ids persistent")
the name of vmbus devices in sysfs changed to be (in 4.9-rc1):
/sys/bus/vmbus/vmbus-6aebe374-9ba0-11e6-933c-00259086b36b
The prefix ("vmbus-") is redundant and differs from how PCI is
represented in s
clarify some error messages by printing the actual function name
involved
Signed-off-by: Stuart Yoder
---
-v2
-patch is result of split of original patch, updated
commit messasge to reflect the change
drivers/staging/fsl-mc/bus/fsl-mc-bus.c | 7 ++-
1 file changed, 2 insertions(+), 5
improve and clarify miscellaneous comments in the bus driver
and allocator
Signed-off-by: Stuart Yoder
---
-v2
-update/improve commit message
drivers/staging/fsl-mc/bus/fsl-mc-allocator.c | 68 +--
drivers/staging/fsl-mc/bus/fsl-mc-bus.c | 18 +++
2 files ch
From: Ioana Ciornei
DPAA2 will not support MC firmware versions prior to MC v10.x.
Update the MC interface code and drivers to reflect this.
-update the object .h files and code that builds commands to include
the new command version in the command header
-object versions are no longer
improve some messages by shortening and rewording
Signed-off-by: Stuart Yoder
---
-v2
-patch is result of split of original patch, updated
commit messasge to reflect the change
drivers/staging/fsl-mc/bus/fsl-mc-allocator.c | 4 ++--
drivers/staging/fsl-mc/bus/fsl-mc-bus.c | 13 +++
Many source files have evolved without copyright date
updates. Update the dates to reflect work through
2016.
Signed-off-by: Stuart Yoder
---
-v2
-no changes
drivers/staging/fsl-mc/bus/dpcon-cmd.h | 2 +-
drivers/staging/fsl-mc/bus/dpmcp.h | 2 +-
driver
Be consistent and use kernel-preferred multi-line comment style
everywhere.
Signed-off-by: Stuart Yoder
---
-v2
-no changes
drivers/staging/fsl-mc/bus/dpbp-cmd.h | 3 ++-
drivers/staging/fsl-mc/bus/dpbp.c | 3 ++-
drivers/staging/fsl-mc/bus/dpcon-cmd.h | 3 ++-
drivers/staging/fs
use one tab to separate name and value in #define definitions
Signed-off-by: Stuart Yoder
---
-v2
-patch is result of split of original patch, updated
commit messasge and author to reflect the change
drivers/staging/fsl-mc/include/dprc.h | 10 +-
1 file changed, 5 insertions(+),
define pr_fmt so non dev_* messages will have an fsl-mc prefix
and remove "fsl-mc" from messages where it would now be redundant
Signed-off-by: Stuart Yoder
---
-v2
-patch is result of split of original patch, updated
commit messasge to reflect the change
drivers/staging/fsl-mc/bus/fsl-m
From: Ioana Ciornei
To improve readability for structs and function definitions, separate type
and variable name by a single space, instead of an inconsistent number of
tabs.
Signed-off-by: Ioana Ciornei
Signed-off-by: Stuart Yoder
---
-v2
-patch is result of split of original patch, update
From: Ioana Ciornei
align function arguments that were not aligned to the starting parenthesis
Signed-off-by: Ioana Ciornei
Signed-off-by: Stuart Yoder
---
-v2
-patch is result of split of original patch, updated
commit messasge to reflect the change
drivers/staging/fsl-mc/bus/dpmcp.h
remove instances of multiple blank lines in comments
Signed-off-by: Stuart Yoder
---
-v2
-patch is result of split of original patch, updated
commit messasge and author to reflect the change
drivers/staging/fsl-mc/bus/dpbp-cmd.h | 1 -
drivers/staging/fsl-mc/bus/dpbp.c | 1 -
drive
This patch does miscellaneous minor cleanup and uprevs the supported
MC firmware version to 10.x.
version 2 changes
-move MAINTAINERS change so it's sorted properly
-split whitespace cleanup into separate patches
-split message cleanup into separate patches
-use pr_fmt to set a message pre
-German has moved on to other things and wished to be
removed as a maintainer
-cleanup the driver description to use the proper name
of the driver (i.e. the fsl-mc bus driver) and remove incorrect
references to Freescale
Signed-off-by: Stuart Yoder
Acked-by: J. German Rivera
---
v2
-move u
On Tue, Oct 25, 2016 at 05:44:20PM +0200, Christian Gromm wrote:
> From: Andrey Shvetsov
>
> This patch puts the synchronization procedure trigger for asynchronous
> channels into the function hdm_configure_channel. Likewise, it removes
> triggering of hardware specific synchronization for other
> -Original Message-
> From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
> Sent: Wednesday, October 26, 2016 7:12 AM
> To: de...@linuxdriverproject.org
> Cc: linux-ker...@vger.kernel.org; KY Srinivasan ;
> Haiyang Zhang
> Subject: [PATCH] Drivers: hv: vmbus: Raise retry/wait limits in
DoS protection conditions were altered in WS2016 and now it's easy to get
-EAGAIN returned from vmbus_post_msg() (e.g. when we try changing MTU on a
netvsc device in a loop). All vmbus_post_msg() callers don't retry the
operation and we usually end up with a non-functional device or crash.
While h
On Tue, Oct 25, 2016 at 05:27:07PM +0100, Jonathan Cameron wrote:
> On 25/10/16 16:56, Arnd Bergmann wrote:
> > As found by "gcc -Wmaybe-uninitialized", the latest change to the
> > driver lacked an initalization for the return code in one of the
> > added cases:
> >
> > drivers/staging/iio/cdc/ad
On Wed, Oct 26, 2016 at 12:39 PM, Greg KH wrote:
> On Wed, Oct 26, 2016 at 12:30:26PM +0530, Souptick Joarder wrote:
>> There are few functions where we need to free previously allocated memory
>> when kmalloc fails. Else it may lead to memory leakage.
>> In _init_cmd_priv() and _r8712_init_xmit_
So, when I'm reviewing these, there are obviously a lot of patches that
go through staging and I try to do them as fast as possible and quite
often make mistakes. Feel free to speak up when that happens, I won't
be offended.
I use a script to review them which strips our all the white space
chang
No actually, what you did is fine. It all sort of hangs together...
You may as well get rid of the ctrl parameter when you get rid of the
macro otherwise it just creates a lot of busy work.
Reviewed-by: Dan Carpenter
regards,
dan carpenter
___
devel
On Wed, Oct 26, 2016 at 12:03:43AM -0200, Elise Lennion wrote:
> Every call to the function waitNextVerticalSync() used the macro
> primaryWaitVerticalSync(), so the macro was removed and the function
> waitNextVerticalSync() renamed to primary_wait_vertical_sync().
>
> With this change, an unnece
On Wed, Oct 26, 2016 at 12:30:26PM +0530, Souptick Joarder wrote:
> There are few functions where we need to free previously allocated memory
> when kmalloc fails. Else it may lead to memory leakage.
> In _init_cmd_priv() and _r8712_init_xmit_priv(),in few places we are not
> freeing previously al
On 10/26/2016 04:35 AM, Stuart Yoder wrote:
-Original Message-
From: Alexander Graf [mailto:ag...@suse.de]
Sent: Monday, October 24, 2016 9:34 AM
To: Stuart Yoder ; gre...@linuxfoundation.org
Cc: German Rivera ; de...@driverdev.osuosl.org;
linux-ker...@vger.kernel.org;
a...@arndb.de; L
There are few functions where we need to free previously allocated memory
when kmalloc fails. Else it may lead to memory leakage.
In _init_cmd_priv() and _r8712_init_xmit_priv(),in few places we are not
freeing previously allocated memory when kmalloc fails.
This patch will address it.
Signed-of
45 matches
Mail list logo