On Thu, Oct 13, 2016 at 1:20 AM, Chase Metzger wrote:
> Removed a checkpatch warning for braces on single argument if and else
> statement.
>
> Signed-off-by: Chase Metzger
> ---
> drivers/staging/greybus/timesync.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/d
On Wed, Oct 12, 2016 at 04:45:54PM +0200, Greg KH wrote:
>
> You can subscribe to the driverdev mailing list to see what othes are
> working on, and you can follow my staging-testing kernel branch in the
> staging.git tree. But sometimes you just get unlucky, lots of people
> are working on clean
Fixes the following checkpatch output:
./pcbit/capi.c:39: WARNING: Use #include instead of
./pcbit/capi.c:40: WARNING: Use #include instead of
./pcbit/callbacks.c:25: WARNING: Use #include instead of
./pcbit/layer2.c:39: WARNING: Use #include instead of
./pcbit/drv.c:34: WARNING: Use #inc
On 10/12/2016 05:49 AM, Dan Carpenter wrote:
copy_to_user() returns the number of bytes remaining to be copied. We
want to return -EFAULT here instead. Also there seems like no point
in continuing the loop if copy_to_user() fails.
Fixes: 02b23803c6af ('staging: android: ion: Add ioctl to query
On 10/10/2016 07:31 PM, ming.ling wrote:
From: Ming Ling
So far some ion heaps such as carveout_heap, chunk_heap,
system_heap have freed buffers asynchrounously. Freed buffers
are placed on a free list and freed from a low priority background
thread. If allocations from a particular heap fail,
On 10/11/2016 11:20 PM, Dan Carpenter wrote:
We're testing "pdev" but we intended to test "heap_pdev". This is a
static checker fix and it's unlikely that anyone is affected by this
bug.
Fixes: 13439479c7de ('staging: ion: Add files for parsing the devicetree')
Signed-off-by: Dan Carpenter
Removed a checkpatch warning for braces on single argument if and else
statement.
Signed-off-by: Chase Metzger
---
drivers/staging/greybus/timesync.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/greybus/timesync.c
b/drivers/staging/greybus/timesync.c
In commit d86e64768859 ("rtlwifi: rtl818x: constify local structures"),
the configuration struct for most of the drivers was changed to be
constant. The problem is that five of the modified drivers need to be
able to update the firmware name based on the exact model of the card.
As the file names w
On 10/12/2016 11:54 AM, Kalle Valo wrote:
Larry Finger writes:
In commit d86e64768859 ("rtlwifi: rtl818x: constify local structures"),
the configuration struct for most of the drivers was changed to be
constant. The problem is that five of the modified drivers need to be
able to update the fir
On Mon, Oct 10, 2016 at 02:03:32AM -0700, Florian Fainelli wrote:
> > +
> > +#ifdef CONFIG_LED_TRIGGER_PHY
> > +
> > +#include
> > +#include
> > +
> > +#define PHY_LINK_LED_MAX_TRIGGERS 5
> > +#define PHY_LED_TRIGGER_SPEED_SUFFIX_SIZE 7
> > +#define PHY_MII_BUS_ID_SIZE(20 - 3)
>
> This
On 10/11/2016 04:50 PM, Ruchi Kandoi wrote:
> Any process holding a reference to these buffers will keep the kernel from
> reclaiming its backing pages. mm counters don't provide a complete picture of
> these allocations, since they only account for pages that are mapped into a
> process's address
Larry Finger writes:
> In commit d86e64768859 ("rtlwifi: rtl818x: constify local structures"),
> the configuration struct for most of the drivers was changed to be
> constant. The problem is that five of the modified drivers need to be
> able to update the firmware name based on the exact model o
Larry Finger wrote:
> In commit d86e64768859 ("rtlwifi: rtl818x: constify local structures"),
> the configuration struct for most of the drivers was changed to be
> constant. The problem is that five of the modified drivers need to be
> able to update the firmware name based on the exact model of
On 10/12/2016 02:53 AM, Kalle Valo wrote:
Larry Finger writes:
In commit d86e64768859 ("rtlwifi: rtl818x: constify local structures"),
the configuration struct for most of the drivers was changed to be
constant. The problem is that five of the modified drivers need to be
able to update the fir
On Wed, Oct 12, 2016 at 07:58:18AM -0700, Victor Carvajal wrote:
> On Wed, Oct 12, 2016 at 03:53:18PM +0200, Greg KH wrote:
> > On Mon, Oct 10, 2016 at 11:42:26PM -0700, Victor Carvajal wrote:
> > > Signed-off-by: Victor Carvajal
> > > ---
> > > Changes in v3:
> > > - Be consistent with spacin
Block comments should align the * on each line as reported by checkpatch.pl
Signed-off-by: Mikhail Golubev
---
drivers/staging/vt6656/card.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/vt6656/card.c b/drivers/staging/vt6656/card.c
index 53b469c..807d3f
On Wed, Oct 12, 2016 at 03:53:18PM +0200, Greg KH wrote:
> On Mon, Oct 10, 2016 at 11:42:26PM -0700, Victor Carvajal wrote:
> > Signed-off-by: Victor Carvajal
> > ---
> > Changes in v3:
> > - Be consistent with spacing before text against previous patch.
> > Changes in v2:
> > - Be consist
On Wed, Oct 12, 2016 at 07:33:07PM +0530, Nadim Almas wrote:
> >Someone else already sent this same patch in before you, sorry
> But sir how can i come to know that Someone else already sent
> particular patch before sending that particular patch
You can subscribe to the driverdev mailing list t
>Someone else already sent this same patch in before you, sorry
But sir how can i come to know that Someone else already sent
particular patch before sending that particular patch
On Wed, Oct 12, 2016 at 6:55 PM, Greg KH wrote:
> On Tue, Oct 11, 2016 at 12:49:54PM -0700, Nadim Almas wrote:
>> f
On Mon, Oct 10, 2016 at 11:42:26PM -0700, Victor Carvajal wrote:
> Signed-off-by: Victor Carvajal
> ---
> Changes in v3:
> - Be consistent with spacing before text against previous patch.
> Changes in v2:
> - Be consistent with spacing before text.
> ---
> drivers/staging/rtl8188eu/includ
On Tue, Oct 11, 2016 at 12:49:54PM -0700, Nadim Almas wrote:
> fixed trailing */ Block comments and 80 character line limit coding style
> issue
>
> Signed-off-by: Nadim Almas
> ---
Someone else already sent this same patch in before you, sorry :(
___
copy_to_user() returns the number of bytes remaining to be copied. We
want to return -EFAULT here instead. Also there seems like no point
in continuing the loop if copy_to_user() fails.
Fixes: 02b23803c6af ('staging: android: ion: Add ioctl to query available
heaps')
Signed-off-by: Dan Carpente
Hello Vaibhav Agarwal,
The patch 6339d2322c47: "greybus: audio: Add topology parser for GB
codec" from Jan 13, 2016, leads to the following static checker
warning:
drivers/staging/greybus/audio_topology.c:374
gbcodec_mixer_dapm_ctl_info()
warn: unsigned 'info->value.integer.min'
Adds tables of all register values for routing various signals to various
terminals on National Instruments hardware. This information is directly
compared to and taken from register-level programming documentation and/or
register-level programming examples as provided by National Instruments.
Fu
Adds interface for configuring options that are global to all sub-devices.
For now, only options to configure device-globally identified signal routes
have been defined.
Signed-off-by: Spencer E. Olson
---
drivers/staging/comedi/comedi.h | 49 +
drivers/staging/comedi/co
Provides the device-global routing interface for ni_660x devices. Using
the device-global names in comedi_cmd structures for commands was already
supported through the ni_tio module.
Signed-off-by: Spencer E. Olson
---
drivers/staging/comedi/drivers/ni_660x.c | 260 +
Update references and notes for the routes that have been implemented.
This includes a guess as two what might be valid for CtrAux and
CtrArmStartTrigger, using mild heuristic evidence from other users.
*** PLEASE FIND ACTUAL PATCH AT:
http://www.umich.edu/~olsonse/patches/comedi-devglobal-v1/0015
Cleans up the pfi routing code to make it easier to follow, read, and also
to prepare to use this cleaned up code for enabling the device-global
routing interface for ni_660x devices.
Signed-off-by: Spencer E. Olson
---
drivers/staging/comedi/drivers/ni_660x.c | 72 +-
Previously, only the PXI version of the NI-6608 board was supported. This
change adds support for the PCI version as well.
Signed-off-by: Spencer E. Olson
---
drivers/staging/comedi/drivers/ni_660x.c | 8 +++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/come
Adds interface and associated unittests for accessing/looking-up/validating
the new ni routing table information.
Signed-off-by: Spencer E. Olson
---
drivers/staging/comedi/Kconfig | 4 +
drivers/staging/comedi/drivers/Makefile| 1 +
drivers/staging/comedi/dri
Implement device-global config interface for ni_mio devices. In
particular, this patch implements:
INSN_DEVICE_CONFIG_TEST_ROUTE,
INSN_DEVICE_CONFIG_CONNECT_ROUTE,
INSN_DEVICE_CONFIG_DISCONNECT_ROUTE,
INSN_DEVICE_CONFIG_GET_ROUTES
for the ni mio devices. This means that the new abstracted signal/
Adds ability to use device-global names in command args, in particular
cmd->start_arg (for NI_CtrArmStartTrigger), and cmd->scan_begin_arg or
cmd->convert_arg (either is used to specify NI_CtrGate, with preference
given to cmd->scan_begin_arg, if it is set).
The actual arguments of cmd->start_arg
Implement the ability to route various signals to NI_CtrOut(x) pin. This
pin is also known as GPFO_{0,1} in the DAQ STC.
Signed-off-by: Spencer E. Olson
---
drivers/staging/comedi/drivers/ni_mio_common.c | 101 +
drivers/staging/comedi/drivers/ni_stc.h| 6 +-
2
See README for a thorough discussion of this content.
Adds two different collections of CSV files that:
1) summarize the various register values for creating routes
for a particular family of NI hardware devices;
2) summarize all possible (direct) routes that a particular device can
make--in
Adds tio sub-devices of ni_mio_common supported hardware to the
implementation of test_route, connect_route, disconnect_route. This change
delegates the actual functionality to the ni_tio module.
Signed-off-by: Spencer E. Olson
---
drivers/staging/comedi/drivers/ni_mio_common.c | 11 +++
Use new signal routing capability for all comedi command *_src == TRIG_EXT
options. This new interface allows the user specify signals and terminals
as TRIG_EXT sources using a very consistent naming convention. Furthermore,
the interface allows backwards compatibility to prior behavior of
specify
This change adds abstracted constants for National Instruments
terminal/signal names.
Some background:
There have been significant confusions over the past many years for users
when trying to understand how to connect to/from signals and terminals on
NI hardware using comedi. The major reas
Adds a framework for unittests for comedi drivers. It was certainly
possible to write some unit tests before and test various aspects of a
particular driver, but this framework makes this a bit easier and hopefully
inspires more unittest modules to be written.
Signed-off-by: Spencer E. Olson
---
This patchset introduces a new framework for providing and maintaining a
consistent namespace to define terminal/signal names for a set of comedi
devices. This effort was primarily focused on supporting NI hardware, but the
interfaces introduced here can be implemented by all other hardware driver
On Tue, Oct 11, 2016 at 04:14:11PM +, Wang, Di wrote:
> Hello,
>
> On 10/11/16, 4:37 AM, "Dan Carpenter" wrote:
>
> >Hello wang di,
> >
> >The patch 2de353860782: "staging: lustre: create striped directory"
> >from Aug 16, 2016, leads to the following static checker warning:
> >
> > driv
Am 12.10.2016 um 01:50 schrieb Ruchi Kandoi:
This patchstack adds memtrack hooks into dma-buf and ion. If there's upstream
interest in memtrack, it can be extended to other memory allocators as well,
such as GEM implementations.
We have run into similar problems before. Because of this I already
Larry Finger wrote:
> This reverts commit d86e64768859fca82c78e52877ceeba04e25d27a.
>
> For drivers rtl8188ee, rtl8192ce, rtl8192ee, rtl8723ae, and rtl8821ae,
> the Coccinelle script missed the fact that the code changes the firmware
> name. When that happens, the kernel issues a BUG splat becaus
Larry Finger writes:
> In commit d86e64768859 ("rtlwifi: rtl818x: constify local structures"),
> the configuration struct for most of the drivers was changed to be
> constant. The problem is that five of the modified drivers need to be
> able to update the firmware name based on the exact model o
43 matches
Mail list logo