Hello David,
On 08/25/2016 12:01 PM, David Daney wrote:
> On 08/25/2016 06:55 AM, Javier Martinez Canillas wrote:
>> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
>> built-in or as a module, use that macro instead of open coding the same.
>>
>> Using the macro makes the
On 08/25/2016 02:18 PM, Aaro Koskinen wrote:
Hi,
On Thu, Aug 25, 2016 at 01:11:45PM -0700, David Daney wrote:
On 08/25/2016 11:22 AM, Aaro Koskinen wrote:
On Thu, Aug 25, 2016 at 09:50:15AM -0700, David Daney wrote:
Ideally we would configure the packet classifiers on the RX side to create
mu
Hi,
On Thu, Aug 25, 2016 at 01:11:45PM -0700, David Daney wrote:
> On 08/25/2016 11:22 AM, Aaro Koskinen wrote:
> >On Thu, Aug 25, 2016 at 09:50:15AM -0700, David Daney wrote:
> >>Ideally we would configure the packet classifiers on the RX side to create
> >>multiple RX queues based on a hash of t
On 08/24/2016 06:29 PM, Ed Swierk wrote:
I'm trying to migrate from the Octeon SDK to a vanilla Linux 4.4
kernel for a Cavium OCTEON II (CN6880) board running in 64-bit
little-endian mode. So far I've gotten most of the hardware features I
need working, including XAUI/RXAUI, USB, boot bus and I2C
On 08/25/2016 11:22 AM, Aaro Koskinen wrote:
Hi,
On Thu, Aug 25, 2016 at 09:50:15AM -0700, David Daney wrote:
Ideally we would configure the packet classifiers on the RX side to create
multiple RX queues based on a hash of the TCP 5-tuple, and handle each queue
with a single NAPI instance. Tha
Hi,
On Thu, Aug 25, 2016 at 09:50:15AM -0700, David Daney wrote:
> Ideally we would configure the packet classifiers on the RX side to create
> multiple RX queues based on a hash of the TCP 5-tuple, and handle each queue
> with a single NAPI instance. That should result in better performance whil
This patch removes multiple switch-case statements
with a new macro. The macro will generate the
corresponding bit mask based on the key index
received as input.
Signed-off-by: Claudiu Beznea
---
drivers/staging/wlan-ng/cfg80211.c | 85 ++---
drivers/staging/wlan
%ul definitely was supposed to be %lu in the format string,
so we print long unsigned int value, not just unsigned int
with a letter l added at the end.
Signed-off-by: Oleg Drokin
---
drivers/staging/lustre/lustre/obdclass/linux/linux-sysctl.c | 5 +++--
1 file changed, 3 insertions(+), 2 deleti
Hi,
On Wed, Aug 24, 2016 at 06:29:49PM -0700, Ed Swierk wrote:
> I'm trying to migrate from the Octeon SDK to a vanilla Linux 4.4
> kernel for a Cavium OCTEON II (CN6880) board running in 64-bit
> little-endian mode. So far I've gotten most of the hardware features I
> need working, including XAUI
> -Original Message-
> From: devel [mailto:driverdev-devel-boun...@linuxdriverproject.org] On
> Behalf Of Yauheni Kaliuta
> Sent: Wednesday, August 24, 2016 9:54 PM
> To: k...@exchange.microsoft.com
> Cc: o...@aepfle.de; gre...@linuxfoundation.org; jasow...@redhat.com; Alex
> Ng (LIS) ; l
This patch removes duplicate code in p80211req_mibset_mibget()
by adding p80211req_handle_action() function.
Changes since v1:
Removed prototype of p80211req_handle_action() from the prototype
list and add directly the function definition.
Signed-off-by: Claudiu Beznea
---
drivers/staging/wlan-
On Thu, Aug 25, 2016 at 09:59:46PM +0800, Ming-Chia Chung wrote:
> On Tue, Aug 23, 2016 at 12:01:36PM +0530, Sudip Mukherjee wrote:
> > On Tue, Aug 23, 2016 at 08:19:46AM +0800, Ming-Chia Chung wrote:
> > > On Mon, Aug 22, 2016 at 10:51:27PM +0530, Sudip Mukherjee wrote:
> > > > On Tue, Aug 23, 201
On Thu, Aug 25, 2016 at 12:09:23PM -0400, Anson Jacob wrote:
> On Thu, Aug 25, 2016 at 06:47:08PM +0300, Andrey Utkin wrote:
> >
> > > +#define CHANNEL_BITS(x) ((x) & 0x7)
> > > +#define CHANNEL_MASK 0x7
> >
> > No uniform alignment. Please get everything in a row.
> > If it'
Thank you for your comments.
On Thu, Aug 25, 2016 at 06:47:08PM +0300, Andrey Utkin wrote:
>
> > +#define CHANNEL_BITS(x)((x) & 0x7)
> > +#define CHANNEL_MASK 0x7
>
> No uniform alignment. Please get everything in a row.
> If it's hard or this part of driver is expected
On 08/25/2016 06:55 AM, Javier Martinez Canillas wrote:
The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.
Using the macro makes the code more readable by helping abstract away some
of the Kconfig bui
On Thu, Aug 25, 2016 at 11:16:13AM -0400, Anson Jacob wrote:
> Fix checkpatch.pl warning 'line over 80 characters'
>
> Signed-off-by: Anson Jacob
> ---
> drivers/staging/comedi/drivers/ni_at_a2150.c | 82
>
> 1 file changed, 46 insertions(+), 36 deletions(-)
>
> di
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Signed-off-by: Anson Jacob
---
drivers/staging/fbtft/fb_tls8204.c | 57 +++---
1 file changed, 29 insertions(+), 28 deletions(-)
diff --git a/d
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Signed-off-by: Anson Jacob
---
drivers/staging/fbtft/fbtft_device.c | 8 +---
1 file changed, 5 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft_devi
On Thu, Aug 25, 2016 at 11:10:25AM -0400, Anson Jacob wrote:
> Fix checkpatch.pl 'line over 80 characters' warning
>
> Signed-off-by: Anson Jacob
> ---
> drivers/staging/android/lowmemorykiller.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/androi
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Signed-off-by: Anson Jacob
---
drivers/staging/fbtft/fbtft-bus.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/fbtft/fbtft-bus.c
b/driv
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Signed-off-by: Anson Jacob
---
drivers/staging/fbtft/fb_ssd1331.c | 40 +++---
1 file changed, 20 insertions(+), 20 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ssd1331.c
b/drivers/staging
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Signed-off-by: Anson Jacob
---
drivers/staging/fbtft/fb_st7735r.c | 43 +++---
1 file changed, 26 insertions(+), 17 deletions(-)
diff --git a/d
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Signed-off-by: Anson Jacob
---
drivers/staging/fbtft/fb_ssd1306.c | 23 ---
1 file changed, 12 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Signed-off-by: Anson Jacob
---
drivers/staging/fbtft/fb_s6d1121.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/fbtft/fb_s6d1121.c
b/drivers/staging/fbtft/fb_s6d1121.c
index d6ae76b
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Signed-off-by: Anson Jacob
---
drivers/staging/fbtft/fb_ssd1289.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ssd1289.c
b/drivers/staging/fbtft/fb_ssd1289.c
index 5d5f280
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Anson Jacob (9):
staging: fbtft: fb_s6d02a1.c: Fix checkpatch warning
staging: fbtft: fb_s6d1121.c: Fix checkpatch warning
staging: fbtft: fb_ssd1289: Fix checkpatch warnin
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Signed-off-by: Anson Jacob
---
drivers/staging/fbtft/fb_s6d02a1.c | 14 --
1 file changed, 8 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/fbtft/fb_s6
Fix checkpatch.pl warning
Block comments use * on subsequent lines
Signed-off-by: Anson Jacob
---
drivers/staging/emxx_udc/emxx_udc.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/emxx_udc/emxx_udc.c
b/drivers/staging/emxx_udc/emxx_udc.c
index 3b56b28..f
Fix checkpatch.pl warning 'line over 80 characters'
Signed-off-by: Anson Jacob
---
drivers/staging/comedi/drivers/ni_at_a2150.c | 82
1 file changed, 46 insertions(+), 36 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ni_at_a2150.c
b/drivers/staging/comed
Fix checkpatch.pl warning 'line over 80 characters'
Signed-off-by: Anson Jacob
---
drivers/staging/comedi/drivers/jr3_pci.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/jr3_pci.c
b/drivers/staging/comedi/drivers/jr3_pci.c
index 6c4ff02..02
Fix checkpatch.pl warning for
Comparisons should place the constant on the right side of the test
Signed-off-by: Anson Jacob
---
drivers/staging/comedi/drivers/s626.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/s626.h
b/drivers/staging/come
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Signed-off-by: Anson Jacob
---
drivers/staging/comedi/drivers/jr3_pci.h | 13 +++--
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/comedi
Fix checkpatch.pl warning for 'Statements should start on a tabstop'
Signed-off-by: Anson Jacob
---
drivers/staging/comedi/drivers/ni_atmio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ni_atmio.c
b/drivers/staging/comedi/drivers/ni_atm
Fix checkpatch.pl warning:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Signed-off-by: Anson Jacob
---
drivers/staging/comedi/drivers/cb_pcidas64.c | 105 ++-
1 file changed, 55 insertions(+), 50 deletions(-)
diff --git a/d
Fix checkpath.pl warning:
line over 80 characters
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Statements should start on a tabstop
Comparisons should place the constant on the right side of the test
Anson Jacob (6):
staging: comedi: cb_pcidas64.c:
Fix checkpatch.pl 'line over 80 characters' warning
Signed-off-by: Anson Jacob
---
drivers/staging/android/lowmemorykiller.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/android/lowmemorykiller.c
b/drivers/staging/android/lowmemorykiller.c
index 45a1b4
On Tue, Aug 23, 2016 at 12:01:36PM +0530, Sudip Mukherjee wrote:
> On Tue, Aug 23, 2016 at 08:19:46AM +0800, Ming-Chia Chung wrote:
> > On Mon, Aug 22, 2016 at 10:51:27PM +0530, Sudip Mukherjee wrote:
> > > On Tue, Aug 23, 2016 at 12:54:17AM +0800, MingChia Chung wrote:
> > > > This patch fixes a
The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.
Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.
Signed-off-by: Javier Ma
Hello Greg,
On 08/21/2016 12:02 PM, Greg Kroah-Hartman wrote:
> On Thu, Jul 14, 2016 at 01:06:09PM -0400, Javier Martinez Canillas wrote:
>> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
>> built-in or as a module, use that macro instead of open coding the same.
>>
>> S
Yauheni Kaliuta writes:
> Hi, kys!
>
>> On Wed, 24 Aug 2016 16:23:10 -0700, kys wrote:
>
> [...]
>
> > -static bool pfn_covered(unsigned long start_pfn, unsigned long pfn_cnt)
> > +static int pfn_covered(unsigned long start_pfn, unsigned long pfn_cnt)
> > {
> >struct list_head *cur
40 matches
Mail list logo