From: Haiyang Zhang
Date: Fri, 19 Aug 2016 14:47:09 -0700
> From: Haiyang Zhang
>
> The existing code uses busy retry when unable to send out receive
> completions due to full ring buffer. It also gives up retrying after limit
> is reached, and causes receive buffer slots not being recycled.
>
On Fri, 2016-08-19 at 14:07 -0400, James Simmons wrote:
> Resolved the last remain bug that prevented earlier submission.
> This covers the remaining patches that were missing from the
> upstream client that was in Lustre 2.6 except for the work for
> LU-2484. The work for LU-2484 depends on the st
On Fri, 2016-08-19 at 20:44 +0100, James Simmons wrote:
> > 1: I'd like to see the lustre #include files separated into
> > only two internal/external directories akin to the
> > include/linux and include/uapi directories used by linux.
[]
> For the first question yes it is reasonable and dev
From: Haiyang Zhang
The existing code uses busy retry when unable to send out receive
completions due to full ring buffer. It also gives up retrying after limit
is reached, and causes receive buffer slots not being recycled.
This patch implements batching of receive completions. It also prevents
> On Fri, 2016-08-19 at 14:07 -0400, James Simmons wrote:
> > Resolved the last remain bug that prevented earlier submission.
> > This covers the remaining patches that were missing from the
> > upstream client that was in Lustre 2.6 except for the work for
> > LU-2484. The work for LU-2484 depend
Resolved the last remain bug that prevented earlier submission.
This covers the remaining patches that were missing from the
upstream client that was in Lustre 2.6 except for the work for
LU-2484. The work for LU-2484 depends on the stat infrastructure
that was removed earlier from the upstream cli
From: wang di
Move directory entries cache from llite to MDC, so client
side dir stripe will use independent hash function(in LMV),
which does not need to be tightly coupled with the backend
storage dir-entry hash function. With striped directory, it
will be 2-tier hash, LMV calculate hash value
With all but one of the the missing patches from the
lustre 2.6 version merged upstream its time to update
the upstream clients version.
Signed-off-by: James Simmons
---
drivers/staging/lustre/lustre/include/lustre_ver.h |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a
From: John L. Hammond
Remove the lmm and lmmsize parameters from both functions, storing
that data in md_op_data when needed. Remove the unused lookup_flags
parameter from md_intent_lock(), and the unused reqp parameter from
md_enqueue(). Add a union ldlm_policy_data * parameter to
md_enqueue().
From: Jian Yu
This patch fixes the following compile error by removing the
dead codes: "error: 'xxx_readpages' defined but not used".
Now that we have md_read_page functionality we can remove
all the *_readpage implementations.
Signed-off-by: Jian Yu
Intel-bug-id: https://jira.hpdd.intel.com/br
From: wang di
All the code needed to implement read_page. This
will eventually replace lmv_readpage.
Signed-off-by: wang di
Reviewed-on: http://review.whamcloud.com/10761
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-4906
Reviewed-by: John L. Hammond
Reviewed-by: Andreas Dilger
Reviewed
From: wang di
Add OBD_CONNECT_DIR_STRIPE to tell if the client supports
striped dir, so only new client (>= 2.6) can access striped
directory.
Signed-off-by: wang di
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-4843
Reviewed-on: http://review.whamcloud.com/10773
Reviewed-by: Andreas Dilg
From: John L. Hammond
Remove unused OBD functions: oti_alloc_cookies(), oti_free_cookies(),
class_observe_import(), class_unobserve_import(),
md_is_subdir(), md_readpage(), obdo2fid(), fid2obdo().
Remove several unused, get-only, and set-only structure members.
Signed-off-by: John L. Hammond
S
Some RTL8821AE devices sold in Great Britain have the country code of
0x25 encoded in their EEPROM. This value is not tested in the routine
that establishes the regulatory info for the chip. The fix is to set
this code to have the same capabilities as the EU countries.
Signed-off-by: Larry Finger
This patch set is needed to fix issues of the aim-cdev module.
Christian Gromm (3):
staging: most: aim-cdev: fix reported error codes
staging: most: aim-cdev: report error returned by alloc_chrdev_region
staging: most: aim-cdev: relocate call to ida_init()
drivers/staging/most/aim-cdev/cde
Currently, the aim-cdev is returning different error codes for the same
root cause. This patch is needed to get rid of the module's inconsistency
when reporting errors.
Signed-off-by: Christian Gromm
---
drivers/staging/most/aim-cdev/cdev.c | 19 +++
1 file changed, 11 insertions
This patch moves the initialization of the idr structure towards the end
of the module's init routine. This keeps the code compact and eliminates
the need of having to call ida_destroy() in case the function exits with
an exception.
Signed-off-by: Christian Gromm
---
drivers/staging/most/aim-cde
This patch forwards the error code returned by function
alloc_chrdev_region(). It is needed to stop the module
from hiding the actual cause of failure.
Signed-off-by: Christian Gromm
---
drivers/staging/most/aim-cdev/cdev.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a
The "broken in pipe" handler of the USB-HDM calls most_stop_enqueue() to
stop the MBO traffic before returning all MBOs back to the Mostcore. As
the enqueue() call from the Mostcore may run in parallel with the
most_stop_enqueue(), the HDM may run into the inconsistent state and
crash the kernel.
This patch is needed to make the driver support Microchip's OS81210 USB
MOST network interface controller. It simply adds the gadget's product
ID to the driver's ID table.
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 5 -
1 file changed, 4 insertions(+), 1 dele
In case a channel that is going to be destroyed has been tagged as not
"healthy" by the function hdm_poison_channel() while the functions
hdm_write_completion() or hdm_read_completion() are being executed, they
race for destruction of buf_anchor.
This patch fixes the problem.
Signed-off-by: Andre
Waiting for the urb_compl object to complete evaluates always as false.
This patch removes this unnecessary completion object.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 11 +--
1 file changed, 1 insertion(+), 10 deletions(
The USB completion callbacks set the status field of an MBO object before
scheduling the clear_work. This patch removes this redundant assignment as
the work_struct does the same for all MBOs.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb
This patch makes the write completion handler use the is_channel_healthy
flag to prevent the hdm from scheduling a second clear_halt workqueue in
case an endpoint reported a STALL condition.
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 3 +++
1 file changed, 3 inse
This patch initializes variables by the time they are declared.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 72 +++---
1 file changed, 23 insertions(+), 49 deletions(-)
diff --git a/drivers/staging/most/
This patch removes the duplication of the expression
(urb->status == -ENOENT || urb->status == -ECONNRESET).
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 8 ++--
1 file changed, 2 insertions(+), 6 deletions(-)
diff --git a/drive
This patch assigns the spinlock of struct mdev to local spinlock_t
variable to get rid of all the ugly dereferencing.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 31 +++
1 file changed, 19 insertions(+),
This patch removes unnecessary parenthesis in boolean expressions.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 51 +-
1 file changed, 25 insertions(+), 26 deletions(-)
diff --git a/drivers/staging/mo
This patch simplifies the code that initializes mbo->status.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 14 +-
1 file changed, 5 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/most/hdm-usb/hdm_usb.c
b/driv
In order to have a consistent naming convention this patch renames
USB_DEV_ID_INIC to USB_DEV_ID_OS81118.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/st
This patch ensures that no more packets are submitted by the core in
case an USB endpoint has reported a broken pipe (-EPIPE).
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff
This patch removes the macro HW_RESYNC that is not used anymore.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/most/hdm-usb/hdm_usb.c
b/drivers/staging/most/hdm-usb/hdm
This patch is needed to ensure that submitted URBs get unlinked before
the driver calls usb_clear_halt(). Since the halt condition of an USB
endpoint is channel related, the work_struct is moved from a buffer
basis to a channel basis.
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-u
This patch adds the additional status parameter to function
free_anchored_buffers. This allows to dispatch further processing based
on this flag.
Signed-off-by: Andrey Shvetsov
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 8 +---
1 file changed, 5 insertions(+
This patch set is needed to fix issues of the hdm-usb module.
Christian Gromm (17):
staging: most: hdm-usb: remove unused macro HW_RESYNC
staging: most: hdm-usb: provide MBO status when freeing buffers
staging: most: hdm-usb: fix clear halt processing
staging: most: hdm-usb: stop core from
This patch adds support for the OS81119 MOST network interface controller
to the driver.
Signed-off-by: Christian Gromm
---
drivers/staging/most/hdm-usb/hdm_usb.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/most/hdm-usb/hdm_usb.c
b/drivers/staging/mos
On Fri, Aug 19, 2016 at 09:55:33AM +0200, Christian Gromm wrote:
> On Thu, 18 Aug 2016 17:18:56 +0200
> Greg KH wrote:
>
> > On Tue, Aug 16, 2016 at 04:10:26PM +0200, Christian Gromm wrote:
> > > This patch set is needed to fix issues of the hdm-usb module.
> >
> > You sent me 2 patch series for
On Thu, 18 Aug 2016 17:18:56 +0200
Greg KH wrote:
> On Tue, Aug 16, 2016 at 04:10:26PM +0200, Christian Gromm wrote:
> > This patch set is needed to fix issues of the hdm-usb module.
>
> You sent me 2 patch series for this same driver right now. One 9
> patches and one 8 patches.
>
> Which go
38 matches
Mail list logo