The 'ch_intr_rx' variable was used only for increasing.
So the 'ch_intr_rx' variable is not useful for this driver.
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long time, if there is any reason
why this patch could NOT be merged into staging tree, let me know.
There we
The 'ch_intr_tx' variable was used only for increasing.
So the 'ch_intr_tx' variable is not useful for this driver.
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long time, if there is any reason
why this patch could NOT be merged into staging tree, let me know.
There we
The 'ch_intr_modem' variable was used only for increasing.
So the 'ch_intr_modem' variable is not useful for this driver.
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long time, if there is any reason
why this patch could NOT be merged into staging tree, let me know.
Th
The 'intr_rx' variable was used only for increasing.
So the 'intr_rx' variable is not useful for this driver.
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long time, if there is any reason
why this patch could NOT be merged into staging tree, let me know.
There were no
The 'intr_tx' variable was used only for increasing.
So the 'intr_tx' variable is not useful for this driver.
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long time, if there is any reason
why this patch could NOT be merged into staging tree, let me know.
There were no
The 'intr_modem' variable was used only for increasing.
So the 'intr_modem' variable is not useful for this driver.
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long time, if there is any reason
why this patch could NOT be merged into staging tree, let me know.
There we
the "brd" was already checked for NULL before calling dgnc_do_remap().
the dgnc_do_remap() function was called only
from the dgnc_found_board() and the DGNC_BOARD_MAGIC value
was assigned to "brd->magic" in dgcn_found_board(). So it doesn't
need to check about magic value.
Signed-off-by: Daeseok
The 'intr_count' variable was used only for increasing.
So the 'intr_count' variable is not useful for this driver.
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long time, if there is any reason
why this patch could NOT be merged into staging tree, let me know.
There we
the "brd" value cannot be NULL in dgnc_finalize_board_init().
Because "brd" as a parameter of this function was already
checked for NULL.
the dgnc_finalize_board_init() as a static function was called
only from dgnc_found_board() function and brd->magic value
was assigned once in dgnc_found_board(
Re-arrange the functions for removing forward declarations in dgnc_cls.c file.
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long time, if there is any reason
why this patch could NOT be merged into staging tree, let me know.
There were no comment for this patch.
I canno
The dgnc_set_modem_info() used only channel_t variable.
Any other variables were used only for checking NULL.
So fist parameter changed from "tty_struct" to "channel_t" and
useless NULL checks and variables are removed.
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long
The unit struct(un_t) was not used in dgnc_tty_hangup().
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long time, if there is any reason
why this patch could NOT be merged into staging tree, let me know.
There were no comment for this patch.
I cannot understand why this
The local variable "bd" was not used in dgnc_carrier() function.
Signed-off-by: Daeseok Youn
---
RESEND: This patch was not merged for a long time, if there is any reason
why this patch could NOT be merged into staging tree, let me know.
There were no comment for this patch.
I cannot understand w
The "result" variable in dgnc_get_mstat() was initialized with
"-EIO". But if the "ch" is not null, "result" will be set to zero
and if the "ch" is null, dgnc_get_mstat() will return "-ENXIO" as
an error. So "-EIO" error value was useless in dgnc_get_mstat().
Signed-off-by: Daeseok Youn
---
RESEN
The dgnc_block_til_ready() is only used in dgnc_tty_open().
The unit data(struct un_t) was stored into tty->driver_data in dgnc_tty_open().
And also tty and un were tested about NULL so these variables doesn't
need to check for NULL in dgnc_block_til_ready().
Signed-off-by: Daeseok Youn
---
RESEN
On 5 July 2016 at 15:56, Joe Perches wrote:
> On Tue, 2016-07-05 at 15:36 -0700, Markus Mayer wrote:
>> On 5 July 2016 at 15:14, Joe Perches wrote:
>> > On Tue, 2016-07-05 at 13:47 -0700, Markus Mayer wrote:
>> > > This series introduces a family of generic string case conversion
>> > > functions
On Tue, 2016-07-05 at 15:36 -0700, Markus Mayer wrote:
> On 5 July 2016 at 15:14, Joe Perches wrote:
> > On Tue, 2016-07-05 at 13:47 -0700, Markus Mayer wrote:
> > > This series introduces a family of generic string case conversion
> > > functions. This kind of functionality is needed in several p
On 5 July 2016 at 15:14, Joe Perches wrote:
> On Tue, 2016-07-05 at 13:47 -0700, Markus Mayer wrote:
>> This series introduces a family of generic string case conversion
>> functions. This kind of functionality is needed in several places in
>> the kernel. Right now, everybody seems to be implemen
From: K. Y. Srinivasan
Use the new APIs for eliminating a copy on the receive path. These new APIs also
help in minimizing the number of memory barriers we end up issuing (in the
ringbuffer code) since we can better control when we want to expose the ring
state to the host.
The patch is being re
This series introduces a family of generic string case conversion
functions. This kind of functionality is needed in several places in
the kernel. Right now, everybody seems to be implementing their own
copy of this functionality.
Based on the discussion of the previous version of this series[1] a
After introducing generic strntolower() and strtolower(), spk_strlwr()
is no longer needed.
Signed-off-by: Markus Mayer
---
Samuel, I left off your ACK, since the implementation of my function changed
somewhat (no check for NULL, return value is different). Please let me know
if you are still ok
Add a collection of generic functions to convert strings to lowercase
or uppercase.
Changing the case of a string (with or without copying it first) seems
to be a recurring requirement in the kernel that is currently being
solved by several duplicated implementations doing the same thing. This
cha
The driver for RTL8188EE chips is converted to use the common routine
for getting the hardware information.
Reported-by: Arnd Bergmann
Signed-off-by: Larry Finger
Cc: Arnd Bergmann
---
V2 - Fixes bug found after V1 was submitted.
V3 - No changes.
This patch requires ("rtlwifi: Add missing newl
The driver for RTL8821AE chips is converted to use the common routine
for getting the hardware information.
Reported-by: Arnd Bergmann
Signed-off-by: Larry Finger
Cc: Arnd Bergmann
---
V2 - Fixes bug found after V1 was submitted.
V3 - No changes.
This patch requires ("rtlwifi: Add missing newl
The driver for RTL8192CE chips is converted to use the common routine
for getting the hardware information.
Reported-by: Arnd Bergmann
Signed-off-by: Larry Finger
Cc: Arnd Bergmann
---
V2 - Fixes bug found after V1 was submitted.
V3 - No changes.
This patch requires ("rtlwifi: Add missing newl
The driver for RTL8723BE chips is converted to use the common routine
for getting the hardware information.
Reported-by: Arnd Bergmann
Signed-off-by: Larry Finger
Cc: Arnd Bergmann
---
V2 - Fixes bug found after V1 was submitted.
V3 - No changes.
This patch requires ("rtlwifi: Add missing newl
The driver for RTL8192DE chips is converted to use the common routine
for getting the hardware information.
Reported-by: Arnd Bergmann
Signed-off-by: Larry Finger
Cc: Arnd Bergmann
---
V2 - Fixes bug found after V1 was submitted.
V3 - No changes.
This patch requires ("rtlwifi: Add missing newl
The driver for RTL8723AE chips is converted to use the common routine
for getting the hardware information.
Reported-by: Arnd Bergmann
Signed-off-by: Larry Finger
Cc: Arnd Bergmann
---
V2 - Fixes bug found after V1 was submitted.
V3 - No changes.
This patch requires ("rtlwifi: Add missing newl
This driver contains some complicated if ... else if ... else constructions.
These are replaced by switch statements to improve readability.
Signed-off-by: Larry Finger
---
V2 - Changes suggested by Joe Perches were incorporated
V3 - Missing break statments are added.
This patch requires ("rtlwi
The driver for RTL8192EE chips is converted to use the common routine
for getting the hardware information.
Reported-by: Arnd Bergmann
Signed-off-by: Larry Finger
Cc: Arnd Bergmann
---
V2 - Fixes bug found after V1 was submitted.
V3 - No changes.
This patch requires ("rtlwifi: Add missing newl
The driver for RTL8192CU chips is converted to use the common routine
for getting the hardware information.
Reported-by: Arnd Bergmann
Signed-off-by: Larry Finger
Cc: Arnd Bergmann
---
V2 - Fixes bug found after V1 was submitted.
V3 - No changes.
This patch requires ("rtlwifi: Add missing newl
All of the rtlwifi family of drivers have a similar routine that acquires
the hardware info from efuse and initializes a number of variables in the
driver's private area. A common routine is created for all drivers to use.
Reported-by: Arnd Bergmann
Signed-off-by: Larry Finger
Cc: Arnd Bergmann
The rtlwifi family of drivers use similar routines to extract hardware
information from EFUSE. This set of patches create a common routine to
extract this data, and converts most of the drivers to use this routine.
In addition, a complicated set of if ... else if ... else statements are
present in
Larry Finger wrote:
> Commit 4b9d8d67b44a ("rtlwifi: rtl8192cu: Remove unused parameter") reworked
> this routine. Those changes were later reverted by commit d3feae41a347
> ("rtlwifi: Update power-save routines for 062814 driver").
>
> There were two changes in commit 4b9d8d67b44a. The first of
تحية يا عزيزي
في مقدمة موجزة، وأنا محام آدمز عدن، وأنا أرسل لك البريد الإلكتروني
فيما يتعلق قتلاكم النسبي الذي توفي في بلدي ولكنني لم أتلق أي يستجيب
منك، كيف من أي وقت مضى ولدي تحفظ الخاص من مكتبي فيما يتعلق بلدي أواخر
العميل يطالب بها الصندوق في البنك، المتوفى هو مواطن من بلدك مع نفس
اللقب مع لكم
Removed a blankline after an opening bracket.
Signed-off-by: Samuele Baisi
---
drivers/staging/gdm724x/gdm_tty.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/gdm724x/gdm_tty.c
b/drivers/staging/gdm724x/gdm_tty.c
index eb7e252..ae39663 100644
--- a/drivers/staging/gdm724x/g
On Tue, 2016-07-05 at 09:31 +, Dexuan Cui wrote:
> > > +/* This is the address fromat of Hyper-V Sockets.
> > format
> I suppose you meant I should change
> /* This is ...
> to
> /*
> * This is ...
> I'll fix this.
No, I just meant fromat should be format
___
> From: Joe Perches [mailto:j...@perches.com]
> Sent: Tuesday, July 5, 2016 17:39
> To: Dexuan Cui ; da...@davemloft.net;
> gre...@linuxfoundation.org; net...@vger.kernel.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jasow...@redhat.com; V
> From: Joe Perches [mailto:j...@perches.com]
>
> > +#define sk_to_hvsock(__sk) ((struct hvsock_sock *)(__sk))
> > +#define hvsock_to_sk(__hvsk) ((struct sock *)(__hvsk))
>
> Might as well be static inlines
Hi Joe,
Thank you for the suggestions (again)! :-)
I'll change them to static inlines.
On Thu, 2016-06-30 at 15:58 +, Dexuan Cui wrote:
> Hyper-V Sockets (hv_sock) supplies a byte-stream based communication
> mechanism between the host and the guest. It's somewhat like TCP over
> VMBus, but the transportation layer (VMBus) is much simpler than IP.
trivia:
> diff --git a/include
40 matches
Mail list logo