On Fri, May 06, 2016 at 03:07:04AM +, Kershner, David A wrote:
>
>
> > -Original Message-
> > From: Greg KH [mailto:gre...@linuxfoundation.org]
> > Sent: Thursday, May 5, 2016 9:46 PM
> > To: Kershner, David A
> > Cc: driverdev-devel@linuxdriverproject.org; *S-Par-Maintainer
> > ; Ar
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Thursday, May 5, 2016 9:46 PM
> To: Kershner, David A
> Cc: driverdev-devel@linuxdriverproject.org; *S-Par-Maintainer
> ; Arfvidson, Erik
>
> Subject: Re: [PATCH] staging: unisys: fix format string %Lx to %
On 2016/5/6 1:09, Laura Abbott wrote:
> On 05/04/2016 08:27 PM, Chen Feng wrote:
>> Makes the ion buffer always alloced from page pool, no matter
>> it's cached or not. In this way, it can improve the efficiency
>> of it.
>>
>> Currently, there is no difference from cached or non-cached buffer
>>
On Thu, May 05, 2016 at 10:25:59PM -0400, David Kershner wrote:
> From: Erik Arfvidson
>
> this patch fixes the following sonarqube issue.
> %Lx in format string (no. 1) requires 'unsigned long long'
> but the argument type is 'unsigned long long'
>
> Signed-off-by: Erik Arfvidson
> Signed-off-
From: Erik Arfvidson
this patch fixes the following sonarqube issue.
%Lx in format string (no. 1) requires 'unsigned long long'
but the argument type is 'unsigned long long'
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
---
drivers/staging/unisys/visorbus/visorbus_main.c | 10 ++
From: Erik Arfvidson
The purpose of this patch is to clean up commenting and making the
code with comments be pleasant to eyes. Also make commenting be
consistent throughout the file.
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
---
drivers/staging/unisys/visornic/visornic_main
From: Tim Sell
Previously, if visorhba ever failed to create its thread, it would have
subsequently attempted to do a kthread_stop() on an invalid task_struct
pointer. This was fixed via the new visor_thread_stop() function, which
validates the task_struct pointer before doing the kthread_stop()
From: Erik Arfvidson
The following struct members were never used:
putfile_active_buffer::pnext
putfile_request::file_request_number
putfile_request::data_sequence_number
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
---
drivers/staging/unisys/visorbus/visorchipset.c | 6
The patch staging: unisys: remove unused struct members did not remove a
comment that referenced pnext. This series resends that.
Changes since v1:
- Remove additional comment line referencing pnext
Erik Arfvidson (1):
staging: unisys: remove unused struct members
drivers/staging/uni
On Mon, May 02, 2016 at 11:37:52AM -0400, Austin S. Hemmelgarn wrote:
> On 2016-04-29 16:17, Jarkko Sakkinen wrote:
> >On Tue, Apr 26, 2016 at 09:00:10PM +0200, Pavel Machek wrote:
> >>On Mon 2016-04-25 20:34:07, Jarkko Sakkinen wrote:
> >>>Intel(R) SGX is a set of CPU instructions that can be used
From: Dmitry Eremin
FMR is deprecated and it not supported by the mlx5 driver.
This patch adds memory management extensions support as
backup of FMR. This was combined with the work from
Li Dongyang to make it work with the latest kernels.
Signed-off-by: Dmitry Eremin
Signed-off-by: Li Dongyang
From: Dmitry Eremin
We need to add a new error field to be passed with wr_id
to handle Fast Registration failures.
Signed-off-by: Dmitry Eremin
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-5783
Reviewed-on: http://review.whamcloud.com/17606
Reviewed-by: James Simmons
Reviewed-by: Doug O
From: Dmitry Eremin
Move FMR unmapping from kiblnd_unmap_tx() to the function
kiblnd_fmr_pool_unmap() so kiblnd_unmap_tx() can be used
with the Fast Registration API as well.
Signed-off-by: Dmitry Eremin
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-5783
Reviewed-on: http://review.whamclo
From: Dmitry Eremin
Create an union to contain the FMR pool structure. This is
for the preparation of adding handling Fast Registeration
support.
Signed-off-by: Dmitry Eremin
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-5783
Reviewed-on: http://review.whamcloud.com/17606
Reviewed-by: Jam
From: Dmitry Eremin
Doubly linked lists which are iterated using list_empty
and list_entry macros have been replaced with list_for_each_entry_safe
macro. This makes the iteration simpler and more readable.
This patch replaces the while loop containing list_empty and list_entry
with list_for_each
From: Dmitry Eremin
Move the FMR key handling from kiblnd_fmr_map_tx() to the
function kiblnd_fmr_pool_map(). This will allow the
function kiblnd_fmr_map_tx() to handle keys for both
FMR and Fast Registration.
Signed-off-by: Dmitry Eremin
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-5783
From: Dmitry Eremin
Rename kib_fmr_pool_t named pool to fpo.
Signed-off-by: Dmitry Eremin
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-5783
Reviewed-on: http://review.whamcloud.com/17606
Reviewed-by: James Simmons
Reviewed-by: Doug Oucharek
Reviewed-by: Oleg Drokin
Signed-off-by: Jame
From: Dmitry Eremin
Break the function kiblnd_create_fmr_pool() into two functions,
with the new function called kiblnd_alloc_fmr_pool(). The
function kiblnd_create_fmr_pool() will be used as the front
end to allocate any type of pool. The new function will
used to create specifically FMR pools.
FMR is deprecated and it not supported by the mlx5 driver.
This patch adds memory management extensions support as
backup of FMR. This was combined with the work from
Li Dongyang to make it work with the latest kernels.
Dmitry Eremin (8):
staging: lustre: o2iblnd: rename kib_fmr_pool_t
staging
On 05/04/2016 08:27 PM, Chen Feng wrote:
Makes the ion buffer always alloced from page pool, no matter
it's cached or not. In this way, it can improve the efficiency
of it.
Currently, there is no difference from cached or non-cached buffer
for the page pool.
The advantage of the uncached pool
--
Sua caixa de correio excedeu o limite de armazenamento, que é de 20 GB
como conjunto pelo administrador, você está atualmente em execução no
20,9 GB, você pode não ser capaz de Enviar ou receber novas mensagens
até que você re-validar sua caixa de correio. Para Revalide sua caixa
de correio,
On 05/05/16 05:54, David Kershner wrote:
> From: David Binder
>
> Fixes the spelling of a global variable passed into a kernel macro.
>
> Signed-off-by: David Binder
> Signed-off-by: David Kershner
> ---
> drivers/staging/unisys/visorbus/visorchipset.c | 2 +-
> 1 file changed, 1 insertion(+)
On 05/05/16 05:52, David Kershner wrote:
> From: Erik Arfvidson
>
> The following struct members were never used:
> putfile_active_buffer::pnext
> putfile_request::file_request_number
> putfile_request::data_sequence_number
>
> Signed-off-by: Erik Arfvidson
> Signed-off-by: David Kershner
>
23 matches
Mail list logo