On Sun, May 01, 2016 at 06:05:31PM +0530, Muhammad Falak R Wani wrote:
> It is safe to use RCU_INIT_POINTER() to NULL a pointer, instead of
> rcu_assign_pointer().
> This results in slightly smaller/faster code.
>
> Signed-off-by: Muhammad Falak R Wani
I'm fine with your commit message and don't
NULL comparison has been changed to correct coding style.
Signed-off-by: rohitsakala
---
drivers/staging/speakup/i18n.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/speakup/i18n.c b/drivers/staging/speakup/i18n.c
index 8960079..a031a2d 100644
--- a/driv
It should probably have some error handling as well as just propogating
the error.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
added operator white space and parentheses for readability
Signed-off-by: Manu Kumar
---
drivers/staging/skein/skein_base.c | 24
drivers/staging/skein/skein_block.c | 8
2 files changed, 16 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/skein/sk
Spaces after casts are removed
Signed-off-by: Manu Kumar
---
drivers/staging/skein/skein_api.c | 2 +-
drivers/staging/skein/skein_base.c | 12 ++--
drivers/staging/skein/skein_base.h | 12 ++--
drivers/staging/skein/skein_block.c | 12 ++--
4 files changed, 19 inser
Align wrapped lines to parentheses (if applicable).
Signed-off-by: Manu Kumar
---
drivers/staging/skein/skein_base.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/skein/skein_base.c
b/drivers/staging/skein/skein_base.c
index 8cafbed..c24a573 10
Added lines between functions in skein_block.c and removed unneeded
lines in skein_block.c
Signed-off-by: Manu Kumar
---
drivers/staging/skein/skein_api.c | 1 -
drivers/staging/skein/skein_block.c | 4 +++-
2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/skein/s
On Sun, May 01, 2016 at 03:15:48PM -0700, Greg KH wrote:
What branch are you using? Please use staging-testing.
My bad, I didn't take my own commits to skein into account. I guess you had
committed those changes (from April 05) after I had started the new patch set.
So all in all, it was silly
On Sun, May 01, 2016 at 03:07:23PM -0700, Manu Kumar wrote:
> On Sun, May 01, 2016 at 02:33:14PM -0700, Greg KH wrote:
> > This series does not apply to my tree anymore, can you please refresh it
> > and resend?
>
> That's odd, I just got the latest commits from the master at
> git://git.kernel.or
On Sun, May 01, 2016 at 02:33:14PM -0700, Greg KH wrote:
This series does not apply to my tree anymore, can you please refresh it
and resend?
That's odd, I just got the latest commits from the master at
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git and the patches
still apply
On Sat, Apr 30, 2016 at 12:06:32PM -0700, Manu Kumar wrote:
> Added lines between functions in skein_block.c and removed unneeded
> lines in skein_block.c
>
> Signed-off-by: Manu Kumar
This series does not apply to my tree anymore, can you please refresh it
and resend?
thanks,
greg k-h
___
On Sat, Apr 30, 2016 at 08:19:48AM +0530, rohitsakala wrote:
> NULL comparison has been changed to correct coding style.
>
> Signed-off-by: Sakala Venkata Krishna Rohit
Your "From:" line in your email does not match this name :(
___
devel mailing list
On Sat, Apr 30, 2016 at 01:53:00AM +0100, Salah Triki wrote:
> These patchs check the return value/propagate error of the functions
> read_nic_word_E, eprom_r, eprom_read, rtl8192_read_eeprom_info, write_nic_*
>
> Salah Triki (9):
> staging: rtl8192u: check return value of read_nic_word_E
> st
On Sun, Mar 27, 2016 at 05:31:38PM +0800, Ming Li wrote:
> hi, i rename Dot11d_Reset function.
Why?
>
> Regards,
> Ming Li
Please don't put this in the changelog text, it's not needed.
And also, make your subject line show the subsystem and driver you are
modifying, so it doesn't get ignored.
On Sun, May 01, 2016 at 09:59:40PM +0100, Colin Pitrat wrote:
> Staging: slicoss: remove unused macros.
That's an odd changelog text, looks like a subject line instead :(
> Signed-off-by: Colin Pitrat
We need a blank line between your changelog text (which you don't have)
and the signed-off-by
Staging: slicoss: remove unused macros.
Signed-off-by: Colin Pitrat
---
drivers/staging/slicoss/TODO | 2 -
drivers/staging/slicoss/slic.h| 43 ---
drivers/staging/slicoss/slichw.h | 107 +-
drivers/staging/slicoss/slicoss.c | 22 ++---
On Sun, Apr 03, 2016 at 12:15:20AM +0100, Martyn Welch wrote:
> This patch introduces a fake VME bridge driver. This driver currently
> emulates a subset of the VME bridge functionality. This allows some VME
> subsystem development and even some VME device driver development to be
> carried out in
On Tue, Mar 22, 2016 at 08:17:07PM +0800, Ming Li wrote:
> hi, i move macros into appropriate header files.
Why? What other code needs these macros to require them being moved to
a .h file?
confused,
greg k-h
___
devel mailing list
de...@linuxdriver
Fixed coding style issue
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index 82269eb..ef04638 100644
---
Fixed coding style issue
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index 7831f19..507e448 100644
Fix coding style issue
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 30 ++---
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index f5
Fix coding style issue
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index ef04638..13c1277 100644
--- a/dr
Fixed coding style issue
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index 814ecec..c37ba49 100644
---
Fix coding style issue
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index a3fffd7..82269eb 100644
--- a/
Fixed typo
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index c5e5d52..7831f19 100644
--- a/drivers/staging/
Fixed coding style issue
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index 58d38d6..814ecec 100644
--- a/
Fixed coding style issue
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index 507e448..58d38d6 100644
--
Fixed coding style issue
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index c37ba49..f5e8ac0 100644
--- a/dr
Fixed coding style issue
Signed-off-by: Jacky Boen
---
drivers/staging/rtl8188eu/hal/usb_halinit.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
b/drivers/staging/rtl8188eu/hal/usb_halinit.c
index 07a61b8..c5e5d52 100644
---
It is safe to use RCU_INIT_POINTER() to NULL a pointer, instead of
rcu_assign_pointer().
This results in slightly smaller/faster code.
Signed-off-by: Muhammad Falak R Wani
---
drivers/staging/rdma/hfi1/init.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rdm
Hi!
On Fri 2016-04-29 23:17:44, Jarkko Sakkinen wrote:
> On Tue, Apr 26, 2016 at 09:00:10PM +0200, Pavel Machek wrote:
> > On Mon 2016-04-25 20:34:07, Jarkko Sakkinen wrote:
> > > The firmware uses PRMRR registers to reserve an area of physical memory
> > > called Enclave Page Cache (EPC). There is
31 matches
Mail list logo