> From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
> Sent: Friday, March 25, 2016 0:11
> To: Dexuan Cui
> Cc: driverdev-devel@linuxdriverproject.org; Chris Valean (Cloudbase Solutions
> SRL) ; KY Srinivasan
> Subject: Re: KVP daemon/module race on module unloading
>
> Dexuan Cui writes:
>
>
2016-03-25 12:19 GMT+09:00 Joe Perches :
> On Fri, 2016-03-25 at 11:44 +0900, Daeseok Youn wrote:
>> fix checkpatch.pl warning about 'line over 80 characters'
>> in dgnc_neo.c
> []
>> diff --git a/drivers/staging/dgnc/dgnc_neo.c
>> b/drivers/staging/dgnc/dgnc_neo.c
> []
>> @@ -77,7 +77,8 @@ struct
On Mar 25, 2016, at 12:49 AM, kbuild test robot wrote:
> tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
> staging-testing
> head: 6d197476df27efdb304959845e43f69d1b971a35
> commit: b8ff756bc3513e489f24c14cfb6a8a39d3f3b150 [144/177] staging: lustre:
> libcfs: merge
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-testing
head: 6d197476df27efdb304959845e43f69d1b971a35
commit: b8ff756bc3513e489f24c14cfb6a8a39d3f3b150 [144/177] staging: lustre:
libcfs: merge code from libcfs_ioctl into libcfs_ioctl_getdata
coccinelle warni
On Fri, 2016-03-25 at 11:44 +0900, Daeseok Youn wrote:
> fix checkpatch.pl warning about 'line over 80 characters'
> in dgnc_neo.c
[]
> diff --git a/drivers/staging/dgnc/dgnc_neo.c b/drivers/staging/dgnc/dgnc_neo.c
[]
> @@ -77,7 +77,8 @@ struct board_ops dgnc_neo_ops = {
> .send_immediate_cha
fix checkpatch.pl warning about 'Logical continuations
should be on the previous line' in dgnc_neo.c file.
I think the 'force' need to check first, because if the 'force' is true,
it doesn't need to call another function call.
Signed-off-by: Daeseok Youn
---
drivers/staging/dgnc/dgnc_neo.c | 4
fix checkpatch.pl warning about 'line over 80 characters'
in dgnc_neo.c
Signed-off-by: Daeseok Youn
---
drivers/staging/dgnc/dgnc_neo.c | 66 +++--
1 file changed, 44 insertions(+), 22 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_neo.c b/drivers/stagin
Urgent Help Please!
Dear Beloved.
My name is Mrs. Marjorie Beattie a British Merchant. I have been
diagnosed with Esophageal Cancer, which was discovered very late, due to
my laxity in caring for my health. This sickness has defiled all forms of
medicine, and right now I have only about a few m
Dexuan Cui writes:
> Hi Vitaly,
> We got the below warning once -- it's pretty hard to repro it.
>
> I think the cause may be: before the daemon is terminated, we can successfully
> "rmmod hv_utils" -- as a result all the code/data segments of the module
> shouldn't be accessed any more, but in
The following changes since commit 01cde1538e1dff4254e340f606177a870131a01f:
Merge tag 'nfs-for-4.6-1' of
git://git.linux-nfs.org/projects/trondmy/linux-nfs (2016-03-22 13:16:21 -0700)
are available in the git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git/
Hi Vitaly,
We got the below warning once -- it's pretty hard to repro it.
I think the cause may be: before the daemon is terminated, we can successfully
"rmmod hv_utils" -- as a result all the code/data segments of the module
shouldn't be accessed any more, but in the kernel we still has a dangli
Commit 4671a0266 change the parameter of the second parameter of
cfs_precpt_alloc() from a sizeof type to sizeof type *pointer.
This was incorrect in this case and it caused a crash when the LNet
layer was brought up in my testing. The reason is cfs_precpt_alloc()
creates an array of items where th
On 23/03/16 22:36, H Hartley Sweeten wrote:
The NI TIO support is split into 2 driver modules, ni_tio and ni_tiocmd.
Theses drivers, and the headers have a lot of checkpatch.pl issues.
drivers/staging/comedi/drivers/ni_tio_internal.h
total: 0 errors, 13 warnings, 61 checks, 245 lines checked
dri
Sua caixa de correio excedeu o limite de armazenamento, que é de 20 GB
como definido pelo administrador, você está atualmente em execução no
20,9 GB, você pode não ser capaz de enviar ou receber novas mensagens
até que você re-validar sua caixa de correio. Para re-validar sua
caixa de co
From: Erik Arfvidson
This patch simply removes the double negative comparison for
test_bit since test_bit already preforms this check.
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
---
drivers/staging/unisys/visorinput/visorinput.c | 2 +-
1 file changed, 1 insertion(+), 1 delet
Remove the double negative condition ( x != 0).
Erik Arfvidson (2):
staging: unisys: remove channel.h double negative comparison
staging: unisys: remove visorinput.c double negative comparison
drivers/staging/unisys/include/channel.h | 6 +++---
drivers/staging/unisys/visorinput/visor
From: Erik Arfvidson
This patch removes the double negative comparisons for function
readb.
Signed-off-by: Erik Arfvidson
Signed-off-by: David Kershner
---
drivers/staging/unisys/include/channel.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/unisys
Hi Enric,
[auto build test WARNING on drm/drm-next]
[also build test WARNING on v4.5 next-20160324]
[if your patch is applied to the wrong git tree, please drop us a note to help
improving the system]
url:
https://github.com/0day-ci/linux/commits/Enric-Balletbo-i-Serra/Add-ANX7814-I2C
drivers/gpu/drm/bridge/anx78xx.c:632:1-3: WARNING: PTR_ERR_OR_ZERO can be used
Use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) + PTR_ERR
Generated by: scripts/coccinelle/api/ptr_ret.cocci
CC: Enric Balletbo i Serra
Signed-off-by: Fengguang Wu
---
anx78xx.c |5 +
1 file changed, 1 i
On Thu, Mar 24, 2016 at 11:41:46AM +0100, Enric Balletbo i Serra wrote:
> + /* Map slave addresses of ANX7814 */
> + for (i = 0; i < I2C_NUM_ADDRESSES; i++) {
> + anx78xx->i2c_dummy[i] = i2c_new_dummy(client->adapter,
> + anx78xx_i2c_a
Although there are other chips from the same family that can reuse this
driver, at the moment we only tested ANX7814 chip.
The ANX7814 is an ultra-low power Full-HD (1080p60) SlimPort transmitter
designed for portable devices. This driver adds initial support for HDMI
to DP pass-through mode.
Sig
Hi all,
This patch set to introduces the anx7814 slimport transmitter driver. These
new series will replace the old series that can be found here [1]. The reason
why I introduce these new series is because the driver changed significantly.
The old approach used a polled state machine ans was not r
The ANX7814 is an ultra-low power Full-HD (1080p60) SlimPort transmitter
designed for portable devices.
Signed-off-by: Enric Balletbo i Serra
---
.../devicetree/bindings/video/bridge/anx7814.txt | 41 ++
1 file changed, 41 insertions(+)
create mode 100644 Documentation/dev
Analogix Semiconductor Inc. develops analog and mixed-signal devices for
digital media and communications interconnect applications.
Signed-off-by: Enric Balletbo i Serra
---
Documentation/devicetree/bindings/vendor-prefixes.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/Documentation/d
On 23/03/16 19:24, H Hartley Sweeten wrote:
Refactor dt282x_ns_to_timer() to remove the magic numbers used to calculate
the divisor needed to generate the pacer clock ns timing.
Remove some unnecessary/redundant cruft from the driver.
v2: Ian Abbott prefered to keep the comedi_check_trigger_arg
25 matches
Mail list logo