Smatch reports the following:
CHECK drivers/net/wireless/realtek/rtlwifi/rtl8723ae/hal_btc.c
drivers/net/wireless/realtek/rtlwifi/rtl8723ae/hal_btc.c:137
rtl8723e_dm_bt_need_to_dec_bt_pwr() warn: inconsistent indenting
Signed-off-by: Larry Finger
---
drivers/net/wireless/realtek/rtlwifi/rt
From: Gustavo Padovan
Change SYNC_IOC_FILE_INFO (former SYNC_IOC_FENCE_INFO) behaviour to avoid
future API breaks and optimize buffer allocation.
Now num_fences can be filled by the caller to inform how many fences it
wants to retrieve from the kernel. If the num_fences passed is greater
than ze
The (*auto_attach) initializes all the DIO channels to a default state.
Add a comment for clarity.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_660x.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/drivers/staging/comedi
This driver supports boards that have 1 or 2 TIO chips with base
addresses 0x800 apart. Replace the static const array 'GPCT_OFFSET'
with a define and calculate the base address based on the chip index.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/
Fix the checkpatch.pl issues.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_660x.c | 40
1 file changed, 20 insertions(+), 20 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ni_660x.c
b/d
2016-03-17 Joe Perches :
> On Thu, 2016-03-17 at 18:19 -0300, Gustavo Padovan wrote:
> > 2016-03-17 Joe Perches :
> > > On Thu, 2016-03-17 at 16:50 -0400, Rob Clark wrote:
> > > > On Thu, Mar 17, 2016 at 4:40 PM, Joe Perches wrote:
> > > []
> > > > > It's a name that seems like it should be a str
On Fri, Mar 18, 2016 at 01:41:19PM +0100, Geert Uytterhoeven wrote:
> On Fri, Mar 18, 2016 at 6:42 AM, Linux Kernel Mailing List
> wrote:
> > Web:
> > https://git.kernel.org/torvalds/c/f45b0fba43f415f69982df743dfa9b5d1b57785e
> > Commit: f45b0fba43f415f69982df743dfa9b5d1b57785e
> > Par
On Thu, 2016-03-17 at 18:19 -0300, Gustavo Padovan wrote:
> 2016-03-17 Joe Perches :
> > On Thu, 2016-03-17 at 16:50 -0400, Rob Clark wrote:
> > > On Thu, Mar 17, 2016 at 4:40 PM, Joe Perches wrote:
> > []
> > > > It's a name that seems like it should be a straightforward
> > > > cast of a kernel
Hello Amitoj Kaur Chawla,
The patch 3eced21a5afb: "staging: most: hdm-dim2: Replace request_irq
with devm_request_irq" from Feb 18, 2016, leads to the following
static checker warning:
drivers/staging/most/hdm-dim2/dim2_hdm.c:841 dim2_probe()
error: 'dev->netinfo_task' dereferenci
Kdump keeps biting. Turns out CHANNELMSG_UNLOAD_RESPONSE is always
delivered to CPU0 regardless of what CPU we're sending CHANNELMSG_UNLOAD
from. vmbus_wait_for_unload() doesn't account for the fact that in case
we're crashing on some other CPU and CPU0 is still alive and operational
CHANNELMSG_UNL
Remove the unnecessary NULL pointer check.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_mio_common.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ni_mio_common.c
b/drive
On Thu, Mar 17, 2016 at 5:19 PM, Gustavo Padovan wrote:
> 2016-03-17 Joe Perches :
>
>> On Thu, 2016-03-17 at 16:50 -0400, Rob Clark wrote:
>> > On Thu, Mar 17, 2016 at 4:40 PM, Joe Perches wrote:
>> []
>> > > It's a name that seems like it should be a straightforward
>> > > cast of a kernel poin
Sort this enum so that it has a 1:1 relationship with the ni_tio.h
enum ni_gpct_register.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_660x.c | 95
1 file changed, 48 insertions(+), 47 deletions(-)
Implement copy-free read APIs.
Signed-off-by: K. Y. Srinivasan
---
drivers/hv/ring_buffer.c | 55 ++
include/linux/hyperv.h |6 +
2 files changed, 61 insertions(+), 0 deletions(-)
diff --git a/drivers/hv/ring_buffer.c b/drivers/hv/ring_buf
These patches fix a problem that occurs for laptops that are constructed
with only a single antenna, but have an incorrect programming of the
on-board EEPROM.
These changes have been extensively tested in the rtlwifi_new repo
at GitHub.com.
As the patches fix a deficiency rather than a bug, they
On Wed, 2016-03-16 at 23:15 +, KY Srinivasan wrote:
>
> > -Original Message-
> > From: James Bottomley [mailto:james.bottom...@hansenpartnership.com
> > ]
> > Sent: Wednesday, March 16, 2016 4:08 PM
> > To: Martin K. Petersen ; KY Srinivasan
> >
> > Cc: Christoph Hellwig ;
> > gre...
A number of new laptops have been delivered with only a single antenna.
In principle, this is OK; however, a problem arises when the on-board
EEPROM is programmed to use the other antenna connection. The option
of opening the computer and moving the connector is not always possible
as it will void
This fuction just returns a pointer from the private data. The name
might provide some confusion since it appears to be an exported
function from the mite driver.
Just remove it and get the pointer directly where needed.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
--
Cleanup the Hyper-V ring buffer code. Also Implement APIs for
supporting copy-free operations on the read side.
K. Y. Srinivasan (5):
Drivers: hv: vmbus: Introduce functions for estimating room in the
ring buffer
Drivers: hv: vmbus: Use READ_ONCE() to read variables that are
volatile
Signed-off-by: James Bottomley
---
drivers/scsi/storvsc_drv.c | 11 +++
1 file changed, 3 insertions(+), 8 deletions(-)
diff --git a/drivers/scsi/storvsc_drv.c b/drivers/scsi/storvsc_drv.c
index 3ddcabb..dcb7393 100644
--- a/drivers/scsi/storvsc_drv.c
+++ b/drivers/scsi/storvsc_drv.c
@@
On Fri, 2016-03-18 at 23:58 -0400, Jes Sorensen wrote:
> Joe Perches writes:
> > On Fri, 2016-03-18 at 13:42 -0400, Jes Sorensen wrote:
> > > Xose Vazquez Perez writes:
> > > >
> > > > People should not waste time and energy working on this staging driver.
> > > > A replacement(rtl8xxxu) using t
Use the READ_ONCE macro to access variabes that can change asynchronously.
Signed-off-by: K. Y. Srinivasan
---
drivers/hv/ring_buffer.c |7 ---
1 files changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/hv/ring_buffer.c b/drivers/hv/ring_buffer.c
index 902375b..2919395 100644
The first parameter to dev_dbg() and dev_err() is struct device *,
not struct device **.
Fixes: de71daf5c839 ("Staging: fsl-mc: Replace pr_debug with dev_dbg")
Fixes: 454b0ec8bf99 ("Staging: fsl-mc: Replace pr_err with dev_err")
Cc: Bhumika Goyal
Signed-off-by: Guenter Roeck
---
drivers/staging
From: Gustavo Padovan
Hi,
This is the first step and the most important one of the de-stage
of the the sync framework, it de-stage the sync_file part which is used
to send/receive fence file descriptors with the userspace.
These patches sits on top of the sync ABI changes that I sent earlier to
Joe Perches writes:
> On Fri, 2016-03-18 at 13:42 -0400, Jes Sorensen wrote:
>> Xose Vazquez Perez writes:
>> > People should not waste time and energy working on this staging driver.
>> > A replacement(rtl8xxxu) using the kernel wireless stack already was merged
>> > in the 4.3 kernel.
> []
>> >
Hi,
Thank you for the email, apologies for that I'll get that sorted out now.
Thanks again
On Thu, Mar 17, 2016 at 10:11:18AM -0700, Greg KH wrote:
> On Thu, Mar 17, 2016 at 04:55:37PM +, Yousof El-Sayed wrote:
> > Signed-off-by: Yousof El-Sayed
>
> I can't take patches without any changel
Remove unnecessary return statement from last line of void function call
Signed-off-by: Nicholas Sim
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
Today's patch by Arndt Bergman showing an indentation problem in rtl8821ae
told me that it was time for rechecking all the code for indentation and
other problems. Along with Arndt's patch, there are no remaining Smatch
warnings.
As with all other cleanup patches, these have low priority.
Larry
-
Shuah Khan wrote:
> On 03/18/2016 08:12 AM, Javier Martinez Canillas wrote:
>> Hello Shuah,
>>
>> On 03/18/2016 11:01 AM, Shuah Khan wrote:
>>> On 03/18/2016 07:05 AM, Mauro Carvalho Chehab wrote:
Now that media_device_unregister() also does a cleanup, rename it
to media_device_unregister
Smatch lists the following:
CHECK drivers/net/wireless/realtek/rtlwifi/rtl8192c/dm_common.c
drivers/net/wireless/realtek/rtlwifi/rtl8192c/dm_common.c:243
rtl92c_dm_false_alarm_counter_statistics() warn: inconsistent indenting
Signed-off-by: Larry Finger
---
drivers/net/wireless/realtek/rtl
Hello Shuah,
On 03/18/2016 11:01 AM, Shuah Khan wrote:
> On 03/18/2016 07:05 AM, Mauro Carvalho Chehab wrote:
>> Now that media_device_unregister() also does a cleanup, rename it
>> to media_device_unregister_cleanup().
>>
>> Signed-off-by: Mauro Carvalho Chehab
>
> I think adding cleanup is red
On Thu, 2016-03-17 at 00:01 +, KY Srinivasan wrote:
> The only attributes I would be interested are:
> 1) node name
> 2) port name
>
> Ideally, if this can show under /sys/class/fc_host/hostx/port_name
> and node_name,
> it will be ideal since all user scripts can work.
OK, like this?
>From
On Fri, 2016-03-18 at 13:42 -0400, Jes Sorensen wrote:
> Xose Vazquez Perez writes:
> > People should not waste time and energy working on this staging driver.
> > A replacement(rtl8xxxu) using the kernel wireless stack already was merged
> > in the 4.3 kernel.
[]
> > drivers/staging/rtl8723au/TO
Add some whitespace to the Digital I/O subdevice init and add a
comment about the channels. This driver is a bit goofy, only 32 of
the 40 channels can actually be used for Digital I/Os and 32 of
them can be routed to the counters for alternate use.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Hard-coding the subdevice order is normally a bad idea. If a new subdevice
is added, or removed, it could potentially break pretty badly.
Remove the enum and associated NI_660X_GPCT_SUBDEV() helper that hard-code
the subdevice order.
Fix the (*auto_attach) so it initializes all the subdevices wit
This driver has a lot of checkpatch.pl issues:
total: 0 errors, 71 warnings, 27 checks, 1222 lines checked
There is also a lot of cruft that bloats the driver and makes it harder
to follow.
This series fixes all the checkpatch.pl issues:
total: 0 errors, 0 warnings, 0 checks, 944 lines checked
A
Tidy up this function to fix the checkpatch.pl issues:
WARNING: Prefer 'unsigned int' to bare use of 'unsigned'
For aesthetics, remove the static const local variables.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_660x.c | 54 ++
Fix the checkpatch.pl issue. Move the memory barrier to a better place.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_660x.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/ni_6
For aesthetics, initialize the TIO chips before the subdevices are
allocated and initialized.
Refactor the function to initialize all the TIO chips and move it
to a better place in the driver.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/dr
We need to issue a full memory barrier prior making a signalling decision.
Signed-off-by: K. Y. Srinivasan
Cc: sta...@vger.kernel.org
---
drivers/hv/ring_buffer.c |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/drivers/hv/ring_buffer.c b/drivers/hv/ring_buffer.c
index 29
Use the virt_xx barriers that have been defined for use in virtual machines.
Signed-off-by: K. Y. Srinivasan
---
drivers/hv/ring_buffer.c | 14 +++---
1 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/hv/ring_buffer.c b/drivers/hv/ring_buffer.c
index 67dc245..c2c2b
41 matches
Mail list logo