Hi Greg,
On 13 February 2016 at 04:26, Greg KH wrote:
>> 1. Include it as an extra kernel module. This is good because it can
>> live in "extra" for a while until it passes checks.
>
> As the driver seems to grab the same device as an existing kernel
> driver, no, that will not work, we don't wan
>On Fri, 2016-02-12 at 12:06 -0500, James Simmons wrote:
>> Add missing spaces in the code reported by checkpatch.pl.
>[]
>> diff --git a/drivers/staging/lustre/include/linux/lnet/lib-types.h
>> b/drivers/staging/lustre/include/linux/lnet/lib-types.h
>[]
>> @@ -112,7 +112,7 @@ typedef struct lnet_
>> diff --git a/drivers/staging/lustre/lustre/libcfs/linux/linux-module.c
>> b/drivers/staging/lustre/lustre/libcfs/linux/linux-module.c
>> index 33f6036..64f0fbf 100644
>> --- a/drivers/staging/lustre/lustre/libcfs/linux/linux-module.c
>> +++ b/drivers/staging/lustre/lustre/libcfs/linux/linux-mod
I looked at the Smatch warnings, plus some bonus stuff I'm still working
on.
drivers/staging/unisys/include/iochannel.h:592 add_physinfo_entries() warn:
inconsistent indenting
drivers/staging/unisys/include/iochannel.h:596 add_physinfo_entries() warn:
inconsistent indenting
drivers/staging/unisy
This patch removes braces {} for single block statements as prescribed
by checkpatch.pl
Signed-off-by: Roger H. Newell
---
drivers/staging/wilc1000/wilc_spi.c | 25 +
1 file changed, 9 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_spi.c
b/dri
This patch corrects spacing errors generated by checkpatch.pl
Signed-off-by: Roger H. Newell
---
drivers/staging/wilc1000/wilc_spi.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_spi.c
b/drivers/staging/wilc1000/wilc_spi.c
index 2928712.
Greg,
Thank you very much for taking our patches. All of us here appreciate
it a lot. :)
It looks to me like our driver set is clean as far as
checkpatch.pl is concerned - there's one error, which was said to be
acceptable as it was, and a small number of checks that can't be
made any prettier.
Signed-off-by: Colin Vidal
---
drivers/staging/rtl8188eu/core/rtw_iol.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c
b/drivers/staging/rtl8188eu/core/rtw_iol.c
index 3dd1a9a..2e2145c 100644
--- a/drivers/staging/rtl8188eu/core/rtw
Signed-off-by: Colin Vidal
---
drivers/staging/rtl8188eu/core/rtw_iol.c | 10 +++---
1 file changed, 3 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c
b/drivers/staging/rtl8188eu/core/rtw_iol.c
index 2e2145c..ba6c492 100644
--- a/drivers/staging/rtl8188eu
Signed-off-by: Colin Vidal
---
drivers/staging/rtl8188eu/core/rtw_iol.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c
b/drivers/staging/rtl8188eu/core/rtw_iol.c
index 000a81c..7642c22 100644
--- a/drivers/staging/rtl8188eu/core/r
Signed-off-by: Colin Vidal
---
drivers/staging/rtl8188eu/core/rtw_iol.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c
b/drivers/staging/rtl8188eu/core/rtw_iol.c
index 7642c22..3dd1a9a 100644
--- a/drivers/staging/rtl8188eu/core/r
Signed-off-by: Colin Vidal
---
drivers/staging/rtl8188eu/core/rtw_iol.c | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c
b/drivers/staging/rtl8188eu/core/rtw_iol.c
index cdcf0ea..000a81c 100644
--- a/drivers/staging/rtl8188eu/core/rtw_iol.c
+++ b/dr
On Fri, 2016-02-12 at 12:06 -0500, James Simmons wrote:
> Add missing spaces in the code reported by checkpatch.pl.
[]
> diff --git a/drivers/staging/lustre/include/linux/lnet/lib-types.h
> b/drivers/staging/lustre/include/linux/lnet/lib-types.h
[]
> @@ -112,7 +112,7 @@ typedef struct lnet_libhand
On Fri, Feb 12, 2016 at 11:55:42PM +1100, Michael wrote:
> Hi,
>
> I've been maintaining an out-of-tree kernel module for the Xbox 360
> "Big Button" controller for about 5 years, called xbox360bb. It is
> based on some code which was submitted to LKML in 2009, which was
> rejected for vague 'sty
Cleanup all occurances of more than one variable being set per line as
reported by checkpatch.pl.
Signed-off-by: James Simmons
---
.../staging/lustre/include/linux/lnet/lib-lnet.h |3 ++-
.../staging/lustre/include/linux/lnet/socklnd.h|3 ++-
.../staging/lustre/lnet/klnds/o2iblnd/o
Remove any useless blank lines reported by checkpatch.pl
for LNet layer.
Signed-off-by: James Simmons
---
drivers/staging/lustre/include/linux/lnet/nidstr.h |3 +++
.../staging/lustre/lnet/klnds/o2iblnd/o2iblnd.c|6 --
.../staging/lustre/lnet/klnds/o2iblnd/o2iblnd_cb.c |2 --
Several function declarations have spacing in them. Lets
remove all those instances reported by checkpatch.pl.
Signed-off-by: James Simmons
---
.../staging/lustre/lnet/klnds/o2iblnd/o2iblnd.h|2 +-
.../staging/lustre/lnet/klnds/socklnd/socklnd_cb.c | 272 ++--
.../lustre
Properly balance the braces done wrong as reported by
checkpatch.pl.
Signed-off-by: James Simmons
---
.../staging/lustre/lnet/klnds/o2iblnd/o2iblnd_cb.c |3 ++-
.../lustre/lnet/klnds/socklnd/socklnd_lib.c|3 ++-
.../lustre/lnet/klnds/socklnd/socklnd_proto.c |3 +--
drive
This is the start of the work to bring the upstream client LNet layer
up to date. Before merging in various bug fixes the majority of the
checkpatch issues need to be addressed. This patch series cleans up
the majority of the check patch issues and brings the code style much
closer to what is requi
In several places in the LNet core the code doesn't align
up properly. This resolves those checkpath issues.
Signed-off-by: James Simmons
---
.../staging/lustre/lnet/klnds/o2iblnd/o2iblnd.c| 49 +--
.../staging/lustre/lnet/klnds/o2iblnd/o2iblnd.h| 10 +-
.../staging/lustre/ln
No need for the parentheses around any function pointer.
Signed-off-by: James Simmons
---
.../staging/lustre/lnet/klnds/o2iblnd/o2iblnd_cb.c |2 +-
drivers/staging/lustre/lnet/lnet/api-ni.c |4 ++--
drivers/staging/lustre/lnet/lnet/lib-move.c| 12 ++--
drivers/
Add missing spaces in the code reported by checkpatch.pl.
Signed-off-by: James Simmons
---
.../staging/lustre/include/linux/lnet/lib-types.h |2 +-
.../staging/lustre/lnet/klnds/o2iblnd/o2iblnd.c|2 +-
.../staging/lustre/lnet/klnds/o2iblnd/o2iblnd.h|4 ++--
.../staging/lustr
In several places in the LNet core comment blocks don't follow the
linux kernel style. This patch cleans those problems up.
Signed-off-by: James Simmons
---
drivers/staging/lustre/include/linux/lnet/api.h| 22 ++-
.../staging/lustre/include/linux/lnet/lib-lnet.h |9 +-
.../staging/lu
When lnet_text_buf data structure was transform from typedef
to struct the *_t which is typical of typedef was not drop.
This patch removes the *_t to be consistent.
Signed-off-by: James Simmons
---
drivers/staging/lustre/lnet/lnet/config.c | 57 ++---
1 files changed,
WORLD BANK GROUP UNITED STATES OF AMERICA
42, 122 E 42nd St, New York, NY 10168, United States
ACCRUED INTEREST PAYMENT UNIT / INTELLIGENT DEPARTMENT
Phone +1-7169022295= Fax +-1 -7162427998
Our Ref: WBA/AGF/IPIX/16
Attention: Esteem Beneficiary
wait_for_completion() may sleep, it enables interrupts and this
is something we really want to avoid on crashes because interrupt
handlers can cause other crashes. Switch to the recently introduced
vmbus_wait_for_unload() doing busy wait instead.
Reported-by: Radim Krcmar
Signed-off-by: Vitaly Ku
We have 3 functions dealing with messages and they all implement
the same logic to finalize reads, move it to vmbus_signal_eom().
Suggested-by: Radim Krcmar
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 10 +-
drivers/hv/hyperv_vmbus.h | 24
dr
First patch of the series addresses a potentially important issue,
second patch tries to make crash path more stable, the rest is just
a cleanup.
Please review.
Vitaly Kuznetsov (4):
Drivers: hv: vmbus: don't loose HVMSG_TIMER_EXPIRED messages
Drivers: hv: vmbus: avoid wait_for_completion() o
Message header is modified by the hypervisor and we read it in a loop,
we need to prevent compilers from optimizing accesses. There are no such
optimizations at this moment, this is just a future proof.
Suggested-by: Radim Krcmar
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/channel_mgmt.c | 2
We must handle HVMSG_TIMER_EXPIRED messages in the interrupt context
and we offload all the rest to vmbus_on_msg_dpc() tasklet. This functions
loops to see if there are new messages pending. In case we'll ever see
HVMSG_TIMER_EXPIRED message there we're going to lose it as we can't
handle it from t
This patch renames result to ret that is used to get return value from
wilc_send_config_pkt.
Some handle_*() function are used as result, others are used as ret.
It will start to rename as ret in all handle_*() function to sync up
with this variable name.
Signed-off-by: Chaehyun Lim
---
drivers/
This patch uses netdev_err instead of PRINT_ER that is a custom debug
print.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b/drivers/staging/wilc1000/host_in
When handle_set_channel is called in hostIFthread that is a kernel
thread, it is not checked return type of this function. This patch
changes return type to void and removes braces if statement due
to have a single statement.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interfac
result variable gets value from wilc_send_config_pkt that has
return value of int. This patch changes data type of result variable to
int.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging
This patch renames au8bssid to bssid to remove au8 prefix in struct
join_bss_param. There is no need to use prefix to show data type of this
variable.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a
This patch renames u8security to security to remove u8 prefix in struct
user_conn_req. There is no need to use prefix to show data type of this
variable.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 6 +++---
drivers/staging/wilc1000/host_interface.h | 2 +-
2 file
struct scan_info is defined as a new local variable in wilc_scan
function. It makes some assignment short as well as improve more
readability.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 31 ---
1 file changed, 16 insertions(+), 15 dele
This patch renames pu8bssid to bssid to remove pu8 prefix in struct
user_conn_req. There is no need to use prefix to show data type of this
variable.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 30 +++---
drivers/staging/wilc1000/host_inter
This patch renames pu8ssid to ssid to remove pu8 prefix in struct
user_conn_req. There is no need to use prefix to show data type of this
variable.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 22 +++---
drivers/staging/wilc1000/host_interface.h |
This patch renames s8rssi to rssi to remove s8 prefix in struct
found_net_info. There is no need to use prefix to show data type of this
variable.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 6 +++---
drivers/staging/wilc1000/host_interface.h | 2 +-
2 files chang
This patch renames au8bssid to bssid to remove au8 prefix. There is no
need to use prefix to show data type of this variable.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 8
drivers/staging/wilc1000/host_interface.h | 2 +-
2 files changed, 5 insertions(+)
Hi,
I've been maintaining an out-of-tree kernel module for the Xbox 360
"Big Button" controller for about 5 years, called xbox360bb. It is
based on some code which was submitted to LKML in 2009, which was
rejected for vague 'style reasons' at the time. I am hoping that I
can get the driver to pa
Remove scope braces that were generating a warning in sync_debug.c since
they were scoping a single statement
Signed-off-by: Oliver Graff
---
drivers/staging/android/sync_debug.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/android/sync_debug.c
b/drivers
43 matches
Mail list logo