re: Staging: fbtft: add ssd1325 controller support

2016-02-11 Thread Dan Carpenter
Hello Alexey Mednyy, The patch 12e2a34165d5: "Staging: fbtft: add ssd1325 controller support" from Jan 27, 2016, leads to the following static checker warning: drivers/staging/fbtft/fb_ssd1325.c:100 blank() warn: passing __func__ while the format string already contains the name

[PATCH v5 2/8] Staging: rts5208: rtsx_transport.c: Align to open parenthesis

2016-02-11 Thread Shaun Ren
This patch fixes the alignment issue reported by checkpatch.pl: CHECK: Alignment should match open parenthesis Add a unsigned char *sgbuffer in rtsx_stor_access_xfer_buffer to make the following memcpy logic easier to read. Add a struct scatterlist *sg in the use_sg branch of rtsx_transfer_data_

Re: [PATCH v4 2/8] Staging: rts5208: rtsx_transport.c: Align to open parenthesis

2016-02-11 Thread Joe Perches
On Thu, 2016-02-11 at 20:07 -0800, Shaun Ren wrote: > This patch fixes the alignment issue reported by checkpatch.pl: > > CHECK: Alignment should match open parenthesis [] > diff --git a/drivers/staging/rts5208/rtsx_transport.c > b/drivers/staging/rts5208/rtsx_transport.c [] > @@ -52,12 +55,14 @@

Re: [PATCH v4 2/8] Staging: rts5208: rtsx_transport.c: Align to open parenthesis

2016-02-11 Thread kbuild test robot
Hi Shaun, [auto build test WARNING on staging/staging-testing] [also build test WARNING on v4.5-rc3 next-20160211] [if your patch is applied to the wrong git tree, please drop us a note to help improving the system] url: https://github.com/0day-ci/linux/commits/Shaun-Ren/Staging-rts5208-Fix

[PATCH v4 5/8] Staging: rts5208: rtsx_transport.c: Remove extra newlines

2016-02-11 Thread Shaun Ren
This patch fixes the following issues in rtsx_transport.c as reported by checkpatch.pl: CHECK: Blank lines aren't necessary after an open brace '{' CHECK: Please don't use multiple blank lines Signed-off-by: Shaun Ren --- drivers/staging/rts5208/rtsx_transport.c | 3 --- 1 file changed, 3 delet

[PATCH v4 6/8] Staging: rts5208: rtsx_transport.c: Fix label naming convention

2016-02-11 Thread Shaun Ren
This patch fixes the following naming convention issue in rtsx_transport.c, as reported by checkpatch.pl: CHECK: Avoid CamelCase: Signed-off-by: Shaun Ren --- drivers/staging/rts5208/rtsx_transport.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rts5

[PATCH v4 7/8] Staging: rts5208: rtsx_transport.c: Remove unnecessary parentheses

2016-02-11 Thread Shaun Ren
This patch removes all unnecessary parentheses found by checkpatch.pl. Signed-off-by: Shaun Ren --- Changes since v3 * Fixed patch conflicts due to commit 9a66d05d82db ("Staging: rts5208: fix check for dma mapping error"), and commit b3232842dbef ("Staging: rts5208: remove unnecessary p

[PATCH v4 8/8] Staging: rts5208: rtsx_transport.c: Fix comparisons to NULL

2016-02-11 Thread Shaun Ren
This patch changes all comparsions to NULL with !..., as reported by checkpatch.pl. Signed-off-by: Shaun Ren --- drivers/staging/rts5208/rtsx_transport.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rts5208/rtsx_transport.c b/drivers/staging/rts5208/

[PATCH v4 2/8] Staging: rts5208: rtsx_transport.c: Align to open parenthesis

2016-02-11 Thread Shaun Ren
This patch fixes the alignment issue reported by checkpatch.pl: CHECK: Alignment should match open parenthesis Add a unsigned char *sgbuffer in rtsx_stor_access_xfer_buffer to make the following memcpy logic easier to read. Add a struct scatterlist *sg in the use_sg branch of rtsx_transfer_data_

[PATCH v4 4/8] Staging: rts5208: rtsx_transport.c: Add spaces around -

2016-02-11 Thread Shaun Ren
This patch fixes the following styling issue in rtsx_transport.c as reported by checkpatch.pl: CHECK: spaces preferred around that '-' (ctx:VxV) Signed-off-by: Shaun Ren --- drivers/staging/rts5208/rtsx_transport.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/

[PATCH v4 3/8] Staging: rts5208: rtsx_transport.c: Remove spaces after casts

2016-02-11 Thread Shaun Ren
This patch removes all spaces after casts in rtsx_transport.c, as reported by checkpatch.pl: CHECK: No space is necessary after a cast Signed-off-by: Shaun Ren --- drivers/staging/rts5208/rtsx_transport.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rts520

[PATCH v4 1/8] Staging: rts5208: rtsx_transport.c: Cleanup comments

2016-02-11 Thread Shaun Ren
This patch fixes all multiline comments to conform to the coding style, which states that multiline comments should start with "/*" and end with "*/" on a separate line. Also cleans up some comments to make them more clear and/or reflect what the code is doing. Signed-off-by: Shaun Ren --- Chang

[PATCH v4 0/8] Staging: rts5208: Fix coding style

2016-02-11 Thread Shaun Ren
This set of patches fixes the coding style issues in rtsx_transport.c. Changes since v3 * Removed the extraneous SCSI comment in the first patch * Removed the last patch (Staging: rts5208: Add missing dma_mapping_error) as it is already done in change 9a66d05d82db (Staging: rts5208: fix ch

Re: [PATCH v2] Staging: fix coding style in rtl8188eu/core

2016-02-11 Thread Greg Kroah-Hartman
On Wed, Feb 10, 2016 at 10:09:28PM +0100, Colin Vidal wrote: > Set constant operand on right of test, and refactor the code in a more > compact and readable way. Please don't do two different things in the same patch, break this up into different patches. thanks, gregk -h ___

[PATCH] rtl8188eu: fix signal strength indication

2016-02-11 Thread Andrew Bradford
RTL8188E can only have a maximum of 2 chains so match that in the actual phy_rx_agc_info structure within phy_status_rpt. This will cause the other data received from the PHY, such as signal strength indication of beacons, to properly align and allow extraction and use within the signal strength r

[PATCH] staging: octeon: refactor rgmii 10 mbps preamble error checking

2016-02-11 Thread Aaro Koskinen
Refactor RGMII 10 Mbps preamble error checking. The current implementation does not work correctly in phydev mode since only the link status changes trigger the callback, and if we stay on 10 Mbps operation the periodic checks for error counters are never done. Provide a periodic worker also durin

[PATCH] staging: wilc1000: spelling corrections

2016-02-11 Thread Roger H. Newell
This patch fixes spelling warnings generated by checkpatch.pl Signed-off-by: Roger H. Newell --- drivers/staging/wilc1000/host_interface.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_interfac

[PATCH 1/3] staging: rtl8188eu: remove _rtl88e_fill_dummy

2016-02-11 Thread Ivan Safonov
The _rtl88e_fill_dummy function replaced by memset in rtl88eu_download_fw. More appropriate names are used for pfwdata and fwsize variables (download_data and download_size respectively). Also u32 replaced by size_t for download_size variable. Signed-off-by: Ivan Safonov --- drivers/staging/rt

[PATCH 2/3] staging: rtl8188eu: remove pfirmware and fwsize of the hal_data_8188e structure

2016-02-11 Thread Ivan Safonov
The pfirmware is used only in rtl88eu_download_fw function (except the kfree(rtlhal->pfirmware) in netdev_close). The fwsize not used after initialization at all. The pfirmvare replaced by fw_data and fwsize removed. Signed-off-by: Ivan Safonov --- drivers/staging/rtl8188eu/hal/fw.c

[PATCH 3/3] staging: rtl8188eu: add release_firmware() between request_firmware and function error exit

2016-02-11 Thread Ivan Safonov
Small memory leak fixed. Signed-off-by: Ivan Safonov --- drivers/staging/rtl8188eu/hal/fw.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/hal/fw.c b/drivers/staging/rtl8188eu/hal/fw.c index 55c17df..656133c 100644 --- a/drivers/staging/rtl8188

[PATCH 1/4] rtlwifi: Prepare for reworking 5G channels

2016-02-11 Thread Larry Finger
There are 3 drivers in this family that have 5G radios. Each of them defines local copies of the available channels. This patch adds the two arrays to the core driver. Signed-off-by: Larry Finger --- Kalle, This material is for kernel 4.6. Larry drivers/net/wireless/realtek/rtlwifi/core.c |

[PATCH 0/4] rtlwifi: Rework 5G channel arrays

2016-02-11 Thread Larry Finger
Several of the rtlwifi drivers have separate definitions of the 5D channel arrays. This patch set replaces 5 separate instances with a single one in the common header. These patches also eliminate spurious messages "rtl8821ae:_rtl8821ae_get_chnl_group(): 5G, Channel 163 in Group not found" from r

[PATCH 3/4] rtlwifi: rtl8192ee: Convert driver to use new 5G channel tables

2016-02-11 Thread Larry Finger
The driver defines its own set of channel tables for the 5G band. With this change, it will use those of the core. Signed-off-by: Larry Finger --- Kalle, This material is for kernel 4.6. Larry drivers/net/wireless/realtek/rtlwifi/rtl8192ee/hw.c | 12 1 file changed, 12 deletions

[PATCH 4/4] rtlwifi: rtl8821ae: Convert driver to use common 5G channel table

2016-02-11 Thread Larry Finger
There are several copies of the 5G channel tables in this driver. These are removed so that the tables in the core will be used. This change also removes a useless message of "Channel 163 in Group not found". The number of possible 5G channels was reduced from 54 to a better value of 49 during the

[PATCH 2/4] rtlwifi: rtl8192de: Convert driver to use common 5G channels

2016-02-11 Thread Larry Finger
This driver defines its owh copy of the 5G channels. Change it to use the common definitions. Signed-off-by: Larry Finger --- Kalle, This material is for kernel 4.6. Larry .../net/wireless/realtek/rtlwifi/rtl8192de/phy.c | 23 -- 1 file changed, 4 insertions(+), 19 dele

[PATCH] rtlwifi: rtl8821ae: Silence useless log output

2016-02-11 Thread Larry Finger
When driver rtl8821ae is loaded but not connected to any AP, it logs a "firmware not ready to run" message roughly once a minute. To eliminate logging this massage under normal debug conditions, the degug level needed to print this message is increased. Signed-off-by: Larry Finger --- Kalle, Th

Re: [PATCH] rdma: amso1100: c2_provider: Use netdev_dbg()

2016-02-11 Thread Doug Ledford
On 02/06/2016 10:11 AM, Amitoj Kaur Chawla wrote: > Replace generic pr_debug() with netdev_dbg() for net devices. > > Found using Coccinelle. The semantic patch used to find this is as > follows: > > // > @@ > expression e; > identifier f,i; > position p; > @@ > > f(...,struct net_device *i,...)

Re: [PATCH V2 net-next] hv_netvsc: cleanup netdev feature flags for netvsc

2016-02-11 Thread David Miller
From: Simon Xiao Date: Thu, 4 Feb 2016 15:49:34 -0800 > 1. Adding NETIF_F_TSO6 feature flag; > 2. Adding NETIF_F_HW_CSUM. NETIF_F_IPV6_CSUM and NETIF_F_IP_CSUM are > being deprecated; > 3. Cleanup the coding style of flag assignment by using macro. > > Signed-off-by: Simon Xiao > Reviewed-by: