On Tue, Feb 09, 2016 at 10:16:12AM -0500, Ben Romer wrote:
> On Mon, 2016-02-08 at 22:39 +0530, Sudip Mukherjee wrote:
> > maybe this is better where you have single exit point and so only one
> > spin_unlock_irqrestore().
>
>
> We discussed this before. I don't want to put any of the goto messes
On Mon, Feb 08, 2016 at 05:31:23PM -0800, Shaun Ren wrote:
> This patch removes all unnecessary parentheses found by checkpatch.pl.
>
> Signed-off-by: Shaun Ren
This will not apply anymore because of some other changes done by:
9a66d05d82db ("Staging: rts5208: fix check for dma mapping error")
On Mon, Feb 08, 2016 at 05:31:18PM -0800, Shaun Ren wrote:
> This patch fixes the alignment issue reported by checkpatch.pl:
>
> CHECK: Alignment should match open parenthesis
>
> Signed-off-by: Shaun Ren
> ---
> drivers/staging/rts5208/rtsx_transport.c | 61
> ++--
On Mon, Feb 08, 2016 at 10:46:57PM +0530, Sudip Mukherjee wrote:
> On Sun, Feb 07, 2016 at 02:04:21PM -0800, Greg Kroah-Hartman wrote:
> > On Tue, Dec 01, 2015 at 04:22:33PM +0530, Sudip Mukherjee wrote:
> > > The success path and the error path both are first doing
> > > spin_unlock_irqrestore() b
On Tue, 2016-02-09 at 18:45 -0800, Shaun Ren wrote:
> This patch fixes the alignment issue reported by checkpatch.pl:
>
> CHECK: Alignment should match open parenthesis
>
> Signed-off-by: Shaun Ren
> ---
> drivers/staging/rts5208/rtsx_transport.c | 61
> ++--
> 1 fi
Hi Shaun.
These comments now reflect common kernel style.
Thanks for addressing my comments.
Just one minor note below. It seems the word SCSI
SCSI got duplicated in one comment. (Noted below).
The rest look great to me.
On Tuesday, February 09, 2016 06:45:20 PM Shaun Ren wrote:
> This patch fix
This patch adds a dma_mapping_error call to debug potential DMA mapping
errors after the dma_map_single call in rtsx_transport.c.
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rts5208/rtsx
This patch fixes the following issues in rtsx_transport.c as reported by
checkpatch.pl:
CHECK: Blank lines aren't necessary after an open brace '{'
CHECK: Please don't use multiple blank lines
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 3 ---
1 file changed, 3 delet
This patch fixes the alignment issue reported by checkpatch.pl:
CHECK: Alignment should match open parenthesis
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 61 ++--
1 file changed, 35 insertions(+), 26 deletions(-)
diff --git a/drivers/sta
This patch fixes the following styling issue in rtsx_transport.c
as reported by checkpatch.pl:
CHECK: spaces preferred around that '-' (ctx:VxV)
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/
This patch changes all comparsions to NULL with !..., as reported by
checkpatch.pl.
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_transport.c
b/drivers/staging/rts5208/
This patch removes all unnecessary parentheses found by checkpatch.pl.
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_transport.c
b/drivers/staging/rts5208/rtsx
This patch fixes the following naming convention issue in rtsx_transport.c,
as reported by checkpatch.pl:
CHECK: Avoid CamelCase:
Signed-off-by: Shaun Ren
---
Changes since v2
* Update patch to reflect the changes made in PATCH 1/9 (block comments)
drivers/staging/rts5208/rtsx_transport.c |
This patch removes all spaces after casts in rtsx_transport.c, as reported
by checkpatch.pl:
CHECK: No space is necessary after a cast
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/
This set of patches fixes the coding style issues in rtsx_transport.c, and
dds a missing call dma_mapping_error() after dma_map_single().
Changes since v2
* Incorporated Joshua Clayton's suggestions regarding the block comments
___
devel mailing list
d
This patch fixes all multiline comments to conform to the coding style,
which states that multiline comments should start with "/*" and end
with "*/" on a separate line.
Also cleans up some comments to make them more clear and/or reflect what
the code is doing.
Signed-off-by: Shaun Ren
---
Chang
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Monday, February 8, 2016 13:34
> To: KY Srinivasan
> Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org;
> o...@aepfle.de;
> a...@canonical.com; vkuzn...@redhat.com; jasow...@redhat.com; Dexuan
> Cui
> Subject: Re: [PATCH V2
On 07/02/16 22:21, Cristina Moraru wrote:
> Fix comment style warnings in order to comply with Coding Style
> standard provided by Documentation/CodingStyle.
>
> This patch solves following issue found with checkpatch:
> WARNING: Block comments use a trailing */ on a separate line
>
> Signed-off-
On 07/02/16 22:21, Cristina Moraru wrote:
> Swap implementations of hmc5843_common_suspend and
> hmc5843_common_resume functions for they have been
> inversed. Device should go on SLEEP mode on suspend
> and on CONTINUOUS mode on resume.
>
> Signed-off-by: Cristina Moraru
I'd normally apply this
On 07/02/16 22:21, Cristina Moraru wrote:
> Add static attribute meas_conf_available to show available
> configurations for the bias current.
>
> API for setting bias measurement configuration:
>
> 0 - Normal measurement configuration (default): In normal measurement
> configuration the devic
> -Original Message-
> From: Lijun Pan [mailto:lijun@freescale.com]
> Sent: Monday, February 08, 2016 5:40 PM
> To: gre...@linuxfoundation.org; a...@arndb.de; de...@driverdev.osuosl.org;
> linux-
> ker...@vger.kernel.org
> Cc: stuart.yo...@freescale.com; itai.k...@freescale.com;
> g
From: Jake Oshins
This patch introduces a new driver which exposes a root PCI bus whenever a
PCI Express device is passed through to a guest VM under Hyper-V. The
device can be single- or multi-function. The interrupts for the devices
are managed by an IRQ domain, implemented within the driver.
Hello Gustavo Padovan,
This is a semi-automatic email about new static checker warnings.
The patch b55b54b5db33: "staging/android: remove struct sync_pt" from
Jan 21, 2016, leads to the following Smatch complaint:
drivers/staging/android/sync_debug.c:108 sync_print_fence()
warn: variab
From: Jake Oshins
This patch adds an fwnode_handle to struct pci_sysdata, which is
used by the next patch in the series when trying to locate an
IRQ domain associated with a root PCI bus.
Signed-off-by: Jake Oshins
---
arch/x86/include/asm/pci.h | 15 +++
include/linux/pci.h
From: Jake Oshins
This version incorporates feedback from Bjorn Helgaas and fixes a build
break reported by the kbuild test robot.
This is a resend of patches that enable PCI pass-through within Hyper-V
VMs. This patch series only includes those which were deemed appropriate
for being incorport
From: Jake Oshins
This patch adds a second way of finding an IRQ domain associated with
a root PCI bus. After looking to see if one can be found through
the OF tree, it attempts to look up the IRQ domain through an
fwnode_handle stored in the pci_sysdata struct.
Signed-off-by: Jake Oshins
---
On Mon, Feb 08, 2016 at 06:33:37PM +, Jonathan Cameron wrote:
> On 06/02/16 22:23, Ksenija Stanojevic wrote:
> > Move mxs-lradc driver from drivers/staging/iio/adc to drivers/iio/adc.
> >
> > Signed-off-by: Ksenija Stanojevic
> Given the input elements in here, cc'ing linux-input and Dmitry.
JAMES BRIEN COMEY
EXECUTIVE DIRECTOR FBI
FEDERAL BUREAU OF INVESTIGATION FBI.WASHINGTON D.C
FEDERAL BUREAU OF INVESTIGATION SEEKING TO WIRETAP
The Federal bureau of investigation (FBI) Washington,D.C
in conjunction with some other relevant Investigations Agencies
have recently been informed throug
JAMES BRIEN COMEY
EXECUTIVE DIRECTOR FBI
FEDERAL BUREAU OF INVESTIGATION FBI.WASHINGTON D.C
FEDERAL BUREAU OF INVESTIGATION SEEKING TO WIRETAP
The Federal bureau of investigation (FBI) Washington,D.C
in conjunction with some other relevant Investigations Agencies
have recently been informed throug
> -Original Message-
> From: David Miller [mailto:da...@davemloft.net]
> Sent: Tuesday, February 9, 2016 5:05 AM
> To: Haiyang Zhang
> Cc: net...@vger.kernel.org; KY Srinivasan ;
> o...@aepfle.de; vkuzn...@redhat.com; linux-ker...@vger.kernel.org;
> driverdev-devel@linuxdriverproject.org
The macros `SDF_MODE0`, `SDF_MODE1`, `SDF_MODE2`, `SDF_MODE3`, and
`SDF_MODE4` are COMEDI subdevice flags originally associated with the
obsolete (and no longer present) COMEDI "trigger" functionality. They
have been of no use since COMEDI release 0.7.61 back in November 2001.
Since they were goin
Remove `struct comedi_trig` and some associated macros, `TRIG_DITHER`,
`TRIG_DEGLITCH`, `TRIG_CONFIG`, and ioctl code `COMEDI_TRIG`. These
have been obsolete since COMEDI release 0.7.61 back in November 2001.
The userspace COMEDILIB library still has some deprecated code that
may attempt to use t
Add "kernel-doc"-formatted comments to COMEDI's general-purpose `enum`
type declarations. Don't bother documenting the low-level
driver-specific ones for now.
Move the declaration of `enum comedi_counter_status_flags` next to the
other general-purpose `enum` types.
Signed-off-by: Ian Abbott
---
The wording at the start of the header comment is a bit misleading,
particularly the part in parentheses: "(installed as
/usr/include/comedi.h)". This version of "comedi.h" certainly won't be
installed as that pathname. Fix it.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/comedi.h | 4
Add "kernel-doc"-formatted comments to the COMEDI `struct` declarations
used with ioctls. Don't bother documenting `struct comedi_trig` as it
is obsolete and not supported.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/comedi.h | 332 +++-
1 file chang
Add some kernel-doc comments to the common enums and structs in
"comedi.h", and remove the cruft related to the non-functional and
obsolete COMEDI_TRIG ioctl.
1) staging: comedi: comedi.h: tweak start of header comment
2) staging: comedi: comedi.h: add kernel-doc to common enums
3) staging: comedi
On Mon, 2016-02-08 at 22:39 +0530, Sudip Mukherjee wrote:
> maybe this is better where you have single exit point and so only one
> spin_unlock_irqrestore().
We discussed this before. I don't want to put any of the goto messes
back in because I don't think it shortens the code or makes it any
sim
From: Haiyang Zhang
Date: Tue, 2 Feb 2016 16:15:56 -0800
> We simulates a link down period for RNDIS_STATUS_NETWORK_CHANGE message to
> trigger DHCP renew. User daemons may need multiple seconds to trigger the
> link down event. (e.g. ifplugd: 5sec, network-manager: 4sec.) So update
> this link
Hi!
Sorry for being a bit late, but since I used to have few clean-ups to the
driver I noticed that they mostly not needed anymore which is really good.
Though, I noticed also that patch "staging: wilc1000: replaces PRINT_XXX with
netdev_xxx" replaced also few open-coded %p-extensions.
That pat
39 matches
Mail list logo